GMS Device Sync Agent stops responding

  • 7017911
  • 02-Aug-2016
  • 11-Aug-2016

Environment

Novell GroupWise 2014
Novell GroupWise
Novell Data Synchronizer

Situation

Device sync agent stops and fails to start because of an email coming through Device Sync Agent shows a "Critical Unknown" error and devices fail to synchronize.
GMS Device Sync Agent stops and fails to start because of a syncing email with an attachment
DataSync stops processing (100% cpu utilization)
mobility-agent.log stops logging
groupwise-agent.log continues to log
Device Sync Agent shows a failed status
Device Sync Stopped
Device Sync Agent won't start
devices unable to connect

The last event to occur, before 100% utilization brings down the device sync agent, shows in the mobility-agent.log as:
DEBUG [Device_Thread-20] [sync:218] [userID:] [eventID:] [objectID:] [] !!!type(htmlBody) = <type 'unicode'>, charset = utf-8
DEBUG [Device_Thread-20] [mobility_util:697] [userID:] [eventID:] [objectID:] [] dname: text.htm  name: text.htm
INFO [Device_Thread-20] [mobility_util:718] [userID:] [eventID:] [objectID:] [] charset "US-ASCII" came with attachment


Traceback Exception Error also reported in the mobility-agent.log:
2016-07-20 11:30:59.342 ERROR [Device_Thread-47] [DeviceInterface:1272] [userID:] [eventID:] [objectID:] [Server] Global Exception handler 32
Traceback (most recent call last):
  File "./mobility/lib/device/DeviceInterface.py", line 1229, in ashandler
  File "./mobility/lib/device/wsgiserver/__init__.py", line 661, in write
  File "./mobility/lib/device/wsgiserver/__init__.py", line 738, in send_headers
  File "./mobility/lib/device/wsgiserver/__init__.py", line 1193, in sendall
  File "./mobility/lib/device/wsgiserver/__init__.py", line 1145, in _safe_call
  File "./mobility/lib/device/wsgiserver/__init__.py", line 759, in sendall
  File "./mobility/lib/device/wsgiserver/__init__.py", line 1196, in send
  File "./mobility/lib/device/wsgiserver/__init__.py", line 1161, in _safe_call
error: 32


Resolution

At the time of writing this document, a publicly available fix is unavailable, please contact MicroFocus Customer Care to have the engineering fix applied.

Cause

Failed to parse an attachment.

Status

Reported to Engineering

Additional Information