The data transfer hangs after some time, migration job status = "running"

  • 7017927
  • 08-Aug-2016
  • 10-Aug-2016

Environment

PlateSpin Migrate 11.x, 12.x

PlateSpin Protect 11.x

PlateSpin Forge 11.x

Situation

During the step "Copying Volume Data from Source to Target", and while some data could be transferred from source to target machine, the job hangs, stuck at "Running" status.



Checking the logs of step "Sending Files" and "Receiving Files", the below error messages are recurring in loop:

[ChannelEndpoingAdapter.Send] Send packet Id:0,Message:Type:ack,LastReceiveId: 0 Content:43325 failed. Cookie:, Exception: PlateSpin.Utility.NetworkTransfer.NewImpl.Protocols.ChannelEndpointException ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host at System.Net.Sockets.Socket.Send(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)

Receive packet failed. PlateSpin.Utility.NetworkTransfer.NewImpl.Protocols.ChannelEndpointException: ---> System.Net.Sockets.SocketException: Connection reset by peer at System.Net.Sockets.Socket.Receive (System.Byte[] buffer, Int32 offset, Int32 size, SocketFlags flags) [0x00000] in <filename unknown>:0 at PlateSpin.PowerConvert.Utility.NetworkTransfer.NewImplementation.Protocol.TCP.TCPChannelEndpoint.Receive (System.Byte[] buffer, Int32 offset, Int32 size) [0x00000] in <filename unknown>:0 --- End of inner exception stack trace --- at PlateSpin.PowerConvert.Utility.NetworkTransfer.NewImplementation.Protocol.TCP.TCPChannelEndpoint.Receive (System.Byte[] buffer, Int32 offset, Int32 size) [0x00000] in <filename unknown>:0


Also, the output of the command "netstat -ano" shows that the connection between source and target machine, via port 3725, does happen:



The Windows Event logs, "Application", on the source server, show recurring error messages related to .Net issue with the OFX controller:


Resolution

Review your firewall settings to allow communication between source and target machine.

If you have a networking issue with a SonicWall TZ or NSA device, you can try the following to mitigate the problem:
  1. Ensure that netbios traffic is allowed to pass both in and outbound through the SonicWall. (UDP 137-139)
  2. Disable the security settings that are created by SonicWall within the Unified Threat Management software platform provided for the device.
  3. Set a custom zone for the target machine with all security disabled on the SonicWall. Allow for an open connection should the device fail to have outbound access.
  4. The Stateful Packet Inspection is hanging onto the target machine outbound connections.
  5. If the previous solutions have failed, you might have to disable SPI or DPI on your device.

Cause

These symptoms are generally observed when a firewall, such as SonicWall TZ and NSA devices, filters out certain network packets based on the identification of possible threatening activity.

The problem is that this software can prevent the offsite replication of your backups.

While the first packet can be sent, opening the TCP connection, SonicWall starts doing traffic shaping on the stream which causes the packets to change and the TCP connection to randomly drop. But both source and target machine can ping each other since it is not a TCP stream.