How to view previously recorded FLV videos in PAM 3.1

  • 7018413
  • 21-Dec-2016
  • 21-Dec-2016

Environment

NetIQ Privileged Account Manager 3.1
NetIQ Privileged Account Manager 3.0.1

Situation

Upgraded to Privileged Account Manager 3.1 from previous version
The previously recorded videos with .flv extension are unplayable in PAM 3.1
PAM 3.1 now records videos with .mp4 extension
Currently unable to convert the FLV videos to MP4, but would still like to play or view old audit videos

Resolution

Please convert the FLV videos to MP4 in order to view the videos in PAM 3.1 and newer.
Note: For more details, please refer to Converting the FLV videos to MP4.

If conversion is not currently possible, the following approach may be used only as a temporary solution until the video files are migrated or until Mainstream Support ends for PAM 3.0.1:

  1. Please upgrade all PAM instances to PAM 3.1.
    Note: Download should be available here.
  2. Have one PAM 3.0.1 agent (linux or windows) be registered to this PAM 3.1 environment.
  3. Using PAM's Admin Console, please add the following 3.0.1 packages to the above 3.0.1 agent:
    • Admin module
    • Audit console
    • Report_command console
    • Report_chngmgnt console
    • Report_pwdcheckout console
  4. Connect to this agent's Admin Console using https://<IPAddress-of-3.0.1-agent>
  5. Now it's possible for video playback of any previous sessions whose video files aren't yet converted.
    Note: For more details on video playback, please refer to Viewing the Videos.

Cause

Upgrading to Privileged Account Manager 3.1 from previous versions requires the conversion of previously recorded videos with .flv extension to .mp4. This will enable playback of the recorded videos in 3.1.