ZMM Connecting to LDAP AD server for importing user gives blank result

  • 7018560
  • 01-Feb-2017
  • 01-Feb-2017

Environment

Novell ZENworks Mobile Management 3.2

Situation

Importing users shows blank (no errors)

Resolution

Issue is expected to be fixed in version 3.2.6.

Workaround for prior release:

Run the following in SQL:

EXEC spUpdateLDAPContainerOrder <YourLDAPServerSAKey>

Replace <YourLDAPServerSAKey> with the LDAPServerSAKey value found for the LDAP server in use by running: Select * from LDAPServers

Alternative Fix if the Administrator is unable to access SQL:

If there is not access to SQL then it is possible to update the LDAP server from the dashboard.  This method is not as reliable as the first method and may need to be done a few times.  

Go into Organization -> Administrative Servers -> LDAP Servers and select Group and Folder Configurations.  

From the Groups tab, select Import Groups.  If the groups load, select one of them and import the group.  With this work-around, the issue may return again after another LDAP periodic update runs. Therefore if the issue returns again, it may be necessary to use this work around again in the future (or run the first method) until the version with fix is released.


Cause

Running an LDAP Periodic Update can insert an extra folder into the LDAP structure that is stored in the MDM/ZMM database. 

The extra folder has its FolderOrder and FolderDepth set to NULL, which causes the PHP code to compose invalid XML. Flash receives the invalid XML, evaluates it, and when it reads the problem folder information, it doesn't display anything.