Filr 3.0 Update Channel Registration to a local SMT server fails with HTTP 500 Error

  • 7018759
  • 31-Mar-2017
  • 06-Jul-2017

Environment

Micro Focus Filr 3.0 Appliance
Micro Focus Filr 3.0 Administration
SUSE Subscription Management Tool

Situation

Registering a Micro Focus Filr, Micro Focus Lucene (Search Index) or Micro Focus MySQL appliance, which have no direct outbound internet connection, to a SMT11 server, this errors out with error 500.

The /var/opt/novell/jetty/logs/jetty.stderrout.out shows the following error:
Exception while dispatching incoming RPC call
com.google.gwt.user.server.rpc.UnexpectedException: Service method 'public abstract java.lang.String com.novell.admin.common.client.services.ApplianceRpcService.configure(com.novell.admin.common.datamodel.beans.OnlineUpdateConfig) throws com.novell.admin.common.server.rpc.beans.RpcException' threw an unexpected exception: com.novell.admin.common.datamodel.beans.DataModelException: /usr/bin/suse_register -E failed with a return code of 2

Resolution

This has been addressed by the Filr Engineering team, and a fix will be made available when a new set of Micro Focus Filr Appliances will be released.

For current Micro Focus Filr 3.0 installations, please use the following workaround:

Preparations:

Make sure that the SMT server is able to mirror and host the Filr update channel.

NOTE: Please be aware that SMT12 servers registered against SCC do not provide any Micro Focus (Legacy Novell) update repositories.

To make sure that the "Mirror Credentials" used for SMT11 is entitled to Filr, check the Mirror Credentials in the Micro Focus Customer Center (MFCC (formerly known as Novell Customer Center (NCC)), when in the "Software" section, select "Mirror Credentials".
In that part of the MFCC, it can be verified whether the Filr 3.0 channel is listed, or not.

In case no Filr repositories are listed as available for mirroring, please send an email to "entitlements@microfocus.com" to investigate why the mirror credentials do not offer the Micro Focus Filr 3.0 repositories.

In case your Mirror Credentials have the Filr 3.0 repositories listed, then, continue to the next step

Verify the SMT server:

1) Open a terminal session on the SMT server (as root) and run :
smt-repos --enable-by-prod Filr3.0,3.0,x86_64
Then:
smt-mirror --debug --verboselevel 127 --logfile /tmp/smt-mirror-d3.txt

NOTE: the above command will launch the mirror operation to download all the needed repo files, this could take some time to finish, please be patient.

2) Once finished, run:
openssl x509 -in /var/lib/CAM/YaST_Default_CA/cacert.pem -text > /tmp/smt-ca-cert.txt 2>&1
openssl x509 -in /var/lib/CAM/YaST_Default_CA/certs/01.pem -text > /tmp/smt-srv-cert.txt 2>&1

Get a new supportconfig file from the SMT server:
supportconfig -l

When there were any errors occurred during these steps, contact the Micro Focus Customer Care Center using a Service Request and provide them with the collected files generated during steps 1 and 2.

If these steps were fulfilled without error, continue on the Micro Focus Appliance.

Adjust the Appliance for registration to the SMT:

3) Open a root session over ssh or the hyper-visor console on the Filr system you wish to register against the SMT and run:
cp /etc/suseRegister.conf /etc/org.suseRegister.conf
vi /etc/suseRegister.conf
    Remove the complete contents of the file (double press d to remove the line)
    Add the following 2 lines (press i to enable editing):
url=https://<dns of smt server>/center/regsvc
register   = command=register

    Save the file (:wq)
Replace the <dns of smt server> with the actual NetBios or DNS name of the SMT server (please do make sure that the Filr can resolve and reach that address).

After that, please reattempt the registration using the Appliance Management Portal (port 9443) > Online Update > Register.

Cause

When the Micro Focus Appliance is unable to reach the Micro Focus Customer Center servers, part of the procedure that attempts to clean out a potential failed previous attempt fails and causes the error 500.

Status

Reported to Engineering

Additional Information

If you're using a Proxy server and registration with your local SMT server is failing, please consult TID 7020906 - Using a Proxy server Filr 3.0 Update Channel Registration fails with HTTP 500 Error

In case the registration to the SMT still fails:
4) In case after all this the registration to the SMT still fails, continue with these debug and troubleshooting steps over ssh or the hyper-visor console of the Appliance:

NOTE: The trailing /'s on the curl command is required.
Replace <DNS of SMT server> with the actual DNS or NetBios name of the SMT server.

    nslookup <DNS of SMT server> > /tmp/nslookupsmt.txt 2>&1
    curl -v --trace-ascii /tmp/scctrace.txt https://<dnsname of SMT server>/
    openssl s_client -connect <DNS of SMT server>:443 -showcerts > /tmp/smt-openssl-cert.txt 2>&1


5) Clean up all data and files related to any previous registration:

    suse_register -E -L /tmp/unregister.log
    rm -f /etc/SUSEConnect
    rm -rf /etc/zypp/credentials.d/*
    rm -rf /etc/zypp/repos.d/*
    rm -f /etc/zypp/services.d/*
    rm -f /var/cache/SuseRegister/*
    rm -f /etc/suseRegister*
    rm -f /var/cache/SuseRegister/lastzmdconfig.cache


NOTE: if any of the above commands returns an error message, do not mind it and continue with this procedure.

6) Now try to register against the SMT using the script provided by the SMT server:

    wget http://<DNS of SMT server>/repo/tools/clientSetup4SMT.sh
    chmod 755 clientSetup4SMT.sh
    ./clientSetup4SMT.sh --host <DNS of SMT server>


The above command will create the log file: /root/.suse_register.log

And then:

    suse_register -r -d 3 -L /tmp/smtregister.txt


7) Once finished get a new supportconfig file from the Micro Focus Appliance:

    supportconfig -l


When all these steps were performed, and the system still is not registerred to the SMT, please collect the files generated in steps 4, 5, 6 and 7 and provide these to the Micro focus Customer Care trough means of a Service Request.

Changing SMT server after a SMT Server Failure:
When a SMT server failed and the Micro Focus Appliances are to be registered to a different SMT server or the MFCC directly, the same issue can occur when the original SMT server becomes unreachable.
In that case the same workaround can be used to switch from the unreachable SMT server to the new one.