Dell System Inventory Reports or Dynamic Groups are Inconsistent

  • 7023107
  • 18-Jun-2018
  • 04-Sep-2018

Environment

ZENworks Asset Management 11.4 Inventory
ZENworks Asset Management 2017 Inventory
ZENworks Configuration Management 11.4 Inventory
ZENworks Configuration Management 2017 Inventory

Situation

  • Running Inventory reports to include Dell systems
  • Creating Dynamic Groups of Dell systems
  • Using System Product or System Model as filters in Inventory reports or Dynamic Groups
  • Inventory report results may be inconsistent
  • Dynamic Group membership may be inconsistent

Resolution

This is fixed in version ZENworks Configuration Management 2017 Update 3 - see KB 7023221 "ZENworks Configuration Management 2017 Update 3 update information and list of fixes" which can be found at https://support.microfocus.com/kb/doc.php?id=7023221 

Workaround:

Create the duplicate filters for both System Product and System Model fields. Use an OR to connect these filters.

Example for Inventory report criteria:
System Product   contains   E6440   OR
System Model     contains   E6440


Example for Dynamic Group filter:
Inventory - System Product   contains   E6440   OR
Inventory - System Model     contains   E6440

Cause

This happens because the information that Dell provides in the system bios is inconsistent, and because of how ZENworks deals with that inconsistency.

Additional Information

For some Dell systems, a number is returned for the system version (00, 01, 001, etc). When this happens, ZENworks will place this number in the System Product field, and will place the actual model (OptiPlex 760, Latitude E6440, etc) in the System Model field.

For other Dell systems, nothing is returned for the system version. When this happens, ZENworks will place the actual model (OptiPlex 760, Latitude E6440, etc) in the System Product field, and will leave the System Model field blank.