TeamWorks Web Client is Blank or Otherwise Unusable in a Large Deployment when fronted by NAM

  • 7023592
  • 14-Dec-2018
  • 17-Dec-2018

Environment

GroupWise Teamworks
Access Manager 4.4

Situation

Steps to duplicate:
Using Chrome browser, log in to web client of TeamWorks.
Things may look normal but you are unable to perform actions like Create Room, Enter Room, Perform Search etc.

With FireFox you can log in and perform some actions but results are never shown.

Resolution

1. Open an ssh session to the TeamWorks application/appliance server

2. Open/edit the file /etc/apache2/vhosts.d/vhost-esn-webclient.conf

3. Add these two strings between </Directory> and </VirtualHost> where teamworks.acme.com is the dns name of the TeamWorks Reverse Proxy: AG Cluster hosted on the NAM server

ProxyPassReverseCookiePath /ssf /
ProxyPassReverseCookieDomain localhost teamworks.acme.com

4. Save and exit the file

5. Restart apache, "systemctl restart apache2" or "rcapache2 restart"

6. Open/edit the /opt/novell/esn/apache-tomcat/webapps/ssf/WEB-INF/web.xml file

7. Add the TeamWorks Reverse Proxy: AG cluster hosted on the NAM server

Here is an example where teamworksstage.microfocus.net is the dns name of the TeamWorks Reverse Proxy: AG Cluster hosted on the NAM server:
<param-value>https://teamworks.acme.com,file://,http://localhost:8080,http://localhost:4200</param-value>
8. Restart teamworks, "systemctl restart teamworks"


Here is the element in the web.xml file that contains the section that needs to be modified. What's new is the string: https://teamworks.acme.com

                        <param-name>cors.allowed.origins</param-name>


                        <param-value>https://teamworks.acme.com,file://,http://localhost:8080,http://localhost:4200</param-value>


                                </init-param>


Cause

Session cookies are lost if a large TeamWorks installation is fronted by Novell Access Manager(NAM)