Zenworks agent modules for ZESM and FDE not updated on Windows 10 devices upgraded from Update 3 to Update 4

  • 7023704
  • 07-Feb-2019
  • 18-Aug-2020

Environment

ZENworks Configuration Management 2017 Update 4
ZENworks Configuration Management 2017 Update 4 System Update

Situation

Windows 10 managed device running ZENworks agent Update 3 is updated to ZENworks 2017 Update 4 and has ZENworks Endpoint Security and / or ZENworks Full Disk Encryption enabled.

When checking the agent versions under z-icon => Technician Application => Agent status it will report the Update 3 versions for Endpoint Security and Full Disk Encryption.
The versions reported are:

- Endpoint Security Management 17.3.0.1268 
- Full Disk Encryption 17.3.0.1268 

NOTE:  Although the version is not updated to 17.4x there is no functionality problem as there were no code changes introduced in 17.4 version.  However, if this is seen when upgrading to 2020 or later, contact Micro Focus customer care, ZENworks support because there is a change to 2020.

Resolution

Although there is not functional impact for the product, Micro Focus plans to release a fix.  This TID will be updated when that is available.

For managed device that already updated to Update 4 there will be a ZENworks bundle available shortly to push out the correct MSIs to these devices.   For devices not yet updated there will be a patch available to patch the Update 4 on the primary servers, so the managed devices will receive the correct version directly when updated to Update 4.

Cause

The corresponding MSIs are not updated to the Update 4 version during the System Update process.

This only applies to Windows 10 devices being updated from Update 3 to Update 4.

Status

Reported to Engineering