iPrint Client Error 1031: URL no longer available with SP6

  • 3111078
  • 07-Dec-2006
  • 27-Apr-2012

Environment

Novell iPrint for NetWare Novell NetWare 6.5 Support Pack 6

Situation

The following error is presented to users when attempting to install iPrint printers after applying Support Pack 6 to NetWare 6.5.

Error Code: 1031
iPrint Client - The given URL is no longer available and should not be referenced in the future.

The same printers that cannot be installed to workstations with the above error will be auto removed from workstations that already have the printer installed.

Resolution

Apply NDPSM.NLM dated 20NOV2006 or later. Search Novell's File Finder for NDPSM.NLM to find the fix.

Workaround:
1. Go to iManager
2. Select iPrint -> Manage Print Manager -> Printer Agent Redirection -> Deleted Printer Agent Redirection
3. Check the Delete box for all printer agents that can duplicate the above error. Click Apply.

Note:
The above steps do not delete the Printer Agent. These steps remove the Printer Agent from the deleted list. Also the latest iPrint plugins from NW65SP6 must be used otherwise the deleted printer redirection list will not show in iManager. Refer to tid 3968737 for an explanation on how to get the latest plugins for SP6.

Cause:
When a printer agent is deleted, the Print Manager stores that information. Prior to SP6, administrators could not view or manage that list. SP6 introduces a new feature within iManager to allow the network administrator to manage the printer agent deleted list. SP6 also introduces a bug that can allow a printer agent to exist in the Print Manager database as an active printer AND be populated in the deleted list at the same time. Of course, it is illogical to have a printer agent present in both lists. Printer agents that fall under this condition will generate the error listed above.