Cool Solutions

Disabling Attachments in WebAccess

coolguys

By:

February 5, 2008 9:44 am

Reads:3,721

Comments:0

Score:Unrated

Problem

A Forum reader recently asked:

“We have currently disabled the possibility for users to send attachments in WebAccess. Now we are going to upgrade to webaccess gw702HP1a. Where and how do we prevent users from sending attachments in that version of WebAccess?”

And here is the response from Gunnar Flygt …

Solution

It’s quite simple (when you know where to look). My system is Linux, but you should be able to find a similar place in the OS you are running.

1. In the /var/opt/novell/gw/WEB-INF/classes/com/novell/webaccess/templates/css/send.inc file you comment out this part:

<td></td>
 <td class="tab_inactive" id="idAttachTab">
   <div class="wrap1"><div class="wrap2"><div class="wrap3">
     <a class="text" href="#" id="idAttachLink">{STRING
Compose.Button.Text.attach}</a>
   </div></div></div>
</td>

2. Make a section that looks like this:

<!--td></td>
 <td class="tab_inactive" id="idAttachTab">
   <div class="wrap1"><div class="wrap2"><div class="wrap3">
     <a class="text" href="#" id="idAttachLink">{STRING
Compose.Button.Text.attach}</a>
   </div></div></div>
</td-->

Note that the line starting with “<a” is on the same line as the ending “</a>”

3. Restart Tomcat and Apache, and the attachment possibility is gone.

0 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 5 (0 votes, average: 0.00 out of 5)
You need to be a registered member to rate this post.
Loading ... Loading ...

Categories: Uncategorized

Disclaimer: This content is not supported by Novell. It was contributed by a community member and is published "as is." It seems to have worked for at least one person, and might work for you. But please be sure to test it thoroughly before using it in a production environment.

Comment

RSS