Cool Solutions

Solving a WebAccess Web Page Issue after Upgrade



By:

October 16, 2007 3:26 am

Reads: 4075

Comments:0

Score:0

Problem

A Forum reader recently asked:

“We upgraded to GroupWise 7.0.2 HP1 from GroupWise 6.5 SP4 (first via GroupWise 7.0.2, then applying HP1). Everything is working fine, except for a small technical issue when going to the webpage of WebAccess.

If I go to gw.xxx.com (my GroupWise WebAccess), I get the language selection page (I think this is from GroupWise 6.5). If I then click Go, I get redirected to the following page: http://gw.xxx.com/servlet/webacc

If I understand this correctly, I should be getting to http://gw.xxx.com/gw/webacc instead. What can I do?”

And here’s the response from Bob Mahar …

Solution

If users are going to http://servername, a quick fix until you can figure it out is to modify the index.html to redirect the user to the proper URL. I assume that if you go to the /gw/webacc it all works properly. The index.html may be the located in the docs folder if you were running NES.

Also, you can make the /servlet/webacc url work properly by modifying the sys:apache2\conf\GWApache2.conf file as follows:

1. In the first few lines, find the line that says “Alias /gw ….”

2. Just after that line, add the following:

redirect permanent /servlet/webacc http://server.DNS.name/gw/webacc

where, obviously, you modify the URL on the end to point to your server.

3. Run the following commands:

UNLOAD APACHE2
LOAD APACHE2

Then /servlet/webacc should work properly. Either way, you have happy users.

VN:F [1.9.22_1171]
Rating: 0.0/5 (0 votes cast)

Tags:
Categories: Uncategorized

Disclaimer: This content is not supported by Novell. It was contributed by a community member and is published "as is." It seems to have worked for at least one person, and might work for you. But please be sure to test it thoroughly before using it in a production environment.

Comment

RSS