Novell Cool Solutions

Workaround for problem with ZENworks for Desktops 6.5 Application Reporting

coolguys

By:

January 19, 2006 12:00 am

Reads:3,721

Comments:0

Score:Unrated

Print/PDF

I wanted to start using the NAL database for application reporting. However when I would right-click the SERVER_nalDatabase object, select Reporting…, Failure Report (or any other report), I would always run into this error:

“ZENworks Reporting encountered an error because of Crystal
Reports”.

SOLUTION: When I searched Novell KB and documentation I found an explanation of this error in the documentation. There were two possible resolutions, one to install MDAC 2.6 or later and second was to update ConsoleOne snapins.

I tried to install every possible version of MDAC, but problem wasn?t solved. ConsoleOne snapins were reinstalled many times, but still no change. As a last hope I tried the SybaseProbe utility and found that in NAL database there weren’t any tables! The Database looked OK, had same size as empty one and Sybase database engine on server hadn’t complained about anything, but it was corrupted.

I used
this TID
to get an empty NAL.DB from install CD and after copying this database to the server my ZfD Application Reporting was functional.

If you have any questions you may contact David at david.krotil@systemnet.cz

0 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 5 (0 votes, average: 0.00 out of 5)
You need to be a registered member to rate this post.
Loading...Loading...

Categories: Uncategorized

0

Disclaimer: This content is not supported by Novell. It was contributed by a community member and is published "as is." It seems to have worked for at least one person, and might work for you. But please be sure to test it thoroughly before using it in a production environment.

Comment

RSS