Cool Solutions

ZCC shows Patch Management constantly “In Progress” and never finishes?



By:

November 25, 2009 11:30 am

Reads:3,743

Comments:0

Score:Unrated

Windows 2003 Primary Server 10.2 running Patch Management with a remote Oracle 10g Database on SUN system.

NOTE: This will clear all ZPM tables which removes ALL Patch Management configs and bundles, so make screenshots (or have license information) of your Configuration.

If your system was upgraded from prior versions of ZCM 10.2 – It is recommended that you run the following query in the database:

Update zZENObject 
Set undeletable = 0 
Where undeletable = 1 And primarytype = 'Bundle' And subtype = 'Patch Bundle';

After doing so navigate to; %Zenworks_Home%\share\datamodel\oracle\uninstall

Grab “nrm-patchlink-saphire-datamodel-drop.sql” and run it in your zcm database this will drop all your patch management tables.

After running the script go to ZCC(web console) navigate to “Bundles” link and delete the “ZPM” folder. You may need to delete bundles w/in “ZPM” folders first.

Then in %Zenworks_Home% move away to some other location the “ZPM” folder it should be recreated later.

Make sure no license info nor subscription activity shows up in the ZCC.

The last step after taking care of all the steps above go to; %Zenworks_Home%\share\datamodel\oracle\

Grab “nrm-patchlink-saphire-datamodel.sql” and run it in your zcm database. This will recreate all the patch-management tables.

You will need to reenter you license information and restart the subscription process.
It did not affect any other component of ZCC except ZPM.

Editors Note: This is a valid workaround for systems running ZCM 10.2, and will temporarily fix this issue: however, the problem may reoccur, and the only long-term fix is to upgrade to ZCM 10.2.1 or later. Do not use this tip on ZCM 10.2.1 or later.

0 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 5 (0 votes, average: 0.00 out of 5)
You need to be a registered member to rate this post.
Loading ... Loading ...

Categories: Uncategorized

Disclaimer: This content is not supported by Novell. It was contributed by a community member and is published "as is." It seems to have worked for at least one person, and might work for you. But please be sure to test it thoroughly before using it in a production environment.

Comment

RSS