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About This Guide

Terminal Launcher is a component of SecureLogin. Terminal Launcher allows users to log into any 
type of host that requires the user to log in using an emulator (for example, ACF2 or RACF 
mainframe, a UNIX* host, or a Cisco* router). The user or administrator configures Terminal 
Launcher to connect to the mainframe or host, wait for the login sequence, then enter usernames 
and passwords.

Terminal Launcher can be configured to work with several different terminal emulators. Terminal 
Launcher can also be used to navigate the user to a particular subsystem or menu within an 
application. Furthermore, any keystrokes that an application will accept from the user can be 
incorporated into SecureLogin scripts to be sent to the host by Terminal Launcher.

This guide is for network administrators. It provides information on configuring Terminal 
Launcher to work with terminal emulators.

For Additional Documentation

For information on installing, using, and managing Novell® SecureLogin, see the SecureLogin 
Administration Guide.

For information on SecureLogin commands and sample scripts, see Script Commands.

For information on Novell SecretStore®, see the SecretStore Administration Guide.

Documentation Updates

For the most recent version of the Novell Configuration Guide for Terminal Emulators, see Novell 
SecureLogin 3.0 (http://www.novell.com/documentation/lg/securelogin30/index.html) on the 
Novell documentation Web page.

Documentation Conventions

In this documentation, a greater than symbol (>) is used to separate actions within a step and items 
within a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.
About This Guide 5

http://www.novell.com/documentation/lg/securelogin30/index.html
http://www.novell.com/documentation/lg/securelogin30/index.html
http://www.novell.com/documentation/lg/securelogin30/
http://www.novell.com/documentation/lg/securelogin30/
http://www.novell.com/documentation/lg/securelogin30/
http://www.novell.com/documentation/lg/secretstore30/


Novell Confidential tepref.fm last saved  4/2/03 Manual Version: 3/17/03103
6   Configuration Guide for Terminal Emulators



Manual (ENU) 3/17/03103Novell Confidential createcfg.fm last saved  4/2/03
1 Creating and Configuring a New Emulator 
Session

Creating a New Session
1 Run the emulator.

2 Select Creating a New Session, then click OK.

Configuring the Session
Configure the session for your network by following the onscreen prompts. The following 
procedure illustrates one possible configuration.

1 Select a host.
Creating and Configuring a New Emulator Session 7
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2 Select a session.

3 Select a connection.
8   Configuration Guide for Terminal Emulators
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4 Type a host IP address and Telnet port.

5 Select a type of file transfer.
Creating and Configuring a New Emulator Session 9
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6 Confirm the configuration for the session.

7 Click File > Save Session As.
10   Configuration Guide for Terminal Emulators
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8 Type a filename for the session, then click Save.

Remember the filename (in this illustration, SESSION1.EDP).

9 Click Options > Global Preferences.
Creating and Configuring a New Emulator Session 11
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10 Click Advanced, then double-click A.

11 Double-click the session file that was just created, click OK, then close the emulator.
12   Configuration Guide for Terminal Emulators
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2 Single Sign-On for AccuTerm 2000

This section helps you enable AccuTerm 2000 for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up AccuTerm 2000 in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
Single Sign-On for AccuTerm 2000 13
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

AccuTerm 2000 is the recommended name.

4 Select AccuTerm 2000, then click Edit.

5 Click the Script tab, then type the following script:
14   Configuration Guide for Terminal Emulators
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling AccuTerm 2000 for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
Single Sign-On for AccuTerm 2000 15
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

AccuTerm 2000 is the recommended name.

4 Configure the emulator:

Emulator Path
16   Configuration Guide for Terminal Emulators
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This is the path to the Atwin2k.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

 \Alt+e,c

Output Offsets

18000,8000

Windows Classes

ThunderRT6MDIForm

5 Click OK, then click Done.

6 Double-click AccuTerm 2000 in the Available Applications list, select AccuTerm 2000 from 
the Emulator drop-down list, then click OK.
Single Sign-On for AccuTerm 2000 17
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
18   Configuration Guide for Terminal Emulators
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3 Single Sign-On for Attachmate Extra 2000 - 
Enterprise

This section can help you enable Attachmate* Extra 2000 - Enterprise for single sign-on through 
Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Attachmate Extra! in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
Single Sign-On for Attachmate Extra 2000 - Enterprise 19
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3 Click New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Attachmate Extra! is the recommended name.

4 Double-click Attachmate Extra!

5 Click Script, then type the following script:
20   Configuration Guide for Terminal Emulators
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling Attachmate Extra! for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
Single Sign-On for Attachmate Extra 2000 - Enterprise 21
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2 Click New.

3 Type a name for the emulator, select HLLAPI as the emulator type, then click OK.

4 Configure the emulator:

Emulator Path

Enter the path to the extra.exe file.
22   Configuration Guide for Terminal Emulators
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Home Directory

Enter the home directory of the emulator.

HLLAPI.DLL

Enter the path to the ehllapi.dll file.

HLLAPI Function

Enter HLLAPI.

Session Files

Enter the path to the session file that you want to use. This is the session file that was 
created earlier.

5 Click OK > Done.

6 Double-click Attachmate Extra! in the Available Applications list, select Attachmate Extra! 
from the Emulator drop-down list, then click OK.
Single Sign-On for Attachmate Extra 2000 - Enterprise 23



Novell Confidential attachma.fm last saved  4/2/03 Manual Version: 3/17/03103
7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
24   Configuration Guide for Terminal Emulators
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4 Single Sign-On for Absolute Telnet v1.84

This section helps you enable Absolute Telnet* v1.84 or single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Absolute Telnet in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
Single Sign-On for Absolute Telnet v1.84 25
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Absolute Telnet is the recommended name.

4 Select Absolute Telnet, then click Edit.

5 Click the Script tab, then type the following script:
26   Configuration Guide for Terminal Emulators
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling Absolute Telnet v1.84 for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
Single Sign-On for Absolute Telnet v1.84 27
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, and then click OK.

Absolute Telnet is the recommended name.

4 Configure the emulator:

Emulator Path
28   Configuration Guide for Terminal Emulators
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This is the path to the emulator .exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

119.

Input IDs

118.

5 Click OK, then click Done.

6 Double-click Absolute Telnet in the Available Applications list, select Absolute Telnet from 
the Emulator drop-down list, then click OK.
Single Sign-On for Absolute Telnet v1.84 29
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches, and the user is logged in to the session.
30   Configuration Guide for Terminal Emulators
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5 Single Sign-On for Attachmate KEA

This section helps you enable Attachmate* KEA for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Attachmate KEA in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
Single Sign-On for Attachmate KEA 31
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Attachmate KEA is the recommended name.

4 Select Attachmate KEA, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling Attachmate KEA for Single Sign-On
1 Run Terminal Launcher and then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, and then click OK.

Attachmate KEA is the recommended name.

4 Configure the emulator:

Emulator Path
34   Configuration Guide for Terminal Emulators
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This is the path to the keavt.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

120

Output Offsets

1000

Windows Classes

KEA!,KText

 Child ID

19177352

5 Click OK, then click Done.

6 Double-click Attachmate KEA in the Available Applications list, select Attachmate KEA 
from the Emulator drop-down list, then click OK.
Single Sign-On for Attachmate KEA 35
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
36   Configuration Guide for Terminal Emulators
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6 Single Sign-On for Attachmate Personal Client

This section helps you enable Attachmate Personal Client for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Attachmate Personal Client in SecureLogin
1 Right-click the SecureLogin icon on the system tray and then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Attachmate Personal is the recommended name.

4 Select Attachmate Personal, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling Attachmate Personal Client for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

Attachmate Personal Client is the recommended name.

4 Configure the emulator:

Emulator Path
40   Configuration Guide for Terminal Emulators
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This is the path to the extra.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

HLLAPI DLLs

This is the path to the ehlapi32.ddd file

HLLAPI Functions

HLLAPI

Session Files

Type the path of the session file you wish to use.

5 Click OK, then click Done.

6 Double-click Attachmate Personal Client in the Available Applications list, select Attachmate 
Personal Client from the Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
42   Configuration Guide for Terminal Emulators
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7 Single Sign-On for CRT 3.4

This section helps you enable CRT for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up CRT in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

CRT is the recommended name.

4 Select CRT, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling CRT for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

CRT is the recommended name.

4 Configure the emulator:

Emulator Path
46   Configuration Guide for Terminal Emulators
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This is the path to the CRT.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

\Alt+e,a,\Alt+e,c (Case-sensitive, no spaces)

Window Classes

Van Dylke Technologies - CRT

5 Click OK, then click Done.

6 Double-click CRT in the Available Applications list, select CRT from the Emulator drop-
down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
48   Configuration Guide for Terminal Emulators
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8 Single Sign-On for Glink 6.2

This section can help you enable Glink 6.2 for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Glink 6.2 in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Glink is the recommended name.

4 Click Glink > Edit.

5 Click Script, then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling Glink 6.2 for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Advanced Generic as the emulator type, then click OK.

4 Configure the emulator:

Emulator Path

Type the path to the gl.exe file.
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Host Name

Type the IP address or host name of the computer that you want to connect to.

Output IDs

Type 133.

Input IDs

Type 172.

Output Offsets

Type 400,800.

Window Classes

Type GLINKC.

5 Click OK > Done.

6 Double-click Glink in the Available Applications list, select Glink from the Emulator 
dropdown list, then click OK.
Single Sign-On for Glink 6.2 53
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
54   Configuration Guide for Terminal Emulators
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9 Single Sign-On for HBO Star Navigator

This section helps you enable HBO Star Navigator for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up HBO Star Navigator in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

HBO Star Navigator is the recommended name.

4 Click HBO Star Navigator, then click Edit.

5 Click the Script tab, then type the following script:
56   Configuration Guide for Terminal Emulators



Manual 3/17/03103Novell Confidential HBO_Star.fm last saved  4/2/03
The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling HBO Star Navigator for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

HBO Star Navigator is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the hbowem.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

311

Input IDs

312

Output Offsets

500,4000

Window Classes

MIDICLIENT

5 Click OK, then click Done.

6 Double-click HBO Star Navigator in the Available Applications list, select HBO Star 
Navigator from the Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
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10 Single Sign-On for Hummingbird HostExplorer 7

This section can help you enable Hummingbird HostExplorer* 7 for single sign-on through 
Novell® SecureLogin.

The configuration for Hummingbird HostExplorer 7 is not a standard Terminal Launcher 
configuration in that it does not use Terminal Launcher at all. This example uses HostExplorer's 
internal macro capabilities to trigger SecureLogin actions.

Setting Up Hummingbird HostExplorer 7
This section provides information on the following:

“Setting Up a Quick Script” on page 61

“Configuring Hummingbird HostExplorer for Usernames” on page 62

“Configuring Hummingbird HostExplorer for Passwords” on page 64

“Saving the Emulator File” on page 66

Setting Up a Quick Script
1 Load the Hummingbird HostExplorer session.

2 Click Tools > Quick Script > Edit.
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3 Double-click Untitled: Description of Quick Script.

4 Type a filename and description for the Quick Script, then click OK.

Ensure that the filename is only one word long (no spaces).

Configuring Hummingbird HostExplorer for Usernames
1 At the Login dialog box, click Commands > Wait For Text.
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2 Configure the Wait For Text dialog box for username prompts, then click OK.

In the Text text box, type the text that the server displays when it prompts for usernames.

Check the Anywhere check box.

Type a timeout period.

We recommend a setting of five seconds.

For the If Found dialog box, select Pop Up a Message from the drop-down list.

For the Otherwise dialog box, select Pop Up a Message from the drop-down list.

3 At the Wait For Text dialog box, click Properties in the If Found section, configure the Popup 
Message Box window, then click OK.

Type Username in the Title text box.

Type Username in the Message text box.

4 At the Wait For Text dialog box, select Properties from the Otherwise section, configure the 
error box, then click OK.
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If the Username prompt is not displayed within the designated timeout period, an error 
message displays.

Type a title in the Title text box.

Type a message in the Message text box.

Configuring Hummingbird HostExplorer for Passwords
1 At the Login dialog box, click Commands > Wait For Text.

2 Configure the Wait For Text dialog box for password prompts, then click OK.
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In the Text text box, type the text that the server displays when it prompts for passwords.

Check the Anywhere check box.

Type a timeout period.

We recommend a setting of five seconds.

For the If Found dialog box, select Pop Up a Message from the drop-down list.

For the Otherwise dialog box, select Pop Up a Message from the drop-down list.

3 At the Wait For Text dialog box, select Properties from the If Found section, configure the 
Popup Message Box dialog box, then click OK.

Type Password in the Title text box.

Type Password in the Message text box.

4 At the Wait For Text dialog box, select Properties from the Otherwise section, configure the 
error box, then click OK.

If the Password prompt is not displayed within the designated timeout period, an error 
message displays. 
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Type a title in the Title text box.

Type a message in the Message text box.

After you click OK, the macro is complete.

Saving the Emulator File
1 At the Login dialog box, click File > Save As.

2 Type Login as the filename, click Save, then close the Quick Script editor.

3 Click Options > Edit Session Profile.
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4 (Conditional) Select not to use the SecureLogin wizard at this time.

If SecureLogin prompts you to run the SecureLogin wizard, check the Don’t Prompt Me In 
the Future check box, then click No.

5 Expand the session in the Settings Group panel.

Click General in the Settings Groups panel, then click the Browse button next to the Auto Start 
Quick-Key drop-down list. 
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6 Browse to where you saved the Quick Script macro file, then click Open.

The default path is c:\documents and settings\all users\application data 
\hummingbird\connectivity \7.10\hostex\quickscript\login.qsv.

7 Click OK, then close the emulator.

8 Open the session again.

This can be performed by using the shortcuts on the Start menu and following the prompts, or 
creating a shortcut directly to the session using the following format:

"Path to hostex32.exe" –P Session name
Eg: "C:\Progra~1\Hummingbird\hostex32.exe" –P Session1
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The emulator connects and displays the following dialog box.
IMPORTANT: Do not click OK.

Adding Hummingbird HostExplorer 7 as a Single Sign-On 
Application

1 Run SecureLogin, then click Add Applications.

2 Click Next until you reach Choose Script Type dialog box, then select Windows Application.
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3 Click next until you reach the Select the Login Panel page.

4 Select the login panel.
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4a Left-click on the hand icon in the SecureLogin Add Application Wizard dialog box.
4b Drag the hand icon and drop it onto the title bar of the Username dialog box.

5 At the Select Window Function, select Login Window from the drop-down list, then click 
Next.

6 Select the login fields, then click Next.
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6a Drag the hand icons and drop them onto the Username, Password, and (if appropriate) 
Optional fields.

6b Drag the hand icon for the Login Button and drop it onto the login button (for example OK, 
Next, Continue). 

7 At the Name the Script dialog box, type a name for the window, then click Finish.

We recommend that you type Hummingbird Login Script.

Enabling Hummingbird HostExplorer for Single Sign-On
1 Bring up SecureLogin’s main dialog box, then click Manage Logins.

2 Double-click hostex32.exe.
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3 Click Script, then edit the script.

Replace the displayed script with the following script:

Dialog
Class #32770
Title "Username"
EndDialog
Click #2
Delay 50
Type -raw $Username
Type -raw \

Dialog
Class #32770
Title "Password"
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EndDialog
Click #2
Delay 50
Type -raw $Password
Type -raw \

4 Click OK > OK, then close SecureLogin.

5 Start the emulator session, type a username, then click OK.

6 (Conditional) Respond to error messages.

Depending on the values that you entered for the Timeouts in the emulator macro, the error 
messages might be displayed after you click OK, in the SecureLogin prompts. 

If the error message is displayed, click OK to close the session, then restart the session. This 
might happen twice. To avoid the problem, raise the timeout value in the Macro settings, or 
enter the username and password more quickly.

7 Type the password, then click OK.
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The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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11 Single Sign-on for IBM Personal 
Communications 4.2

This section can help you enable IBM* Personal Communications 4.2 for single sign-on through 
Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up IBM Personal Communications in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.
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IBM Personal Communications 4.2 is the recommended name.

4 Click IBM Personal Communications 4.2 > Edit.

5 Click Script, then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling IBM Personal Communications for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Enter a name for the emulator, select HLLAPI as the emulator type, then click OK.

IBM Personal Communications 4.2 is the recommended name.

4 Configure the emulator:

Emulator Path
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Type the path to the pcsws.exe file.

Home Directory

This is the home directory of the emulator.

HLLAPI.DLL

This is the path to the pcshll32.dll file.

HLLAPI Function

Type HLLAPI.

Session files

This is the path to the session file that you want to use.

5 Click OK > Done.

6 Double-click IBM Personal Communications in the Available Applications list, select IBM 
Personal Communications from the Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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12 Single Sign-On for IDX Term 2.25

This section helps you enable IDX Term for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up IDX Term in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

IDX Term is the recommended name.

4 Select IDX Term, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling IDX Term for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

IDX Term is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the idxterm.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

201

Input IDs

202

Output Offsets

400,8000

Window Classes

IDXterm

Window Titles

IDXterm

5 Click OK, then click Done.

6 Double-click IDX Term in the Available Applications list, select IDX Term from the Emulator 
drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
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13 Single Sign-On for Jolly Giant GWS3270 Plus

This section can help you enable Jolly Giant GWS3270 for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Jolly Giant in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

QWS3270 is the recommended name.
Single Sign-On for Jolly Giant GWS3270 Plus 89



Novell Confidential jollyg.fm last saved  4/2/03 Manual Version: 3/17/03103
4 Click QWS3270 > Edit.

5 Click Script, then type the following script:
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This script uses the Delay command, rather than the WaitForText command. 

You might need to modify the Delay time to suit your network conditions.

The Type @E@E command is a variation of Type @E. It is used with this emulator to send 
the Enter keystroke to the emulator.

6 Click OK > OK, then close SecureLogin.

Enabling Jolly Giant for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Advanced Generic as the emulator type, then click OK.

QWS3270 Plus is the recommended name.
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4 Configure the emulator:

Emulator Path

This is the path to the qws3270p.exe file. Ensure that the path follows the 8.3 filename 
format. (for example, change c:\progam files\ to c:\progra~.

Host Name

This is the name or IP address of the server that you want to connect to.

Input IDs

Type 1035.

Output Offsets

Type 700,8000.
NOTE: There are no spaces.

Window Classes

Type QWS3270X.

5 Click OK > Done.

6 Double-click QWS3270 Plus in the Available Applications list, select QWS3270 Plus from 
the Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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14 Single Sign-On for Lawsons

This section helps you enable Lawsons for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Lawsons in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Lawsons is the recommended name.

4 Select Lawsons, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The omission of the “L” in Login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling Lawsons for Single Sign-On
1 Run Terminal Launcher and then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

Lawsons is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the Univwin.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

202

Input IDs

203

Output Offsets

100

Startup IDs

110

Windows Classes

GlobalClass,TerminalClass

Child ID

100

5 Click OK, then click Done.

6 Double-click Lawsons in the Available Applications list, select Lawsons from the Emulator 
drop-down list, then click OK.
Single Sign-On for Lawsons 99



Novell Confidential Lawsons.fm last saved  4/2/03 Manual Version: 3/17/03103
7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
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15 Single Sign-On for MiniSoft WS92

This section helps you enable MiniSoft WS92 for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up MiniSoft WS92 in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

MiniSoft WS92 is the recommended name.

4 Select MiniSoft WS92, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The script waits for the text “ACF82003 ACF2, ENTER LOGON 
ID -”. After the script detects the text “ACF82003 ACF2, ENTER LOGON ID -”, it enters the 
value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling MiniSoft WS92 for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

MiniSoft WS92 is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the Ws92_32.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

\Alt+e,a

Output Offsets

1000,500

Windows Classes

MS92WClass

5 Click OK, then click Done.

6 Double-click MiniSoft WS92 in the Available Applications list, select MiniSoft WS92 from 
the Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
106   Configuration Guide for Terminal Emulators



Manual (99a) 3/17/03103Novell Confidential mochaw32.fm last saved  4/2/03
16 Single Sign-On for Mocha W32 Telnet

This section can help you enable Mocha W32 Telnet for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Mocha W32 Telnet in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Mocha W32 Telnet is the recommended name.
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4 Click Mocha W32 Telnet > Edit.

5 Click Script and then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling Mocha W32 Telnet for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

Mocha W32 Telnet is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the mtelnet.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

Type 32906,57634.

Input IDs

Type 57637.

5 Click OK > Done.

6 Double-click Mocha W32 Telnet in the Available Applications list, select Mocha W32 Telnet 
from the Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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17 Single Sign-On for MS Windows 2000 Telnet

This section helps you enable MS Windows* 2000 Telnet for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Windows 2000 Telnet in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Windows 2000 Telnet is the recommended name.

4 Select Windows 2000 Telnet, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling Windows 2000 Telnet for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

Windows 2000 Telnet is the recommended name.

4 Configure the emulator:

Emulator Path
116   Configuration Guide for Terminal Emulators



Manual 3/17/03103Novell Confidential MSWin2K_Telnet.fm last saved  4/2/03
This is the path to the Telnet.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

\n

Output Offsets

500,5000

Windows Classes

ConsoleWindowClass

5 Click OK, then click Done.

6 Double-click Windows 2000 Telnet in the Available Applications list, select Windows 2000 
Telnet from the Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
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18 Single Sign-On for NetTerm V4.2C 32bit

This section can help you enable NetTerm V4.2C for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up NetTerm V4.2C in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

NetTerm is the recommended name.
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4 Click NetTerm > Edit.

5 Click Script, then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling NetTerm V4.2C for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Advanced Generic as the emulator type, then click OK.

NetTerm is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the netterm.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

Type 11001.

Input IDs

Type 11002.

Output Offsets

Type 700,8000.

Window Classes

Type NetTermClass.

5 Click OK > Done.

6 Double-click NetTerm in the Available Applications list, select NetTerm from the Emulator 
drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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19 Single Sign-On for Passport TN 3270E

This section can help you enable Passport* TN 3270E for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Passport TN 3270E in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Passport TN is the recommended name.
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4 Click Passport TN > Edit.

5 Click Script, then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling Passport TN 3270E for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Enter a name for the emulator, select HLLAPI as the emulator type, then click OK.

Passport TN is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the passport.exe file.

Home Directory

This is the home directory of the emulator.

HLLAPI.DLL

This is the path to the passhll.dll file.

HLLAPI Function

Type HLLAPI.

Session Files

This is the path to the session file that you want to use.

5 Click OK > Done.

6 Double-click Passport TN in the Available Applications list, select Passport TN from the 
Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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20 Single Sign-On for PCXWare

This section can help you enable PCXWare for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up PCXWare in SecureLogin
1 Right-click the SecureLogin icon on the system tray and then click Manage Logins.

2 Click New.
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3 Click New Application, type xcnd.exe in the Name box, select Windows as the type, then click 
Create.

4 Select xncd.exe or PCXWare, then click Edit.

5 Click the Script tab, then type the following script:
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The Delay commands are dependent on how long it takes for PCXWare to load/connect to 
your UNIX*/SUN* server. 1000 is equal to 1 second, you many increase or decrease the delay 
at your discretion.

6 Click OK, click OK again, then close SecureLogin.

7 The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
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21 Single Sign-On for PowerTerm V6.34

This section helps you enable PowerTerm* V6.34 for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Creating a PowerTerm Connection
1 Run PowerTerm.

2 Type the address or name of the host you want to connect to, then click Connect.

3 Click Terminal > Setup.
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4 Click the Preferences tab, select Auto Connect, then click OK.

5 Click File > Save Terminal Setup As.
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6 Type a filename, then click Save.

Setting Up PowerTerm in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.
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2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

PowerTerm is the recommended name.
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4 Select PowerTerm, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling PowerTerm for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select WinHLLAPI as the emulator type, then click OK.

PowerTerm is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the ptw32.exe file.

Home Directory

This is the home directory of the emulator.

HLLAPI

This is the path to the hllapi32.dll file.

HLLAPI Function

Type WinHLLAPI

Session Files

This is the path to the session file you wish to use.

5 Click OK, then click Done.

6 Double-click PowerTerm in the Available Applications list, select PowerTerm from the 
Emulator drop-down list, then click OK.
142   Configuration Guide for Terminal Emulators



Manual 3/17/03103Novell Confidential PowerTerm.fm last saved  4/2/03
7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches, and the user is logged in to the session.
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22 Single Sign-On for QVT Term

This section can help you enable QVT Term for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up QVT Term in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

QVT/Term is the recommended name.
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4 Click QVT/Term > Edit.

5 Click Script, then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling QVT Term for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Enter a name for the emulator, select Generic as the emulator type, then click OK.

QVT/Term is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the term.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

Type 2024.

Input IDs

Type 2022.

5 Click OK > Done.

6 Double-click QVT/Term in the Available Applications list, select QVT/Term from the 
Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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23 Single Sign-On for SDI TN3270 Plus

This section can help you enable SDI* TN3270 Plus for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up SDI TN3270 Plus in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

TN3270 Plus is the recommended name.
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4 Click TN3270 Plus > Edit.

5 Click Script, then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling SDI TN3270 Plus for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Enter a name for the emulator, select WinHLLAPI as the emulator type, then click OK.

TN3270 Plus is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the tn3270.exe file.

Home Directory

This is the home directory of the emulator.

HLLAPI.DLL

This is the path to the whllapi.dll file.

HLLAPI Function

Type WinHLLAPI.

Session File

This is the IP address of the host that you want to connect to.

5 Click OK > Done.

6 Double-click TN3270 Plus in the Available Applications list, select TN3270 Plus from the 
Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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24 Single Sign-On for TinyTerm V2.0

This section helps you enable TinyTerm* for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up TinyTerm in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

TinyTerm is the recommended name.

4 Select TinyTerm, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling TinyTerm for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

TinyTerm is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the WTT.exe file.

Host Name

This is the name of the emulator session you want to connect to.

Output IDs

\Alt+e,c

Output Offsets

500,7000

Windows Classes

CS_MAIN_CLASS

5 Click OK, then click Done.

6 Double-click TinyTerm in the Available Applications list, select TinyTerm from the Emulator 
drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches, and the user is logged in to the session.
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25 Single Sign-On for ViewNow 1.01

This section can help you enable ViewNow 1.01for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up ViewNow 1.01 in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

ViewNow is the recommended name.
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4 Click ViewNow > Edit.

5 Click Script, then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK and then close SecureLogin.

Enabling ViewNow 1.01 for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Enter a name for the emulator, select WinHLLAPI as the emulator type, then click OK.

ViewNow is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the nsterm.exe file.

Home Directory

This is the home directory of the emulator.

HLLAPI.DLL

This is the path to the whllapi.dll file.

HLLAPI Function

Type WinHLLAPI.

5 Click OK > Done.

6 Double-click ViewNow in the Available Applications list, select ViewNow from the Emulator 
drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
168   Configuration Guide for Terminal Emulators



Manual (99a) 3/17/03103Novell Confidential wdrumba.fm last saved  4/2/03
26 Single Sign-On for Wall Data Rumba 2000

This section can help you enable Wall Data* Rumba* 2000 for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Wall Data Rumba 2000 in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Rumba 2000 is the recommended name.
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4 Click Rumba 2000 > Edit.

5 Click Script, then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling Wall Data Rumba 2000 for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Enter a name for the emulator, select WinHLLAPI as the emulator type, then click OK.

Rumba 2000 is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the rumbawsf.exe file.

Home Directory

This is the home directory of the emulator.

HLLAPI.DLL

This is the path to the whllapi.dll file.

HLLAPI Function

Type WinHLLAPI.

Session Files

This is the path to the session file that you want to use.

5 Click OK > Done.

6 From the Rumba toolbar, click Options > API.

7 Edit the API options by typing a short name in the DDE Topic Name text box, then click OK.
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8 From the Rumba toolbar, click Connection > Configure.

9 Check the Auto Connect check box, then click OK.

10 Save the file by using the short name you typed in Step 7.
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11 Run Terminal Launcher.

12 Double-click Rumba 2000 in the Available Applications list, select Rumba 2000 from the 
Emulator drop-down list, then click OK.

13 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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27 Single Sign-On for WinComm 2000 V5.2

This section helps you enable WinComm 2000 V5.2 for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up WinComm 2000 in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

WinComm 2000 is the recommended name.

4 Select WinComm 2000, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling WinComm 2000 for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

WinComm 2000 is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the wc52.exe file.

Host Name

This is the name of the emulator session you want to connect to.

Output IDs

\Alt+e,c

Output Offsets

500,7500

Windows Classes

twmainS

5 Click OK, then click Done.

6 Double-click WinComm 2000 in the Available Applications list, select WinComm 2000 from 
the Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
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28 Single Sign-On for Windows Telnet

This section can help you enable Windows Telnet for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Windows Telnet in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Windows Telnet is the recommended name.
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4 Click Windows Telnet > Edit.

5 Click Script, then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling Windows Telnet for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Enter a name for the emulator, select Advanced Generic as the emulator type, then click OK.

Windows Telnet is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the telnet.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

Type \n.

Output Offsets

Type 400,3000.

Windows Classes

Type ConsoleWindowClass.

5 Click OK > Done.

6 Double-click Windows Telnet in the Available Applications list, select Windows Telnet from 
the Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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29 Single Sign-On for Window VT TE

This section can help you enable Window VT TE for single sign-on through Novell® SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up Window VT TE in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.

3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Window Telnet VT is the recommended name.
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4 Click Window Telnet VT > Edit.

5 Click Script, then type the following script:
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The script is case sensitive. The omission of the “L” in login and the “P” in password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin”. After the script detects the text “ogin”, 
the script enters the value of the variable $Username.

6 Click OK > OK, then close SecureLogin.

Enabling Window VT TE for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Enter a name for the emulator, select Generic as the emulator type, then click OK.

Window Telnet VT is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the emulator.exe file.

Host Name

This is the name or IP address of the server that you want to connect to.

Output IDs

Type 1043, 1074.

Input IDs

Type 1010.

Check the Emulator Is 16 Bit check box.

WndClass

Type TNVT.

5 Click OK > Done.

6 Double-click Window Telnet VT in the Available Applications list, select Window Telnet VT 
from the Emulator dropdown list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

The emulator launches, the username and password are automatically entered, and the user is 
logged in to the session.
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30 Single Sign-On for WRQ Reflection V7.0

This section helps you enable WRQ Reflection* V7.0 for single sign-on through Novell® 
SecureLogin.

If you haven’t already created and configured an emulator session, see Chapter 1, “Creating and 
Configuring a New Emulator Session,” on page 7. If you have already configured a session, take 
note of the filename and continue.

Setting Up WRQ Reflection in SecureLogin
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click New.
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3 Select New Application, type a name in the Name box, select Terminal Launcher as the type, 
then click Create.

Reflection 7 is the recommended name.

4 Select Reflection 7, then click Edit.

5 Click the Script tab, then type the following script:
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The script is case-sensitive. The omission of the “L” in Login and the “P” in Password allows 
the script to work regardless of whether the “L” and the “P” are displayed in uppercase or 
lowercase type. The script waits for the text “ogin.” After the script detects the text “ogin,” 
the script enters the value of the variable $Username.

6 Click OK, click OK again, then close SecureLogin.

Enabling WRQ Reflection for Single Sign-On
1 Run Terminal Launcher, then click Edit Available Emulators.
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2 Click New.

3 Type a name for the emulator, select Generic as the emulator type, then click OK.

Reflection 7 is the recommended name.

4 Configure the emulator:

Emulator Path
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This is the path to the r2win.exe file.

Host Name

This is the name of the emulator session you want to connect to.

Output IDs

\Alt+e,a\Alt+e,cc

Windows Classes

r2Window

5 Click OK, then click Done.

6 Double-click Reflection 7 in the Available Applications list, select Reflection 7 from the 
Emulator drop-down list, then click OK.
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7 Enter login data.

The first time that the script is run, SecureLogin prompts the user to enter a username and 
password.

Enter the Username.
Enter the Password.
Click OK.

When the user clicks OK, the emulator launches and the user is logged in to the session.
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31 Configuring an Advanced Generic Emulator

SecureLogin can provide single sign-on from a user's workstation to mainframe and UNIX 
systems. For this to happen, SecureLogin must be plugged in to the emulator that the user uses to 
connect to this system. Terminal Launcher (tlaunch.exe) provides this connectivity.

Where Terminal Launcher Fits In
Terminal Launcher acts as the translator between the SecureLogin single sign-on login sequence 
and a user's specific variables (for example, the username and password). Terminal Launcher 
coordinates the information being entered onto a mainframe or Telnet screen.

The following figure illustrates Terminal Launcher’s main window.

You can configure Terminal Launcher to work with several different terminal emulators, launch 
the terminal session, and then run a script to log the user in to the system. You can use Terminal 
Launcher to navigate the user to a particular subsystem or menu within an application. 

Terminal Launcher can perform any keystrokes within an application that a user can do manually. 
At the corporate level, all who log in can use the same script. Only the username, password, and 
other login-specific variables change.
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Terminal Launcher is preconfigured for numerous emulators. As a first preference, you should use 
these preconfigurations. If the emulator you want to use is not preconfigured, browse the chapters 
in this Guide. If the chapters don’t have the information you need, use this section to manually 
configure the emulator. 

Emulator Types
Terminal Launcher is designed to work with three different classes of emulators:

“HLLAPI Emulators” on page 202

“VBA Emulators” on page 202

“Generic Emulators” on page 202

Terminal Launcher also works with some special-case emulators, such as TeraTerm and GLink.

HLLAPI Emulators
HLLAPI (High Level Language Application Programming Interface) emulators are designed to be 
easy to interface with. HLLAPI functions allow external programs, such as SecureLogin, to 
interact with and control the emulator.

HLLAPI emulators can often be configured as Generic emulators. However, generic configuration 
offers limited functionality.

For more information on configuring an HLLAPI emulator, see Type Commands Used with 
Terminal Launcher.

VBA Emulators
VBA emulators support the Visual Basic* scripting language. In most cases, it is possible to write 
a macro for the emulator. The macro prompts SecureLogin to enter credentials.

Configuring VBA emulators to work with Terminal Launcher is a specialized field and is specific 
to each emulator.

VBA emulators can often be configured as Generic emulators. However, generic configuration 
offers limited functionality.

Generic Emulators
Generic emulators don’t feature HLLAPI support or VBA script support. Terminal Launcher 
interfaces with generic emulators though the Windows Clipboard by copying and pasting.

Because an emulator doesn’t have to be programmed to allow external programs to interface with 
it, almost any emulator can be configured as a generic emulator.

Terminal Launcher supports two classes of generic emulators:

 “Normal Generic Configuration” on page 203

 “Advanced Generic Configuration” on page 203
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Normal Generic Configuration

Normal generic emulators have Select All, Copy, and Paste functions available. These functions 
are most often found in the Edit menu, which is at the top of the emulator screen. However, buttons 
or keyboard shortcuts may be available.

Terminal Launcher uses these functions to interface with the emulator. Upon running a 
WaitForText command in a script, Terminal Launcher repeatedly simulates the selection of Select 
All, then Copy, which places the content of the emulator’s screen on the Windows Clipboard. 
Terminal Launcher then searches the content of the Clipboard for the text it is waiting for. 

If the text is not found, Terminal Launcher repeats the procedure, which usually takes about half a 
second.

If Terminal Launcher finds the text it is looking for, Terminal Launcher goes to the next line of the 
script, which is most often a Type command. The Type command is used to enter a username or 
password. To enter the text into the emulator, it is possible to configure Terminal Launcher to type 
the text in, or to use the Clipboard.

When using the Clipboard, Terminal Launcher copies the text (for example, a username) to the 
Clipboard and then simulates the selection of the Paste function of the emulator. This procedure 
copies the text to the screen of the emulator. When using the direct typing method, Terminal 
Launcher simulates pressing the applicable keys on the keyboard.

The process is then repeated for the password, and the user’s login to the mainframe session is 
complete.

Advanced Generic Configuration

Advanced generic emulators have Copy and Paste functions, but do not have a Select All function.

For advanced generic emulators, Terminal Launcher follows the same process as for normal 
generic emulators, except for one difference. Instead of simulating the selection of Select All, 
Terminal Launcher clicks and drags the mouse cursor over the emulator screen. This procedure 
selects all the text that the emulator is displaying.

From there, the same process is followed.

Finding the Input and Output IDs of an Emulator
Every option (for example, File and Edit) in an emulator’s menu has a unique Control ID number. 
Terminal Launcher uses these IDs to simulate the selection of options.

Terminal Launcher uses

The IDs of the Select All and Copy functions as the Output IDs

The ID of the Paste function as the Input ID

To find these numbers, use Spy++, a Microsoft* utility.

Setting Up Spy++
FTP Software’s PCTCP Window Telnet VT v3.1 emulator will be used for all screen shots and 
examples in this section.

1 Launch the Emulator normally.
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2 Launch Spy++.

3 Arrange the windows so that emulator window and Spy++ window are fully visible on the 
screen.

4 In the Spy++ window, click the Message Log button (the fourth button from the left).

5 In the Message Options dialog box, click and hold the Finder Tool, drag the target icon from 
its position on the Spy++ dialog box to the title bar of the emulator, and then release the mouse 
button.
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6 Click Messages > Clear All.

7 From the Messages to View list, click WMCommand, then click OK.

A new, blank window appears in Spy++. Spy++ is now ready to watch for any ID numbers that are 
passed by the emulator.
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Adding the IDs
1 Click Edit > Select All in the emulator’s menu.

If the emulator does not have a Select All option, use Copy instead.

Note that a line of text has appeared in the Spy++ window. This line contains the ID of the 
Select All command. In this example, the ID is 209.
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2 Click Edit > Copy, and then Edit > Paste in the emulator. 

Two more lines appear in Spy++. 

These are the Control IDs of the Copy and Paste functions. In this example, the IDs are as 
follows:

Take note of the ID numbers for the emulator that you are configuring. Terminal Launcher 
needs them.

If the emulator only has Copy and Paste, take note of the two ID numbers. If emulator doesn’t 
have a Select All function, you must configure the emulator as an Advanced Generic 
emulator.

Using Alternatives to Control ID Numbers
In the following situations, use an alternative to Control ID numbers:

If an emulator doesn’t have standard Control IDs. Either no IDs are present or all functions 
have the same ID.

If the Control IDs in the Terminal Launcher configuration don’t work.

If you don’t have access to software such as Spy++ to find the Control IDs.

The alternatives simulate key presses or keyboard shortcuts that achieve the same outcome.

For example, if the Select All Control ID 209 and the Copy Control ID 205 don’t work with 
Terminal Launcher, try any of the following alternatives in the Output IDs text box.

Function Control ID

Select All 209

Copy 205

Paste 207
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Alternative One

\Alt+E,S,\Alt+E,C

This output simulates the following:

Alt+E (displays the Edit menu list)

S (selects Select All)

Alt+E (brings up the Edit menu list)

C (selects Copy)

Keys are not case-sensitive.

Alternative Two

\Ctrl+a,\Ctrl+c

This output simulates the following:

Control+A (a keyboard shortcut for Select All)

Control+C (a keyboard shortcut for Copy)

Alternative Three

\Alt+e,\|40,\|40,\N,\Alt+e,\N

This output simulates the following:

Alt+E (displays the Edit menu list)

Down-arrow

Down-arrow (scrolls down to Select All)

Enter (selects Select All)

Alt+E (displays the Edit menu list)

Enter (selects Copy)

All of these alternatives might or might not work with particular emulators. They will all need 
customizing to suit the emulator. You can adapt the alternatives to suit any requirement (for 
example, selecting other menu items).

Finding a Terminal Launcher configuration, including finding alternatives to the Control IDs, 
requires trial and error, which becomes easier with experience.

When you use alternatives, the increased number of steps slows the Terminal Launcher process 
slightly.

Scenario for Using an Alternative: The Select All Control ID of 209 and the Copy Control ID 
of 205 don’t work with Terminal Launcher. You try Alternative 1 in the Output ID’s text box.
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Configuring an Emulator
To configure an emulator, configure Terminal Launcher and then write an emulator script

Configuring Terminal Launcher
The steps for a generic emulator and an advanced generic emulator are mostly the same. The one 
difference is in Step 5, where you configure output IDs, input IDs, and other parameters.

1 Run Terminal Launcher (tlaunch.exe).

Either use the shortcuts placed on the Start menu by the installation program, or manually 
execute C:\Program Files\Protocom\SecureLogin\TLaunch.exe.

2 At Terminal Launcher’s main screen, click Edit Available Emulators.

3 At the Available Emulators screen, click New.

4 Enter a name for the emulator, select the Type, then click OK.

For a normal generic emulator, select Generic. For an advanced generic emulator, select 
Advanced Generic.

5 Configure the emulator.

To configure a normal generic emulator, set the following parameters:
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Emulator path

This is the directory path and executable filename of the emulator. Either type the path or 
use the Browse button located to the right of the text box. Occasionally, configurations 
will not work if the Emulator Path does not follow the 8.3 filename format.

In the example, the Emulator Path is C:\Pctcp\WTNVT.EXE.

Host Name

This is the IP address, host name, or emulator session file you want Terminal Launcher 
to connect to or load. Occasionally, emulators require command line switches before they 
accept connection commands at startup. If so, put the switches in the Host Name text box.

Scenario for Including a Command Line Switch: An emulator requires the /h switch 
so that the emulator can accept an IP address at startup. Henri types /h 192.168.130.222 
in the Host Name text box:

Because the example emulator does not need switches, the Host Name in the example is 
192.168.130.222.

Output IDs

The Output IDs are the Select All and Copy function IDs that were found earlier using 
Microsoft Spy++. Type them in the text box, using the following syntax:

xxx,xxx

For this example, you would type 209,205. The Select All ID is followed by a comma (no 
space) and then the Copy ID.

This is where you use a keyboard simulation alternative, if necessary.

Input IDs

The Input ID is the Paste function ID that was found earlier using Microsoft Spy++. Type 
it in the text box. 

For this example, you would type 207.

This is also where you use a keyboard simulation alternative, if necessary.

Emulator is 16 Bit

Check this check box if the emulator is a 16-bit program.
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WndClass

The WndClass text box only becomes available if the emulator is a 16-bit program. To 
find the window class, use the Window Finder tool, which is supplied with SecureLogin.

Right-click and drag the SecureLogin icon onto the title bar of the emulator. The Window 
Class is displayed in the third text box from the top. Copy and paste text from the Window 
Class text box into the WndClass text box in Terminal Launcher.

The following figure illustrates the complete Terminal Launcher configuration for this 
example (Window Telnet VT v3.1 emulator):

To configure an advanced generic emulator, set the following parameters:
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Emulator Path

The emulator path is the directory path and executable filename of the emulator. 
Either type the path or use the Browse button located to the right of the text box. 
Occasionally, configurations won’t work if the Emulator Path does not follow the 8.3 
filename format.

In the example, the Emulator Path is C:\PCTCP\WTNVT.EXE.

Host Name

The Host Name is the IP address, host name, or emulator session file you want 
Terminal Launcher to connect to or load. Occasionally, emulators require command 
line switches before they will accept connection commands at startup. If so, put the 
required switches in the Host Name text box.

Scenario for Including a Command Line Switch: An emulator requires the /h 
switch so that the emulator can accept an IP address at startup. Henri configures the 
advanced generic emulator by typing /h 192.168.130.222 in the Host Name text box.

Because the example emulator does not need switches, the Host Name in the 
example is 192.168.130.222.

Output IDs

The Output ID is the Copy function Control ID that was found earlier using 
Microsoft Spy++. Type this ID in the text box. 

For this example, you would type 205.

This is where you use a keyboard simulation alternative, if necessary.

Input IDs

This is the Paste function Control ID that was found earlier using Microsoft Spy++. 
Type it in the text box.

For this example, you would type 207.

This is also where you use a keyboard simulation alternative, if necessary.
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An Input ID is not always required. Most emulators allow Terminal Launcher to type 
text directly into them.

Output Offset

For Terminal Launcher to select the text on the screen without a Select All function, 
Terminal Launcher needs to use the mouse to click and drag the cursor over the entire 
emulator screen to select all the text.

For Terminal Launcher to do this correctly, it needs to be told how much space to 
allow for the toolbar (or other items) when it starts the drag. This is what the Output 
Offset is. It tells Terminal Launcher where to start the click and drag process.

The Output Offset is a set of two numbers, separated with a comma and no space. 
The numbers can be from zero up to tens of thousands. However, 10,000 is generally 
the highest number that is needed.

Finding the Output Offset generally takes a bit of trial and error, and gets easier with 
experience. Start with high numbers (for example, 10000,10000) and work your way 
down.

The first number is the horizontal offset. The second number is the vertical offset. 
Notice where the mouse starts with the click and drag, and lower the numbers until 
it clicks in the top left corner of the emulator screen.

Normally, the Output Offset number is somewhere around 500,7000 or lower.

For this example, the Output Offset is 500,7000.

Startup IDs

Startup IDs are the Control ID numbers of any functions or buttons that you want 
Terminal Launcher to select before attempting to log in. For example, if the emulator 
does not automatically connect, provide a control ID for a Connect button.

If several functions or buttons are needed, separate them with a comma.

This example does not require startup IDs.

Window Class

The Window Class setting is used to assist Terminal Launcher in detecting the 
emulator window. If no window class is specified, Terminal Launcher might not 
detect the emulator opening.

To find the window class, use the Window Finder tool. Load the Window Finder and 
then right-click and drag the SecureLogin icon to the title bar of the emulator.

The window class that is used for an advanced generic configuration is displayed in 
the Class Name text box, as indicated in the following figure.
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Copy and paste the window class exactly as it is displayed. Copy it into the Window 
Class text box of the Terminal Launcher configuration. Window Class text boxes are 
case-sensitive.

In this example, the window class is TNVT.

Child ID

A Child ID is given to each “child” window that the main application launches. The 
following figure illustrates a child window:

Enter a Child ID into the Terminal Launcher configuration only if it is necessary to 
interact with a child window.
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This example does not require a Child ID.

Window Title

The Window Title setting is used to assist Terminal Launcher in detecting the 
emulator window. If no Window Title text is specified, Terminal Launcher might not 
detect the emulator opening.

The window title is found by using Window Finder.

Some emulators hide the real window title. For example, the title bar of the PCTCP 
emulator displays the text shown in the Window Text text box. However, the real 
window title is displayed in the Window Title text box.

No rule describes which text you should type into the Terminal Launcher 
configuration. (The text you need depends on how it is hidden by the emulator). First, 
try using the configuration without any text in the Window Title text box. If that 
doesn’t work, try typing the text that is actually displayed in the title bar of the 
emulator. If that doesn’t work either, try typing the text found in the Window Title 
text box.

This example doesn’t require Window Title text.

6 Click OK, then click Done.

Writing an Emulator Script
After you configure Terminal Launcher, write a script that Terminal Launcher will use to launch 
and log in to the emulator.

1 Right-click the SecureLogin system tray icon, click Manage Logins, then click New.

2 Select New Application, then enter a name for the emulator script
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3 Select Terminal Launcher as the type, then click Create.

The new script appears in the Application pane.

4 Double-click the script, then click the Script tab.

5 Enter a script for the emulator.

For scripting assistance, see Administering Scripts in the Novell SecureLogin Administration 
Guide and Script Commands.

6 Click OK, then click OK.

Testing the Configuration
1 Run Terminal Launcher (tlaunch.exe).

2 Double-click your script in the Available applications list, select your emulator from the 
Emulator drop-down list, then click OK.
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The emulator launches and Terminal Launcher logs in to the session. The first time that the 
configuration runs, provide your credentials to Terminal Launcher.

For information on troubleshooting, see Chapter 32, “Troubleshooting,” on page 219 and 
Troubleshooting SecureLogin in the Novell SecureLogin Administration Guide.
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32 Troubleshooting

This section provides troubleshooting tips for terminal emulation. For other troubleshooting 
information about SecureLogin, see Troubleshooting SecureLogin in the Novell SecureLogin 
Administration Guide.

The Emulator Didn’t Launch
Problem: The emulator did not launch at all, or gave errors upon loading.

Possible Cause: Either the Emulator Path or the Host Name was incorrectly specified in the 
configuration.

Possible Action

Convert the path so that it follows the 8.3 filename format.

Specify the correct .EXE file.

Provide a valid Host Name.

Provide a command line switch so that the emulator can load a connection on startup.

Handling Error Messages
Problem: Terminal Launcher gave an error message when attempting to launch the 
emulator

Possible Action

Locate the error number, with possible causes and actions, in Error Codes for SecureLogin in 
Troubleshooting SecureLogin, in the Novell SecureLogin Administration Guide.

Terminal Launcher Didn’t Detect the Emulator
Problem: The emulator launched, but Terminal Launcher did not detect it loading.

Possible Action

Specify more information about the emulator in the configuration. Add or remove some or all of 
the following details:

Window Class

Window Title

Child ID
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No Connection to the Host
Problem: The emulator loaded but did not connect to the host.

Possible Cause: The emulator failed to recognize the commands that were sent in the command 
line. To launch the emulator, Terminal Launcher joins the Host Name content to the end of the 
Emulator Path and then passes this joint information to a run command.

If the emulator requires any additional switches or information on the command line for it to 
connect to the host upon loading, this information must be specified in the Terminal Launcher 
configuration.

Possible Action

Place any command line switches that are required by the emulator into the Host Name text 
box in the Terminal Launcher configuration.

Enter the Control ID of the Connect button in the Startup ID section of the configuration.

Not Finding the Prompt Text on the Screen
Problem: The emulator loaded and connected to the host. Terminal Launcher detected the 
emulator but is not finding the prompt text on the screen.

Possible Cause: Something is not correct in your Output ID settings or the Output Offset settings.

Possible Action

Check the Select All and Copy Control IDs.

Check any keyboard simulation alternatives that you are using.

Check the Output Offset numbers.

Make sure that the script is correct.

The Emulator is Not Entering the Credentials
Problem—The emulator loaded and connected to the host. Terminal Launcher detected the 
emulator and found the prompt text on the screen, but it is not entering the credentials.

Possible Cause—Something is not correct in your Input ID settings.

Possible Action

Check the Paste Control ID.

Check any keyboard simulation alternatives you are using.

Put in or take out any content you have in the Input ID section of the configuration.
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A What’s New or Updated

This section contains new or updated information on terminal emulators. The information is new 
since SecureLogin 3.0.3.

This documentation is also provided on the Web in two formats: HTML and PDF. The HTML and 
PDF documentation are both kept up-to-date with the documentation changes listed in this section. 
See SecureLogin 3.0 (http://www.novell.com/documentation/lg/securelogin30/index.html).

If you need to know whether a copy of the PDF documentation you are using is the most recent, 
check the date that the PDF file was published. The date is in the Legal Notices section, which 
immediately follows the title page.

This guide was updated on the following dates:

“November 21, 2002” on page 221

“December 11, 2002” on page 222

November 21, 2002
The following sections were added: 

Chapter 4, “Single Sign-On for Absolute Telnet v1.84,” on page 25

Chapter 2, “Single Sign-On for AccuTerm 2000,” on page 13

Chapter 5, “Single Sign-On for Attachmate KEA,” on page 31

Chapter 6, “Single Sign-On for Attachmate Personal Client,” on page 37

Chapter 7, “Single Sign-On for CRT 3.4,” on page 43

Chapter 9, “Single Sign-On for HBO Star Navigator,” on page 55

Chapter 12, “Single Sign-On for IDX Term 2.25,” on page 83

Chapter 14, “Single Sign-On for Lawsons,” on page 95

Chapter 17, “Single Sign-On for MS Windows 2000 Telnet,” on page 113

Chapter 15, “Single Sign-On for MiniSoft WS92,” on page 101

Chapter 20, “Single Sign-On for PCXWare,” on page 131

Chapter 21, “Single Sign-On for PowerTerm V6.34,” on page 135

Chapter 24, “Single Sign-On for TinyTerm V2.0,” on page 157

Chapter 27, “Single Sign-On for WinComm 2000 V5.2,” on page 177

Chapter 30, “Single Sign-On for WRQ Reflection V7.0,” on page 195

Chapter 31, “Configuring an Advanced Generic Emulator,” on page 201
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December 11, 2002
Two topics were moved from the Attachmate Extra! 2000 module into the new Creating and 
Configuring a New Session section. See Chapter 1, “Creating and Configuring a New Emulator 
Session,” on page 7. 

All modules (sections on specific emulators) link to Creating and Configuring a New Section.
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