ZENworks 2017 Update 4 System Requirements

1.0 Primary Server Requirements

Ensure that the server where you install the Primary Server software meets the following requirements:

NOTE:The operating systems listed below are the ones on which the ZENworks Primary Server software can be installed. The list does not necessarily represent the operating systems that ZENworks Patch Management can update. For this list, see the ZENworks Patch Management Content Report.

Item

Requirements

Additional Details

Server Usage

Your server might be capable of handling tasks in addition to the tasks that a Primary Server performs. However, we recommend that any server where you install the Primary Server software be used only for ZENworks.

For example, you might not want the server to do the following:

  • Host NetIQ eDirectory

  • Host Active Directory

  • Host Terminal Services

Operating System Windows

  • Windows 2012 Server x86_64 (Foundation, Essential, Standard, and Datacenter editions)

  • Windows 2012 Server R2 x86_64 (Foundation, Essential, Standard, and Datacenter editions)

  • Windows 2016 Server x86_64 (Essential, Standard, Datacenter and Storage editions)

Installation on a server in a clustered environment is not supported.

Operating System Linux

  • SLES 11 SP3 x86_64

  • SLES 11 SP4 x86_64

  • SLES 12 x86_64

  • SLES 12 SP1 x86_64

  • SLES 12 SP2 x86_64

  • SLES 12 SP3 x86_64

  • SLES 12 SP4 x86_64

IMPORTANT:

  • SLES 12 requires the libXtst6-32bit-1.2.2-3.60.x86_64.rpm to install ZENworks Server. This rpm is available on the SLES 12 media.

  • Remote management is not supported on Linux devices at runlevel 3 (text-only, no X server).

  • If ZENworks is already installed on the system, do not perform a major in-place upgrade of the operating system (for example, from SLES 11 SP4 to SLES 12) as this might cause issues and the Primary Servers might have to be replaced.

    For information on how to replace the servers, see Replacing Primary Servers in the ZENworks Disaster Recovery Reference.

Processor

Speed:2.0 GHz or faster

Type: Quad-core or faster

 

RAM

8 GB minimum; 12 GB and above recommended

8 GB for the first 3000 devices

Add 1 GB RAM for every 3000 additional devices

Disk Space

20 GB for installation. Depending on the amount of content you need to distribute the space.

For ZENworks database add 10 GB for every 1000 devices and for Audit database add 10 GB for every 5000 devices.

500 MB is recommended for the tmp directory. This disk space is required for rebuilding and editing the packages.

Patch Management file storage (downloaded patch content) requires at least 25 GB of additional free disk space. All content replication servers also require this same amount of additional free disk space if Patch Management is enabled. If you use Patch Management in additional languages, each server also requires this additional amount of free space for each language.

Because the ZENworks database file and ZENworks content repository can each become very large, you might want a separate partition or hard drive available.

For information on changing the default content repository location on a Windows server, see Content Repository in the ZENworks Primary Server and Satellite Reference.

For Linux servers, you might want the /var/opt directory to be located on a large partition. This is where the database (if embedded) and content repository are stored.

The /etc directory requires less space.

Display Resolution

Video Adaptor: 256 colors

Screen Resolution: 1024 × 768 minimum

 

File System

If you have installed embedded Sybase on your device, ensure that the file system of the drive where you have installed ZENworks Configuration Management supports files larger than 4 GB.

 

DNS Resolution

The servers and workstations in the Management Zone must use properly configured DNS to resolve device hostnames; otherwise, some features in ZENworks will not work properly. If the DNS is not properly configured, the servers cannot communicate with each other, and the workstations cannot communicate with the servers.

Server names must support DNS requirements, such as not including underscores; otherwise, ZENworks login fails. Acceptable characters include the letters a-z (uppercase and lowercase), numbers, and the hyphen (-).

NOTE:If the host name of a Linux Primary Server contains upper case characters, the server host name should be included in the /etc/hosts file located on that server.

 

IP Address

The server must have a static IP address or a permanently leased IP address in the case of DHCP configuration.

An IP address must be bound to all NICs on your target server.

Installation hangs if it is trying to use a NIC that does not have an IP address bound to it.

Microsoft .NET (Only for Windows)

The Microsoft.NET 4.5 Framework and its latest updates must be installed and running on the Windows Primary Server in order to install ZENworks 2017.

Ensure that the full.NET 4.5 Framework is installed on the device and not the.NET 4.5 Client Profile.

On Windows Server 2012, .NET 4.5 is available by default. However, you need to enable it. You are given the option to enable .NET during the ZENworks installation. If you select the option, .NET is automatically enabled.

Firewall Settings: TCP and UDP Ports

Many TCP and UDP ports are opened by the ZENworks Installer during installation. If a port required by ZENworks is in use, the ZENworks Installer prompts you to configure an alternate port.

IMPORTANT:If the firewall is disabled during installation or upgrade, ensure that you manually open the ports in the firewall settings when the firewall is enabled.

For the list of TCP and UDP ports and how ZENworks uses them, see TCP and UDP Ports Used by ZENworks Primary Servers in the ZENworks Primary Server and Satellite Reference.

Supported Hypervisors

Primary server software can be installed in the following virtual machine environments:

  • XEN on SLES 11 SP4, SLES 12 and SLES 12 SP1, SP2, SP3

  • VMware ESXi 6.x

  • Microsoft Hyper-V Server Windows 2012, 2012 R2 and 2016.

  • Only released versions of guest operating systems (VMs) are supported. Experimental guest operating systems are not supported.

  • The guest operating system must match the operating system specified when creating the VM. For example, if during creation of the VM, the guest operating system is specified as Windows Server 2012, the actual guest operating system must be Windows Server 2012.

2.0 Virtual Appliance Requirements

Item

Requirement

Additional Details

ZENworks Virtual Appliance

  • RAM: 8 GB recommended

  • Disk Space: 60 GB minimum

ZENworks Virtual Appliance can be deployed in the following virtual machine environments:

  • VMware ESXi 6.x

  • Microsoft Hyper-V Server Windows 2012, 2012 R2, 2016

  • XEN on SLES 12 and the support packs.

Deployment of ZENworks Virtual Appliance is not supported on:

  • Citrix XenServer

3.0 Managed Device Requirements

The ZENworks Agent is the management software that is installed on all managed devices, including Primary Servers.

NOTE:The operating systems listed below are the ones on which the ZENworks Agent software can be installed. The list does not necessarily represent the operating systems that ZENworks Patch Management can update. For this list, see the ZENworks Patch Management Content Report.

3.1 Windows Managed Device Requirements

ZENworks 2017 can manage any Windows workstation and server that meets the following requirements. If you plan to use ZENworks Full Disk Encryption on a managed device, the device must meet the additional requirements listed in System Requirement in the ZENworks Full Disk Encryption Agent Reference.

Item

Requirements

Additional Details

Operating System: Windows Servers

  • * Windows Server 2008 SP2, x86, x86_64 (Standard, Enterprise, Datacenter)

  • * Windows Server 2008 R2

  • Windows 2008 R2 Server SP1 x86_64 (Standard, Enterprise, Datacenter)

  • Windows 2012 Server x86_64 (Foundation, Essential, Standard, Datacenter)

  • Windows 2012 R2 Server x86_64 (Foundation, Essential, Standard, Datacenter)

  • Windows 2016 Server x86_64 (Essential, Standard, Datacenter and Storage)

  • Windows 2019 Server x86_64 (Essential, Standard, Datacenter and Storage)

  • Window 10 enterprise LTSC 2019

IMPORTANT:* Indicates that the Windows Server 2008 SP2 and Windows Server 2008 R2 SP0 are supported in the backward compatibility mode (with an older version of the agent installed on them).

In the backward compatibility mode, the 11.x version of the agent cannot be updated, however, it can be managed. You can also register new managed devices and Satellite Servers with the older versions of the agent to the zone, and manage them, but you cannot upgrade the older agents.

 

Operating System: Windows Workstations

  • Windows 7 SP1 x86, x86-64 (Professional, Ultimate, and Enterprise editions)

  • Windows Embedded 7 SP1

  • Windows 8 x86, x86_64 (Professional and Enterprise editions)

  • Windows Embedded 8

  • Windows 8.1 Enterprise and Professional x86 and x86_64

  • Windows Embedded 8.1

  • Windows 10 x86, x86_64 (Professional, Enterprise, Education, up to the 1809 version)

  • Windows 10 x86, x86_64 (Up to the 2016 Enterprise and 2016 LTSB editions)

  • Windows 2019 Server x86_64 (Essential, Standard, Datacenter and Storage)

  • Window 10 enterprise LTSC 2019

  • Windows Embedded 10 (LTSB edition)

  • * Windows XP SP3 x86 (Professional and Enterprise)

IMPORTANT:

  • Prior to installing or updating the agent, you need to ensure that Microsoft .NET 4.5 Framework and its latest updates are installed and running on the Windows managed device.

  • * Indicates that Windows XP is supported only in the backward compatibility mode (only 11.x versions of the agent are supported).

  • Windows 7 SP0 is not supported.

A managed device name must not exceed 32 characters. If a device name exceeds 32 characters, that device is not inventoried. In addition, ensure that the device name is unique so that the device is recognized appropriately in the inventory reports.

IMPORTANT:

  • ZENworks supports Windows 10 that is migrated from older versions (Windows 7, Windows 8, and Windows 8.1).

    Microsoft does not retain the applications from the older versions of Windows to Windows 10 across editions. Hence, ZENworks will not be available if you migrate to Windows 10 from different editions (Windows older versions).

    For example:

    Windows 7 Enterprise to Windows 10 Enterprise or Enterprise LTSB is supported.

    Windows 8 Enterprise to Windows 10 Education is not supported.

    I

Operating System: Thin Client sessions

  • Windows Server 2012 SP2

  • Windows Server 2012 R2 SP1

  • Windows 2016 Server x86_64

  • Citrix XenApp 6.0,6.5,7.x(7.6 onwards)

 

Hardware

The following are minimum hardware requirements. Use these requirements or the hardware requirements provided with your operating system, whichever is greater.

  • Processor: Pentium III 700 MHz, or equivalent AMD or Intel

  • RAM: 256 MB minimum; 1 GB recommended

  • Disk Space: 230 MB minimum for installing; 4GB recommended for running. Depending on the amount of content you need to distribute, this number can vary greatly.

    If an agent is promoted to a content or imaging satellite role, ensure that you increase the disk space accordingly.

  • Display resolution: 1024 × 768 with 256 colors

 

Microsoft .NET

The Microsoft .NET 4.5 framework and its latest updates must be installed and running on the Windows managed device in order to install ZENworks 2017.

On Windows 8, Windows 8.1, and Windows Server 2012, .NET is available by default. However, you must enable the .NET framework before deploying the agent on these devices.

Microsoft Windows Installer

The Microsoft Windows Installer 4.5 or later must be installed and running on the Windows managed device in order to install ZENworks 2017.

If you choose to deploy the PreAgentPkg_AgentCompleteDotNet.exe standalone package, Windows Installer 4.5 is automatically installed. If you choose to deploy the PreAgentPkg_Agent.exe network package or the PreAgentPkg_AgentComplete.exe standalone (.NET required) package, you must manually install Windows Installer 4.5 or later before you begin to install the agent.

TCP Ports

7628

In order to view the status of the ZENworks Agent for a managed device in ZENworks Control Center, ZENworks automatically opens port 7628 on the device if you are using the Windows firewall. However, if you are using a different firewall, you must open this port manually.

Port 7628 must also be opened on the device if you want to send a Quick Task to the client from ZENworks Control Center.

 

5950

For Remote Management where the ZENworks Agent is running, the device listens on port 5950.

You can change the port in ZENworks Control Center (Configuration tab >Management Zone Settings > Device Management > Remote Management).

Remote Management is used only with ZENworks Configuration Management.

Supported Hypervisors

ZENworks managed device software can be installed in the following hypervisors:

  • XEN on SLES (XEN on SLES 11 SP4, SLES 12 SP1, SP2, SP3)

  • VMware ESXi 6.x

  • Microsoft Hyper-V Server Windows 2012, 2012 R2 and 2016.

Only released versions of guest operating systems (VMs) are supported. Experimental guest operating systems are not supported.

The guest operating system must match the operating system specified when creating the VM. For example, if the guest operating system is specified as Windows Vista during creation of the VM, the actual guest operating system must be Windows Vista.

Deployment of ZENworks Virtual Appliance is not supported on the Citrix XenServer

Supported Virtual Desktop Interface

ZENworks managed device software can be installed in the following VDI environments:

  • Citrix XenDesktop 7.x

  • VMware Horizon View 6.x and 7.x

  • Microsoft VDI Windows 2012, 2012 R2, 2016

  • XenDesktop 7.x

  • XenApp 7.x

 

Client for Open Enterprise Server 2 SP4/Novell Client

The Novell Client is not required. However, if you choose to use the Novell Client on the managed device, the following versions are supported with ZENworks:

  • Client 2 SP4 and higher (for Windows 7, 8, 8.1 and Windows 10)

  • Client 2 SP4 and higher (for Windows Server 2008, 2008 R2 and 2012)

 

3.2 Linux Managed Device Requirements

ZENworks 2017 can manage any Linux workstation and server that meets the following requirements:

Item

Requirements

Operating System: Servers

  • SLES 11 SP3 x86_64 (Intel and AMD Opteron processors)

  • SLES 11 SP4 x86_64 (Intel and AMD Opteron processors)

  • SLES 12 SP1 x86_64

  • SLES 12 SP2 x86_64

  • SLES 12 SP3 x86_64

  • SLES 12 SP4 x86_64

  • SLES for SAP Applications 12 SP4

  • SLES 15 x86_64

  • SLES For SAP Applications 15

  • Open Enterprise Server 11 SP1 x86_64

  • Open Enterprise Server 11 SP2 x86_64

  • Open Enterprise Server 2015 (OES 2015) x86_64

  • Open Enterprise Server 2015 SP1 (OES 2015 SP1) x86_64

  • Open Enterprise Server 2018 x86_64

  • OES 2018 SP1

  • openSUSE Leap 42.3,42.4,15

Operating System: Workstations

  • SLED 11 SP3 x86_64 (Intel and AMD Opteron processors)

  • SLED 11 SP4 x86_64 (Intel and AMD Opteron processors)

  • SLED 12 x86_64

  • SLED 12 SP1 x86_64

  • SLED12 SP2 x86_64

    NOTE:SLED 12 SP2 Linux distributions require rpm-python installation as a prerequisite to run the patch scan process. For more information, see the ZENworks 2017 Patch Management Reference.

  • SLED12 SP4 x86_64

  • Red Hat Enterprise Linux 6.7 and 6.8 (RHEL 6.7, RHEL 6.8) x86, x86_64 (AS and ES) s

  • RHEL 7.2, 7.3, 7.5 (without LPM subscriptions)

  • Scientific Linux 6.7, 6.8, x86, x86_64, 7.5

* Indicates that the platform is supported in the backward compatibility mode, with the older version of the agent running on them.

Hardware

  • Processor: Minimum - Pentium IV 2.8 GHz 32-bit (x86) and 64-bit (x86_64), or equivalent AMD or Intel processor

  • RAM: 512 MB minimum; 2 GB recommended

  • Disk Space: 230 MB minimum for installing; 4 GB recommended for running. Depending on the amount of content you need to distribute, this number can vary greatly.

  • Display resolution: 1024 × 768 with 256 colors minimum

Hostname Resolution

  • The server must resolve device hostnames by using a method such as DNS (recommended).

  • Server names must support DNS requirements, such as not having underscores in their names; otherwise, ZENworks login fails. Acceptable characters are the letters a-z (uppercase and lowercase), numbers, and the hyphen (-). If the server host name contains upper case characters, the server host name should be included in the /etc/hosts file located on that server.

    If you use DNS, it must be properly set up, or some features in ZENworks might not work.

IP Address

  • The server must have a static IP address.

  • If you have multiple NICs, we recommend that you bind the IP addresses on all the NICs. However, ZENworks works even if one IP address is configured.

TCP Ports: 7628

You must assign the Network Interface to the firewall zone. Firewall rules are applied to this zone for managing the ports used by ZENworks 2017.

Supported Hypervisors

ZENworks managed device software can be installed in the following hypervisors:

  • XEN (SLES 11, SLES 12)

  • VMware ESXi 6.x

  • Microsoft Hyper-V Server Windows 2012, 2012 R2 and 2016.

In addition, the following requirements apply:

  • Only released versions of guest operating systems (VMs) are supported. Experimental guest operating systems are not supported.

  • The guest operating system must match the operating system specified when creating the VM. For example, if the guest operating system is specified as SLES 12 during creation of the VM, the actual guest operating system must be SLES 12.

3.3 Macintosh Managed Device Requirements

ZENworks can manage Macintosh workstations that run the following operating systems:

*Macintosh 10.8.3 (Mountain Lion)

Item

Requirements

Version

10.8.x

Supported Architecture

64 bit

Hardware

  • Processor Intel Core 2 Duo

  • Disk space: 2 GB recommended for running.

  • Display resolution:1024 × 768 with 256 colors minimum

TCP ports

7628

*Macintosh 10.9.x (Mavericks)

Item

Requirements

Version

10.9.x

Supported Architecture

64 bit

Hardware

  • Processor Intel Core 2 Duo

  • Disk space: 2 GB recommended for running.

  • Display resolution:1024 × 768 with 256 colors minimum

TCP ports

7628

Macintosh 10.10.x (Yosemite)

Item

Requirements

Version

10.10.x

Supported Architecture

64 bit

Hardware

  • Processor Intel Core 2 Duo

  • Disk space: 2 GB recommended for running.

  • Display resolution:1024 × 768 with 256 colors minimum

TCP ports

7628

Macintosh 10.11.x (EL Capitan)

Item

Requirements

Version

10.11.x

Supported Architecture

64 bit

Hardware

  • Processor Intel Core 2 Duo

  • Disk space: 2 GB recommended for running.

  • Display resolution:1024 × 768 with 256 colors minimum

TCP ports

7628

Macintosh 10.12.x (Sierra)

Item

Requirements

Version

10.12.x

Supported Architecture

64 bit

Hardware

  • Processor Intel Core 2 Duo

  • Disk space: 2 GB recommended for running.

  • Display resolution:1024 × 768 with 256 colors minimum

TCP ports

7628

Macintosh 10.13.x (High Sierra)

Item

Requirements

Version

10.13.x

Supported Architecture

64 bit

Hardware

  • Processor Intel Core 2 Duo

  • Disk space: 2 GB recommended for running.

  • Display resolution:1024 × 768 with 256 colors minimum

TCP ports

7628

Macintosh 10.14.x (Mojave)

Item

Requirements

Version

10.14.x

Supported Architecture

64 bit

Hardware

  • Processor Intel Core 2 Duo

  • Disk space: 2 GB recommended for running.

  • Display resolution:1024 × 768 with 256 colors minimum

TCP ports

7628

4.0 Satellite Requirements

A Satellite is a managed device that can perform some of the roles that a ZENworks Primary Server normally performs, including authentication, information collection, content distribution, and imaging. A Satellite can be any managed Windows, Macintosh, or Linux device (server or workstation), but not a Primary Server.

The following sections contain more information:

4.1 Windows Satellite Requirements

A Windows device performing satellite roles must meet the minimum requirements of a Windows managed device, as listed in Section 3.1, Windows Managed Device Requirements with the following exception:

  • Windows Embedded XP is not a supported workstation operating system for Satellite devices.

The following table lists additional Windows Satellite requirements:

Item

Requirements

Additional Details

ZENworks Agent Version

Same version as the ZENworks Primary Server

When you create a Satellite, you designate a ZENworks Primary Server as the parent server for the Satellite. The Satellite’s agent version must be the same version as the parent Primary Server version. For example, the Satellite’s agent version cannot be 11.4.3 if the parent Primary Server version is 2017.

Firewall Settings: Open TCP Ports

80

Used for content replication.

 

443

Used for CASA authentication.

998

Used by Preboot Server (novell-pbserv).

The Preboot Server (novell-pbserv) is used only with ZENworks Configuration Management.

 

7019

Used by Join Proxy.

Firewall Settings: Open UDP Ports

67

Used by proxy DHCP when it is not running on the same device as the DHCP server.

 

69

Used by the Imaging TFTP, but will not work across the firewall because it opens a random UDP port for each PXE device.

The Imaging TFTP is used only with ZENworks Configuration Management.

 

997

Used by the Imaging Server for multicasting.

The Imaging Server is used only with ZENworks Configuration Management.

 

4011

Used for proxy DHCP when it is running on the same device as the DHCP server.Ensure that the firewall is configured to allow the broadcast traffic to the proxy DHCP service.

 

13331

Used by the zmgpreboot policy, but will not work across the firewall because it opens a random UDP port for each PXE device.

The zmgpreboot policy is used only with ZENworks Configuration Management.

4.2 Linux Satellite Requirements

A Linux device performing satellite roles must meet the minimum requirements of a Linux managed device, as listed in Section 3.2, Linux Managed Device Requirements.

The following table lists additional Linux Satellite requirements:

Item

Requirements

Additional Details

ZENworks Agent Version

Same version as the parent ZENworks Primary Server

When you create a Satellite, you designate a ZENworks Primary Server as the parent server for the Satellite. The Satellite’s agent version must be the same version as the parent Primary Server version. For example, the Satellite’s agent version cannot be 11.4.3 if the parent Primary Server version is 2017.

Firewall Settings: Open TCP Ports

80

Used for Tomcat non-secure port.

 

443

Used for CASA authentication.

 

998

Used by Preboot Server (novell-pbserv).

The Preboot Server (novell-pbserv) is used only with ZENworks Configuration Management.

 

7628

Used by the ZENworks Agent.

 

8005

Used by Tomcat to listen to shutdown requests. This is a local port, and cannot be accessed remotely.

 

8009

Used by Tomcat AJP connector.

 

7019

Used by Join Proxy.

Firewall Settings: Open UDP Ports

67

Used by proxy DHCP when it is not running on the same device as the DHCP server.

 

69

Used by the Imaging TFTP, but will not work across the firewall because it opens a random UDP port for each PXE device.

The Imaging TFTP is used only with ZENworks Configuration Management.

 

997

Used by the Imaging Server for multicasting.

The Imaging Server is used only with ZENworks Configuration Management.

 

4011

Used for proxy DHCP when it is running on the same device as the DHCP server. Make sure that the firewall is configured to allow the broadcast traffic to the proxy DHCP service.

 

13331

Used by the zmgpreboot policy, but will not work across the firewall because it opens a random UDP port for each PXE device.

The zmgpreboot policy is used only with ZENworks Configuration Management.

4.3 Macintosh Satellite Requirements

A Macintosh device performing satellite roles must meet the minimum requirements of a Macintosh managed device as listed in Section 3.3, Macintosh Managed Device Requirements.

The following table lists additional Macintosh Satellite requirements:

Item

Requirements

Additional Details

ZENworks Agent Version

Same version as the parent ZENworks Primary Server

When you create a Satellite, you designate a ZENworks Primary Server as the parent server for the Satellite. The Satellite’s agent version must be the same version as parent Primary Server version. For example, the Satellite’s ZENworks Agent version cannot be 11.4.3 if the parent Primary Server version is 2017.

Firewall Settings: Open TCP Ports

80

Used for HTTP non-secure port.

 

7628

Used by the ZENworks Agent.

5.0 Database Requirements

If you choose to use a database for the ZENworks database other than the embedded Sybase SQL Anywhere database that is available as the default for ZENworks 2017, the database must meet the following requirements:

Item

Requirement

Database Version

  • Oracle 11g R2 with version 11.2.0.4 Standard, Enterprise Edition and Oracle RAC (with or without partitioning). For information about partitioning, see Oracle Enterprise with Partitioning.

  • Oracle 12c R1 with version 12.1.0.2 Standard, Enterprise Edition and Oracle RAC (with or without partitioning).

  • Oracle 12c R2 with version 12.2.0.1 Standard, Enterprise Edition and Oracle RAC (with or without partitioning).

    NOTE:If you are planning to use Oracle Real Application Clusters (Oracle RAC) with ZENworks, see the following information:

  • Microsoft SQL 2008 SP3 and higher, including Cluster (Standard and Enterprise editions)

  • Microsoft SQL 2008 R2 and higher, including Cluster (Datacenter, Standard and Enterprise editions)

  • Microsoft SQL Server 2012 SP3 and later, including Cluster (Standard, Enterprise, and Business Intelligence editions)

  • Microsoft SQL Server 2014and later, including Cluster (Standard, Enterprise, and Business Intelligence editions)

  • Microsoft SQL Server 2016, 2016 SP1, including Cluster (Standard and Enterprise editions)

  • Microsoft SQL Server 2017, including Cluster (Standard and Enterprise editions)

  • Sybase Anywhere 17 (and latest Electronic Bug Fix)

  • PostgreSQL 9.5.

  • PostgreSQL 10.x (supported only on an external server)

    NOTE:

    • PostgreSQL 10.x is not supported as an embedded database.

    • Embedded PostgreSQL can support a maximum of 5000 devices and external PostgreSQL can support a maximum of 20,000 devices.

Database Server Hostname

The database server hostname must be resolvable by the Domain Name Server Service.

TCP Ports

The server must allow Primary Server communication on the database port. For MS SQL, ensure that you configure static ports for the database server.

Default Ports:

  • 1433 for MS SQL

  • 2638 for Sybase SQL

  • 2639 for Audit Sybase DB

  • 1521 for Oracle

  • 54327 for embedded PostgreSQL

  • 5432 for external PostgreSQL (you can assign a different port, if required.)

You can change the default port number if there is a conflict. However, you must ensure that the port is opened for the Primary Server to talk to the database.

UDP Ports

1434 for MS SQL (if ZENworks uses named instance of the database)

WAN Consideration

Primary Servers and the ZENworks database must reside on the same network segment. Primary Servers cannot write across a WAN to the ZENworks database.

Default Character Set

For Sybase, the UTF-8 character set is required.

For MS SQL, ZENworks does not require any specific character set. ZENworks supports all character sets supported by MS SQL.

For Oracle, the NLS_CHARACTERSET parameter must be set to AL32UTF8, and the NLS_NCHAR_CHARACTERSET parameter must be set to AL16UTF16. If the existing Oracle Database is installed with another character set, then to migrate to the AL32UTF8 character set, contact Oracle Support.

Collation

ZENworks is not supported with a case-sensitive instance of the MS SQL database. Therefore, you must ensure that the database is case insensitive before setting it up.

Database User

Ensure that there is no restriction for the ZENworks database user to connect to a remote database.

For example, if the ZENworks database user is an Active Directory user, ensure that the Active Directory policies allow the user to connect to a remote database.

6.0 Reporting Server Support

Item

Requirements

ZENworks Reporting Server Platform

ZENworks Reporting Server Appliance

ZENworks Reporting Server backward compatibility (support for the older versions).

From ZENworks 11.4.x

Browser

Refer to Section 10.0, Administration Browser Requirements

Database

Refer to Section 5.0, Database Requirements

NOTE:ZENworks Reporting does not support the PostgreSQL database.

7.0 LDAP Directory Requirements

ZENworks 2017 can reference existing user sources (directories) for user-related tasks such as assigning content to users, creating ZENworks administrator accounts, and associating users with devices. LDAP (Lightweight Directory Access Protocol) is the protocol used by ZENworks for interacting with directories.

Item

Requirements

LDAP version

LDAP v3

OPENLDAP is not supported. However, if you have eDirectory installed on a SUSE Linux server, you can use that as a user source. LDAP v3 can be used to access eDirectory on the Linux server by using the alternate ports that you specified for eDirectory when installing it (because OPENLDAP might have been using the default ports).

Authoritative user source

  • Novell eDirectory 8.7.3, 8.8 or 9.0 (on all supported platforms)

    If you use eDirectory as the user source, ensure that no two eDirectory users have the same user name and password. Even if the user names are the same, ensure that the passwords are different.

  • Microsoft Active Directory (as shipped with Windows 2000 SP4 or later)

  • Domain Services for Windows (DSfW)

LDAP user access

ZENworks requires only read access to the LDAP directory. For more information, see Connecting to User Sources in the System Configuration.

LDAP Authentication

Simple bind

With simple bind, an application provides a Distinguished Name (DN) and the clear text password for that DN. To use a simple bind, the client must supply the DN of an existing LDAP entry and a password that matches the userPassword attribute for that entry. The Administrator can also enter the DN and the clear text password by using the Configuration page in ZENworks Control Center.

8.0 Inventoried-Only Device Requirements

You can use ZENworks 2017 to inventory workstations and servers by deploying the Inventory-Only module on these devices.

IMPORTANT:In situations where ZENworks product issues are caused by an issue with the platform, the following support standards apply:

  • Platforms that are generally supported by platform vendors are supported by Micro Focus.

  • If the platform vendor provides support for your installations through a special agreement (such as extended support), Novell expects you to extend this support infrastructure to us in order to resolve the issue.

  • If the platform vendor does not support the platform at all, Micro Foucs offers no additional support.

The inventoried-only devices must meet the following requirements:

Item

Requirements

Operating System: Servers

  • Mac OS X 10.10 to 10.12

  • Windows 2012 Server x86_64 (Foundation, Essential, Standard, Datacenter)

  • Windows 2012 R2 Server x86_64 (Foundation, Essential, Standard, Datacenter)

  • Windows 2016 Server x86_64 (Essential, Standard, Datacenter and Storage)

  • SLES 11 SP3 x86, x86_64 (Intel and AMD Opteron processors)

  • SLES 11 SP4 x86, x86_64 (Intel and AMD Opteron processors)

  • SLES 12 x86, x86_64

  • SLES 12 SP1 x86, x86_64

  • SLES 12 SP2 x86, x86_64

  • SLES 12 SP3 x86, x86_64

  • SLES 12 SP4 x86, x86_64

  • Open Enterprise Server 2015 (OES 2015) x86 and x86_64

  • Open Enterprise Server 2015 SP1 (OES 2015 SP1) x86 and x86_64

  • Open Enterprise Server 2018 x86_64

Operating System: Workstations

  • Mac OS X 10.10 to 10.12

  • Windows 7 SP1 x86, x86-64 (Professional, Ultimate, and Enterprise editions)

  • Windows Embedded 7 SP1

  • Windows 8 x86, x86_64 (Professional and Enterprise editions)

  • Windows Embedded 8

  • Windows 8.1 Enterprise and Professional x86 and x86_64

  • Windows Embedded 8.1

  • Windows 10 x86, x86_64 (Professional, Education, Enterprise, up to the 1809 version)

  • Windows 2019 Server x86_64 (Essential, Standard, Datacenter and Storage)

  • Windows Embedded 10 (LTSB edition)

  • SLED 11 SP3 x86, x86_64 (Intel and AMD Opteron processors)

  • SLED 11 SP4 x86, x86_64 (Intel and AMD Opteron processors)

  • SLED 12 x86, x86_64

  • SLED 12 SP1 x86, x86_64

  • SLED 12 SP2 x86, x86_64

  • SLED 12 SP3 x86, x86_64

  • SLED 12 SP4 x86, x86_64

  • Red Hat Enterprise Linux 6.7 and 6.8 (RHEL 6.7 and RHEL 6.8) x86, x86_64 (AS and ES)

  • * RHEL 7.0, 7.1 (without subscription)

  • RHEL 7.2, 7.3, 7.4 (without subscription)

  • Scientific Linux 6.7 and 6.8, x86, x86_64

  • * Scientific Linux 7.0, 7.1 (without subscription)

  • Scientific Linux 7.x, x86_64 (without subscription)

* Indicates that the platform is supported in backward compatibility mode (support for the 11.x version of the agent)

Operating System: Thin Client Sessions

  • Windows Server 2012 SP2

  • Windows Server 2012 R2 SP1

  • Windows 2016 Server x86_64

  • Citrix XenApp 6.0, 6.5,7.6 onwards

Inventory Only Module

After installing ZENworks 2017 to your network, you must install this module on the above-listed devices to inventory them. For more information, see Deploying the Inventory-Only Module in the ZENworks Discovery, Deployment, and Retirement Reference.

Hardware: Disk Space

The Inventory-Only module requires the following minimum disk space:

  • Linux: 900 KB

  • Windows: 15 MB

  • Mac OS: 8 MB

9.0 Mobile Management Support

Item

Requirements

Browser Support - EUP

  • Google Chrome

  • Firefox ESR 45, 52 and Firefox 56 onwards

  • Internet Explorer 11 and Edge

  • Safari

Browser Support - Mobile Devices

  • Google Chrome for Android devices

  • Safari for iOS devices

Mobile OS support

  • Android 4.5 and higher

  • iOS 9.0 9.3,12 and higher

  • Windows 8.0 and higher (ActiveSync only)

ActiveSync Server Support

  • ActiveSync Server version 12.1 bundled with:

    • Microsoft Exchange 2007 and higher

ActiveSync Client Support

  • Exchange ActiveSync 12.1 and higher. Tested on supported mobile operating system platforms.

10.0 Administration Browser Requirements

Ensure that the workstation or server where you run ZENworks Control Center to administer your system meets the following requirements:

Item

Requirements

Web Browser

The following web browsers are supported:

  • Internet Explorer 11 and above

  • Firefox version 58 and higher

  • Firefox ESR version 52

  • Edge 40 and above

  • Chrome version 55 and higher

NOTE:Administration of features dependent on ZCC Helper is supported only on Windows and SUSE Linux Enterprise devices.

TCP Ports

To fulfill a user’s request for a remote session on a managed device, you must open port 5550 on the device, in order to run Remote Management Listener.

11.0 Installation User Requirements

The user running the installation program must have administrator or root privileges on the device. For example:

  • Windows: Log in as a Windows administrator.

  • Linux: If you log in as a non-root user, use the su command to elevate your privileges to root, then run the installation program.

12.0 Supported Smart Cards and Smart Card Readers

For information about smart cards and smart card readers supported for ZENworks login, see Novell Enhanced Smart Card Method Installation and Administration Guide.

If you are using ZENworks Full Disk Encryption, see Supported Smart Card Terminals and Tokens in the ZENworks Full Disk Encryption Agent Reference for information about smart cards supported for both ZENworks Full Disk Encryption Pre-Boot Authentication and general ZENworks login.

13.0 Legal Notice

For information about legal notices, trademarks, disclaimers, warranties, export and other use restrictions, U.S. Government rights, patent policy, and FIPS compliance, see https://www.novell.com/company/legal/.

© Copyright 2008 - 2019 Micro Focus or one of its affiliates.

The only warranties for products and services of Micro Focus and its affiliates and licensors (“Micro Focus”) are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. Micro Focus shall not be liable for technical or editorial errors or omissions contained herein. The information contained herein is subject to change without notice.