Legal Notices

Novell, Inc. makes no representations or warranties with respect to the contents or use of this documentation, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right to revise this publication and to make changes to its content, at any time, without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc. makes no representations or warranties with respect to any software, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right to make changes to any and all parts of Novell software, at any time, without any obligation to notify any person or entity of such changes.

Any products or technical information provided under this Agreement may be subject to U.S. export controls and the trade laws of other countries. You agree to comply with all export control regulations and to obtain any required licenses or classification to export, re-export or import deliverables. You agree not to export or re-export to entities on the current U.S. export exclusion lists or to any embargoed or terrorist countries as specified in the U.S. export laws. You agree to not use deliverables for prohibited nuclear, missile, or chemical biological weaponry end uses. See the Novell International Trade Services Web page (http://www.novell.com/info/exports/) for more information on exporting Novell software. Novell assumes no responsibility for your failure to obtain any necessary export approvals.

Copyright © 2014 Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, stored on a retrieval system, or transmitted without the express written consent of the publisher.

Novell, Inc.
1800 South Novell Place
Provo, UT 84606
U.S.A.
www.novell.com

Online Documentation: To access the latest online documentation for this and other Novell products, see the Novell Documentation Web page (http://www.novell.com/documentation/).

Novell Trademarks

For Novell trademarks, see the Novell Trademark and Service Mark list (http://www.novell.com/company/legal/trademarks/tmlist.html).

Third-Party Materials

All third-party trademarks are the property of their respective owners.
## Contents

**About This Guide**  

### 1 ZENworks Reporting Migration  

1.1 Migrating ZRS Custom Reports with Simple Filters and without Filters  
1.2 Migrating ZRS Custom Reports with Prompt Filters  
1.3 Migrating ZRS Custom Reports that have Multiple Measures  
1.4 Connecting to ZENworks Reporting from iReport Designer
About This Guide

This Novell ZENworks Reporting Migration Guide includes information to help you successfully migrate from ZENworks Reporting Server (ZRS) to ZENworks Reporting 5. The information is organized as follows:

- Chapter 1, “ZENworks Reporting Migration,” on page 7

Audience

This guide is intended for ZENworks Reporting administrators.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation included with this product. Please use the User Comments feature at the bottom of each page of the online documentation.

Additional Documentation

ZENworks Reporting is supported by other documentation (in both PDF and HTML formats) that you can use to learn about and implement the product. For additional documentation, see the ZENworks 11 SP2 documentation Web site (http://www.novell.com/documentation/zenworks11/).
This guide includes information to help you migrate reports from ZENworks Reporting Server (ZRS) to ZENworks Reporting 5.

Novell is discontinuing the support of ZRS starting with the ZENworks 11 SP3 release. When you upgrade ZENworks Reporting server (ZRS) to ZENworks 11 SP3, all BOE-related functionality is deleted. ZENworks Reporting 5 is a replacement for ZRS and is available from the ZENworks 11.2.4 release. If you want to migrate your reports, you must upgrade to ZENworks 11.2.4, and install ZENworks Reporting 5.

All standard reports available in ZRS are also available in ZENworks Reporting 5. However, any user-defined custom reports must be manually migrated to ZENworks Reporting 5 since, they are no longer available, starting with the ZENworks 11 SP3 release.

To help in this report migration, ZENworks 11.2.4 supports both ZRS and ZENworks Reporting 5. Thus, both servers can run simultaneously in the zone and point towards the same database. This document provides steps to migrate custom reports from ZRS to ZENworks Reporting 5.

If you are unable to migrate custom reports before upgrading to ZENworks 11 SP3, backup of ZENworks Reporting Server, ZENworks Primary Server, and ZENworks database, and move the backup to a location outside the ZENworks Zone. This ensures that a copy of ZRS (running on 11.2.4) is available for your report migration.

The following report types are available in ZENworks Reporting Server (ZRS):

- Custom reports without filter
- Custom reports with simple filter
- Custom reports with objects as prompts
- Custom reports with multiple measures

Simple reports are custom reports without filter prompts.

To migrate your reports, see the information in the following sections:

- Section 1.1, “Migrating ZRS Custom Reports with Simple Filters and without Filters,” on page 7
- Section 1.2, “Migrating ZRS Custom Reports with Prompt Filters,” on page 9
- Section 1.3, “Migrating ZRS Custom Reports that have Multiple Measures,” on page 11
- Section 1.4, “Connecting to ZENworks Reporting from iReport Designer,” on page 12

### 1.1 Migrating ZRS Custom Reports with Simple Filters and without Filters

1. Launch ZRS report.
2. Click `Edit Query`. 
3 Click View SQL Query on the top left.
4 In the SQL Viewer panel, select Use custom SQL.
5 Copy and save the query.
6 Launch iReport on the ZENworks Reporting 5 device.
7 Connect to ZENworks Reporting 5 through iReport Designer.
   For more information, see Section 1.4, “Connecting to ZENworks Reporting from iReport Designer,” on page 12.
8 Click Tools > Options > Class path > Add jar.
9 Select the JDBC jar file based on the database. The file is located at %ZRS_HOME%/js/Apachetomcat/lib.
   - For Oracle: the ojdbc5.jar file.
   - For SQL Server: the sqljdbc.jar file.
   - For Sybase: the jconn4.jar file.
10 Click OK.
11 Click the datasource icon.
12 In the Connections / Datasources panel, click New > Database JDBC connection > Next.
13 Specify a name for the datasource. For example, zenworks.
14 Select the database based on your database.
   - For Oracle: Oracle {oracle.jdbc.driver.OracleDriver}
   - For SQL Server: MS SQLServer (2005) {com.microsoft.sqlserver.jdbc.SQLServerDriver}
   - For Sybase: Manually specify Sybase {com.sybase.jdbc4.jdbc.SybDataSource}
15 Specify JDBC URL as follows:
   - For Oracle: jdbc:oracle:thin:@"+server+":"+port+"/"+database
   - For SQL Server: jdbc:sqlserver://"+server+"\"+instanceName+";databaseName="+database
   - For Sybase:jdbc:sysbase:Tds:"+server+"":"+port+"?ServiceName="+database
   Where server is database IP address, port is database port, databaseName is database. If SQL Server is configured with named instance, then specify instanceName.
16 Specify the database credentials, then select Save password.
17 Click Test to test the database connection, then click Save.
18 Click File > New, after the Query to create a report in the iReport Designer.
19 In the New File panel, select the template for the report.
20 Click Open this Template.
21 Specify the details, click Next, then click Finish to display the Report template.
   The Report template includes various columns, such as Column Header, Page Header, Detail, and so forth.
   You can format and create the report by using the Report Inspector panel, Repository Navigator panel, and Properties panel. Report Inspector provide details about the report, Repository Navigator enables you to connect to ZENworks Reporting, and Palette panel provides report elements that are used in the report. These sub menus are available in the Window menu.
   For more information, see the Jaspersoft iReport Guide.
22 In the Designer panel, click 📔.

23 In the Report Query panel, select SQL from the Query language list.

24 Paste the copied query (from ZRS report) mentioned in Step 5.

   All fields related to the query are displayed. If an error is displayed, it indicates that the query has issues, and the query must be modified.

25 Click OK.

26 In the Report Inspector panel, expand Fields.

27 Select all of the fields and drag them into the Designer > Detail band.

   All of the fields are added to the report with their respective names on Column Header.

   If you want to format the report, for example, to change the Column Header, select Column Header > Properties, then change the Height, Width, Border, Font Size, Font Style, and so forth.

28 After creating a report, perform the following steps to upload it into ZENworks Reporting 5:

28a In the Repository Navigator panel, expand Server tree.

28b Select the folder location, then right-click > Add > JasperServer Report.

28c In the ReportUnit Wizard, specify the details, then click Next.

28d Select Locally Defined and browse to a report.

28e Click Next.

28f In the From the repository list, select /datasources/ZENworks_DATASOURCE.

28g Click Finish.

29 Run the report in ZENworks Reporting 5.

1.2 Migrating ZRS Custom Reports with Prompt Filters

1 Perform Step 1 to Step 5 in Section 1.1, “Migrating ZRS Custom Reports with Simple Filters and without Filters,” on page 7.

2 Get the query for Input Control (filters).

   For example, if you have a prompt filter for Platform, create a report and select Platform in the Result Objects panel, instead of the Query Filters panel.

3 Click View SQL.

4 In the SQL Viewer panel, copy the query and save it on your device.

5 Perform Step 6 to Step 23 in Section 1.1, “Migrating ZRS Custom Reports with Simple Filters and without Filters,” on page 7.

6 Delete the content from the SQL keyword WHERE through the end.

   For example, the original query is as follows:

   ```sql
   SELECT zDevice1.Platform
   FROM zDevice zDevice1 INNER JOIN zZENOObject zZENOObject1 ON (zDevice1.ZUID=zZENOObject1.ZUID AND zZENOObject1.PrimaryType='Device')
   WHERE zZENOObject1.Name IN @prompt('Enter value(s) for Device Name:','A','Managed Device Status\Device Name',Multi,Free,Persistent,,User:0)
   AND (zZENOObject1.Path like '/-/dev%')
   ```
And the modified query is as follows:

```
SELECT
  zDevice1.Platform
FROM
  zDevice zDevice1 INNER JOIN zZENObject zZENObject1 ON
  (zDevice1.ZUID=zZENObject1.ZUID AND zZENObject1.PrimaryType='Device')
```

All fields related to the query are displayed. If an error is displayed, it indicates that the query has issues, and the query must be modified.

7. Click OK.
8. In the Report Inspector panel, expand Fields.
9. Select all the fields and drag them into the Designer > Detail column.

All of the fields are added to the report, with their respective names on Column Header.

If you want to format the report, for example, to change the Column Header, select Column Header > Properties, then change the Height, Width, Border, Font Size, Font Style, and so forth.

10. After creating a report, perform the following steps to upload it into ZENworks Reporting 5:

10a. In the Repository Navigator panel, expand Server tree.
10b. Select the folder location, then right-click > Add > JasperServer Report.
10c. In the ReportUnit Wizard, specify the details, then click Next.
10d. Select Locally Defined and browse to a report.
10e. Click Next.
10f. In the From the repository list, select /datasources/ZENworks_Datasource.
10g. Click Finish.

11. In the Report Navigator panel, select Input controls, right-click, then click Create a local input control.

12. In the Input Control panel, specify the details.

For example, to create input control for Platform, then in ID specify as Platform, and specify Name, and Description.

13. Click the Input Control Details tab.
14. In the Type list, select Multi-select Query.
15. Select Locally Defined, then click Edit Local Resource.
16. Specify the details.
17. Click the Query tab in the Query Language list, select SQL, then specify the query in the Query.

You must specify the query that you saved on your device in Step 4.

18. Click the Data Source tab, select From the repository, then select /datasources/ZENworks_Datasource from the list.
19. Click Save.
20. In the Input Control, click the Input Control Details tab.
21. Click the Value and Visible Columns tab.
22. Specify the details.

Specify the Name used in the modified query in Step 17.
23. Click Save.
24. In the Report Inspector panel, right-click Parameters > Add Parameter.
25 In the Parameter Properties panel, change Name to the same ID in Step 12, then select java.util.Collection in the Parameter Class list.

26 In the Designer panel, click .

27 In the Report Query, append WHERE $X{IN, zZENobject1.name, Platform}
zZENobject1.name is from Step 17 and Platform is from Step 12.

28 Click Read Fields and then click OK. If an error is displayed, it indicates that the query has issues, and it must be modified.

29 (Conditional) If your report has more than one Input Control, perform Step 2 to Step 4 and Step 11 to Step 28.

30 Go to Repository Navigator, expand your report, right-click the Main jrxml file, then click Replace with current document.

31 Click Yes to save the report and upload it to the server.

32 Click OK.

33 Run the report in ZENworks Reporting 5.

1.3 Migrating ZRS Custom Reports that have Multiple Measures

If you have more than one measure in a ZRS custom report, then depending on the number of measures, the number of queries is displayed. For example, in a custom report if you have two measures, then two queries are displayed for that report. Thus, getting a single query from multiple queries is difficult. However, by importing an updated Universe (.biar) file, you can get a single query for multiple queries.

1 Back up the ZENworks Configuration Management_MSSql.biar and ZENworks Configuration Management_SybOra.biar files. The files are located at the following path:
   - For Windows: %ZRS_HOME%\share\boe-publish\universe
   - For Linux: /opt/novell/zenworks/share/boe-publish/universe

2 Replace the ZENworks Configuration Management_MSSql.biar and ZENworks Configuration Management_SybOra.biar files with updated files.

3 Run the novell-zenworks-configure -c UpdateBOEConfigureAction command from a command prompt.

4 Perform Step 1 to Step 5 in Section 1.1, “Migrating ZRS Custom Reports with Simple Filters and without Filters,” on page 7.

5 (Conditional) If your custom report has Input Control (filters).

   For example, if you have prompt filter for Platform, then create a report and select Platform in the Result Objects panel, instead of Query Filters panel.

   5a Click View SQL.

   5b In the SQL Viewer panel, copy the query and save it on your device.

6 Perform Step 6 to Step 23 in Section 1.1, “Migrating ZRS Custom Reports with Simple Filters and without Filters,” on page 7.

7 Paste the copied query (from ZRS report) in Step 5 under Section 1.1, “Migrating ZRS Custom Reports with Simple Filters and without Filters,” on page 7.

8 (Conditional) If your custom report has a prompt, delete the content from the SQL keyword WHERE through the end.

   For example, the original query is as follows:
SELECT
zDevice1.Platform
FROM
zDevice zDevice1 INNER JOIN zZENObject zZENObject1 ON
(zDevice1.ZUID=zZENObject1.ZUID AND zZENObject1.PrimaryType='Device')
WHERE
zZENObject1.Name IN @prompt('Enter value(s) for Device Name:','A','Managed Device Status\Device Name',Multi,Free,Persistent,,User:0)
AND (zZENObject1.Path like '/~dev%')

The modified query is as follows:
SELECT
zDevice1.Platform
FROM
zDevice zDevice1 INNER JOIN zZENObject zZENObject1 ON
(zDevice1.ZUID=zZENObject1.ZUID AND zZENObject1.PrimaryType='Device')

All fields related to the query are displayed. If an error is displayed, it indicates that the query has issues, and it must be modified.

9 Click OK.

10 In the Report Inspector panel, expand Fields.

11 Select all of the fields and drag them into the Designer > Detail band.

All of the fields are added to the report, with their respective names on Column Header.

If you want to format the report, for example, to change the Column Header, select Column Header > Properties, then change the Height, Width, Border, Font Size, Font Style, and so forth.

12 After creating a report, perform the following to upload it into ZENworks Reporting 5:

12a In the Repository Navigator panel, expand the Server tree.
12b Select the folder location, then right-click > Add > JasperServer Report.
12c In the ReportUnit Wizard, specify the details, then click Next.
12d Select Locally Defined and browse to a report.
12e Click Next.
12f In the From the repository list, select /datasources/ZENworks_Datasource.
12g Click Finish.

13 (Conditional) If your custom report has an input control, perform Step 11 to Step 32 in Section 1.2, “Migrating ZRS Custom Reports with Prompt Filters,” on page 9.

14 Run the report in ZENworks Reporting 5.

1.4 Connecting to ZENworks Reporting from iReport Designer

1 Start iReport:
   For Windows: Start > ZENworks Reporting > Start iReport Designer.
   For Linux: Change to /opt/novell/zenworks-reporting/js/ireport/bin and enter the ./iReportLoader.sh command.
2 Click Window > JasperReports Server Repository.
   The Repository Navigator tool bar is displayed. On initial startup of iReport, no servers are configured.
3 To add a server, click in the Repository Navigator tool bar. 
The JasperServer Plugin panel is displayed.
4 Specify the following configuration information to access the server:
   - ID: An identifier for this server that appears in the Repository Navigator.
   - JasperReports Server URL: Full URL to the repository web service; ensure that the default URL is jasperserver-pro. You need to change hostname to the name of your server:
     https://hostname:<secure server port>/jasperserver-pro/services/repository
   - Organization: (Optional) Specify the ID or the user’s organization.
   - Username: ID of the user accessing the server from iReport.
   - Password: The password of the user.
5 Click Save.
The created ID is displayed in the Repository Navigator panel.
6 Expand the ID tree structure.
The Certificate panel is displayed.
7 Accept the certificate by selecting one of the following options:
   - Accept this certificate permanently.
   - Accept this certificate only for the current iReport session.
8 Click OK.