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About This Guide

In Novell® Open Enterprise Server (OES) 2 SP2 and earlier, this guide was entitled the OES Lab Guide.

Starting with OES 2 SP3, the title has changed to better reflect the purposes explained below and 
documented in the following sections:

 Chapter 1, “Installing the OES 2 SP3 Server in Your Getting-started Lab,” on page 9

 Chapter 2, “Installing a NetWare Virtual Machine,” on page 25

 Chapter 3, “eDirectory, Users and Groups, and Identity Services,” on page 41

 Chapter 4, “eDirectory Linux Access (LUM),” on page 55

 Chapter 5, “Novell CIFS on OES 2,” on page 63

 Chapter 6, “Novell AFP,” on page 67

 Chapter 7, “NetWare CIFS and AFP on OES 2,” on page 69

 Chapter 8, “iFolder 3.8,” on page 73

 Chapter 9, “iPrint,” on page 79

 Chapter 10, “NetStorage,” on page 85

 Chapter 11, “Getting Acquainted with OES,” on page 91

 Appendix A, “Supplementary Information,” on page 109

To install OES 2 SP3 in a getting-started lab prior to installing it in a production environment, we 
recommend using the following documentation.

 OES 2 SP3 Readme

 OES 2 SP3: Planning and Implementation Guide

 OES 2 SP3: Installation Guide

Guide Purposes

This guide is designed to help you with your transition from NetWare® to OES 2 by helping you to 
get acquainted with basic OES services. 

The information and instructions it contains help you to do the following:

 Install an OES 2 SP3 server into a new eDirectory™ tree named EXAMPLE_TREE

 Install selected OES 2 components on the server

 Install an OES 2 SP3 virtual machine host server, create a virtual machine (VM) on the server, 
and install NetWare 6.5 SP8 on the VM

 Create seven different user types, at least one of which should closely align with the users on 
your network

 Perform simple tasks to get acquainted with basic OES 2 services on a Windows XP or Windows 
7 workstation.
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Work through the Guide Sequentially

The sections in this guide are designed to be accessed sequentially, thus guiding you through the 
main tasks of setting up an OES 2 environment that you can then explore further as desired.

If You Want to Use This Guide as a Reference

If you want to install additional OES 2 servers, create a different tree structure than the one specified 
in this guide, or diverge from the instructions presented, you can still use these instructions as a basic 
outline for setting up OES 2 services in a getting-started lab environment. However, be aware that 
any divergence from the instructions presented or the order they are presented in, can cause ripple 
effects through the rest of the guide. If you need to diverge, refer to the information found in the 
following guides for assistance:

 OES 2 SP3: Planning and Implementation Guide

 OES 2 SP3: Installation Guide

 OES2 SP3: Linux Tips for NetWare Administrators

 NW65 SP8: Installation Guide

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation, or go to www.novell.com/documentation/feedback.html and enter your 
comments there.

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
within a cross-reference path.
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1 1Installing the OES 2 SP3 Server in Your 
Getting-started Lab

Use the instructions in this section to install Novell® Open Enterprise Server 2 SP3 (OES 2 SP3) in 
your getting-started lab.

 Section 1.1, “Getting-started Lab Setup Requirements,” on page 9

 Section 1.2, “Obtaining Installation Media,” on page 10

 Section 1.3, “Installing the Server Software,” on page 11

 Section 1.4, “Setting the Root Password, Configuring the Network, and Updating the Server,” on 
page 14

 Section 1.5, “Configuring eDirectory and OES Services,” on page 17

 Section 1.6, “Setting Up the Graphical User Interface,” on page 19

 Section 1.7, “Completing the Update Process,” on page 20

 Section 1.8, “Setting Up the Server as an SLP Directory Agent,” on page 20

 Section 1.9, “Accessing iManager,” on page 21

 Section 1.10, “Configuring the Browser for the eDirectory CA,” on page 22

 Section 1.11, “Enabling Pop-Ups for iManager,” on page 23

1.1 Getting-started Lab Setup Requirements
For the tasks and exercises described in this guide, you need the following:

 A server-class computer with the following:

Component Minimum Recommended

Processor Pentium* II or AMD* K7 450 MHz Pentium III, Pentium III Xeon*, 
Pentium 4, Intel* Xeon 700 MHz, 
AMD K8 CPUs (Athlon64 and 
Opteron*), Intel EM64T or higher 
processor

RAM 1 GB 2 GB

Display adapter Super VGA VESA 1.2-compliant, high 
resolution

Display monitor Compatible with adapter

CD/DVD drive Support for the ElTorito 
specification
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 A network printer with an assigned static IP address and a connection to your getting-started 
lab network.

 A Windows workstation with 

 One of the following platforms installed:

 Windows XP

 Windows 7

 An Ethernet 100 Mbps adapter

 An IP address on the same subnet as the server

 Mozilla* Firefox* browser installed. (This is optional, but Firefox is the assumed browser for 
most of the instructions in this guide)

 A print driver installed on the workstation for the network printer listed above.

 (Optional for exploring Novell AFP and iPrint) An Apple* Macintosh* workstation with

 Mac OS* 10.4 or later installed

Novell AFP supports earlier versions of Mac OS, but iPrint doesn’t.

 An Ethernet adapter

 An IP address on the same subnet as the server

 A print driver installed on the workstation for the network printer listed above.

1.2 Obtaining Installation Media
To complete the instructions in this guide, you need to download various ISO files, depending on 
your hardware.

 Section 1.2.1, “Identifying the Files to Download,” on page 11

 Section 1.2.2, “Downloading the Files,” on page 11

 Section 1.2.3, “Creating the Installation Media,” on page 11

Hard drive

(All data will be erased)

40 GB

Network card Ethernet 100 Mbps

IP address  IP address on the getting-
started lab subnet. For 
example, 192.168.1.100. 

 Subnet mask. For example, 
255.255.255.0.

 Default gateway. For example, 
192.168.1.1.

Mouse Not required USB or PS/2*

Component Minimum Recommended
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1.2.1 Identifying the Files to Download

You need to download the set of files in Table 1-1 that matches the architecture (32-bit or 64-bit) of 
your server computers:

Table 1-1   Files to Download

1.2.2 Downloading the Files

After identifying which files you need to download:

1 Go to “Downloading OES 2 SP3 Software from the Novell Web Site” in the OES 2 SP3: Planning 
and Implementation Guide.

2 Complete all the steps in the section, except the instructions on deciding which files to 
download. You should have already identified the files you need, using the list in Section 1.2.1, 
“Identifying the Files to Download,” on page 11.

3 Be sure to print the pages as instructed, record the two activation codes, print and check the 
MD5 verification checksums, and so on.

4 After you have downloaded all of the files you need, continue with Creating the Installation 
Media.

1.2.3 Creating the Installation Media

To prepare physical installation media:

1 Go to “Preparing Physical Media for a New Server Installation or an Upgrade ” in the OES 2 
SP3: Installation Guide and use the instructions there to create media for installing your OES 2 
server.

Continue with Installing the Server Software.

1.3 Installing the Server Software
Complete the instructions in the following sections.

 Section 1.3.1, “Prerequisites,” on page 12

 Section 1.3.2, “Procedure,” on page 12

Platform Files needed

32-bit server with CD/DVD drive  SLES-10-SP3-DVD-i386-GM-DVD1.iso

 OES2-SP3-i386-CD1.iso

64-bit server with CD/DVD drive  SLES-10-SP3-DVD-x86_64-GM-DVD1.iso

 OES2-SP3-x86_64-CD1.iso
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1.3.1 Prerequisites

Before installing OES 2 on your server, you must complete the following tasks:

 Ensure that the server computer meets the requirements outlined in Section 1.1, “Getting-started 
Lab Setup Requirements,” on page 9.

 Prepare the software for installation as explained in Section 1.2, “Obtaining Installation Media,” 
on page 10.

1.3.2 Procedure

WARNING: This procedure permanently erases any data currently on your server’s hard drive.

1 Prepare the BIOS on your server machine so that it will boot from the DVD drive first.

2 Insert the SLES 10 SP4 DVD1 into your server and reboot the machine.

3 When the boot selection page appears, immediately press the Down-arrow key to select the 
Installation option, then press Enter.

If you don’t respond before the machine starts booting from the hard disk, reboot the server and 
repeat this step.

4 After the boot process finishes, select an installation language, then click Next.

5 Read and agree to the software license agreement, then click Next.

6 Select New Installation, select the Include Add-On Products from Separate Menu option, then click 
Next.

7 On the Add-on Product Installation page, click Add.

8 Select CD, then click Next.

9 Insert the OES 2 SP3 CD as prompted, then click Continue.

10 After the catalog is added, read and agree to the OES 2 license agreement, then click Next > Next.

11 Select the time zone for the server, then click Next.

12 On the Installation Settings page, click Partitioning.

If your server has existing partitions, the OES install tries to add new SLES partitions to them. 

13 To ensure a clean install, use the following table to navigate the partitioning pages and prepare 
your system disk.

IMPORTANT: The steps in the following table prepare the system disk for management by the 
EVMS volume manager. This is only required if you want to have NSS volumes on the system 
disk, and is not the default use case. We have included the process in this guide to provide 
exposure to installing NSS volumes on a single-drive server.

The steps also assume that you are installing on a machine that was previously used, and that 
you want to remove all of the existing data. If that is not the case, see “Installing with EVMS as 
the Volume Manager of the System Device” in the OES 2 SP3: Installation Guide for other 
installation options. 

Keep in mind that the guide assume that you can use 40GB of the hard drive space on the 
machine that you are are installing OES 2 on.
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14 On the Installation Settings page, click Software.

Use the following table to navigate and configure the software pages:

15 When prompted, insert the SLES 10 media and click Retry. 

Insert DVD 1 when you are prompted for any SLES 10 media.

Page Name Action

Suggested Partitioning 1. Select Create Customer Partition Setup.

2. Click Next.

Preparing Hard Disk—Step 1 1. Select the hard disk you are installing on.

2. Click Next.

Preparing Hard Disk—Step 2 1. Click Use Entire Hard Disk.

This only appears when the disk contains existing 
partitions.

WARNING: This erases all data from the disk you are 
installing to.

2. Click Create EVMS Based Proposal > Next.

Page Name Action

Software Selection and System 
Tasks

1. Under OES Services, select (or confirm the selection of) 
the following:

 Novell AFP

 Novell CIFS

 Novell eDirectory* 

 Novell iFolder

 Novell iManager

 Novell iPrint

 Novell NCP Server/Dynamic Storage Technology*

 Novell NetStorage

 Novell Storage Services*

Services marked with an asterisk (*) are selected with 
AFP and CIFS.

Novell Backup/Storage Management Services (SMS), 
Novell Linux User Management, and Novell Remote 
Manager are all selected by default when any OES 
selections are made, and they are installed on every OES 
2 server.

2. Click Accept.

agfa fonts 1. Click Accept.

Installation Settings 1. Click Accept.

Confirm Installation 1. Click Install.
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After the files are copied, the system configuration takes a few minutes to complete.

16 Continue with Setting the Root Password, Configuring the Network, and Updating the Server.

1.4 Setting the Root Password, Configuring the Network, and 
Updating the Server
After the initial system configuration and system reboot, the installation needs information about the 
root user and the network.

1 Use the following table to navigate and complete the various configuratinovellon pages.
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Page Name Action

Password for the System 
Administrator “root”

1. Enter and confirm the root user password, then click Next.

Hostname and Domain Name 1. In the Host Name field, type the DNS hostname for the IP 
address you are assigning to the server. For example, 
myserver.

2. In the Domain Name field, type the DNS Domain Name for 
your network. For example, mysite.company.example.com.

3. Deselct Change Hostname via DHCP.

4. Click Next.

Network Configuration 1. Click Network Interfaces.

Network Card Configuration 
Overview

1. If your server has multiple network cards, select the card the 
server will use.

2. Click Edit.

3. Select Static Address Setup.

4. In the IP Address field, type the IP address for the server. For 
example, 192.168.1.100

5. Change the Subnet Mask if needed. For example, 
255.255.255.0.

6. Click Host Name and Name Server.

Host Name and Name Server 
Configuration

1. Type the IP address of at least one name server and type your 
DNS domain name in the Domain Search field. For example, 
company.example.com.

2. Click OK.

Network Address Setup 1. Click Routing.

Routing Configuration 1. Type the IP address of the default gateway for your getting-
started lab subnet. For example, 192.168.1.1.

2. Click OK.

Network Address Setup 1. Click Next.

Network Card Configuration 
Overview

1. Click Next.

Network Configuration 1. Click Next.

Test Internet Connection You will need to register your server on the Internet to download the 
latest patches, so you should test the Internet connection at this 
point to make sure everything is configured correctly.

1. Select Yes, Test Connection to the Internet.

2. Click Next.

Running Internet Connection Test After a few moments, the Test Status should indicate Success.

If it does not, you need to click Back and fix your network 
configuration and the connection to the Internet. It is essential that 
OES 2 servers always have the latest security and other critical 
patches downloaded and installed.

1. Click Next.
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Novell Customer Center 
Configuration

1. Click Next.

The server establishes a connection with the Novell Customer 
Center.

Manual Interaction Required 1. Click Continue.

Novell Customer Center System 
Registration

1. In the fields indicated, type and confirm the e-mail address to 
which you want administrative notifications sent.

2. In the Activation code for SLES components field, type the 
SLES activation code you noted or printed while downloading 
the image files.

If this code is not entered, the server can’t download updates 
and patches through the Novell patch channels. For the OES 2 
SP3 release, downloading the SLES patches is critical for 
service configuration success.

3. In the Activation code for OES components field, type the OES 
2 activation code you noted or printed while downloading the 
image files.

If this code is not entered, the same patch channel restriction 
applies as for SLES.

4. Click Submit.

Your registration information is sent to the Customer Center. 
This might take a couple of minutes to complete.

5. Click Continue.

The update server is added to your system configuration. 
Again, this might take a few minutes.

Novell Customer Center 
Configuration pop-up

1. Click OK.

Page Name Action
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2 Continue with Configuring eDirectory and OES Services.

1.5 Configuring eDirectory and OES Services
For the exercises in this guide, you need specific eDirectory, NTP, and SLP configurations.

1 Use the following table to navigate and complete the eDirectory pages:

Online Update Depending on the patches that are in the Update channels, you 
might need to run the update process more than once. 

1. Select Run Update, then click Next.

2. WARNING: At this point it is critical that you deselect any 
patches that will cause the server to reboot before the 
installation process completes. The fstab file is updated for 
compatibility with the EVMS volume manager at the end of the 
installation. If that doesn’t happen before the server reboots, 
certain system resources, such as your network cards, won’t 
be available on the system.

Deselect the slesp3-kernel Security update for 
the Linux kernel patch by clicking its checkbox twice.

3. Click Accept. 

4. If you see one or more YaST pop-ups indicating that a reboot 
is required, then you must click Cancel to deselect the patch or 
patches indicated.

The update patches are downloaded and installed.

5. When both status bars indicate 100%, click Next.

IMPORTANT: After the server installation completes and you 
log in as the root user, you will need to complete the update/
patch process. Otherwise, your server resources won’t be 
available the first time you reboot the server.

Installation Settings 1. Click Next.

Page Name Action
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Page Name Action

eDirectory Configuration - New or 
Existing Tree

1. In the Tree Name field, type EXAMPLE_TREE.

Notice that the Use eDirectory Certificates for HTTPS 
Services option is selected. This option configures all of 
the HTTPS services (OES 2 and SLES 10) to use the new 
eDirectory tree’s Organizational CA for certificate 
management and encryption of HTTPS communications. 

For more information on the value this adds to your 
network, see “Certificate Management” in the OES 2 SP3: 
Planning and Implementation Guide.

2. Click Next.

eDirectory Configuration - New 
Tree Information

1. In the FDN Admin Name with Context field, type 
CN=admin.O=COMPANY. 

In this guide, the Admin User object is named admin (all 
lowercase) to differentiate the name from the object itself 
(Admin User), which is a standard eDirectory object and is 
always capitalized in the documentation by convention. 

The eDirectory Admin User object can have any name you 
choose, although most administrators use “admin.”

In this guide, all container objects, such as COMPANY, are 
created in uppercase so they are more easily 
distinguished in the illustrations and procedures.

2. In the Admin Password and Verify Admin Password fields, 
specify the password for the eDirectory Admin User.

3. Click Next.

eDirectory Configuration - Local 
Server Configuration

1. Change the server context to 
OU=SERVERS.OU=LAB.O=COMPANY.

2. Click Next.

eDirectory Configuration - NTP 
and SLP

Time synchronization is required for eDirectory. 

1. Type the IP address or DNS name of the reliable, external 
Network Time Protocol (NTP) server you want the servers 
in your tree to use for time synchronization. 

2. Click Next. 

SLP Configuration 1. Click Yes to confirm that SLP is not being configured at 
this time.

Later in this guide you will configure this server as the SLP 
Directory Agent. For more information on SLP, see “SLP” 
in the OES 2 SP3: Planning and Implementation Guide.

Novell Modular Authentication 
Services

1. Click Next.

OES common proxy user 
Information

1. Click Next.

This creates a common proxy user for some of the OES 
services you are installing. For more information, see 
“Common Proxy User - New in SP3” in the OES 2 SP3: 
Planning and Implementation Guide.
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2 Continue with Setting Up the Graphical User Interface.

1.6 Setting Up the Graphical User Interface
Although most Linux servers don’t have a graphical user interface loaded, the getting-started lab 
server you are installing runs the GNOME* interface by default.

When the Hardware Configuration page appears:

1 Review the Graphics Cards configuration to make sure your monitor was detected and that your 
color and resolution settings are the way you want them. 

If the settings are correct, skip to Step 3.

2 If the configuration is incomplete or wrong, click the blue links to configure your monitor, color, 
resolution, etc.

3 Click Next.

4 When the Installation Completed page appears, deselect Clone This System for Autoyast, then click 
Finish.

5 When the login splash page appears, continue with Completing the Update Process.

Novell Open Enterprise Server 
Configuration

1. Click NetStorage.

2. Change the User Context to the following:

OU=USERS.OU=LAB.O=COMPANY

3. Click Next.

The eDirectory and iManager configuration processes can 
take a few minutes or much longer depending on the 
server processor speed, etc. The other OES services 
should self-configure fairly quickly.

User Authentication Method 1. Click Next.

New Local User The local root user was created during the SLES install. On 
OES 2 servers, we recommend that all users except root be 
defined in eDirectory. Therefore, you don’t create additional 
local users.

1. Click Next.

Empty User Login 1. Click Yes.

Release Notes 1. Click Next.

The official OES 2 Release Notes (http://www.novell.com/
documentation/oes2/oes_readme/data/readme.html) are 
published with the OES 2 Online Documentation (http://
www.novell.com/documentation/oes2).

Page Name Action
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1.7 Completing the Update Process
You must update the server at this point to avoid problems with system resources.

1 Log into the server as root.

2 Click the Software Updater icon .

3 In the Sofware Updater dialog, click Update.

4 In the Change Summary dialog, click Apply, then Accept the license agreement.

5 After the update is downloaded and installed, click Close > Yes.

6 After the system reboots, continue with Section 1.8, “Setting Up the Server as an SLP Directory 
Agent,” on page 20.

1.8 Setting Up the Server as an SLP Directory Agent
For OES 2 services to work, the OES 2 server must have one of the following:

 An eDirectory replica installed on the server. This is not automatic after the third server 
installed in a tree because it is not recommended to have more than three to five replicas in the 
tree. 

This means that in a large network with many servers, most of the servers won’t have replicas, 
which leaves only the OpenSLP option.

 OpenSLP running on the server with eDirectory as a registered service. This requires that you 
configure a network server (for example, the first server in the tree) as an SLP Directory Agent 
(DA), and then configure the other network servers that don’t have an eDirectory replica to point 
to the DA server.

For the getting-started lab setup, you don’t actually need SLP services set up because each of the two 
getting-started lab servers (this server and the NetWare VM) has an eDirectory replica. However, it’s 
important to understand the basics of setting up SLP on OES 2. For more information, see “SLP” in 
the OES 2 SP3: Planning and Implementation Guide.

1 Log in to the server as root.

2 Configure the server as an SLP DA server:

2a Click Computer > Home Folder.

2b In the left panel, double-click File System, then double-click the etc directory.

2c Scroll down to the slp.conf file, right-click the file, and select Open with gedit.

2d In slp.conf, find the following line:

;net.slp.useScopes = myScope1, myScope2, myScope3

2e Remove the semicolon (;) and change the line as follows:

net.slp.useScopes = Directory

2f Find:

;net.slp.isDA = true

2g Remove the semicolon (;) so that it reads:
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net.slp.isDA = true

2h Save and close the file and the file browser.

3 Configure the firewall on the DA server to allow SLP daemon traffic:

3a Click Computer > YaST Administrator Settings, then click Security and Users > Firewall. 

3b In the left navigation frame, click Allowed Services. 

3c Click the Services to Allow drop-down list and select SLP Daemon. 

3d Click Add > Next.

3e Click Accept.

4 Restart OpenSLP and eDirectory:

4a Click Computer > Gnome Terminal.

4b At the command prompt, enter the following command to restart the SLP daemon with the 
changed configuration:

rcslpd restart

4c Restart eDirectory by entering the following command:

rcndsd restart

This registers eDirectory as an SLP service.

5 Verify that OpenSLP is running as expected.

5a After eDirectory restarts, enter the following command:

slptool findsrvs service:ndap.novell

After a moment or two, the system should respond with a line that indicates 
EXAMPLE_TREE is being advertised as a service in SLP.

5b Close the terminal by entering the following command:

exit

6 Continue with Accessing iManager.

1.9 Accessing iManager

IMPORTANT: You must access iManager multiple times in this guide. If you get a Tomcat error in 
response to any launch requests, see Section A.2, “iManager Tomcat Error,” on page 111.

Novell iManager is the main browser-based tool you use to manage eDirectory and your OES 2 
services. 

To start iManager and prepare your browser for future sessions:

1 On your getting-started lab workstation, in your Web browser, open the OES 2 Welcome page by 
entering the following URL:

http://IP_or_DNS

where IP_or_DNS is the IP address or DNS name of your OES 2 server.

2 Click the Management Services tab.

3 On the Available Services page, click iManager.
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You can also start iManager directly by including /nps after IP_or_DNS in the access URL. For 
example, enter http://192.168.1.100/nps.

4 You should receive a security alert, such as a warning that the connection is not trusted. 

Select the options to continue, such as I Understand the Risks > Add Exception.

5 Make sure that the option to permanently store the exception is selected if available, then 
confirm the exception.

6 Log in as the eDirectory Admin user:

6a In the Username field, type admin.

6b In the Password field, type the eDirectory Admin user password.

6c In the Tree field, type example_tree.

If SLP services are not working properly, you need to enter the IP address instead of the tree 
name.

6d Click Login.

7 Do not close iManager. Continue with the next section, Configuring the Browser for the 
eDirectory CA.

1.10 Configuring the Browser for the eDirectory CA
If you didn’t receive an offer to permanently store the security warning exception, you can configure 
your Web browser to trust the eDirectory-based certificate authority by completing the instructions 
in the next two sections. Otherwise, skip to Section 1.11, “Enabling Pop-Ups for iManager,” on 
page 23.

 Section 1.10.1, “Exporting the CA’s Self-Signed Certificate,” on page 22

 Section 1.10.2, “Importing the CA Certificate into Mozilla Firefox 3.6 on Windows,” on page 23

 Section 1.10.3, “Importing the CA Certificate into Windows Explorer 8 on Windows,” on page 23

1.10.1 Exporting the CA’s Self-Signed Certificate

1 In iManager, click the Roles and Tasks icon . 

2 Click Novell Certificate Server > Configure Certificate Authority.

3 Click the Certificates tab, then select the check box for the self-signed certificate.

4 Click the Export sub-tab.

5 Deselect Export Private Key.

The Export Format changes to DER.

6 Click Next.

7 Click Save the Exported Certificate and save the file to disk, noting the filename and location if 
indicated.

8 Click Close > OK.

9 Find the file you just saved. By default it is usually on the desktop.
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10 To configure Mozilla Firefox on Windows, continue with Importing the CA Certificate into 
Mozilla Firefox 3.6 on Windows. 

Instructions for configuring other browsers are in “Eliminating Browser Certificate Errors” in 
the OES 2 SP3: Planning and Implementation Guide.

1.10.2 Importing the CA Certificate into Mozilla Firefox 3.6 on Windows

1 In Firefox, click Tools > Options

2 Select the Advanced tab.

3 Select the Encryption tab.

4 Click the View Certificates button.

5 Select the Authorities tab, then click Import.

6 Browse to the certificate file you downloaded in “Exporting the CA’s Self-Signed Certificate” on 
page 22 and click Open.

7 Select Trust this CA to identify Web sites, then click OK > OK > OK.

Firefox now trusts certificates from the servers in your getting-started lab’s tree.

8 To verify success, close all instances of Firefox, then restart the browser and log in to iManager 
again. 

The certificate warning doesn’t appear.

1.10.3 Importing the CA Certificate into Windows Explorer 8 on Windows

1 In Internet Explorer, click Tools > Internet Options.

2 Click the Content tab.

3 Click the Certificates button.

4 Select the Trusted Root Certification Authorities tab.

5 Click the Import button.

6 Click Next.

7 Browse to the certificate file you downloaded in “Exporting the CA’s Self-Signed Certificate” on 
page 22 and click Open.

8 Click Next.

9 Click Finish > Yes > OK > Close > OK.

1.11 Enabling Pop-Ups for iManager
Some iManager plug-ins use pop-up dialog boxes that are blocked by most browsers. To use 
iManager, you must enable pop-ups that originate from the servers where iManager is running. 

1.11.1 Firefox 3.6.x

1 On the Firefox menu bar, click Tools > Options > Content.

2 Disable all pop-up blocking by deselecting the Block Popup Windows option and clicking OK. 

or 
Installing the OES 2 SP3 Server in Your Getting-started Lab 23



Add the getting-started lab server to the list of exceptions by doing the following:

2a Click the Exceptions button.

2b In the Address of Web Site field, type the OES 2 getting-started lab server’s IP address.

2c Click Allow > Close.

1.11.2 Internet Explorer 8

1 On the Command bar, click Tools > Pop-up Blocker > Turn Off Pop-up Blocker.

Continue with Chapter 2, “Installing a NetWare Virtual Machine,” on page 25.
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2 2Installing a NetWare Virtual Machine

Use the instructions in this section to install an Open Enterprise Server 2 (OES 2) virtual machine host 
server in your getting-started lab, create a virtual machine on the server, and install NetWare® 6.5 SP8 
on the virtual machine.

This section describes the following:

 Section 2.1, “Virtualization Host Server Requirements,” on page 25

 Section 2.2, “Installing the Virtualization Host Server,” on page 26

 Section 2.3, “Installing the NetWare 6.5 SP8 Virtual Machine,” on page 34

2.1 Virtualization Host Server Requirements
For the tasks and exercises described in this section, you need the following in addition to those listed 
in Section 1.1, “Getting-started Lab Setup Requirements,” on page 9.

 A server-class computer with the following:

Component Minimum Recommended

Processor Pentium II or AMD K7 450 MHz Pentium III, Pentium III Xeon, 
Pentium 4, Intel Xeon 700 MHz, 
AMD K8 CPUs (Athlon64 and 
Opteron), Intel EM64T or higher 
processor

RAM 1 GB 2 GB

Display adapter Super VGA VESA 1.2-compliant, high 
resolution

DVD drive Supports the ElTorito Specification

Hard drive

(All data will be erased)

40 GB

Network card Ethernet 100 Mbps
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 Installation software to match the processor type and removable media support of your VM host 
server.

If you need to download and prepare different media than you used for the first server, go to 
Section 1.2, “Obtaining Installation Media,” on page 10.

IMPORTANT: For installing the virtualized NetWare 6.5 SP8 guest server, you download the 
NetWare DVD ISO file to the VM host server desktop after the host server is installed and 
running.

2.2 Installing the Virtualization Host Server

Although it is possible to install NetWare 6.5 SP8 on a SUSE® Linux Enterprise Server (SLES) 10 SP4 
server that has no OES 2 services installed, we recommend that you install the basic OES 2 services on 
the host server to provide backup services through SMS and management services through Novell® 
Remote Manager. 

IMPORTANT: Virtualized NetWare in Xen* is an OES 2 product feature. Support of NetWare in a 
Xen virtual machine is available to only OES 2 registered customers.

Complete the instructions in the following sections.

 Section 2.2.1, “Prerequisites,” on page 27

 Section 2.2.2, “Starting the Installation,” on page 27

 Section 2.2.3, “Setting the Root Password, Configuring the Network, and Updating the Server,” 
on page 29

 Section 2.2.4, “Configuring LDAP and OES Services,” on page 32

 Section 2.2.5, “Setting Up the Graphical User Interface,” on page 33

 Section 2.2.6, “Booting with the Xen Kernel,” on page 34

IP address  Two IP addresses on the 
getting-started lab subnet (one 
for the OES 2 VM host and 
one for the NetWare VM). For 
example, 192.168.1.120 and 
192.168.1.130. 

 Subnet mask. For example, 
255.255.255.0.

 Default gateway. For example, 
192.168.1.1.

Mouse Not required USB or PS/2

Component Minimum Recommended
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2.2.1 Prerequisites

Before installing OES 2 on your server, you must complete the following task:

 Ensure that the server computer meets the requirements outlined in Section 2.1, “Virtualization 
Host Server Requirements,” on page 25.

2.2.2 Starting the Installation

WARNING: This procedure permanently erases any data currently on your server’s hard drive.

1 Prepare the BIOS on your server machine so that it will boot from the DVD drive first.

2 Insert the SLES 10 SP4 DVD into your server and reboot the machine.

3 When the boot selection page appears, immediately press the Down-arrow key to select the 
Installation option, then press Enter.

If you don’t respond before the machine starts booting from the hard disk, reboot and repeat this 
step.

4 After the boot process finishes, select an installation language, then click Next.

5 Read and agree to the software license agreement, then click Next.

6 Select New Installation, select the Include add-on product from separate menu option, then click Next.

7 On the Add-on Product Installation page, click Add.

8 Select CD, then click Next.

9 Insert the OES 2 SP3 CD as prompted.

10 After the catalog is added, read and agree to the OES 2 license agreement, then click Next > Next.

11 Select the time zone for the server, then click Next.

12 On the Installation Settings page, scroll down the list and click Partitioning.

If your server has existing partitions, the OES install tries to add new SLES partitions to them. 

13 To ensure a clean install, use the following table to navigate and configure the partitioning 
pages:

Page Name Action

Suggested Partitioning 1. Select Create Custom Partition Setup.

2. Click Next.

Preparing Hard Disk—Step 1 1. Select Custom Partitioning (for experts).

2. Click Next.

Expert Partitioner 1. Click Expert > Delete partition table and disk label.

2. When prompted to select a new partition table type, click OK.

Caution! 1. Click Yes.

Expert Partitioner First, you specify the swap partition information.

1. Click Create.

Which type of partition do you want 
to create?

1. Select Primary partition.

2. Click OK.
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14 On the Installation Settings page, scroll down and click Software.

Use the following table to navigate and configure the software pages.

Create a Primary Partition 1. In the File System drop-down list, select Swap.

2. In the End field, type 512M.

3. Click OK.

Expert Partitioner Next, you specify information for the partition for installing the VM 
host server.

1. Click Create.

Which type of partition do you want 
to create?

1. Select Primary partition.

2. Click OK.

Create a Primary Partition 1. In the End field, type 10GB.

2. Click OK.

Expert Partitioner 1. Click Create.

Which type of partition do you want 
to create?

1. Select Primary partition.

2. Click OK.

Create a Primary Partition And finally, you specify information for the partition where the 
NetWare virtual machine runs. 

1. In the File System drop-down list, select Ext2.

Operating systems running in paravirtual mode should run 
their kernels on non-journaling file systems, such as Ext2. For 
more information, see “Paravirtual Mode and Journaling File 
Systems (http://www.novell.com/documentation/sles10/
xen_admin/data/sec_xen_filesystem.html)” in the Virtualization 
with XEN (http://www.novell.com/documentation/sles10/
xen_admin/data/bookinfo.html) guide.

2. In the End field, type 25GB.

3. In the Mount Point field, type /vm.

4. Click OK.

Expert Partitioner 1. Click Finish.

Page Name Action
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15 When prompted, insert the SLES media and click Retry. 

Insert the DVD when you are prompted for CD1. 

Insert additional media as instructed.

16 After the files are copied, the system configuration takes a few minutes to complete. 

17 If you are prompted for additional input during the configuration, accept the default actions.

18 Continue with Setting the Root Password, Configuring the Network, and Updating the Server.

2.2.3 Setting the Root Password, Configuring the Network, and Updating the 
Server

After the initial system configuration and system reboot, the installation needs more information 
about the root user and the network.

1 Use the following table to navigate and complete the various configuration pages.

Page Name Action

Software Selection and System 
Tasks

1. Under OES Services, select Novell Backup / Storage 
Management Services (SMS). 

Notice that Novell Linux User Management and Novell 
Remote Manager are also selected by default.

These three are the only OES 2 services that are 
supported to run directly on a Xen virtualization host 
server. 

All OES 2 services are supported to run on Xen guest 
servers.

2. Under Primary Functions, select Xen Virtual Machine Host 
Server.

3. Click Accept.

agfa fonts 1. Click Accept.

Installation Settings 1. Click Accept.

Confirm Installation 1. Click Install.
Installing a NetWare Virtual Machine 29



Page Name Action

Password for the System 
Administrator “root”

1. Enter and confirm the root user password, then click 
Next.

Hostname and Domain Name 1. In the Host Name field, type the DNS hostname for the IP 
address you are assigning to the server. For example, 
myserver.

2. In the Domain Name field, type the DNS Domain Name for 
your network. For example, 
mysite.company.example.com.

3. Click Next.

Network Configuration 1. Click Network Interfaces.

Network Card Configuration 
Overview

1. If your server has multiple network cards, select the card 
the server will use.

2. Click Edit.

3. Select Static Address Setup.

4. In the IP Address field, type the IP address for the server. 
For example, 192.168.1.120

5. Change the Subnet Mask if needed. For example, 
255.255.255.0.

6. Click Host Name and Name Server.

Host Name and Name Server 
Configuration

1. Type the IP address of at least one name server and type 
your DNS domain name in the Domain Search field. 

2. Click OK.

Network Address Setup 1. Click Routing.

Routing Configuration 1. Type the IP address of the default gateway for your 
getting-started lab subnet. For example, 192.168.1.1.

2. Click OK.

Network Address Setup 1. Click Next.

Network Card Configuration 
Overview

1. Click Next.

Network Configuration 1. Click Next.

Test Internet Connection You will need to register your server on the Internet to download 
the latest patches, so you should test the Internet connection at 
this point to make sure everything is configured correctly.

1. Select Yes, Test Connection to the Internet.

2. Click Next.

Running Internet Connection Test After a few moments, the Test Status should indicate Success.

If it does not, you need to click Back and fix your network 
configuration and the connection to the Internet. It is essential 
that OES 2 servers always have the latest security and other 
critical patches downloaded and installed.

1. Click Next.
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Novell Customer Center 
Configuration

1. Click Next.

The server establishes a connection with the Novell 
Customer Center.

Manual Interaction Required 1. Click Continue.

Novell Customer Center System 
Registration

1. In the fields indicated, type and confirm the e-mail address 
to which you want administrative notifications sent.

2. In the Activation code for SLES components field, type the 
SLES activation code you noted or printed while 
downloading the image files.

IMPORTANT: If you don’t enter this code, the server 
cannot receive software updates from the Novell patch 
channels and your installation of OES 2 SP3 will fail.

3. In the Activation code for OES components field, type the 
OES 2 activation code you noted or printed while 
downloading the image files.

If you don’t enter this code, the same patch channel 
restriction applies.

4. Click Submit.

Your registration information is sent to the Customer 
Center. This might take a couple of minutes to complete.

5. Click Continue.

The update server is added to your system configuration.

Novell Customer Center 
Configuration pop-up

1. Click OK.

Online Update You might need to run the update process more than once. 

1. Select Run Update, then click Next.

Although you might need to scroll down to see them, the 
correct patches are automatically selected. Do not change 
the selections.

2. Click Accept.

If one or more notification dialog boxes appear, accept or 
continue through each one.

Insert additional installation media as instructed.

The security and other critical patches and updates are 
downloaded and installed.

The update patches are downloaded and installed.

3. When both status bars indicate 100%, click Next > OK.

If the system refreshes with additional patches selected, 
apply them as well.

4. When both status bars indicate 100%, click Next > OK.

The system restarts.

Installation Settings Notice the red text under CA Management. This is because the 
system restarted and the installation no longer has the root 
password in memory.

1. Click CA Management.

Page Name Action
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2 Continue with Configuring LDAP and OES Services

2.2.4 Configuring LDAP and OES Services

The VM host server is not created as an object in eDirectoryTM, but it uses eDirectory LDAP for the 
OES 2 services installed on it.

1 Use the following table to navigate and complete the eDirectory pages:

Managing CAs and Certificates 1. Click Edit Default Settings.

Edit Default Settings 1. Type the root password in the Password and Confirm 
Password fields, then click Next.

Managing CAs and Certificates 1. Click Next.

Installation Settings 1. Click Next.

Page Name Action
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2 Continue with Setting Up the Graphical User Interface.

2.2.5 Setting Up the Graphical User Interface

When the Hardware Configuration page appears:

1 Review the Graphics Cards configuration to make sure your monitor was detected and that your 
color and resolution settings are the way you want them. 

If the settings are correct, skip to Step 3.

2 (Conditional) If the configuration is incomplete or wrong, click the blue links to configure your 
monitor, color, resolution, etc.

3 Click Next.

Page Name Action

Configured LDAP Servers 1. In the eDirectory Tree Name field, type 
EXAMPLE_TREE.

2. In the Admin User and Context field, type 
cn=admin.o=company.

3. In the Admin Password field, type the admin 
password.

4. Under the Configured LDAP Servers list, click 
Add.

5. Specify the IP address of the first getting-started 
lab server.

6. Click Add > Next.

7. Click Next.

Novell Open Enterprise Server 
Configuration

1. Click Next.

The configuration settings are saved for the OES 
services you’ve installed.

User Authentication Method 1. Click Next.

New Local User The root user was created during the SLES install. 
On OES 2 servers (including virtualization host 
servers), we recommend that all users except root be 
defined in eDirectory. Therefore, you don’t create 
additional local users.

1. Click Next.

Empty User Login 1. Click Yes.

Release Notes 1. Click Next.

The official OES 2 Release Notes (http://
www.novell.com/documentation/oes2/
oes_readme/data/readme.html) are published 
with the OES 2 Online Documentation (http://
www.novell.com/documentation/oes2).
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4 When the Installation Completed page appears, deselect Clone This System for Autoyast and click 
Finish.

5 Continue with Booting with the Xen Kernel.

2.2.6 Booting with the Xen Kernel

By default, the OES 2 server doesn’t load the Xen kernel required for hosting virtual machines. To 
configure the server to boot the Xen kernel by default:

1 Log in to the server as root. 

2 On the desktop, click Computer > YaST.

3 Click System > Boot Loader.

4 Select the XEN option and click Set as Default.

5 Click Finish.

6 Restart the server by clicking Computer > Log Out > Log Out. Then click Reboot and enter the root 
password.

7 Continue with Installing the NetWare 6.5 SP8 Virtual Machine.

2.3 Installing the NetWare 6.5 SP8 Virtual Machine
After preparing the virtualization host server, complete the following instructions. For complete 
information and instructions, see the Novell Virtualization Technology documentation Web site 
(http://www.novell.com/documentation/vmserver/index.html).

 Section 2.3.1, “Disabling the Alt+Esc Shortcut on the VM Host Server,” on page 34

 Section 2.3.2, “Downloading the NetWare ISO File,” on page 35

 Section 2.3.3, “Creating a Virtual Machine and Installing NetWare,” on page 35

2.3.1 Disabling the Alt+Esc Shortcut on the VM Host Server

Alt+Esc is used on a NetWare server to switch between console screens, but on SLES 10 it moves 
between open windows. To provide the expected behavior for the virtualized NetWare server, you 
must disable the shortcut for SLES 10.

1 On the host server as the root user, click Computer > Control Center.

2 Click Personal > Shortcuts.

3 Under the Window Management category, click Move between windows immediately, then press the 
Backspace key to disable the shortcut.

4 Click Close.

5 Close the Control Center.

6 Continue with Downloading the NetWare ISO File.
34 OES 2 SP3: Getting Started with OES 2 and Virtualized NetWare

http://www.novell.com/documentation/vmserver/index.html


2.3.2 Downloading the NetWare ISO File

You install NetWare from the DVD .iso file copied to the server’s hard drive.

1 On the host server, click Computer > Firefox and access the NetWare 6.5 SP8 e Media Kit on the 
Novell Download Web site (http://download.novell.com/Download?buildid=dpIR3H1ymhk~).

2 On the evaluation page, click Proceed to Download.

3 Log in using your Novell Account information.

4 Click the Download button for the NW65SP8_OVL_DVD.iso file.

5 Select Save to Disk and click OK.

The file is saved to the desktop.

6 After the file downloads, verify its integrity.

6a Click Computer > Gnome Terminal.

6b At the command prompt, enter cd Desktop.

The terminal opens in the root user’s home directory (/root). The desktop is contained in a 
subfolder of /root named Desktop.

6c Check the MD5 checksum value of the downloaded image file by entering:

md5sum NW65SP8_OVL_DVD.iso

6d Compare the displayed value against the value listed on the evaluation download page.

If the values don’t match, you must download the file again until you get a matching 
checksum.

6e Close the terminal by entering exit.

6f You can also close the browser and the download dialog box.

7 Continue with Creating a Virtual Machine and Installing NetWare.

2.3.3 Creating a Virtual Machine and Installing NetWare

1 On the desktop, click Computer > YaST.

2 Select Virtualization > Virtual Machine Manager.

Notice that one virtual machine, Domain-0 (the OES 2 virtual machine host server) is already 
running.

3 Use the information in the following table to create a second virtual machine and start the 
NetWare installation.

Page Name Action

Virtual Machine Manager 1. In the list of virtual machines, select the localhost entry.

2. Click New.

The Create a Virtual Machine Wizard launches. 

Create a Virtual Machine 1. Click Forward.

Install an Operating System? 1. Click Forward.
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Type of Operating System 1. Click the expand icon next to NetWare, then select Novell 
Open Enterprise Server 2 (NetWare).

2. Click Forward.

Summary 1. Click Name of Virtual Machine.

Name of Virtual Machine 1. In the Name field, type LAB_NW_VM. 

It is easier to know which VM you are managing if it reflects the 
name of the server it contains.

2. Click Apply.

Summary 1. Click Hardware.

Hardware 1. If your server has more than 1 GB memory installed, increase 
the initial memory allocated to the VM by clicking the arrows. 

For example, if your server has 2 GB memory installed, you 
can easily increase the initial memory amount to 1024 MB.

2. Click Apply.

Summary 1. Click Disks.

Disks Initially, a 10 GB file is specified for the partitions/volumes on the 
virtual server. By default, this is a sparse file, meaning that although 
10 GB is allocated, the size of the file on the disk will only be as 
large as the actual data it contains. Sparse files conserve disk 
space, but they have a negative impact on performance. 

The NetWare install allocates 500 MB for a DOS partition and 8 GB 
for the SYS: volume. The default disk size of 10 GB leaves about 
1.5 GB for other partitions, which isn’t very much, although it is 
sufficient for the exercises in this guide.

However, you allocated 25 GB for the /vm mount point on the 
server, so let’s allocate all of that to this virtual machine.

1. With the default Hard Disk selected, click Edit.

2. Modify the path in the Server field to be

file:/vm/LAB_NW_VM/disk0

This creates the virtual machine files on the Ext2 /vm partition 
you created during the installation.

3. In the Size field, replace 10.0 with 25.

4. Deselect Create Sparse Image File.

This dedicates 25 GB of physical disk space on the file system 
to the VM file and improves performance of the Virtual 
NetWare server.

5. Click OK.

6. Click CD-ROM.

7. Click Browse, then navigate to and select the 
NW65SP8_OVL_DVD.iso file you downloaded to the desktop.

8. Click Open.

9. Click OK.

10. Click Apply.

Page Name Action
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4 After the NetWare installation starts, use the following table to navigate the pages listed in the 
left column:

IMPORTANT: Some of the instructions that follow assume you have a mouse attached to the 
server. If not, as you install, use the Tab key to select the options indicated, then press Enter to 
continue.

Summary 1. Click OK.

The virtual machine is created and the NetWare installation 
starts.

This can take a few minutes or longer, depending on processor 
speed, memory, etc. Most of the time is required to prepare the 
25 GB VM file. However, after the file is prepared, the VM will 
run much more efficiently than if it were using a sparse file.

Page Name Action

NetWare Installation 1. Click inside the installation window to set the mouse 
pointer. 

The mouse is not used on the first few screens, but you 
must set it now. Otherwise, the mouse and the keyboard 
might not work as expected when the GUI pages appear.

2. Use the arrow keys to select a language, then press Enter.

3. Modify the Regional Settings if desired, then select 
Continue and press Enter.

4. Press F10 twice to accept the license agreements.

5. Press the Down-arrow key to select Continue, then press 
Enter.

6. Press Enter to 

 Create an 8 GB SYS: volume.

 Begin copying files for the installation.

As the files copy, notice the Run, Pause, and Shutdown 
options above the window displaying the installation. After 
the server is installed, they are activated, and you can then 
use them to manage the state of the virtual machine.

Choose a Pattern 1. Click Next.

At the start of the installation you set the mouse pointer 
inside the window boundary. To free the mouse to move 
outside the window, press Ctrl+Alt. To start working in the 
window again, click inside it to set the pointer.

Components 1. Select

 Apache 2 Web Server and Tomcat 4 Servlet 
Container 

 Tomcat 5 Servlet Container 

 Novell iManager 2.7.2

2. Click Next.

Page Name Action
Installing a NetWare Virtual Machine 37



Novell iManager 2.7.2 1. Click Yes.

Summary 1. Click Copy Files.

Server Properties 1. Type LAB_NW for the server name.

2. Click Next.

Protocols 1. Click IP.

The installation process accesses the server.

2. Click the first IP Address field, then type the IP address of 
the server. For example, 192.168.1.130.

3. Type the subnet mask for the address. For example, 
255.255.255.0.

4.  Type the router (gateway) address for the subnet. For 
example, 192.168.1.1.

5. Click Advanced.

Advanced 1. Click the SLP tab.

2. In the DA Server 1 field, type the IP address of the SLP 
Directory Agent (DA), which is the first OES 2 server you 
installed in the getting-started lab. For example, 
192.168.1.100.

3. In the SLP Scope List field, type Directory.

4. Click OK.

Protocols 1. Click Next.

Domain Name Service 1. Type the DNS hostname associated with the IP address 
you just entered.

In contrast to OES 2 servers, this can be different than the 
name used in eDirectory. Of course, you can choose to 
use the DNS name for NetWare servers in eDirectory in 
your production network. In this guide, however, the 
eDirectory server name is assumed to be LAB_NW.

2. Type the domain name.

3. Type at least one DNS name server IP address. For 
example, 192.168.1.50.

4. Click Next

Time Zone 1. Click the correct time zone for your area.

2. Click Advanced. 

Time Synchronization 1. Leave the protocol set to Timesync.

2. Click Use Configured Sources.

3. In the Time Source 1 field, type the IP address of the same 
reliable time source you specified for the OES 2 getting-
started lab server (not the VM host server). 

4. Select NTP.

5. Click OK.

6. Click Next.

eDirectory Installation 1. Click Next.

Page Name Action
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eDirectory Information 1. Click the Tree icon.

2. Browse to and select EXAMPLE_TREE.

3. Click OK.

4. Click the browse icon to the right of the Context for Server 
Object  field. 

5. Browse to and select SERVERS (in COMPANY > LAB).

6. Click OK.

7. Click Next.

eDirectory Login 1. Click the browse icon to the right of the Name field.

2. Browse to and select admin (in COMPANY).

3. Click OK.

4. Type the Admin user’s password.

5. Click OK.

NDS/eDirectory Patch 
Detection

The warning doesn’t apply because you are installing into an 
eDirectory 8.8 tree.

1. Click OK.

The system checks time synchronization, extends the 
eDirectory schema, and installs an eDirectory replica on 
the virtualized NetWare server.

eDirectory Summary 1. Click Next.

Licenses In this page you install the license included with NetWare 6.5 
SP8. The software license doesn’t expire, but your evaluation 
period expires 90 days after you install the server. At that point 
you should either uninstall NetWare or purchase the OES 2 
product. For more information, see “NetWare 6.5 SP8 Includes 
MLA License Files” in the NW 6.5 SP8: Licensing Services 
Administration Guide.

1. Click the Browse icon to the right of the License Location 
field.

2. In the Select a License dialog box, click the expansion dots 
to the left of NW65OS and then the dot to the left of 
LICENSE.

3. Click the NLF file that appears in the right frame.

4. Click OK.

5. Click Next.

MLA License Certificate 
Context

1. Change the NDS Context for the license file to 
O=COMPANY. This makes this license available to any 
additional NetWare 6.5 servers you might choose to install 
in a different context in the tree, including any physical 
NetWare servers you install.

2. Click Next.

Page Name Action
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5 Close the Virtual Machine Manager windows by clicking the X on the upper right corner, or by 
right-clicking the title bar and selecting Close. The NetWare server continues to run. 

IMPORTANT: It is wise to keep Virtual Machine Manager open only while you are actively 
using it to manage the virtual machines on your host server. Otherwise, the manager 
incrementally consumes domain 0 memory and eventually causes out-of-memory errors. For 
more information, see “Virtual Machine Manager (http://www.novell.com/documentation/
sles10/xen_admin/data/sec_xen_virtualization_vmanager.html)” in the Virtualization with Xen 
Guide (http://www.novell.com/documentation/sles10/xen_admin/data/bookinfo.html) guide.

6 Continue with Chapter 3, “eDirectory, Users and Groups, and Identity Services,” on page 41.

Novell Modular Authentication 
Service

1. Click Next.

It takes a few minutes for the installation to configure your 
OES 2 services. If you want to learn more about various 
OES 2 services (most of which we have not installed), you 
can read the information pages as the configuration 
process runs. 

You can install more services later if you want to 
experiment further.

Reset Your Server Now? 1. Click Yes.

Page Name Action
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3 3eDirectory, Users and Groups, and 
Identity Services

Novell® eDirectory™ is the central, key component of Novell Open Enterprise Server (OES). It 
provides the following:

 Centralized identity management

 The underlying infrastructure for managing your network servers and the services they provide

 Secure access to network services both within the firewall and from the Web

The installation steps presented in this guide thus far have created a new eDirectory tree named 
EXAMPLE_TREE that you are using to learn about OES 2. As you work with the tree and the objects 
it contains, you will begin to better understand the role eDirectory plays.

This section discusses the following:

 Section 3.1, “Using the eDirectory Information in This Guide,” on page 41

 Section 3.2, “An Introduction to eDirectory Planning,” on page 42

 Section 3.3, “Setting Up Role-Based Services,” on page 45

 Section 3.4, “Updating the iManager Plug-in Modules,” on page 46

 Section 3.5, “Creating a Context for Your Users and Groups,” on page 46

 Section 3.6, “Assigning a Password Policy to Your Users,” on page 47

 Section 3.7, “Creating NCP and NSS Volumes for Home Directories,” on page 48

 Section 3.8, “Creating Users,” on page 51

 Section 3.9, “A Note about Identity Manager 3.6 Bundle Edition,” on page 54

3.1 Using the eDirectory Information in This Guide
Before you install OES 2 in a production environment, it is critical that you and your organization 
take time to plan and design your tree.

However, the instructions in this guide require no planning on your part. In fact, most of the 
eDirectory objects needed for the exercises in this guide were created in Chapter 1, “Installing the 
OES 2 SP3 Server in Your Getting-started Lab,” on page 9.

The information that follows introduces eDirectory.

If you are already familiar with eDirectory and want to skip the planning introduction, we 
recommend that you do the following:

1. View the eDirectory tree structure used in this guide (Figure 3-1 on page 42).

2. Skip to Section 3.4, “Updating the iManager Plug-in Modules,” on page 46.
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3.2 An Introduction to eDirectory Planning
If you want an efficient and intuitive eDirectory design, you and your organization need to base it on 
two things: 

 The layout of your network

 The structure of your organization

You and your team should carefully think through the issues and design considerations discussed in 
“Designing Your Novell eDirectory  Network” in the Novell eDirectory 8.8 Administration Guide.

 Section 3.2.1, “Your Getting-started Lab’s eDirectory Tree,” on page 42

 Section 3.2.2, “Your Current Getting-started Lab Tree,” on page 43

 Section 3.2.3, “Expanding Your Getting-started Lab Tree,” on page 44

3.2.1 Your Getting-started Lab’s eDirectory Tree

Figure 3-1 illustrates an eDirectory tree like the one you will use in the getting-started lab exercises 
found in this guide. It also illustrates and explains the basic elements you should consider when 
designing an eDirectory tree.

NOTE: The IS Organizational Unit object is included for explanatory purposes and is not created in 
this guide.

Figure 3-1   Your Getting-started Lab’s eDirectory Tree

COMPANY

SERVERS PRINTERS

LAB ISadmin

USERS

EXAMPLE_TREE

A

C

B

D

E
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3.2.2 Your Current Getting-started Lab Tree

The eDirectory tree you have created by installing OES 2 in your getting-started lab is illustrated by 
the darker objects in Figure 3-2. The objects that are dimmed are for explanatory purposes and do not 
exist in your current tree. When you finish with this guide, the upper level organization of your tree 
will look more like Figure 3-1, except that the IS Organizational Unit shown in that illustration will 
not be created.

Reference 
Letter Explanation

The Tree object is the top container object in the tree. It usually contains an Organization 
object (specified in the install by using o=company) that represents your company or 
organization.

The Organization object is normally the first (and often the only) container object under the 
Tree object. It is typically named after your organization.

Small organizations keep object management simple by having all other objects, such as 
users, printers, and servers, directly under the Organization object.

Organizations that are large enough to have departments or other organizational units 
usually decide to have their tree structure reflect their organizational structure.

As shown in this getting-started lab example, these organizations create Organizational Unit 
objects (specified during the install by using ou=name) that reflect their departments, 
divisions, geographical locations, etc., as is logical for their organization. 

Sometimes large organizations create multiple Organization objects below the Tree object to 
represent separate business units or subsidiaries.

Every tree requires an Admin User object. You will log in as Admin to create or import other 
User objects and to create the rest of your tree structure.

This example shows two Organizational Unit objects at the department level (LAB and IS).

This example also illustrates how Organizational Unit objects can be nested to provide a 
complex hierarchy if it is necessary to manage the organization.

A

B

C

D

E
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Figure 3-2   Your Current Getting-started Lab Tree

3.2.3 Expanding Your Getting-started Lab Tree

The instructions in this guide cover only the installation of an OES 2 and a virtualized NetWare® 6.5 
SP8 server in the tree. 

If you were to decide to install additional servers in the tree, the processes you would follow could 
involve some additional planning tasks, as illustrated in Figure 3-3. 

Reference 
Letter Explanation

The OES installation process requires that you specify names for the following objects:

 A1: A Tree object

 A2: An Organization object

One of the first objects you specify during an initial installation is the Admin user.

The OES installation process can also create Organizational Unit (OU) objects to define a 
context for the OES 2 Server object.

All other OU objects that you have planned for your tree must be created after the 
installation finishes. For example, you will create the PRINTERS and USERS OU objects 
later in this guide.

The exception to D is that subsequent installations can create additional contexts to contain 
other OES servers that you install into the tree. For example, you could create a SERVERS 
OU under the IS OU as illustrated.

COMPANY
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Figure 3-3   An Expanded Tree

3.3 Setting Up Role-Based Services
When iManager is installed in connection with OES 2, the administrative tasks available through the 
Roles and Tasks icon are available to all users until you run the configuration wizard. In this exercise, 
you create a Role-Based Services (RBS) collection that contains all of the management roles in the 
tree. 

When the installation process finishes as outlined below, the eDirectory Admin user is the only user 
configured to perform the administrative tasks available through the Roles and Tasks icon. If you 
want to create other administrative users and assign them a subset of administrative roles, you need 
to create additional collections with subsets of roles and assign the other administrative users to 
them. For more information, see “Configuring and Customizing iManager” in the Novell iManager 
2.7.4 Administration Guide.

1 At your Windows workstation, log in to iManager on the OES 2 getting-started lab server, using 
the eDirectory Admin user account and password. For more information, see the steps in 
Section 1.9, “Accessing iManager,” on page 21.

If you receive a Tomcat error, see Section A.2, “iManager Tomcat Error,” on page 111.

2 Click the Configure icon .

Reference 
Letter Explanation

During subsequent installations into the same tree, you can create new Organizational Unit 
objects to provide a context for other OES 2 servers being installed.

If you want to specify other Admin users in the OES 2 installation parameters, you can do 
this during the installation. Note, however, that such an Admin would probably not be 
granted rights to the entire tree, only to the objects under the IS OU. Admin objects like this 
are often referred to as sub-container admins.

COMPANY
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USERS SERVERS

B

A
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3 Select Role Based Services > RBS Configuration.

4 Click iManager 2.x collections > New > Collection and Setup.

5 If you are prompted to extend the schema, click Next.

6 In the Name field, type the following:

Tree Admin Role

7 Click the Browse icon  next to the Container field.

8 Click COMPANY, then click Next.

9 Click the Browse icon  next to the Scope field.

10 Click EXAMPLE_TREE.

11 Click Start.

12 Do not close iManager. After the operation finishes, continue with the next section, Updating the 
iManager Plug-in Modules.

3.4 Updating the iManager Plug-in Modules
1 In the Configure pane, click Plug-in Installation > Available Novell Plug-in Modules.

A list shows the plug-ins on novell.com that have been updated or created since OES 2 was 
initially released.

2 Click the check box in the header row.

All of the available plug-in modules are selected.

3 Click Install.

4 Agree to the license agreement and click OK.

5 When the plug-in installation process concludes, click Close.

You can safely ignore plug-in installation errors in connection with the exercises in this guide. If 
you have concerns about the errors for production servers, contact Novell support or visit the 
Novell Support Web page (http://support.novell.com).

6 Do not close iManager. Continue with the next section, Creating a Context for Your Users and 
Groups.

3.5 Creating a Context for Your Users and Groups
All OES 2 services require that you create User objects to represent the users on your system. The 
Linux User Management component for OES 2 servers requires that you also create a Group object 
that you can assign the users to.

If you reviewed Section 3.2, “An Introduction to eDirectory Planning,” on page 42, you might have 
noticed an Organizational Unit object named USERS in Figure 3-2 and Figure 3-3. It is helpful to have 
at least one Organization Unit object to contain user-related objects, such as User objects and Group 
objects. 
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To create an Organizational Unit container object named USERS in the LAB Organizational Unit 
object:

1 In iManager, click the View Objects icon .

2 In the left pane, click the Browse tab.

3 Click the down-arrow  next to the COMPANY Organization object . 

4 Click LAB, then select Create Object from the drop-down list.

5 From the Available Object Classes list, select Organizational Unit, then click OK.

6 In the Organizational Unit name field, type USERS.

7 Click OK > OK.

8 Do not close iManager. Continue with the next section, Assigning a Password Policy to Your 
Users.

3.6 Assigning a Password Policy to Your Users
Beginning with OES 2 SP3, the configuration of proxy users and universal password policies is 
simplified by default. In “Configuring eDirectory and OES Services” on page 17 you created a 
common proxy user, and a universal password policy named Common Proxy Policy.

In order for the users you create to use some of the OES services you have installed, such as Novell 
CIFS, you must associate the Common Proxy Policy with those users. The simplest method for doing 
this is to associate the policy with the USERS container created in Section 3.5, “Creating a Context for 
Your Users and Groups,” on page 46.

NOTE: The Common Proxy Policy is associated with the server’s parent container (SERVERS) by 
default. If your users were in the same container as the server or in a subcontainer of it, then the 
following steps would not be needed. However, the USERS container is a sibling to the SERVERS 
container in the tree created in this guide.

1 In iManager, click the Roles and Tasks icon .

2 Click Passwords > Password Policies.

3 Click the Common Proxy Policy link.

4 Click the Policy Assignment tab.

5 Click the Browse icon  next to the Assign To field.

6 In the Contents pane, browse to the LAB Organizational Unit.

7 Select the USERS Organizational Unit object, then click OK.

8 Click Apply > OK.

9 Do not close iManager. Continue with the next section, Creating NCP and NSS Volumes for 
Home Directories.
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3.7 Creating NCP and NSS Volumes for Home Directories
For the exercises in the guide, you need home directories for the users you create.

When you create NCPTM and NSS volumes before creating users, you can then create home 
directories at the same time as you create the user objects. For that reason, it makes sense to set up the 
volumes prior to user object creation.

 Section 3.7.1, “Home Directories on OES 2,” on page 48

 Section 3.7.2, “Home Directories on NetWare 6.5,” on page 50

 Section 3.7.3, “Summary of Getting-started Lab Home Directories and Purposes,” on page 51

3.7.1 Home Directories on OES 2

On OES 2, home and other data directories can reside in three possible volume types, each of which is 
presented in this guide. The volume types are: 

 Linux POSIX volumes: Your OES 2 getting-started lab server already contains a / (root) 
partition with an empty /home directory (the default location for home directories on Linux 
servers).

 NCP volumes that point to Linux POSIX volumes: Your OES 2 server has NCP Server installed 
so you can create NCP volumes that point to the Linux POSIX* file systems. 

 Novell Storage Services (NSS) volumes: Your OES 2 server is prepared with EVMS to support 
NSS volumes. (NSS is the native file system on NetWare.)

There are important differences between the home directories in each of these locations and in the 
configuration steps required to create them and set the needed file/directory trustee assignments, etc. 

 “The Linux POSIX /home Directory” on page 48

 “Creating an NCP Volume on the OES 2 Server” on page 49

 “Creating an NSS Pool and Volume on the OES 2 Server” on page 49

The Linux POSIX /home Directory

For the exercises in this guide, you create POSIX home directories for two users. This lets you easily 
see the differences between directories created through POSIX and directories created through NCP. 
Both directory types exist on the same physical disk space and are displayed as POSIX home 
directories, but only the NCP directories appear in NCP interfaces.
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Creating an NCP Volume on the OES 2 Server

OES 2 lets you create NCP volumes that point to directories on the Linux POSIX partitions of your 
server. For the exercises in this guide, you create an NCP volume that points to the /home directory 
on your server. NCP volumes support the Novell File and Directory Trustee Rights model when files 
are accessed through an NCP client. 

NCP volumes on Linux POSIX file systems differ from NSS volumes; NCP volumes do not support 
NSS file attributes, such as Delete Inhibit. For more information, see “Directory and File Attributes” 
in the OES 2 SP3: NCP Server for Linux Administration Guide.

1 Log into your server as root and click Computer > Gnome Terminal.

2 Create an NCP volume in NCPCON that points to the /home directory by entering the following 
commands:

ncpcon create volume home_ncp /home

exit

Creating an NSS Pool and Volume on the OES 2 Server

OES 2 supports NSS volumes. NSS is a fast-mounting, journaled file system for OES 2 and NetWare. 
It is the only file system in the industry that is integrated with identity management. NSS volumes 
support the Novell File and Directory Trustee Rights model and also NSS file attributes. For more 
information, see “The Traditional Novell Access Control Model” in the OES 2 SP3: Planning and 
Implementation Guide.

NSS volumes can span partitions and even hard disks. For a graphical overview of NSS volumes, see 
Section A.1, “NSS Partitions, Pools, and Volumes,” on page 109.

1 On your getting-started lab workstation in iManager, click the Roles and Tasks icon .

2 Click Storage > Pools.

3 Click the Browse icon  next to the Server field, 

4 Browse to and select your OES 2 getting-started lab server object (in COMPANY > LAB > 
SERVERS).

5 Click New.

6 Name the pool pool_lx and click Next.

7 Click the box next to the system disk in your server (sda, hda, etc.). 

8 By default, all of the free space on the disk should be automatically entered in the Used Size field, 
and the amount should match the Free Size (MB) displayed to the right of the system disk. If the 
Used Size field is blank, type the free space amount.

9 Click Finish.

POOL_LX is listed as an available pool. Notice that the NSS pool name is uppercase, even 
though you typed lowercase. All NCP and NSS volumes, are created and displayed in uppercase 
to give a visual distinction from the Linux POSIX lowercase norm, to prevent visual confusion of 
letters and numbers (vol1 vs. VOL1), and because names are case insensitive on NSS.

10 After the pool appears in the list, continue in the Storage task by clicking Volumes.

11 Click New.

12 In the Name field, type home_nss, then click Next.
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13 Click the box next to POOL_LX, then click Next.

14 Scroll down to File Information > Lookup Namespace

Long should be selected by default.

This setting avoids having the NCP server spend cycles doing Long namespace lookups.

15 Click Finish.

HOME_NSS is listed as an available volume.

16 Continue with the next section, Home Directories on NetWare 6.5.

3.7.2 Home Directories on NetWare 6.5

The default file system for NetWare 6.5 is NSS, which is an NCP volume by definition. 

NetWare servers don’t contain a HOME volume (partition) by default, but it is standard practice 
among NetWare administrators to create a HOME volume for their network users’ private 
directories.

Creating a HOME_NW Volume on the NetWare 6.5 SP8 Server

Your NetWare virtual machine has approximately 16.5 GB of disk space still available for another 
NSS pool and volume on disk 0, which is the 25 GB file you created for the VM in Section 2.3.3, 
“Creating a Virtual Machine and Installing NetWare,” on page 35.

1 In iManager, click the Roles and Tasks icon .

You can manage storage on the NetWare LAB_NW_VM server even though you are running 
iManager on your OES 2 getting-started lab server. This demonstrates one advantage of the tight 
integration of OES 2 services with eDirectory.

2 Click Storage > Pools.

3 Click the Browse icon  next to the Server field, 

4 Browse to and select the LAB_NW server object (in COMPANY > LAB > SERVERS).

Notice that a pool named SYS already exists. This pool contains the default volumes and files 
created with the NetWare server, including a volume that is also named SYS.

5 Click New.

6 Name the pool pool_nw and click Next.

7 Click the box next to the XenHD device in your virtual machine. 

This “device” is the 25 GB file that you created for the virtual machine. The file currently 
contains all the virtualized NetWare server’s partitions and files.

8 By default, all of the free space on the disk should be automatically entered in the Used Size field, 
and the amount should match the Free Size (MB) displayed to the right of the system disk. If the 
Used Size field is blank, type in the free space amount.

9 Click Finish.

POOL_NW is listed as an available pool. 

10 In the left frame, click Volumes.

11 Click New.

12 In the Name field, type home_nw, then click Next.
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13 Click the box next to POOL_NW, then click Next.

14 Click Finish.

3.7.3 Summary of Getting-started Lab Home Directories and Purposes

Your getting-started lab servers now have four home directory access points in three physical 
locations (the first two share the same physical partition):

 /home: This is the default home directory on SLES 10 servers. The underlying file system is 
Reiser. On SLES 10 servers, home directories are normally created on /home by users logging in 
to the server for the first time. 

Home directories on OES 2 servers are normally created on NCP or NSS volumes. However, 
they can be created manually on /home. User and Group ownership must be manually adjusted 
because the directories belong initially to the root user that creates them.

 HOME_NCP: This is an NCP volume mount point that points to and shares disk space with the 
/home directory mentioned above. In this guide, it illustrates the functionality of the NCP server, 
the Novell File and Directory Trustee Model, and Novell ClientTM access to a Linux POSIX 
volume. (The underlying file system is Reiser.) Home directories on NCP volumes are easily 
created when users are created in iManager. POSIX permissions to home directories created in 
iManager must be adjusted before users can access the directories through non-NCP 
applications. This is because when the directories are created, the directory owner in POSIX is 
initially the eDirectory Admin User who created the users in eDirectory and their home 
directories on the Linux file system (NCP volume).

 HOME_NSS: This is an NSS volume on the OES 2 server. It illustrates the functionality of the 
NCP server, the Novell File and Directory Trustee Model, and NSS file attributes. Because NSS 
volumes are also NCP volumes by default, home directories are easily created at user-creation 
time in iManager. POSIX permissions do not apply to NSS volumes. However, NSS can interface 
with POSIX permissions for applications and access methods that require them. Trustee 
assignments (ownership) are automatically assigned to the eDirectory username or user when 
the home directory is created.

 HOME_NW: This is an NSS volume on your virtualized NetWare server. It illustrates the 
functionality of the NCP server, the Novell File and Directory Trustee Model, and NSS file 
attributes on a NetWare server. Trustee assignments (ownership) are automatically assigned to 
the eDirectory user when the home directory is created.

3.8 Creating Users
For the getting-started lab exercises, you need to create the users shown in Table 3-1. 

IMPORTANT: There are seven users, each representing a different user type you might need on your 
network.

Although the user names are unusual, they let you track home directory locations and service access 
at a glance.

Each name includes “edir” to indicate that eDirectory users have access to the traditional Novell 
services highlighted in this guide: 

 Novell AFP (Macintosh networking)

 Novell CIFS (Windows networking)
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 Novell iFolder® 3.8

 NetStorage

The steps for creating users begin after Table 3-1.

Table 3-1   Users to Create

Username First 
Name

Last 
Name

Home Directory Volume What This User Demonstrates

linux1_lum-
edir

Linux1 Lum-edir /home You manually create this user’s 
home directory in the server’s /
home directory.

If LUM is configured to allow login 
or sshd access, this user can 
access the OES 2 server as 
though it is a local user.

linux2_lum-
edir

Linux2 Lum-edir /home You manually create this user’s 
home directory in the server’s /
home directory.

If LUM is configured to allow login 
or sshd access, this user can 
access the OES 2 server as 
though it is a local user.

The difference between this user 
and the linux1 user is that its home 
directory is not adjusted for 
privacy but has the default POSIX 
permissions.

ncp_edir Ncp Edir DNSname_HOME_NCP This user’s home directory is 
created by specifying the 
HOME_NCP volume at user-
creation time in iManager. 

When the instructions in this 
section are complete, the user has 
access to only the traditional 
Novell services: AFP, CIFS, 
iFolder, and NetStorage.

ncp_lum-edir Ncp Lum-edir DNSname_HOME_NCP This user’s home directory is 
created by specifying the 
HOME_NCP volume at user-
creation time in iManager. 

When the instructions in this 
section are complete, the user has 
potential access to the server as a 
local user, in addition to traditional 
Novell service access.
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1 In iManager, in the left pane, click Users > Create User.

2 In the Username field, type a username from Table 3-1. 

For the first user, this is linux1_lum-edir.

3 Type the first name and last name for the user as shown in Table 3-1.

4 Click the Browse icon  next to the Context field.

5 For the first user, browse to the USERS object (COMPANY > LAB > USERS), then click the object.

For subsequent users, click the Object History icon  and select the USERS object’s fully 
distinguished name (FDN).

6 Type the same password in both the Password and Retype Password fields. 

7 Do not select Set Simple Password. 

This is not required for OES because Universal Password is used.

8 If the Home Directory Volume cell in the table shows /home, skip to Step 9. 

nss_edir Nss Edir DNSname_HOME_NSS This user’s home directory is 
created by specifying the 
HOME_NSS volume at user-
creation time in iManager. 

The user has access to only the 
traditional Novell services: AFP, 
CIFS, iFolder, and NetStorage.

nss_lum-edir Nss Lum-edir DNSname_HOME_NSS This user’s home directory is 
created by specifying the 
HOME_NSS volume at user-
creation time in iManager. 

In additional to traditional Novell 
services access, the user has 
access to the server as a local 
user.

nw_edir Nw Edir LAB_NW_HOME_NW This user represents the traditional 
NetWare user in eDirectory. 

This user’s home directory is 
created by specifying the 
HOME_NW (NSS) volume at user-
creation time in iManager. 

The user has access to only the 
traditional Novell services: AFP, 
CIFS, iFolder, and NetStorage. 
However, you could also LUM-
enable the user (and the other 
non-LUM users as well) to verify 
that full OES 2 services are 
potentially available to all 
eDirectory users.

Username First 
Name

Last 
Name Home Directory Volume What This User Demonstrates
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For the other users, select the Create Home Directory option and browse  to the NCP volume 
indicated. (Volumes are in the SERVERS OU.)

The home directories for the linux* users are created later.

9 Click OK.

10 Click Repeat Task to repeat the process until the other users listed in Table 3-1 on page 52 are 
created.

11 Do not close iManager. Continue with the next section, A Note about Identity Manager 3.6 
Bundle Edition.

3.9 A Note about Identity Manager 3.6 Bundle Edition
If your organization has more than one directory service that stores user information, you should 
consider implementing the Novell Identity Manager 3.6 Bundle Edition included with Novell Open 
Enterprise Server.

The Identity Manager 3.6 Bundle Edition provides licensed synchronization of information 
(including passwords) held in NT Domains, Active Directory* Domains, and eDirectory trees. 

Not only can you import User objects into eDirectory rather than creating them as you have in this 
section, but you can use Identity Manager to keep all the user data (including passwords that are 
stored in your different databases) synchronized. 

When data from one system changes, Identity Manager detects and propagates these changes to 
other connected systems based on the business policies you define. 

For more information, see “Using the Identity Manager 3.6.1 Bundle Edition ” in the OES 2 SP3: 
Planning and Implementation Guide.

Continue with Chapter 4, “eDirectory Linux Access (LUM),” on page 55.
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4 4eDirectory Linux Access (LUM)

Novell® Linux User Management (LUM) is a key component of Novell Open Enterprise Server (OES) 
and lets you require users who are accessing PAM-enabled services, such as FTP or SSH, on the OES 
2 server to authenticate through eDirectoryTM. 

This section discusses the following:

 Section 4.1, “Overview of Linux User Management,” on page 55

 Section 4.2, “Creating Group Objects,” on page 56

 Section 4.3, “Enabling the LUMUsers Group for Linux User Management (LUM),” on page 57

 Section 4.4, “Allowing SSH Access,” on page 58

 Section 4.5, “Creating a Home Directory for the linux* Users,” on page 59

4.1 Overview of Linux User Management
Figure 4-1 illustrates how LUM works with PAM-enabled services. For more detailed information, 
see “Linux User Management: Access to Linux for eDirectory Users” in the OES 2 SP3: Planning and 
Implementation Guide. As illustrated, OpenWBEM is the only PAM-enabled service that is active by 
default.

Figure 4-1   Linux User Management on OES
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The user-creation steps you completed earlier in this guide (Section 3.8, “Creating Users,” on 
page 51) created three LUM users with limited rights as local users on the OES 2 server. 

4.2 Creating Group Objects
To simplify user management, you should create one or more groups and associate users with those 
groups. Groups let you manage multiple users at the same time. 

Some actions can only be performed at the group level. For example, enabling users for LUM 
requires making them members of a group that is enabled for LUM. 

For the exercises in this guide, you will create two groups:

 LUMUsers: This group is used to LUM-enable some of the users you have created. Having the 
group lets us explore how LUM works and directly experience the SSH security precautions that 
are built into OES 2.

 AllUsers: This group is for all of the eDirectory user objects, including those that are LUM-
enabled and those that have only traditional Novell services access.

IMPORTANT: Creating a group named users seems logical to many eDirectory administrators.

Unfortunately, all SLES 10 servers already have a system-created local group named users, and 
creating a duplicate group in eDirectory causes problems. 

For more information, see “Avoiding POSIX and eDirectory Duplications” in the OES 2 SP3: Planning 
and Implementation Guide.

To create the required group objects:

1 In iManager > Roles and Tasks, click Groups > Create Group.

2 In the Group Name field, type LUMUsers.

The name contains uppercase and lowercase letters simply to illustrate that case is preserved in 
object names. Some administrators use mixed case to improve readability.

3 Click the Browse  icon next to the Context field.

4 Browse to the USERS container object.

5 Click OK > Modify.

6 Click the Members tab.

7 Click the Browse icon  next to the Member field.

8 Browse to the USERS container and click the down-arrow  next to it

9 Select the following User objects:

 linux1_lum-edir

 linux2_lum-edir

 ncp_lum-edir

 nss_lum-edir

10 Click OK > Apply > OK.

11 Click Create Group.

12 In the Group Name field, type AllUsers.
56 OES 2 SP3: Getting Started with OES 2 and Virtualized NetWare



13 Click the Object History icon  and select the USERS object’s fully distinguished name (FDN).

14 Click OK > Modify.

15 Click the Members tab.

16 Click the Browse icon  next to the Members field.

17 Shift-click linux1_lum-edir, drag the mouse down to select all the users, then click nw_edir.

All of the users are added to the list.

18 Click OK > Apply > OK.

19 Do not close iManager. Continue with the next section, Enabling the LUMUsers Group for Linux 
User Management (LUM).

4.3 Enabling the LUMUsers Group for Linux User Management 
(LUM)

IMPORTANT: LUM-enabling users is an important part of these getting-started lab exercises. 
However, in a production environment you should avoid LUM-enabling users until you fully 
understand the potential security issues. For more information, see “SSH Services on OES 2” in the 
OES 2 SP3: Planning and Implementation Guide.

If you want eDirectory users to access PAM-enabled services such as login or sshd (SSH), on an OES 
2 server, you must LUM-enable the users. 

1 In the Roles and Tasks list, click Linux User Management > Enable Groups for Linux.

2 Click the Browse icon  next to the Group Name field.

3 Click LUMUsers > OK.

4 Make sure the Linux-Enable All Users in These Groups option is selected, then click Next twice.

5 Click the Browse icon  next to the Uinux Workstation Name field.

6 Click the up-arrow .

7 Click the down-arrow  next to SERVERS.

8 Click the UNIX Workstation object for the OES 2 getting-started lab server, then click OK.

9 Click the Browse icon  next to the Unix Config Object field.

10 Click the up-arrow . twice

11 Click the UNIX Config object.

12 Click Next > Finish > OK.

LUM-enabled access to OES 2 servers is enabled on an individual server basis. If you install 
additional OES 2 servers that require LUM access, they must also be added to a LUM-enabled 
group.

The LUMUsers group and its users are now recognized by the OES 2 server as local users.

13 Do not close iManager. Continue with the next section, Allowing SSH Access.
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4.4 Allowing SSH Access
To illustrate how LUM-enabled services work, we will briefly experiment with SSH access for 
eDirectory LUM-enabled users. In Section 10.2.4, “SSH and NetStorage Administration,” on page 88, 
you will see that SSH access is required for a key NetStorage administration feature.

Complete the steps in the following sections:

 Section 4.4.1, “Allowing SSH Access Through the Firewall,” on page 58

 Section 4.4.2, “Adding SSH as an Allowed Service in LUM,” on page 58

 Section 4.4.3, “Verifying SSH Access,” on page 58

4.4.1 Allowing SSH Access Through the Firewall

1 On the OES 2 getting-started lab server, click Computer > YaST Administrator Settings, then click 
Security and Users > Firewall.

2 In the left navigation frame, click Allowed Services.

3 In the Services to Allow drop-down list, select SSH.

4 Click Add > Next > Accept.

The firewall is now configured to allow SSH connections with the server.

5 Continue with Adding SSH as an Allowed Service in LUM.

4.4.2 Adding SSH as an Allowed Service in LUM

1 In YaST in the Open Enterprise Server group, click OES Install and Configuration.

2 Click Accept.

3 When the Novell Open Enterprise Server Configuration page has loaded, click the Disabled link 
under Linux User Management.

The option changes to Enabled and the configuration settings appear.

4 Click Linux User Management.

5 Type the eDirectory Admin password in the appropriate field, then click OK > Next.

6 In the list of allowed services, click sshd.

7 Click Next > Next > Finish, then close YaST.

8 Continue with Verifying SSH Access.

4.4.3 Verifying SSH Access

The LUMUsers group in eDirectory now has SSH as an allowed service. To verify this:

1 On the getting-started lab workstation, in the iManager Roles and Tasks list, click Directory 
Administration > Modify Object.

2 Click the Browse icon  next to the Object Name field.

3 Browse to and select the LUMUsers group object (in COMPANY > LAB > USERS), then click OK.

4 Click the Linux Profile tab, click the General sub-tab, then select the UNIX Workstation object.

5 Click the Linux Services sub-tab.
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6 Notice that sshd (the SSH daemon) is listed as a LUM-Enabled service, then click OK.

7 (Optional) If you want to verify that SSH access works, install an SSH client on the workstation 
and attach to the getting-started lab server through one of the LUM-enabled users. Be aware, 
however, that this creates a POSIX home directory for the user in /home and might require 
adjustments to procedures in the next section, Creating a Home Directory for the linux* Users.

8 Continue with Creating a Home Directory for the linux* Users.

4.5 Creating a Home Directory for the linux* Users
The NetStorage exercises in this guide involve users’ home directories and specific files they will 
copy to those directories. However, neither of the linux* users currently has a home directory.

There are two standard ways to create home directories on Linux servers. The first way is for a user to 
log in to the server as a local user (or for OES 2, as a LUM-enabled user). For example, opening an 
SSH session creates a home directory.

Because it is unlikely that you want your users to have direct physical access to a production server, 
we will use the second way, which is to create the directory manually, assign the user and group to 
the directory, and then modify access permissions.

There are two methods you can use to do this.

 Section 4.5.1, “Using the File Browser,” on page 59

 Section 4.5.2, “Using Terminal Commands,” on page 60

4.5.1 Using the File Browser

To create home directories for your linux* users using the graphical interface, do the following:

1 As the root user, open a terminal prompt and enter the following command:

namconfig cache_refresh

This refreshes the LUM cache and is required for Linux-enabled users and groups to display in 
the GUI unless a few hours have elapsed since you created them. The default cache refresh rate 
in SP3 is 8 hours.

2 As the root user on the server’s desktop, click Computer > Home Folder.

3 In the left panel, double-click File System, then double-click the home folder.

4 If you see home directories for only the ncp_* users that were created in iManager on the 
HOME_NCP volume, continue with Step 5.

If you see a home directory for one of the linux* users, that means you used it to experiment with 
SSH access in Step 7 on page 59, thus creating a home directory for the user. In that case, adjust 
the steps that follow as required. 

5 Right-click the white space in the right panel and select Create Folder.

6 Type linux1_lum-edir as the folder name, then right-click the folder and select Properties.

7 Click the Permissions tab.

8 Click the File Owner drop-down list, then use the Up-arrow and Down-arrow keys to navigate to 
and select the linux1_lum-edir user.

Notice that the users that you created who are not enabled for LUM are not listed. 

9 Click the File Group drop-down list, navigate to and select LUMUsers, then press Enter.
eDirectory Linux Access (LUM) 59



Neither this group nor the user you selected exist locally. However, because they are LUM-
enabled, the server recognizes them as though they do.

The next three lines (Owner, Group, Others) indicate access permissions for the directory owner 
(linux1_lum-edir), the assigned group (LUMUsers), and everyone else (others). 

Notice that both Group and Others have permission to Read (open) the contents of the folder and 
Execute (browse its contents). This is not what NetWare® administrators and users expect 
because home directories are private on NetWare servers.

10 Make this directory private by deselecting all of the access permissions for Group and Others.

For more information about directory privacy and aligning access on Linux servers to match 
what NetWare administrators are accustomed to, see “Aligning NCP and POSIX File Access 
Rights” in the OES 2 SP3: Planning and Implementation Guide.

11 Click Close.

12 Right-click the white space in the right panel and select Create Folder.

13 Type linux2_lum-edir as the folder name, then right-click the folder and select Properties.

14 Click the Permissions tab.

15 Change the file owner to linux2_lum-edir and the file group to LUMUsers by using the drop-
down lists.

16 Adjust the permissions for this directory by enabling the Write right for the group. This gives 
full rights to the user’s home directory for anyone in the LUMUsers group, which is obviously 
not something you would normally do. 

Later in the guide we will use this to contrast default POSIX file permissions with the Novell File 
and Directory Security Model.

17 Click Close.

18 Continue with Novell CIFS on OES 2.

4.5.2 Using Terminal Commands

Creating home directories for the linux* users, assigning ownership of the directories, and granting 
access permissions involves three terminal commands:

 mkdir: Use this command to make POSIX directories. 

 chown: Use this command to change user, group, and other ownership of a directory. For more 
information, see “Managing Access Rights” in the OES 2 SP3: Planning and Implementation Guide.

 chmod: Use this command to change access permissions.  For more information, see “Managing 
Access Rights” in the OES 2 SP3: Planning and Implementation Guide

Do the following:

1 As the root user, open a terminal prompt by clicking Computer > Gnome Terminal.

2 Create a home directory for the linux1_lum-edir user by entering the following command:

mkdir /home/linux1_lum-edir

3 Assign the linux1_lum-edir user and the LUMUser group as the owners of the linux1_lum-
edir directory.

chown -R linux1_lum-edir:LUMUsers /home/linux1_lum-edir

Neither this group nor the user you specified exist locally. However, because they are LUM-
enabled, the server recognizes them as though they do.
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By default, both the LUMUsers group and other users on the system have permission to Read 
(open) the contents of the folder and Execute (browse its contents). This is not what NetWare® 
administrators and users expect because home directories are private on NetWare servers.

4 Assign all access privileges to the user owner of the linux1_lum-edir directory, and no 
privileges to the group owner or to other users on the system.

chmod 700 /home/linux1_lum-edir

5 Now create a home directory for the linux2_lum-edir user.

mkdir /home/linux2_lum-edir

6 Assign the linux2_lum-edir user and the LUMUser group as the owners of the linux2_lum-
edir directory.

chown -R linux2_lum-edir:LUMUsers /home/linux2_lum-edir

7 Adjust the permissions for this directory by enabling the Read, Write and Execute rights for the 
group. This gives full rights to the user’s home directory for anyone in the LUMUsers group, 
which is obviously not something you would normally do.  

chmod 775 /home/linux2_lum-edir

By default, the permissions are set to 755. This command addss the Write right for the group. For 
more information, see  “Aligning NCP and POSIX File Access Rights” in the OES 2 SP3: Planning 
and Implementation Guide.

Later in the guide we will use this to contrast default POSIX file permissions with the Novell File 
and Directory Security Model.
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5 5Novell CIFS on OES 2

Novell® CIFS lets Windows users access NSS volumes on Novell Open Enterprise Server 2 servers 
exactly as they would access a Windows file server. For a comparison to Novell Samba, see 
“Comparing Your CIFS File Service Options” in the OES 2 SP3: Planning and Implementation Guide.

This section discusses the following:

 Section 5.1, “Overview of Novell CIFS,” on page 63

 Section 5.2, “Setting the Search Context,” on page 64

 Section 5.3, “Making Novell CIFS Shares Available to CIFS Users,” on page 65

 Section 5.4, “Novell CIFS Users Access Rights,” on page 65

5.1 Overview of Novell CIFS
Figure 5-1 illustrates the file services available through Novell CIFS in OES 2. 

More Information on Novell CIFS file services in OES 2 is found in “Novell CIFS Implementation and 
Maintenance” in the OES 2 SP3: Planning and Implementation Guide.
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Figure 5-1   Novell CIFS
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5.3 Making Novell CIFS Shares Available to CIFS Users
By default, all NSS volumes hosted on an OES 2 server have shares associated with them. If you need 
a share to point to a subdirectory on an NSS volume, then you must create a new share. See “Adding 
a New CIFS Share” in the OES 2 SP3: Novell CIFS for Linux Administration Guide.

If a volume is created while the Novell CIFS service is running, the service must be restarted to 
discover the volume.

1 Click the Shares tab.

2 If the HOME_NSS share is listed, skip to Novell CIFS Users Access Rights. 

If not, continue with Step 3.

3 Click the General tab, then click Stop. The service status changes to Stopped.

4 Click the Start sub-tab. The service status changes to Running.

5 Click the Shares tab.

The HOME_NSS share is listed.

5.4 Novell CIFS Users Access Rights
As illustrated in Figure 5-1, all eDirectory users have automatic access to the Novell CIFS file service, 
assuming that the service is configured correctly. 

However, access to the CIFS file service does not equate to access to the NSS file system and the 
folders and files it contains. The Novell File and Directory Trustee Rights model ensures that users 
can see only those files and folders to which they have access rights.
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6 6Novell AFP

Novell® AFP lets Macintosh users access NSS volumes on Novell Open Enterprise Server 2 servers 
using AFP networking, exactly as they would Macintosh file servers.

This section discusses the following:

 Section 6.1, “Overview,” on page 67

 Section 6.2, “Setting the Search Context,” on page 68

 Section 6.3, “Making NSS Volumes Available to AFP Users,” on page 68

 Section 6.4, “Novell AFP Users Access Rights,” on page 68

6.1 Overview
Figure 6-1 illustrates the file services available through Novell AFP in OES 2. 

More Information on Novell AFP file services in OES 2 is found in “Novell AFP Implementation and 
Maintenance” in the OES 2 SP3: Planning and Implementation Guide.

Figure 6-1   AFP File Access Support on OES 2
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6.2 Setting the Search Context
By default, the search context for AFP users is set to the container where the OES 2 server is installed. 
AFP searches in this context for users seeking access to the AFP file service. You must set a context 
that points to the USERS container where your User objects are located.

1 In iManager > Roles and Tasks, click File Protocols > AFP.

2 Click the Browse icon next to the Server field, then browse to and select the OES 2 getting-started 
lab server.

3 Click the Contexts tab.

4 Select the entry that points to the SERVERS container and click Remove.

5 Click Add.

6 Browse to and select the USERS container, then click OK.

7 Continue with Making NSS Volumes Available to AFP Users.

6.3 Making NSS Volumes Available to AFP Users
1 Click the Volume tab, then click Add.

2 Click the Browse icon  next to the Volume field.

3 In the Object Selector, click the down-arrow  next to the servername_HOME_NSS volume, 
then click the link to the volume.

4 In the Shared Volume Name field, type AFP_Home_NSS and click OK.

6.4 Novell AFP Users Access Rights
As illustrated in Figure 6-1, eDirectory users can access any NSS volume where they are granted 
Novell trustee rights. For example, if they have a system-created home directory on the HOME_NSS 
volume, they can see that directory. 

However, if they don’t have Novell trustee rights, they cannot access the volume. This is different 
than for CIFS users.

As with CIFS users, the Novell File and Directory Trustee Rights model ensures that users can see 
only those files and folders to which they have access rights. 
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7 7NetWare CIFS and AFP on OES 2

NetWare® 6.5 SP8 supports native file access methods from Linux, Macintosh, UNIX*, and Windows 
workstations to NSS volumes on NetWare servers. (Access to NetWare Traditional File System 
volumes is not supported.)

This section discusses the following:

 Section 7.1, “Overview,” on page 69

 Section 7.2, “Enabling NFAP Services on the LAB_NW Server,” on page 70

7.1 Overview
Figure 5-1 illustrates the native File Access Protocol (NFAP) support services that are enabled by 
installing NetWare 6.5. A more detailed overview of NFAP file services on OES is found in “Native 
File Access Protocols” in the NW 6.5 SP8: Planning and Implementation Guide.

Figure 7-1   Native File Access Support on NetWare 6.5
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The exercises in this guide have you access the NetWare server by using native Windows 
functionality. 

If you want to also experiment with Linux, UNIX, or Macintosh workstations, refer to the 
information in “Native File Access Protocols Implementation and Maintenance” in the NW 6.5 SP8: 
Planning and Implementation Guide after completing all the sections in this guide.

7.2 Enabling NFAP Services on the LAB_NW Server
When you created the nw_edir user in iManager, you also created a home directory for the user on 
the HOME_NW NSS volume on the virtualized NetWare server LAB_NW. 

By default, all NSS volumes on NetWare servers are available for CIFS and AFP access. To configure 
CIFS access, you must complete two tasks:

 Section 7.2.1, “Creating a Share for the HOME_NW Volume,” on page 70

 Section 7.2.2, “Specifying a Search Context,” on page 70

7.2.1 Creating a Share for the HOME_NW Volume

NetWare CIFS requires that you specify the shares that users can access.

1 In iManager > Roles and Tasks, click File Protocols > CIFS. 

2 Click the Browse icon next to the Server field, then browse to and select the LAB_NW server.

3 Click the Shares tab, then click the Add sub-tab.

4 In the Share Name field, type home_nw.

This is the name used to attach to the share.

5 Click the Browse icon  next to the Volume field.

6 In the Object Selector, click the down-arrow  next to the LAB_NW_HOME_NW volume, then 
click the link to the volume.

7 Click OK > OK.

7.2.2 Specifying a Search Context

You must specify a search context that NetWare can use to find users needing CIFS access. 

1 Log into your VM host server as root and click Computer > YaST > Virtualization > Virtual Machine 
Manager.

2 Double-click the LAB_NW_VM virtual machine.

3 On the NetWare GUI, click the File Browser (folder) icon once to activate the mouse pointer and 
once to select the browser.

4 Double-click the SYS: volume.

5 Double-click the ETC folder.

6 Scroll down and double-click the cifsctxs.cfg file.

Notice that the search context is set to the SERVERS container. User searches occur only in the 
contexts specified in this file. Subcontainers are not searched. 

7 Edit the file, replacing SERVERS with USERS, so that the line reads
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OU=USERS.OU=LAB.O=COMPANY

8 Save the file, close the editor, and close the file browser.

9 Click the Server Console (computer) icon.

10 Stop and then start the CIFS service by entering the following commands:

CIFSSTOP

CIFSSTRT

11 Press Ctrl+Alt to release the mouse, then close both of the Virtual Machine Manager windows.

12 Continue with Chapter 8, “iFolder 3.8,” on page 73.
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8 8iFolder 3.8

As a key file service component of Novell® Open Enterprise Server (OES), Novell iFolder® 3.8 
provides a repository on one or more OES 2 servers that stores master copies of locally accessible 
files. 

This section discusses the following:

 Section 8.1, “Overview of iFolder,” on page 73

 Section 8.2, “Installing the iFolder Client,” on page 74

 Section 8.3, “Creating Corresponding Windows Users,” on page 75

 Section 8.4, “Refreshing the List of iFolder Users,” on page 75

 Section 8.5, “Configuring iFolder Accounts and Creating iFolders,” on page 76

8.1 Overview of iFolder
Figure 8-1 illustrates the file services that are enabled by completing the steps in the sections that 
follow. 

More detailed information on iFolder file services on OES 2 is found in “Novell iFolder 3.8” in the 
OES 2 SP3: Planning and Implementation Guide.
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Figure 8-1   iFolder File Services on OES
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3 On the OES 2 Welcome Page in the left panel, click the Client Software link.

4 Under Available Downloads, click the iFolder Client for Windows link appropriate for your 
workstation (32-bit or 64-bit).

5 Save the file.

6 Open the downloaded file and install the client. 

The installation process includes several steps. For the installation to succeed, you must agree, 
accept, and answer Yes to the various prompts, including the unknown publisher alert and the 
Microsoft .NET installation if prompted. Accept all the defaults.

7 If you install Microsoft .NET, you might be prompted to restart the workstation. If prompted, 
click the Restart button, then after the workstation restarts, log in as the Windows administrative 
user.

8 Click through the dialog boxes, accepting the defaults until the process is finished. Then click 
Finish > Yes to restart the workstation.

9 After the workstation restarts, log in as an administrative user.

10 If needed, cancel the iFolder Account Creation Wizard by right-clicking the iFolder icon in the 
system tray and selecting Exit, then continue with Creating Corresponding Windows Users.

8.3 Creating Corresponding Windows Users
Some OES services, such as Novell iFolder, interact seamlessly with Windows users that have the 
same username and password as the eDirectoryTM users.

For the exercises in this guide, you must now create Windows user accounts for the users listed in 
Table 3-1 on page 52 and assign each user the same password you specified for the corresponding 
eDirectory account.

1 On the Windows workstation, log in as an Administrator user.

2 Access the Control Panel and select User Accounts and Family Safety > Add or Remove User 
Accounts (Windows 7) or User Accounts (Windows XP).

3 Create a user account for each user in Table 3-1 on page 52, specifying that the account is a 
computer administrator.

4 Select the user after creating it, and then create the same password for the user that you specified 
in Step 6 on page 53.

5 Repeat from Step 3 for each additional user, then continue with Refreshing the List of iFolder 
Users.

8.4 Refreshing the List of iFolder Users
All eDirectory users are enabled for access to iFolder 3.8 by default. However, the iFolder 3.8 
Administration utility must be synchronized with eDirectory. By default this happens every 24 hours.

1 Open your browser and log in to iManager as admin.

If you receive a Tomcat error, see Section A.2, “iManager Tomcat Error,” on page 111.

2 In Roles and Tasks, click iFolder 3.8 > Launch iFolder Admin Console.

3 In the iFolder Server field, type the IP address of the OES 2 getting-started lab server.

4 Select the Authenticate Using Current iManager Credentials option.
iFolder 3.8 75



5 Click OK.

The Users tab shows the users that are recognized by the iFolder server as having iFolder service 
access. Because the LDAP search context doesn’t include the USERS container, the eDirectory 
users you have added don’t appear in the list.

6 Click the Servers tab.

7 Click the blue link for the OES 2 getting-started lab server.

8 In the LDAP Details section, click the Edit button.

9 In the LDAP Admin DN field, type cn=admin,o=company.

Notice that the delimeter is a comma (,), not a period (.).

10 In the LDAP Admin Password field, type the Admin user password.

11 In the LDAP Contexts field, change SERVERS to USERS, then click OK.

This changes the search context to the USERS directory.

12 In the LDAP Details section, click the blue Sync Now link.

Notice that the default synchronization interval is 1440 minutes (24 hours). 

13 Click the Users tab.

Notice that the users you have created are added to the list.

14 Close the iFolder Administration console, then continue with Configuring iFolder Accounts and 
Creating iFolders.

8.5 Configuring iFolder Accounts and Creating iFolders
Before users can create iFolders, they must set up an iFolder account on the workstation. 

You should have already created a Windows user account for each eDirectory user as instructed in 
Section 8.3, “Creating Corresponding Windows Users,” on page 75. You will now configure an 
iFolder for linux1_lum-edir and invite the ncp_edir and nw_edir users to share the iFolder. Although 
you can create accounts for the other users, there are no exercises in this guide that involve them 
having iFolder accounts.

1 Log off as the administrative user, then log in to the Windows workstation as the linux1_lum-
edir user that you created in Section 8.3, “Creating Corresponding Windows Users,” on page 75. 

2 After the login process finishes, you should be prompted to set up an iFolder account. Click 
Next. 

If you are not prompted to set up an account, right-click the iFolder icon on the toolbar, select 
Accounts, then click New.

3 In the Server Address field, type the IP address or DNS hostname of your OES 2 server, then click 
Next.

4 Type the linux1_lum-edir for the username, then type the password you assigned to the user.

5 Select Remember Password, then click Next > Connect.

6 If prompted, accept the certificate by clicking Yes. 

7 When prompted to create a default iFolder, deselect Create Default Folder, click Next, click Finish, 
and then close the iFolder information window.

8 Right-click the desktop, then click New and create a new folder named linux1_lum-edir_IF3.

9 After creating the folder, right-click it, then click Convert to an iFolder.
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10 Click OK.

11 In the message that points out how iFolder folder icons look different, select Do Not Show This 
Message Again, then click Close.

12 Right-click the iFolder, then select iFolder > Share with.

13 In the iFolder Properties dialog box, click Add.

14 In the iFolder Users column, click Ncp Edir, then click Add>>.

Ncp Edir is added to the Selected Users column.

15 Add Nw Edir to the Selected Users column as well.

16 Click OK.

17 Change the access rights for Ncp Edir from Read Only to Read/Write by doing the following:

17a Click Ncp Edir.

17b Click Rights.

17c Select Read/Write.

17d Click OK.

18 Click Apply > OK.

The two users are configured to access linux1_lum-edir’s iFolder.

19 Log off the workstation.

20 Continue with Chapter 9, “iPrint,” on page 79.
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9 9iPrint

As the print services component of Novell® Open Enterprise Server (OES), Novell iPrint provides a 
powerful and easy-to-implement printing solution that lets your network users print from any Linux, 
Macintosh, or Windows workstation to any network printer.

This section discusses the following:

 Section 9.1, “Overview of iPrint,” on page 79

 Section 9.2, “Creating an eDirectory Context for Printers,” on page 80

 Section 9.3, “Creating a Print Driver Store,” on page 81

 Section 9.4, “Creating a Print Manager Object,” on page 81

 Section 9.5, “Adding Printer Drivers to the Driver Store from the Windows Platforms,” on 
page 82

 Section 9.6, “Creating iPrint Printer Objects,” on page 83

9.1 Overview of iPrint
Figure 9-1 illustrates the printing services that are enabled by completing the steps in the sections 
that follow. 

More detailed information on iPrint services in OES 2 is found in “iPrint Functionality” in the OES 2 
SP3: Planning and Implementation Guide.
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Figure 9-1   iPrint on OES

9.2 Creating an eDirectory Context for Printers
System administrators often create one or more container objects just for network printers. 
Obviously, this is an optional organizational preference issue. The printers themselves can be placed 
in the most convenient and accessible locations for your network users. 

1 Log in to the getting-started lab Windows workstation as a Windows user with Administrator 
privileges.

2 If it appears, cancel the iFolder wizard.

3 Start iManager and log in as the Admin user.

If you receive a Tomcat error, see Section A.2, “iManager Tomcat Error,” on page 111.

4 Click the View Objects icon .

5 Click the Browse tab.

6 In the left pane, click the down-arrow  next to the COMPANY Organization object. 

7 Click LAB, then select Create Object from the drop-down list.

8 From the Available Object Classes list, select Organizational Unit, then click OK.

9 In the Organizational Unit Name field, type PRINTERS.

10 Click OK twice.
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9.3 Creating a Print Driver Store
iPrint stores print driver files by workstation type for each of your network printers in a driver store 
in eDirectory™.

1 In iManager, click the Roles and Tasks icon .

2 Click iPrint > Create Driver Store.

3 In the Driver Store Name field, type Print_Drivers.

4 Click the Browse icon  next to the Container Name field.

5 Click the down-arrow next to LAB, then click the PRINTERS Organizational Unit object.

6 In the Target Server field, type the DNS name or the IP address of the server that will host the 
driver store.

7 Click the Browse icon  next to the eDir Server name field.

8 Click the down-arrow next to LAB, click the down-arrow  next to SERVERS, then click 
your OES 2 getting-started lab server.

9 Click OK twice.

10 Continue with Section 9.4, “Creating a Print Manager Object,” on page 81.

9.4 Creating a Print Manager Object
The iPrint Manager is represented by and managed through a Print Manager object in eDirectory. It is 
a daemon that runs on the OES 2 server, and it must be running when you create Print objects. After 
printing is set up, the iPrint Manager receives print job requests and forwards them to printers when 
the printers are ready.

1 Continuing from Step 9 in the previous section, click iPrint > Create Print Manager.

2 In the Manager Name field, type the following:

iPrint_Manager

3 Click the Browse icon  next to the Container Name field.

4 Click the down-arrow  next to LAB, then click PRINTERS.

5 Click the Browse icon  next to the eDir Server name field.

6 Click the down-arrow  next to LAB, click the down-arrow  next to SERVERS, then click your 
OES 2 getting-started lab server.

7 Click the Browse icon  next to the Driver Store name field.

8 Click the down-arrow  next to LAB, click the down-arrow  next to PRINTERS, then click 
Print_Drivers.

9 In one of the iPrint Service fields, type either the full DNS name of your getting-started lab server 
or its IP address, depending on the option you select.

10 Click OK twice.
iPrint 81



9.5 Adding Printer Drivers to the Driver Store from the 
Windows Platforms
You can load printer drivers to the Driver Store by using driver files. However, because most 
Windows workstations have an extensive list of printer drivers available on the system, the simplest 
way to add drivers for a Windows workstation is to upload them directly.

You can upload Windows 7 drivers from a Windows 7 workstation and Windows XP drivers from a 
Windows XP workstation, etc.

Complete the following steps once for each of the Windows platforms (7, XP, etc.) that you have in 
your getting-started lab:

IMPORTANT: This procedure requires Internet Explorer 6 or later.

1 Open Internet Explorer 6 or later on the workstation and enter the following URL in the Address 
field:

http://IP_or_DNS/ipp

where IP_or_DNS is the IP address or DNS name of your OES 2 server.

2 Click the iPrint client link.

3 Click Run (or the corresponding option for your platform).

4 Answer yes to any security warnings, then click Next and follow any prompts.

5 After the client installs, click Finish.

6 Close the browser, then open it again.

7 Start iManager (http://server/nps) and log in as the Admin user.

If you receive a Tomcat error, see Section A.2, “iManager Tomcat Error,” on page 111.

8 If you are running Internet Explorer 6, skip to Step 12. 

or

For Internet Explorer 7 or later, you must configure the pop-up blocker. Continue with Step 9.

9 Right-click above the iManager panel and make sure the Menu Bar option is selected.

10 In the Menu Bar, click Tools > Pop-Up Blocker > Pop-Up Blocker Settings.

11 In the Address of Website to Allow field, type the IP address of the OES 2 getting-started lab server, 
then click Add > Close.

12 Click iPrint > Manage Driver Store.

13 Click the Browse icon  next to the iPrint Driver Store Name field.

14 Browse to the Printers container (COMPANY > LAB > PRINTERS), then click the Print_Drivers 
object.

15 Click OK.

16 Click the Drivers tab.

17 If you are running Internet Explorer 6, skip to Step 21.

or

If you are running Internet Explorer 7 or later and have not previously approved the iPrint 
ActiveX* plug-in to run, an Information Bar might appear directly above the iManager pane. 
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18 If no Information Bar appears directly above the iManager pane, skip to Step 21.

19 Click the Information Bar and select Run ActiveX Control, then click Run > Retry.

20 Repeat from Step 12.

21 In the Drivers Platform drop-down list, select the workstation type you are running. 

You can add drivers from the system only for the workstation type you are running.

22 Click Add from System.

TIP: Although not practical for the step-by-step guided approach used in this guide, the Add 
from File is a more useful option for most administrators because it lets them install print drivers 
for multiple platforms from a single workstation. For more information see, “Adding Printer 
Drivers” in the OES 2 SP3: iPrint for Linux Administration Guide.

23 In the Add Resource dialog box, select the correct driver for the printer you plan to use for the 
getting-started lab test.

24 Click OK.

25 (Optional) To test multiple printers, repeat Step 22 through Step 24 for each printer you want to 
test.

26 When you are finished, click Apply > OK.

9.6 Creating iPrint Printer Objects
You can create iPrint Printer objects for all your printers that have drivers in the Driver Store and an 
IP address or DNS name.

1 In iManager, click the Roles and Tasks icon .

2 Click iPrint > Create Printer.

3 In the Printer Name field, type a name for your printer.

4 Click the Browse icon  next to the Container Name field.

5 Click the down-arrow  next to LAB, then click PRINTERS.

6 Click the Browse icon  next to the Print Manager Name field.

7 Click the down-arrow  next to LAB, click the down-arrow  next to PRINTERS, then click 
iPrint_Manager.

8 Type the DNS name or IP address of the printer in the field indicated.

9 Type a location so users know where to find the printer.

10 (Optional) Type a description.

11 Click Next.

12 Select the printer driver by using the drop-down list for the Windows platform of your getting-
started lab workstation.

13 Click Next.

14 Select the default driver for your workstation type, then click Next.

15 Click OK.

16 Close iManager.

17 Continue with Chapter 10, “NetStorage,” on page 85.
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10 10NetStorage

As a versatile file services component of Novell® Open Enterprise Server (OES), NetStorage provides 
Web-based access to and management of any files on OES 2 servers, except the iFolder 3 files, which 
are accessed through the iFolder Web Access Server instead.

This section discusses the following:

 Section 10.1, “Overview of NetStorage,” on page 85

 Section 10.2, “Making Directories Accessible Through NetStorage,” on page 86

10.1 Overview of NetStorage
Figure 10-1 on page 86 illustrates the NetStorage file services that are enabled by default. 

More detailed information on NetStorage file services on OES is found in “NetStorage” in the OES 2 
SP3: Planning and Implementation Guide.
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Figure 10-1   NetStorage on OES

10.2 Making Directories Accessible Through NetStorage
NetStorage makes files on OES 2 servers available on the Internet. Directories can be made available 
as organizational needs dictate. For the exercises in this guide, we will focus on user home 
directories.

 Section 10.2.1, “NCP Users Have Automatic Access to Their Home Directories,” on page 86

 Section 10.2.2, “Creating a Storage Location Object in iManager,” on page 87

 Section 10.2.3, “Adding the Object to a Storage Location List,” on page 88

 Section 10.2.4, “SSH and NetStorage Administration,” on page 88

10.2.1 NCP Users Have Automatic Access to Their Home Directories

For users who have a home directory specified in eDirectoryTM (on an NCPTM or NSS volume), access 
to that home directory is automatic. 

By default, when users log in to NetStorage, they see a storage location named Home@TREE_NAME. 
This means that the ncp_*, the nss_* users, and the nw_edir user each see their home directories 
when they log into NetStorage.
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The label that users see is configurable in the File Access (NetStorage) iManager plug-in by using the 
NetWare Storage Provider task. You can also specify home directories in additional trees if users log in 
to multiple trees. For more information, see “NetWare Storage Provider” in the OES 2 SP3: NetStorage 
Administration Guide.

TIP: The first time you access the NetWare Storage Provider task in iManager, the configuration is 
blank and the column headings are collapsed. To display the configuration, click Set Defaults, click 
another task, then click NetWare Storage Provider again. All of the columns are then displayed.

To make other directories on an OES 2 server available through NetStorage, including non-NCP/NSS 
home directories, you must create a Storage Location Object that points to the directory and then add 
the object to a Storage Location List as explained in the following sections.

10.2.2 Creating a Storage Location Object in iManager

A Storage Location object specifies an access protocol and points to a directory on either the 
NetStorage server itself or another accessible server. After object creation, users with rights to the 
directory can access storage location objects through NetStorage.

For connections to Storage Location objects, NetStorage supports both CIFS and SSH as alternatives 
to NCP (the default NetStorage protocol). Although they are used in this guide, SSH storage 
locations should only be used after certain security issues are understood and dealt with. (For more 
information, see “SSH Security Considerations” in the OES 2 SP3: Planning and Implementation Guide.) 

Because the linux*_lum-edir users’ home directories are on a Linux traditional volume, there is no 
default access and you must create a Storage Location object for them to use.

Because the CIFS protocol on your getting-started lab server uses Novell CIFS, and because Novell 
CIFS provides access to only NSS volumes, the Storage Location object must use SSH. 

To create an SSH Storage Location object: 

1 Start iManager by entering the following URL in a browser Address field:

http://IP_or_DNS/nps

where IP_or_DNS is the IP address or DNS name of your OES 2 server.

If you receive a Tomcat error, see Section A.2, “iManager Tomcat Error,” on page 111.

2 Log in to iManager as the Admin user.

3 Click the Roles and Tasks icon .

4 Click File Access (NetStorage) > New Storage Location.

5 In the Object Name field, type

StorLoc_hostname

where hostname is the name of your getting-started lab server. This is the name of the Storage 
Location object in eDirectory (for example, StorLoc_myserver).

6 In the Display Name field, type

Linux_Home_Directories

This is the name that users see in the NetStorage directory access list.

7 In the Directory Location field, type

ssh://IP_or_DNS_Name/home
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where IP_or_DNS_Name is the IP address or full DNS name of your getting-started lab server 
(for example, ssh://myserver.mysite.company.example.com/home).

IMPORTANT: Protocol designators, such as ssh and cifs, are case-sensitive on OES 2 servers. 
Make sure you don’t type the common uppercase (SSH or CIFS) out of habit.

8 Click the Browse icon  next to the Context field.

9 Browse to and select the SERVERS Organizational Unit object.

The new Storage Location object will be created in the SERVERS organizational unit object.

10 Click Create > OK.

10.2.3 Adding the Object to a Storage Location List

Storage Location Lists are required for granting access for users, groups, or containers 
(Organizational Unit objects) to Storage Location objects.

1 In the list of tasks below File Access (NetStorage), click Assign Storage Location to Object. 

2 Click the Browse icon  next to the Object field.

This field contains the user, group, or OU object that is granted access to the Storage Location 
object.

3 Click USERS > OK.

4 Click the Browse icon  next to the Storage Location Objects field.

5 Click the down-arrow  next to SERVERS.

6 Click the StorLoc_hostname object for your getting-started lab server, then click OK.

You could add multiple Storage Location objects to the list if needed, but we are only adding 
one.

7 Click OK twice.

10.2.4 SSH and NetStorage Administration

Many network administrators prefer to use SSH for remote server administration. NetStorage 
includes a special SSH-based Storage Location object named NSS_Volumes that lets eDirectory 
Admin users administer NSS volumes on OES 2 through NetStorage. Admin users can assign 
trustees, administer NSS file and directory attributes, restrict directory size, and so on. 

As a general security precaution, SSH services are not enabled by default on OES 2 servers. However, 
you enabled SSH services through the firewall in Section 4.4, “Allowing SSH Access,” on page 58, and 
then you enabled SSH as a LUM-enabled service, thus giving SSH access to LUM-enabled users.

The eDirectory Admin user has SSH access because it is a LUM-enabled user by default. This means 
that the Admin user can use SSH for remote server administration and it can administer the server’s 
NSS volumes through NetStorage.

NOTE: Unlike home directory access, which automatically connects all users in the tree with their 
NCP or NSS home directories no matter which server the directories are on, default administrative 
access is limited to the nssvolumes Storage Location object located in COMPANY. To provide 
administrative access to the HOME_NW volume on the LAB_NW NetWare® server, you would need 
to create an NCP Storage Location object that points to that volume. 
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Continue with Chapter 11, “Getting Acquainted with OES,” on page 91.
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11 11Getting Acquainted with OES

After you have installed Novell® Open Enterprise Server (OES) and completed the configuration 
instructions located in the preceding sections, your OES 2 server is ready for getting-started lab use.

The instructions and information in this section acquaint you with the basic services available in OES. 
More detailed service overviews are available in the OES 2 SP3: Planning and Implementation Guide. 
For comprehensive documentation for each service, see the administration guides and other 
documentation listed on the OES documentation Web site (http://www.novell.com/documentation/
oes).

This section guides you through the following tasks:

 Section 11.1, “Preparing Files for the Getting-started Lab Exercises,” on page 91

 Section 11.2, “Exercises for linux1_lum-edir,” on page 92

 Section 11.3, “Exercises for linux2_lum-edir,” on page 94

 Section 11.4, “Exercises for ncp_lum-edir,” on page 96

 Section 11.5, “Exercises for ncp_edir,” on page 98

 Section 11.6, “Exercises for nss_edir,” on page 101

 Section 11.7, “Administrative Tasks Available in NetStorage,” on page 103

 Section 11.8, “Exercises for nss_lum-edir,” on page 104

 Section 11.9, “Exercises for nw_edir,” on page 106

 Section 11.10, “Macintosh Exercises and Novell AFP,” on page 107

 Section 11.11, “What’s Next,” on page 107

11.1 Preparing Files for the Getting-started Lab Exercises
You will use four small text files in the exercises that follow. 

1 Log in to the Windows workstation as a Windows user with Administrator privileges.

2 Access this page in the online documentation.

3 Right-click each of the following links, select Save Link (or Save Target) As, and save the file to the 
desktop. 

 MyPrivateFile.txt (http://www.novell.com/documentation/oes2/download/
MyPrivateFile.txt)

 PublicInformation.txt (http://www.novell.com/documentation/oes2/download/
PublicInformation.txt)
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 TeamProjectReadOnly.txt (http://www.novell.com/documentation/oes2/download/
TeamProjectReadOnly.txt)

 TeamProjectWrite.txt (http://www.novell.com/documentation/oes2/download/
TeamProjectWrite.txt)

4  If you are working on Windows 7, move the downloaded files to the Libraries > Documents > 
Public Documents folder on the workstation.

Or

If you are working on Windows XP, move the downloaded files to My Computer > Shared 
Documents.

5 Log off Windows.

6 Continue with the next section, Exercises for linux1_lum-edir.

11.2 Exercises for linux1_lum-edir
 Section 11.2.1, “What linux1_lum-edir Can Do,” on page 92

 Section 11.2.2, “Using NetStorage,” on page 93

11.2.1 What linux1_lum-edir Can Do

This user has the following service access:
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Table 11-1   linux1_lum-edir Service Access

11.2.2 Using NetStorage

1 Log in to the Windows workstation as the linux1_lum-edir user.

2 Close the iFolder window.

3 Open your browser and log into NetStorage by using the following URL:

http://IP or DNS/netstorage

where IP or DNS is your OES 2 server’s IP address or DNS name.

4 Type linux1_lum-edir as the User Name, type the associated password in the Password field, 
then click OK.

5 Select the Linux_Home_Directories storage location you created in Section 10.2.2, “Creating a 
Storage Location Object in iManager,” on page 87.

6 Open the linux1_lum-edir directory.

7 Click File > Upload.

NetStorage doesn’t support dragging and copying files. Instead you upload files you want to 
store from the workstation to the server, and you download files you want to work with from 
the server to the workstation.

8 If prompted, disable the pop-up blocker and click File > Upload again if necessary to open the 
Upload File dialog box.

Service Details Explored for This User in This Guide

Novell iFolder® 
3.8

Can create and share its own iFolders and 
accept invitations from others to share their 
iFolders.

Yes. This was done previously in Section 8.5, 
“Configuring iFolder Accounts and Creating 
iFolders,” on page 76.

Novell AFP Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

See Section 11.10, “Macintosh Exercises and 
Novell AFP,” on page 107.

Novell CIFS Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

No

NetStorage Can access NetStorage because of the 
Storage Location Object created in 
Section 10.2.2, “Creating a Storage Location 
Object in iManager,” on page 87. 

NetStorage provides this user with access to 
its home directory, which it would otherwise 
not have.

Yes, to demonstrate file copying and deleting. 

Also to show that the linux2_lum-edir 
directory is publicly available, and not private 

as a NetWare® administrator would expect it 
to be. In fact, the directory can also be written 
to by any member of the LUMUsers group 
because of the action you took in Step 15 on 
page 60.

iPrint Can install and use the printer made available 
in Chapter 9, “iPrint,” on page 79.

No
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9 Click the Browse button.

10 If you are using Windows XP, browse to the Shared Documents folder where you copied the 
four files in Step 3 on page 91, select the first file and click Open.

If you are using Windows 7, browse to Libraries > Documents. Select the first file and click Open.

11 Click the plus (+) sign next to Browse, then repeat the same process to select and open the other 
three files.

12 Click the Upload button.

All four files should now be copied to the linux1_lum-edir directory.

13 Select the linux2_lum-edir, ncp_edir, and ncp_lum-edir folders in turn and attempt to copy 
the first file to each folder. 

Because you assigned full rights the LUMUsers group in Step 15 on page 60, the first copy 
attempt succeeds, but the other attempts fail because the linux1_lum-edir user doesn’t have the 
necessary rights to the ncp* user folders.

14 Open the linux1_lum-edir folder, then select MyPrivateFile.txt. 

15 Click File > Delete > OK.

The file is deleted.

16 Click View > Show Deleted Files.

The deleted file is not listed because this feature relies on the Salvage and Purge functionality 
that is available only on NSS volumes, and the underlying file system for the /home directory we 
are working with is Reiser, not NSS.

For more information on using NetStorage, see the OES 2 SP3: NetStorage Administration Guide.

17 Continue with the next section, Exercises for linux2_lum-edir.

11.3 Exercises for linux2_lum-edir
 Section 11.3.1, “What linux2_lum-edir Can Do,” on page 94

 Section 11.3.2, “Using NetStorage,” on page 95

 Section 11.3.3, “Using iPrint,” on page 96

11.3.1 What linux2_lum-edir Can Do

This user has the following service access:
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Table 11-2   linux2_lum-edir Service Access

11.3.2 Using NetStorage

1 Log in to the Windows workstation as the linux2_lum-edir user.

2 When the iFolder wizard launches, click Cancel.

3 Open your browser. If you are running Windows 7, use the Run as Administrator option.

4  Log into NetStorage by using the following URL:

http://IP or DNS/netstorage

where IP or DNS is your OES 2 server’s IP address or DNS name.

5 Type linux2_lum-edir as the User Name, type the associated password in the Password field, 
then click OK.

6 Click the Linux_Home_Directories storage location you created in Section 10.2.2, “Creating a 
Storage Location Object in iManager,” on page 87.

7 In the left navigation frame, click linux2_lum-edir.

8 Right-click the file in the right frame and notice that you can move, copy, download, delete, and 
rename the file through the NetStorage interface. Select Properties.

9 Notice that the file is owned by the linux1_lum-edir user who copied it to this folder.

10 Close the Properties window, right click the file again, and select Delete.

11 Click OK.

Service Details Explored for This User in This Guide

iFolder 3.8 Can create and share its own iFolders and 
accept invitations from others to share their 
iFolders.

No

Novell AFP Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

See Section 11.10, “Macintosh Exercises 
and Novell AFP,” on page 107.

Novell CIFS Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

No

NetStorage Can access NetStorage because of the 
Storage Location Object created in 
Section 10.2.2, “Creating a Storage Location 
Object in iManager,” on page 87. Otherwise, 
this user would not have access to its home 
directory because it was created manually as 
a POSIX directory rather than being 
specified in iManager.

Yes

iPrint Can install and use the printer made 
available in Chapter 9, “iPrint,” on page 79.

Yes
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The file is deleted.

Although the file was owned by the linux1_lum-edir user who copied it to the folder, 
linux2_lum-edir can delete the file because it has all rights to the folder. 

For a brief overview of what the different POSIX rights allow on directories and files, see “Linux 
(POSIX) File System Access Rights” in the OES 2 SP3: Planning and Implementation Guide.

12 Click File > Upload.

13 Click the Browse button, browse to the Documents folder, select the first file, and click Open.

14 Click the plus (+) sign next to Browse, and then repeat the same process to select and open the 
other three files.

15 Click the Upload button.

All four files should now be copied to the linux2_lum-edir directory.

For more information on using NetStorage, see the OES 2 SP3: NetStorage Administration Guide.

11.3.3 Using iPrint

1 In the browser, access the iPrint page by using the following URL:

http://IP or DNS/ipp

where IP or DNS is your OES 2 server’s IP address or DNS name.

IMPORTANT: If you are using Windows 7, you will need to run the browser as the 
administrator user.

2 (Conditional) If you have not previously installed the iPrint client on the workstation, click the 
Install iPrint Client link and install the client now.

3 Click the link for the printer you created in Section 9.6, “Creating iPrint Printer Objects,” on 
page 83.

You might need to click the Refresh button to see the printers.

4 Answer the prompts to install the printer on the workstation.

5 Access the Printers property page. 

On Windows 7 click Start > Devices and Printers. 

On Windows XP click Start > Settings > Printers.

6 Right-click the printer, then click Printer Properties.

7 Click Print Test Page > OK > OK.

A test page should print at your printer.

For more information on various iPrint capabilities, see “Customizing iPrint” in the OES 2 SP3: 
iPrint for Linux Administration Guide.

8 Continue with the next section, Exercises for ncp_lum-edir.

11.4 Exercises for ncp_lum-edir
 Section 11.4.1, “What ncp_lum-edir Can Do,” on page 97

 Section 11.4.2, “Using NetStorage,” on page 97
96 OES 2 SP3: Getting Started with OES 2 and Virtualized NetWare



11.4.1 What ncp_lum-edir Can Do

This user has the following service access:

Table 11-3   ncp_lum-edir Service Access

11.4.2 Using NetStorage

1 Log in to the Windows workstation as the ncp_lum-edir user.

2 When the iFolder wizard launches, click Cancel.

3 Open your browser and log into NetStorage by using the following URL:

http://IP or DNS/netstorage

where IP or DNS is your OES 2 server’s IP address or DNS name.

4 Type ncp_lum-edir as the User Name, type the associated password in the Password field, then 
click OK.

5 Click the HOME@EXAMPLE_TREE storage location.

Unlike the Linux_Home_Directories storage location, this directly opens the home directory. 

6 Click File > Upload, browse to the Documents folder, and upload one of the text files.

The file appears in the folder.

7 Click the ncp_lum-edir folder in the Linux_Home_Directories storage location.

Notice that the folder appears to be empty.

Service Details Explored for This User in This Guide

iFolder 3.8 Can create and share its own iFolders and 
accept invitations from others to share their 
iFolders.

No

Novell AFP Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

See Section 11.10, “Macintosh Exercises 
and Novell AFP,” on page 107.

Novell CIFS Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

No

NetStorage Can access its home directory through 
NetStorage because all home directories 
created through iManager and stored as 
attributes in eDirectoryTM are exposed 
through the HOME@EXAMPLE_TREE 
default storage location.

Yes

iPrint Can install and use the printer made 
available in Chapter 9, “iPrint,” on page 79.

No
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This is because the ncp_lum-edir home directory was created when the user object was created 
in iManager by the eDirectory Admin user. The ncp_lum-edir user can see that the directory 
exists because it is a member of the LUMUsers group and has SSH access to the /home directory 
on the OES 2 server, but it has no POSIX rights to view the ncp_lum-edir directory’s contents. 
From a POSIX perspective, the Admin user owns the directory. 

8 Click the linux2_lum-edir folder in the Linux_Home_Directories storage location.

Notice that the four files uploaded by the user in Step 12 on page 96 are listed.

This is because the ncp_lum-edir user is a member of the LUMUsers group, and that group has 
all rights to linux2_lum-edir’s home directory as assigned in Step 16 on page 60. 

For more information on using NetStorage, see the OES 2 SP3: NetStorage Administration Guide.

11.5 Exercises for ncp_edir
 Section 11.5.1, “What ncp_edir Can Do,” on page 98

 Section 11.5.2, “Using iFolder,” on page 99

 Section 11.5.3, “Using NetStorage,” on page 100

11.5.1 What ncp_edir Can Do

This user has the following service access:

Table 11-4   ncp_edir Service Access

Service Details Explored for This User in This Guide

iFolder 3.8 Can create and share its own iFolders and 
accept invitations from others to share their 
iFolders.

Yes

Novell AFP Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

See Section 11.10, “Macintosh Exercises 
and Novell AFP,” on page 107.

Novell CIFS Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

No

NetStorage Can access its home directory through 
NetStorage because all home directories 
created through iManager and stored as 
attributes in eDirectory are exposed through 
the HOME@EXAMPLE_TREE default 
storage location.

Yes

iPrint Can install and use the printer made 
available in Chapter 9, “iPrint,” on page 79.

No
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11.5.2 Using iFolder

 “Setting Up iFolder” on page 99

 “Observing File Synchronization” on page 99

 “Using iFolder Web Access” on page 100

Setting Up iFolder

linux2_lum-edir has full access to all iFolder user functionality, but for the purposes of this guide we 
will accept only the invitation that was extended by linux1_lum-edir and briefly explore what is 
available through that invitation.

1 At the Windows workstation, log in as ncp_edir.

2 After the iFolder Account Creation Wizard launches, click Next.

3 In the Server Address field, type the IP address or DNS name of the OES 2 getting-started lab 
server, then click Next.

4 Type the username and password for ncp_edir, select Remember password on This Computer, then 
click Next.

5 Click Connect.

6 If prompted, accept the certificate by clicking Yes. 

7 Deselect Create Default iFolder, then click Next.

8 Click Finish.

9 Right-click in the iFolder dialog boxand select Refresh, then click linux1_lum-edir_IF3. 

Remember that this is the iFolder that linux1_lum-edir shared with the ncp_edir user.

10 In the icon row at the top, click Download.

11 Click OK.

The iFolder is created on the desktop.

12 Double-click the iFolder on the desktop to open it in Windows Explorer.

13 Navigate to the Documents folder, then drag and copy (using the Ctrl key) the four files to the 
linux1_lum-edir_IF3 folder. 

You can do this because ncp_edir has default Read/Write permissions to the shared iFolder.

Make sure you copy (by pressing the Ctrl key) rather than moving the files from the Shared 
Documents folder. Otherwise, the files will be moved and won’t be available to other users who 
log in.

14 Continue with the next section, “Observing File Synchronization.”

Observing File Synchronization

To understand more about how iFolder works, it is helpful to observe the file synchronization 
processes in action.

1 On the desktop in the taskbar, right-click the iFolder icon and select Synchronization Log.

The iFolder Synchronization Log opens.

2 Right-click the iFolder icon again and select Preferences.

3 Change the Synchronization interval to 1 minute and click Apply.
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Normally you would not want to synchronize this often, but for our current purposes it helps to 
expedite log activity.

4 Delete the MyPrivateFile.txt file from the linux1_lum-edir iFolder on the desktop.

Within a couple of minutes the change is synchronized with the iFolder server. Notice that there 
are various synchronization operations involved to ensure that all changes are tracked in order 
and coordinated among the various iFolders on the server and affected workstations.

5 Continue with the next section, “Using iFolder Web Access.”

Using iFolder Web Access

NOTE: By default, interaction with an iFolder 3.8 server is encrypted through SSL 3.0.

Users can access their iFolders through most browsers that support SSL 3.0. 

1 Open your browser and enter the following URL:

https://IP_or_DNS_name/ifolder

where IP_or_DNS_name is the IP address or complete DNS name of your OES 2 server.

2 If prompted, accept the certificate.

3 Log in as ncp_edir.

4 Click the linux1_lum-edir_IF3 link and observe the following:

 The files you copied to the iFolder are available in the browser.

 By clicking a file link, you can automatically download and open the file, or you can save it 
to your desktop. After downloading and modifying a file, you can upload it and replace the 
original on the iFolder server.

 Using the links above the files, you can create new folders, upload files, and delete a 
selected file from the server.

Changes made to iFolders on the server through browser connections are synchronized 
with the corresponding iFolders on workstation desktops the next time users log in. 

5 Close the browser.

6 Continue with the next section, “Using NetStorage.”

11.5.3 Using NetStorage

1 Using your browser, log into NetStorage by using the following URL:

http://IP or DNS/netstorage

where IP or DNS is your OES 2 server’s IP address or DNS name.

2 Type ncp_edir as the User Name and the associated password in the Password field, then click 
OK.

3 In the left navigation frame, click Home@EXAMPLE_TREE.

4 Click File > Upload.

If you are prompted, enable pop-ups and repeat this step.

5 Click the Browse button and navigate to the Shared Documents folder, then select the first file and 
click Open.
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6 Click the Plus sign (+) by the Browse button to add another field. Then click Browse, select the next 
file, and repeat this step until all four files are selected. 

7 Click Upload.

8 Log in to the OES 2 server as the root user and click Computer > Home Folder. 

9 Double-click File System > home > ncp_edir.

10 Verify that the files you copied in NetStorage are on the server.

11 Right-click a file, select Properties, then click the Permissions tab and observe the following:

 The File Owner is root.

 The File Group is root.

 Group and Others have no rights, reflecting the fact that the file is on an NCPTM volume.

Generally speaking, these POSIX permissions do not cause any problems. They do not affect 
NetStorage functionality for the user in this configuration because Home@EXAMPLE_TREE is an 
NCP storage location object; NCP file and directory trustee assignments govern access, not 
POSIX permissions. If the user accesses the files through a Novell ClientTM, NCP assignments 
govern. 

12 On the getting-started lab workstation, in NetStorage, click the Linux_Home_Directories storage 
location.

After a few moments, a message displays indicating that NetStorage cannot access the location. 
This is because the ncp_edir user is not LUM-enabled and therefore has no SSH access to the 
server.

13 Continue with the next section, Exercises for nss_lum-edir.

11.6 Exercises for nss_edir
 Section 11.6.1, “What nss_edir Can Do,” on page 101

 Section 11.6.2, “Using NetStorage,” on page 102

11.6.1 What nss_edir Can Do

This user has the following service access:
Getting Acquainted with OES 101



Table 11-5   nss_edir Service Access

11.6.2 Using NetStorage

1 Log in to the Windows workstation as the nss_edir user.

2 When the iFolder wizard launches, click Cancel.

3 On the Windows workstation in your browser, log into NetStorage by using the following URL:

http://IP or DNS/netstorage

where IP or DNS is your OES 2 server’s IP address or DNS name.

4 Type nss_edir as the User Name, type the associated password in the Password field, then click 
OK.

5 In the left navigation frame, click Home@EXAMPLE_TREE.

This share point links directly to the NSS home directory for the user that is specified in 
eDirectory. 

6 Click File > Upload.

If needed, allow the pop-up and repeat this step.

7 Click the Browse button and navigate to the Shared Documents folder, then select the first file and 
click OK.

8 Click the Plus sign (+) by the Browse button to add another field. Then click Browse, select the next 
file, and repeat this step until all four files are selected. 

9 Click Upload.

10 Select MyPrivateFile.txt, then click File > Rename and rename the file to junk.txt.

Service Details Explored for This User in This Guide

iFolder 3.8 Can create and share its own iFolders and 
accept invitations from others to share their 
iFolders.

No

Novell AFP Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

See Section 11.10, “Macintosh Exercises and 
Novell AFP,” on page 107.

Novell CIFS Can access any NSS directory to which it has 
rights.

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

Yes

NetStorage Can access its home directory through 
NetStorage because all home directories 
created through iManager and stored as 
attributes in eDirectory are exposed through 
the HOME@EXAMPLE_TREE default 
storage location.

Yes

iPrint Can install and use the printer made available 
in Chapter 9, “iPrint,” on page 79.

No
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11 Upload MyPrivateFile.txt again.

12 Right-click junk.txt and select Delete, then click OK.

The file is removed from the list, but because this is an NSS volume with Salvage enabled, the 
file is not gone from the NSS file system.

13 Click View > Show Deleted Files.

14 Select junk.txt, then click File > Undelete.

In Internet Explorer 8 you must allow the Windows script to run and repeat this step.

15 Click OK.

Notice that the file is still displayed as a deleted file and an error is indicated in the lower left 
frame.

This is because NSS cannot track POSIX ownership of files for users that are not LUM-enabled. 
For more information, see “Services That Do Not Require LUM-Enabled Access But Have Some 
LUM Requirements” in the OES 2 SP3: Planning and Implementation Guide.

If nss_edir were using the Novell Client, the file could be salvaged through the client, but 
because we are not exploring the Novell Client in this guide, this is a good place to look at a few 
of the administrative features for NSS volumes that are available to eDirectory Admin users 
through NetStorage.

16 Continue with the next section, Administrative Tasks Available in NetStorage.

11.7 Administrative Tasks Available in NetStorage
 Section 11.7.1, “Recovering the junk.txt File,” on page 103

 Section 11.7.2, “Setting Rights to TeamProjectReadOnly.txt,” on page 103

 Section 11.7.3, “Setting Rights to TeamProjectWrite.txt,” on page 104

11.7.1 Recovering the junk.txt File

1 Log in to NetStorage as the eDirectory Admin user and browse to the nss_edir home directory.

2 Click View > Show Deleted Files.

3 Select junk.txt.

4 Click File > Undelete, then click OK.

In Internet Explorer 8 you must allow the Windows script to run and repeat this step.

5 Click View > Refresh.

You might have to refresh the Windows to see the deleted file.

The file has been fully recovered.

11.7.2 Setting Rights to TeamProjectReadOnly.txt

1 Right-click TeamProjectReadOnly.txt and select Properties.

2 Click NetWare Rights.

This displays the Novell File Trustee assignments for the file.

3 Click the Browse icon next to the blank field under the Trustees list.
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4 Click EXAMPLE_TREE > COMPANY > LAB > USERS > AllUsers.

5 Click the plus sign, then click the NetWare Rights tab again.

The AllUsers group members are now trustees of the TeamProjectReadOnly.txt file in the 
nss_edir home directory. 

Notice the check boxes to the right of the AllUsers group, indicating that the group has Read and 
File Scan rights to the file.

6 Click Apply > Close.

7 Continue with Setting Rights to TeamProjectWrite.txt.

11.7.3 Setting Rights to TeamProjectWrite.txt

1 If the previous file is still selected, deselect it. Right-click options are only available on single 
files and are prevented if multiple files are selected.

2 Right-click TeamProjectWrite.txt and select Properties.

3 Select Rename Inhibit, select Delete Inhibit, then click Apply.

The NSS file system is now set to prevent the file from being renamed or deleted by anyone, 
including nss_edir.

4 Click NetWare Rights.

5 Click the Browse icon next to the blank field.

6 Click EXAMPLE_TREE > COMPANY > LAB > USERS > LUMUsers.

7 Click the plus sign (+), then click the NetWare Rights tab again.

The LUMUsers group members are now trustees of the TeamProjectWrite.txt file in the 
nss_edir home directory.

Notice the check boxes to the right of the LUMUsers group, indicating that the group has Read 
and File Scan rights to the file.

8 Assign the group the Write right by selecting the check box to the right of the first one that is 
checked (the Read check box).

9 Click Apply > Close.

10 Continue with the next section, Exercises for nss_lum-edir.

11.8 Exercises for nss_lum-edir
 Section 11.8.1, “What nss_lum-edir Can Do,” on page 104

 Section 11.8.2, “Using Novell CIFS File Services,” on page 105

11.8.1 What nss_lum-edir Can Do

This user has the following service access:
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Table 11-6   nss_lum-edir Service Access

11.8.2 Using Novell CIFS File Services

1 Log in to the Windows workstation as the nss_lum-edir user.

2 When the iFolder wizard launches, click Cancel.

3 On Windows 7, click Start > Computer > Map Network Drive.

On Windows XP, open Windows Explorer or My Computer and click Tools > Map Network Drive.

4 Click the Drive drop-down list and select an unused drive letter.

5 In the Folder field, type the following:

\\IP_or_DNS\home_nss.

where IP_or_DNS is the IP address or full DNS name of the OES 2 server.

6 Click Finish.

The system maps the drive and opens at the root of the HOME_NSS volume.

Normally, only the nss_lum-edir home directory would appear. However, because we granted 
rights to two files in the nss_edir home directory, it also appears.

7 Open the nss_edir home directory and notice that the two files are displayed, but the other files 
in nss_edir are not. 

This illustrates the granular access capabilities of NCP file services.

8 Open the TeamProjectReadOnly.txt file in a text editor, such as Notepad. Then change the file 
contents and try to save the changes.

Service Details Explored for This User in This Guide

iFolder 3.8 Can create and share its own iFolders and 
accept invitations from others to share their 
iFolders.

No

Novell AFP Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

See Section 11.10, “Macintosh Exercises 
and Novell AFP,” on page 107.

Novell CIFS Can access any NSS directory to which it 
has rights.

Access rights to directories are governed by 
the NSS file system, allowing the user to only 
see and do what it has rights for.

Yes

NetStorage Can access its home directory through 
NetStorage because all home directories 
created through iManager are stored as 
attributes in eDirectory are made available 
through the HOME@EXAMPLE_TREE 
default storage location.

No

iPrint Can install and use the printer made 
available in Chapter 9, “iPrint,” on page 79.

No
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You are prevented from doing anything except reading the file, including saving the file with a 
different name.

9 Open the TeamProjectWrite.txt file in the text editor. Then change the file contents and save 
the file.

10 Close the file and reopen it in the editor.

Your changes were saved because of the rights you have to the file.

11 Close the file and try to delete it. 

Windows 2000 and some versions of Windows XP wrongly report that the file has been deleted. 
However, if you close the drive and reopen it, you will see that it is still there. See “Windows XP 
SP2 Wrongly Reports File Deletion.”

12 Continue with the next section, Exercises for nw_edir.

11.9 Exercises for nw_edir
 Section 11.9.1, “What nw_edir Can Do,” on page 106

 Section 11.9.2, “Using NetWare CIFS File Services,” on page 107

11.9.1 What nw_edir Can Do

This user has the following service access:

Table 11-7   nw_edir Service Access

Service Details Explored for This User in This Guide

iFolder 3.8 Can create and share its own iFolders and 
accept invitations from others to share their 
iFolders.

No

NetWare AFP Can access any NSS directories to which it 
has rights. 

Access rights to directories are governed by 
the NSS file system, allowing the user to 
only see and do what it has rights for.

No

NetWare CIFS Because its home directory is on the 
virtualized NetWare server, this user has 
automatic CIFS/SMB access to the directory 
(assuming the configuration steps in 
Section 7.2, “Enabling NFAP Services on 
the LAB_NW Server,” on page 70 are 
completed.)

Yes

NetStorage Can access its home directory through 
NetStorage because all home directories 
created through iManager are stored as 
attributes in eDirectory are made available 
through the HOME@EXAMPLE_TREE 
default storage location.

No

iPrint Can install and use the printer made 
available in Chapter 9, “iPrint,” on page 79.

No
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11.9.2 Using NetWare CIFS File Services

1 Log in to the Windows workstation as the nw_edir user.

2 When the iFolder wizard launches, click Cancel.

3 Open Windows Explorer or My Computer and click Tools > Map Network Drive.

4 Click the Drive drop-down list and select an unused drive letter.

5 In the Folder field, type the following:

\\IP_or_DNS\home_nw

where IP_or_DNS is the IP address or full DNS name of the LAB_NW server.

TIP: After doing so many exercises involving the OES 2 Getting-started Lab server, it is easy to 
use the wrong IP address or DNS name. Make sure you are accessing your virtualized NetWare 
server.

6 Click Finish.

The system maps the drive and opens at the root of the HOME_NW volume.

7 Navigate to the Shared Documents folder, then drag and copy the four files to the nw_edir 
folder.

8 Continue with the next section, Macintosh Exercises and Novell AFP.

11.10 Macintosh Exercises and Novell AFP
Most of the exercises you have performed in this guide can also be performed on a Macintosh 
workstation, so we will not repeat them. 

OES 2 includes iPrint and iFolder clients for the Mac, and NetStorage and iFolder Web services work 
equally well on most browsers, including those on mobile devices.

Novell CIFS even works well with the Macintosh file sharing functionality.

To explore Novell AFP on your getting-started lab’s Macintosh workstation, do the following:

1 While logged into the workstation, click the Finder, then click Go > Connect to Server.

2 In the Connect to Server dialog box, type the OES 2 server’s IP address or DNS name, then click 
Connect.

3 Type an nss* user’s name and password and click Connect.

You should see the folders on the HOME_NSS volume to which the user has access rights.

11.11 What’s Next
Your getting-started lab is now set up and ready to use for building your experience with OES 2.

The exercises in this guide have highlighted only a few major points and features. There are 
numerous additional things worth exploration.

After you complete the exercises in this guide, we recommend that you do the following:

1. Think about the needs of your organization and how the various OES 2 product components can 
help you address those needs.
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2. Think about your network users and their file and print service needs. Match them against the 
different user types created in this guide. Then take the opportunity to do some hands-on 
exploring of the access capabilities and limitations for the matching users. For example, set up 
and experiment with the privacy and collaboration capabilities for each user through both NCP 
and POSIX.

3. Begin planning your organization’s eDirectory tree and the rollout of OES 2 services to your 
organization.

As you plan for, work with, and install OES 2, be sure to consult the other OES 2 product 
documentation mentioned in “If You Want to Use This Guide as a Reference” on page 8.
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A ASupplementary Information

This section contains supplementary explanations and instructions.

 Section A.1, “NSS Partitions, Pools, and Volumes,” on page 109

 Section A.2, “iManager Tomcat Error,” on page 111

A.1 NSS Partitions, Pools, and Volumes
For a complete discussion about NSS, refer to the OES 2 SP3: NSS File System Administration Guide for 
Linux.

This section presents the following:

 A quick overview of the three Linux partitions on your getting-started lab server

 A general overview of NSS partitions and the mechanisms that let you create NSS volumes on 
them

Figure A-1   Partitions, Pools, and Volumes
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Reference Letter Explanation

Partitions are physical sections on a hard disk that are managed by a file system. 
The most common file systems on Linux servers today are Ext3, Reiser, and XFS.

The boot partition on your getting-started lab server is managed by the Reiser file 
system. The files and configuration data it contains start the server.

The swap partition is managed by a file system that swaps information between 
memory and the disk, thus augmenting the RAM installed in the server.

The / (root) partition on your server is managed by Reiser and stores all the getting-
started lab server’s system and data files, including OES services, eDirectoryTM, and 
so on.

OES 2 servers can also include NSS partitions. These are similar to Linux partitions 
in that they occupy physical disk space, but they are also significantly different in a 
number of ways.

1. You create the Linux partitions shown in this illustration during OES 2 
installation. 

You always create NSS partitions after the OES installation is completed.

2. You create Linux partitions by allocating an amount of disk space to the 
partition and assigning it a mount point, such as /boot, /home, or / (root). 

You create NSS partitions by creating an NSS pool (see G) and assigning 
space on the server’s storage devices (physical or logical disks) to the pool. 
The space you assign to a given pool from a specific disk is designated on that 
disk as an NSS partition.

3. On Linux, files are stored on a partition. 

On NSS, files are stored in an NSS volume—a logical mechanism that can 
span multiple NSS partitions and also the devices that contain them.

4. On Linux, a partition is allocated a set amount of disk space on a single device. 
The amount of disk space that can be used is limited by the size of the partition.

NSS volumes are not bound by individual partition or device sizes. Rather, they 
take disk space from their assigned NSS pool as needed. 

1. Additional disk space can be dynamically added to NSS pools as needed, and 
NSS volumes can grow dynamically in return as long as there is free space 
available in the pool, unless the volume size has been restricted by an 
eDirectory Admin user.

IMPORTANT: The illustration shows the NSS pool spanning NSS partitions on both 
the server’s primary hard disk and a second hard disk, which could be added later. 
The NSS pool contains an NSS volume (HOME_NSS in this case) that contains the 
NSS volume data (illustrated in red). The NSS pool also has free space that is not 
yet allocated to a volume (illustrated in white). 

Free space and volume data aren’t necessarily distributed across all partitions, or 
distributed evenly as the graphic might imply. The NSS file system manages what 
each partition contains, independent of any administrative controls.
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A.2 iManager Tomcat Error
If you experience a Tomcat error when attempting to access iManager 2.7, the likely cause is a 
corrupted browser cookie. Clearing the browser cookies should solve the problem.

1 In Firefox, click Tools > Clear Private Data.

2 Select Cookies.

3 Deselect the other options.

4 Click Clear Private Data Now.

The NSS file system logically combines multiple partitions to form pools of space (up 
to 8 TB in size) that can span multiple devices. 

In the illustration, POOL_LX contains two NSS partitions that are created from the 
unformatted space on both hard disks when the pool is created.

In some ways, NSS pools are like pools of water. The space from each partition is 
logically “poured” into an NSS pool and made available to the pool’s assigned 
volumes, such as HOME_NSS. Neither the volume nor the users with rights to 
access it know which physical partitions contain the disk space actually being used.

Of course, the NSS file system continues to track each partition below the surface, 
but from a logical standpoint, all of the disk space assigned to a pool is one 
continuous source of disk space.

The sole purpose of NSS pools is to provide storage space from which you can form 
one or more NSS volumes. 

Your getting-started lab server contains a single NSS pool named POOL_LX with a 
single NSS volume named HOME_NSS. The pool’s free space is unallocated until 
used.

The instructions for creating the HOME_NSS volume leave the option set to have 
the volume grow to the pool size. As additional space is needed, the HOME_NSS 
volume automatically expands into the free space shown.

Free space in the pool is not reserved for the HOME_NSS volume; instead, space is 
allocated to HOME_NSS as needed. You can optionally add other volumes to the 
same pool and, in a sense, “overbook” the pool’s free space.

You can also grow the pool as needed by adding more NSS partitions to the pool.

Reference Letter Explanation
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B BDocumentation Updates

This section summarizes the changes made to this guide since the initial release of Novell® Open 
Enterprise Server 2.

April 17, 2012

January 18, 2012

September 2011

December 2010

January 19, 2010

Chapter or Section Changed Summary of Changes

Section 9.3, “Creating a Print Driver Store,” 
on page 81

Added a link to information in the iPrint administration guide 
about the Add from File option.

Chapter or Section Changed Summary of Changes

Various. Updated format to comply with new corporate standard.

Chapter or Section Changed Summary of Changes

Various. Updated contents for change to SLES 10 SP4 as the install 
base for OES 2 SP3.

Chapter or Section Changed Summary of Changes

Various. Updated contents for OES 2 SP3.

Chapter or Section Changed Summary of Changes

Various. Editing changes for SP2. 
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December 17, 2009

November 9, 2009

May 20, 2009

May 11, 2009

March 5, 2009

Chapter or Section Changed Summary of Changes

“Identifying the Files to Download” on 
page 11.

The media filenames for OES 2 SP2 now show SP2a to indicate 
that they are updated to resolve a problem with the NCP Server 
object, which involves Novell Clustering and has no impact on 
this guide. 

Chapter or Section Changed Summary of Changes

Various. Updated guide contents for OES 2 SP2. 

Chapter or Section Changed Summary of Changes

“Identifying the Files to Download” on 
page 11.

The media filenames for OES 2 SP1 Linux  now show SP1b to 
indicate that they are updated for:

 Compatibility with all of the patches in the OES 2 update 
channel.

 Correction of a build problem with the SP1b media. See 
May 11, 2009.

For more details, see TID 7003153 on the Novell Support site.

Chapter or Section Changed Summary of Changes

“Identifying the Files to Download” on 
page 11.

The media filenames for OES 2 SP1 Linux  now show SP1a to 
indicate that they are updated for compatibility with all of the 
patches in the OES 2 update channel.

For more details, see TID 7003153 on the Novell Support site.

Chapter or Section Changed Summary of Changes

“Creating a Storage Location Object in 
iManager” on page 87.

Clarified statements regarding Novell CIFS and SSH as used in 
the creation procedure. Corrected the protocol used to create 
the Storage Location Object from CIFS to SSH.
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