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Legal Notices

Novell, Inc. makes no representations or warranties with respect to the contents or use of this documentation, and 
specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. 
Further, Novell, Inc. reserves the right to revise this publication and to make changes to its content, at any time, 
without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc. makes no representations or warranties with respect to any software, and specifically disclaims 
any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. 
reserves the right to make changes to any and all parts of Novell software, at any time, without any obligation to 
notify any person or entity of such changes.

Any products or technical information provided under this Agreement may be subject to U.S. export controls and the 
trade laws of other countries. You agree to comply with all export control regulations and to obtain any required 
licenses or classification to export, re-export or import deliverables. You agree not to export or re-export to entities on 
the current U.S. export exclusion lists or to any embargoed or terrorist countries as specified in the U.S. export laws. 
You agree to not use deliverables for prohibited nuclear, missile, or chemical biological weaponry end uses. Please 
refer to www.novell.com/info/exports/ for more information on exporting Novell software. Novell assumes no 
responsibility for your failure to obtain any necessary export approvals.

Copyright © 2006 Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, 
stored on a retrieval system, or transmitted without the express written consent of the publisher.

Novell, Inc. has intellectual property rights relating to technology embodied in the product that is described in this 
document. In particular, and without limitation, these intellectual property rights may include one or more of the U.S. 
patents listed at http://www.novell.com/company/legal/patents/ and one or more additional patents or pending patent 
applications in the U.S. and in other countries.

Novell, Inc.
404 Wyman Street, Suite 500
Waltham, MA 02451
U.S.A.
www.novell.com

Online Documentation: To access the online documentation for this and other Novell products, and to get 
updates, see www.novell.com/documentation.
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Novell Trademarks

For a list of Novell trademarks, see Trademark and Service Mark List  (http://www.novell.com/company/legal/
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Third-Party Materials

All third-party trademarks are the property of their respective owners.
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About This Guide

This book has the following information:

Chapter 1, “Setting up Terminal Emulation,” on page 9
Chapter 2, “Emulator Settings,” on page 15
Chapter 3, “Single Sign-On for Hummingbird HostExplorer 7,” on page 53
Chapter 4, “Single Sign-On for MS Windows XP Telnet,” on page 67
Chapter 5, “Single Sign-On for PCXWare,” on page 73
Chapter 6, “Single Sign-On for SmarTerm for IBM 3270,” on page 75
Chapter 7, “Single Sign-On for WRQ Reflection v10,” on page 81
Chapter 8, “Single Sign-On for Reflections 2,” on page 87
Appendix A, “Error Codes: Terminal Launcher,” on page 91

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation, or go to www.novell.com/documentation/feedback.html and enter your 
comments there.

Documentation Updates

This is the Support Pack 1 (SP1) release for Novell SecureLogin 6.0. The version for this support 
pack in the product is, 6.0.103.

For the most recent version of the Guide for Configuring Terminal Emulation, visit the Novell 
Documentation Web site (http://www.novell.com/documentation/securelogin60).

Additional Documentation

This Configuration guide for Terminal Emulators is a part of documentation set for SecureLogin 6.0 
SP1. Other documents include:

Novell SecureLogin 6.0 SP1 Overview
Novell SecureLogin 6.0.SP1 Administration Guide
Novell SecureLogin 6.0 SP1 Installation Guide
Novell SecureLogin 6.0 SP1 User Guide
Novell SecureLogin 6.0 SP1 Application Definition Guide
Novell SecureLogin 6.0 SP1 Citrix and Terminal Services Guide

Documentation Conventions

In Novell documentation, a greater-than symbol (>) is used to separate actions within a step and 
items in a cross-reference path.
About This Guide 7
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A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as Linux or UNIX, should use forward slashes as required by your software.
reLogin 6.0 SP1 Congifuration Guide for Terminal Emulation
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1Setting up Terminal Emulation

Terminal Launcher is a component of Novell® SecureLogin. Terminal Launcher enables you to log 
in to any type of host that requires you to log in using an emulator (for example, ACF2 or RACF 
mainframe, a Unix host, or a Cisco router).

You can configure Terminal Launcher to work with several different terminal emulators, navigate to 
a particular subsystem, or navigate to a menu within an application.

Also, you can save Terminal Launcher application definitions as corporate application definitions, 
allowing all users access to the application definition.

This section provides information on the following;

Section 1.1, “Creating a SecureLogin Application Definition,” on page 9
Section 1.2, “Terminal Launcher,” on page 10
Section 1.3, “Creating a Login for an Emulator,” on page 13

1.1  Creating a SecureLogin Application 
Definition
The following example sets up SecureLogin Terminal Launcher to single sign-on to a session using 
Jolly Giant QWS3270 Plus.

1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.
2  Click Applications, then click New.
Setting up Terminal Emulation 9
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3 Select New Application Definition, Specify a name in the Name text box, select Terminal 
Emulator as the Type, then click OK.

4 Click Definition.

5 Specify an application definition for the program, then click Apply.
For example, type a MessageBox command. By entering one command, you can find out the 
following:

Terminal Launcher is working as expected.
The Application Definition is ready for you to enter the appropriate commands.

For Application Definitions on specific emulators, refer to the list of emulators in Chapter 2, 
“Emulator Settings,” on page 15.

1.2  Terminal Launcher
1 Click Start > Programs > Novell SecureLogin > Terminal Launcher.
reLogin 6.0 SP1 Congifuration Guide for Terminal Emulation
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As the following figure illustrates, Terminal Launcher displays emulators that you have created 
application definitions for:

2 Click Edit Available Emulators > New. 

3 Specify a name for the emulator, select an emulator type from the drop-down list, then click 
OK.
Setting up Terminal Emulation 11
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To find the emulator type, you might have to refer to the documentation for your emulator.
4 Specify values, then click OK.

The text boxes for the values depend on the type of emulator. The following figure illustrates 
values for a WinHLLAPI emulator.

For values on a specific emulator, see the list of emulators in Chapter 2, “Emulator Settings,” 
on page 15. If an emulator is not listed, see “Build a Terminal Emulator Application 
Definition” in the Novell SecureLogin 6.0.SP1 Administration Guide.

5 In the Available Emulators dialog box, click Done.
reLogin 6.0 SP1 Congifuration Guide for Terminal Emulation
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1.3  Creating a Login for an Emulator
1 From the list in the Available Applications pane, click the application that you want to log in to, 

then click Add.

2 To move an entry from one side to another, you can double-click it.
Setting up Terminal Emulation 13
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3 Select the emulator from the Emulator drop-down list, then click Launch.

The selected application definition runs, using the selected emulator. 
The first time the application definition is run, you encounter a prompt to enter your username 
and password. Enter the required values, then click OK. Terminal Launcher launches the 
emulator, enters your username and password, and logs you in to a session.
reLogin 6.0 SP1 Congifuration Guide for Terminal Emulation
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2Emulator Settings

This section provides information on configuring SecureLogin Terminal Launcher to work with 
your emulator. The information is a guide. If you need to modify the information to suit your 
environment or a particular version of software, see “Build a Terminal Emulator Application 
Definition” in the Novell SecureLogin 6.0 SP1 Administration Guide.

“Absolute Telnet” on page 16
“AccuTerm 2000” on page 17
“AniTa 32” on page 18
“Attachmate Extra 2000 Enterprise” on page 19
“Attachmate Kea!” on page 20
“Attachmate Personal Client” on page 21
“CRT v3.4” on page 24
“DynaComm” on page 25
“GLink v6.2” on page 26
“HBO Star Navigator v2.7” on page 27
“Host Access v7.2” on page 28
“IBM Personal Client” on page 29
“IDX Term v2.25” on page 30
“Inet 3270” on page 31
“Jolly Giant QWS3270 Plus v3.6” on page 32
“Lawsons” on page 33
“Microsoft Windows 2000 Telnet” on page 34
“Microsoft Windows XP Telnet” on page 35
“MiniSoft WS92” on page 36
“Mocha W32 Telnet v4.1” on page 37
“NetTerm v4.2 32bit” on page 38
“Passport TN 3270E v7.0” on page 39
“PowerTerm v6.34” on page 40
“QVT Term v4.1” on page 41
“SDI TN3270 Plus” on page 42
“SmarTerm v10 for Digital VT” on page 43
“Tandem 6530” on page 44
“TinyTerm v2.0.7” on page 45
“TinyTerm 4.21” on page 46
“ViewNow v8.0” on page 47
“Walldata Rumba 2000 v6.0” on page 48
Emulator Settings 15
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“WinComm 2000 v5.2” on page 49
“Window Telnet VT TE v3.10” on page 50
“WRQ Reflection v7.0 for Unix and Digital” on page 51

Because the following emulators require particular steps or information, see the complete module:

Chapter 3, “Single Sign-On for Hummingbird HostExplorer 7,” on page 53
Chapter 4, “Single Sign-On for MS Windows XP Telnet,” on page 67
Chapter 5, “Single Sign-On for PCXWare,” on page 73
Chapter 6, “Single Sign-On for SmarTerm for IBM 3270,” on page 85
Chapter 7, “Single Sign-On for WRQ Reflection v10,” on page 81

2.1  Absolute Telnet
Generic Configuration

Emulator Path

The path to the executable file for the emulator.
Host Name
The IP address of the host that you want to connect to.
Output IDs
119
Input IDs
118

Application Definition
WaitForText "ogin:"
Type $Username
reLogin 6.0 SP1 Congifuration Guide for Terminal Emulation
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Type @E 
WaitForText "assword:" 
Type $Password 
Type @E

2.2  AccuTerm 2000
Advanced Generic Configuration

Emulator Path

The path to the atwin2k.exe file. This path must follow the 8.3 filename format (for 
example, c:\Progra~1\ instead of c:\Program Files\).
Host Name
The session file of the host that you want to connect to.
Output IDs
\Alt+e,c
Output Offsets
8000,8000
Window Classes
ThunderRT6MDIForm

Application Definition
Delay 7000
WaitForText "ogin:"
Type $Username
Type @E
Emulator Settings 17
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WaitForText "assword:"
Type $Password
Type @E

2.3  AniTa 32
Generic Configuration

Emulator Path

The path to the anita.exe file.
Output IDs
32847,57634
Input IDs
57637

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
reLogin 6.0 SP1 Congifuration Guide for Terminal Emulation
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2.4  Attachmate Extra 2000 Enterprise
HLLAPI Configuration

Emulator Path

The path to the extra.exe file.
Home Directory
The home directory of the emulator.
HLLAPI DLL
The path to the ehllapi.dll file.
HLLAPI Function
HLLAPI
Session Files
The path to the session file that you want to use.

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
Emulator Settings 19
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2.5  Attachmate Kea!
Advanced Generic Configuration

Emulator Path

The path to the keavt.exe file. This path must follow the 8.3 filename format (for example, 
c:\Progra~1\ instead of c:\Program Files\).
Host Name
The session file of the host that you want to connect to.
Output IDs
120
Output Offsets
1000
Window Classes
KEA!,KTtext
Child ID
19177352

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.6  Attachmate Personal Client
This section shows the specific configuration required for Attachmate Personal Edition to work with 
SecureLogin. These settings are required for the application definition and communication to work. 

1 Define a session.

You typically use a wizard to do this. The wizard defines the terminal type and the Host address 
that will be contacted.

2 Save the session as a session file, in this case Session1.
3 Within the live Attachmate session, select Options > Global Preferences.

The Advanced Tab displays a list of the HLLAPI short names.

Link the session identifier A with the active session in the emulator. This tells the HLLAPI to 
insert any commands into the correct session identifier.
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4 Using Browse, identify the session correctly as the current running session, in this case 
Session1 again.

5 Verify the session document by using the Advanced tab within Global Preferences.

After you save this session file, the Secure Login TLAUNCH system is able to interact with the 
emulator correctly.
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HLLAPI Configuration

Emulator Path

The path to the extra.exe file.
Home Directory
The home directory of the emulator.
HLLAPI DLL
The path to the ehlapi32.dll file.
HLLAPI Function
HLLAPI
Session Files
The path to the session file that you want to use.

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
Emulator Settings 23



24 Novell Secu

novdocx (E
N

U
)  10 A

ugust 2006
2.7  CRT v3.4
Advanced Generic Configuration

Emulator Path

The path to the crt.exe file.
Host Name
The IP address of the host that you want to connect to.
Output IDs
\Alt+e,a,\Alt+e,c
Window Classes
Van Dylke Technologies - CRT.

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.8  DynaComm
Generic Configuration

Emulator Path

The path to the de3270.exe file.
Output IDs
532,528
Input IDs
529
Window Title
The title that the emulator window displays when the emulator is launched and connected to the 
host.
Emulator is 16 Bit
Checked
WndClass
DE3270_FRAME

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.9  GLink v6.2
Advanced Generic Configuration

Emulator Path

The path to the gl.exe file.
Host Name
The IP address of the host that you want to connect to. Type -h in front of the address.
Output IDs
133
Input IDs
172
Output Offsets
400,8000
Window Classes
GLINKC

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.10  HBO Star Navigator v2.7
Advanced Generic Configuration

Emulator Path

The path to the hbowem.exe file.
Host Name
The session file of the host that you want to connect to.
Output IDs
311
Input IDs
312
Output Offsets
500,4000
Window Classes
MIDICLIENT

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.11  Host Access v7.2
Advanced Generic Configuration

Emulator Path

The path to the host32.exe file. The path must follow the 8.3 filename format (for 
example, c:\Progra~1\ instead of c:\Program Files\).
Host Name
The name of the session file that you want to use.
Output IDs
55013
Input IDs
55015
Window Title
The title of the emulator window.

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.12  IBM Personal Client
HLLAPI Configuration

Emulator Path

The path to the pcsws.exe file.
Home Directory
The home directory of the emulator.
HLLAPI DLL
The path to the pcshll32.dll file.
HLLAPI Function
HLLAPI
Session Files
The path to the session file that you want to use.

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
Emulator Settings 29



30 Novell Secu

novdocx (E
N

U
)  10 A

ugust 2006
2.13  IDX Term v2.25
Advanced Generic Configuration

Emulator Path

The path to the idxterm.exe file.
Host Name
The IP address of the host that you want to connect to.
Output IDs
201
Input IDs
202
Output Offsets
400,8000
Window Classes
IDXterm
Window Title
IDXterm

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
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Type @E

2.14  Inet 3270
Advanced Generic Configuration

Host Name

The IP address of the host that you want to connect to.
Output IDs
33213
Input IDs
33214
Output Offsets
10000,10000
Window Classes
IDXterm
Window Title
The title that the emulator window displays when the emulator is launched and connected to the 
host.

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
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Type @E

2.15  Jolly Giant QWS3270 Plus v3.6
Advanced Generic Configuration

Emulator Path

The path to the qws3270p.exe file. The path must follow the 8.3 filename format (for 
example, c:\Progra~1\ instead of c:\Program Files\).
Host Name
The IP address of the host that you want to connect to.
Input IDs
1035
Output Offsets
700,8000
Window Classes
QWS3270X

Application Definition
Delay 2000
Type $Username
Type @E@E
Delay 1000
Type $Password
Type @E@E
reLogin 6.0 SP1 Congifuration Guide for Terminal Emulation



novdocx (E
N

U
)  10 A

ugust 2006
2.16  Lawsons
Advanced Generic Configuration

Emulator Path

The path to the univwin.exe file.
Host Name
The IP address of the host that you want to connect to.
Output IDs
202
Input IDs
203
Output Offsets
100
Startup IDs
110
Window Classes
GlobalClass,TerminalClass
Child ID
100

Application Definition
WaitForText "ogin:"
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Type $Username
Type \N
WaitForText "assword"
Type $Password
Type \N

2.17  Microsoft Windows 2000 Telnet
Advanced Generic Configuration

Emulator Path

The path to the telnet.exe file.
Host Name
The name or IP address of the host that you want to connect to.
Output IDs
\n
Output Offsets
500,5000
Startup IDs
110
Window Classes
ConsoleWindowClass
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Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E

2.18  Microsoft Windows XP Telnet
Advanced Generic Configuration

Emulator Path

The path to the telnet.exe file.
Host Name
The IP address, host name, or session file of the host that you want to connect to.
Output IDs
\n
Output Offsets
400,3000
Window Classes
ConsoleWindowClass
Emulator Settings 35



36 Novell Secu

novdocx (E
N

U
)  10 A

ugust 2006
Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E

2.19  MiniSoft WS92
Advanced Generic Configuration

Emulator Path

The path to the ws92_32.exe file.
Host Name
The session file of the host that you want to connect to.
Output IDs
\Alt+e,a
Output Offsets
1000,500
Window Classes
MS92WClass
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Application Definition
WaitForText "ACF82003 ACF2, ENTER LOGON ID -"
Type $Username
Type \N
WaitForText "ACF82004 ACF2, ENTER PASSWORD -"
Type $Password
Type \N
WaitForText "HIT ENTER TO CONTINUE"
Type \N

2.20  Mocha W32 Telnet v4.1
Generic Configuration

Emulator Path

The path to the mtelnet.exe file.
Host Name
The name or IP address of the host that you want to connect to.
Output IDs
32906,57634
Input IDs
57637

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
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WaitForText "assword:"
Type $Password
Type @E

2.21  NetTerm v4.2 32bit
Advanced Generic Configuration

Emulator Path

The path to the netterm.exe file.
Host Name
The name or IP address of the host that you want to connect to.
Output IDs
11001
Input IDs
11002
Output Offsets
700,8000
Window Classes
NetTermClass

Application Definition
Type $Username
Type @E
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WaitforText "assword:"
Type $Password
Type @E

2.22  Passport TN 3270E v7.0
HLLAPI Configuration

Emulator Path

The path to the passport.exe file.
Home Directory
The home directory of the emulator.
HLLAPI DLL
The path to the passhll.dll file.
HLLAPI Function
HLLAPI
Session Files
The path to the session file that you want to use.

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.23  PowerTerm v6.34
WinHLLAPI Configuration

Emulator Path

The path to the ptw32.exe file.
Home Directory
The home directory of the emulator.
HLLAPI DLL
The path to the hllapi32.dll file.
HLLAPI Function
WinHLLAPI
Session Files
The path to the session file that you want to use.

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
reLogin 6.0 SP1 Congifuration Guide for Terminal Emulation



novdocx (E
N

U
)  10 A

ugust 2006
2.24  QVT Term v4.1
Generic Configuration

Emulator Path

The path to the term.exe file.
Host Name
The name or IP address of the server that you want to connect to.
Output IDs
2024
Input IDs
2022

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.25  SDI TN3270 Plus
WinHLLAPI Configuration

Emulator Path

The path to the tn3270.exe file.
Home Directory
The home directory of the emulator.
HLLAPI DLL
The path to the WHLLAPI.DLL file.
HLLAPI Function
WinHLLAPI
Session Files
The IP address of the host that you want to connect to.

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.26  SmarTerm v10 for Digital VT
Advanced Generic Configuration

Emulator Path

The path to the stoffice.exe file. This path must follow the 8.3 filename format (for 
example, c:\Progra~1\ instead of c:\Program Files\).
Host Name
The session file of the host that you want to connect to.
Output IDs
57634
Input IDs
57637
Output Offsets
1300,9000
Window Title
SmarTerm - [session name]

Application Definition
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.27  Tandem 6530
Generic Configuration

Emulator Path

The path to the cttw32.exe.
Host Name
The session file of the host that you want to connect to.
Output IDs
299,121
Input IDs
122
Window Title
The title that the emulator window displays when the emulator is launched and connected to the 
host.

Application Definition
WaitForText "ogin:"
Type $Username
Type \N
WaitForText "assword:"
Type $Password
Type \N
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2.28  TinyTerm v2.0.7
Advanced Generic Configuration

Emulator Path

The path to the wtt.exe file.
Host Name
The name of the emulator session that you want to connect to.
Output IDs
\Alt+e,c
Output Offsets
500,7000
Window Class
CS_MAIN_CLASS

Application Definition
WaitForText "ogin"
Type $Username
Type \N
WaitForText "assword"
Type $Password
Type \N
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2.29  TinyTerm 4.21
Advanced Generic Configuration

Emulator Path

The path to the tt.exe file. This path must follow the 8.3 filename format (for example, 
c:\Progra~1\ instead of c:\Program Files\).
Host Name
The session file of the host that you want to connect to.
Output IDs
7022
Input IDs
7023
Output Offsets
500,12000
Window Classes
cenMainWindow

Application Definition
WaitForText "ogin"
Type $Username
Type @E
WaitForText "assword"
Type $Password
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Type @E

2.30  ViewNow v8.0
WinHLLAPI Configuration

Emulator Path

The path to the nterm.exe file.
Home Directory
The home directory of the emulator.
HLLAPI DLL
The path to the whllapi.dll file.
HLLAPI Function
WinHLLAPI

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.31  Walldata Rumba 2000 v6.0
WinHLLAPI Configuration

Emulator Path

The path to the rumbawsf.exe file.
Home Directory
The home directory of the emulator.
HLLAPI DLL
The path to the WHLLAPI.DLL file.
HLLAPI Function
WinHLLAPI
Session Files
The path to the session file you want to use.

Application Definition
WaitForText "ogin:"
Type $Username
Type @E
WaitForText "assword:"
Type $Password
Type @E
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2.32  WinComm 2000 v5.2
Advanced Generic Configuration

Emulator Path

The path to the wc52.exe file.
Host Name
The name of the emulator session that you want to connect to.
Output IDs
\Alt+e,c
Output Offsets
500,7500
Window Classes
twmain

Application Definition
WaitForText "ogin"
Type $Username
Type @E
WaitForText "assword"
Type $Password
Type @E
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2.33  Window Telnet VT TE v3.10
Generic Configuration

Emulator Path

The path to the emulator’s executable file.
Host Name
The IP address of the host that you want to connect to.
Output IDs
1043,1074
Output Offsets
1010
Emulator is 16 Bit
Checked
WndClass
TNVT

Application Definition
WaitForText "ogin"
Type $Username
Type @E
WaitForText "assword"
Type $Password
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Type @E

2.34  WRQ Reflection v7.0 for Unix and Digital
Advanced Generic Configuration

Emulator Path

The path to the r2win.exe file. This path must follow the 8.3 filename format (for example, 
c:\Progra~1\ instead of c:\Program Files\).
Host Name
The session file of the host that you want to connect to.
Output IDs
\Alt+e,a,\Alt+e,c
Window Classes
r2Window

Application Definition
Delay 1000
WaitForText "ogin"
Type $Username
Type \N
WaitForText "assword"
Type $Password
Type \N
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3Single Sign-On for Hummingbird 
HostExplorer 7

This section can help you enable Hummingbird HostExplorer* 7 for single sign-on through Novell® 
SecureLogin.

Hummingbird HostExplorer 7 is not a standard Terminal Launcher configuration. It does not use 
Terminal Launcher at all. This example uses internal macro capabilities of the HostExplorer to 
trigger SecureLogin actions.

3.1  Setting Up Hummingbird HostExplorer 7
This section provides information on the following:

Section 3.1.1, “Creating the Emulator Macro Script,” on page 53
Section 3.1.2, “Configuring Hummingbird HostExplorer for Usernames,” on page 55
Section 3.1.3, “Configuring Hummingbird HostExplorer for Passwords,” on page 57
Section 3.1.4, “Configuring the Emulator Session,” on page 59
Section 3.1.5, “Creating a SecureLogin Application Definition,” on page 61
Section 3.1.6, “Enabling Hummingbird HostExplorer for Single Sign-On,” on page 64
Section 3.1.7, “Testing the Configuration,” on page 65

3.1.1  Creating the Emulator Macro Script
1 Create and configure a session in the emulator for your environment, then open the session.
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2 Click Tools > Quick Script > Edit.

3 Double-click Untitled: Description of Quick Script.

4 Specify a filename and description for the Quick Script, then click OK.
Ensure that the filename is only one word (no spaces).
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3.1.2  Configuring Hummingbird HostExplorer for Usernames
1 In the Login dialog box, click Commands > Wait For Text.

2 Configure the Wait For Text dialog box for username prompts, then click OK.

In the Text field, specify the text that the server displays when it prompts for a username.
Check the Anywhere check box.
Specify a timeout period.
We recommend a setting of five seconds.
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From the If Found drop-down list, select Pop Up a Message.
From the Otherwise drop-down list, select Pop Up a Message.
In the If Found pane, click Properties, configure the Popup Message Box window, then 
click OK.

Specify the username in the Title field.
Specify the username in the Message field.

In the Otherwise pane, click Properties, configure the error box, then click OK.

This is the message that is displayed if the prompt text is not found within the set timeout 
period.

In the Title field, specify a title for the error dialog box.
Specify a message in the Message text box.
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3.1.3  Configuring Hummingbird HostExplorer for Passwords
1 In the Login dialog box, click Commands > Wait For Text.

2 Configure the Wait For Text dialog box for password prompts, then click OK.

In the Text field, type the text that the server displays when it prompts for the password.
Check the Anywhere check box.
Specify a timeout period.
We recommend a setting of five seconds.
In the If Found pane, select Pop Up a Message from the drop-down list.
In the Otherwise pane, select Pop Up a Message from the drop-down list.
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In the If Found pane, click Properties, configure the Popup Message Box dialog box, then 
click OK.

Specify Password as the title.
Specify Password as the message.

In the Otherwise pane, click Properties, configure the error box, then click OK.

This is the message that is displayed if the prompt text is not found within the set timeout 
period.
In the Title text box, specify a title for the error dialog box.
Specify a message in the Message text box.

3 At the Login dialog box, click File > Save As.
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4 Specify Login as the filename, click Save, then close the Quick Script editor.

The macro is now complete.

3.1.4  Configuring the Emulator Session
1 Click Options > Edit Session Profile.

2 (Conditional) Select not to use the SecureLogin wizard at this time.
If SecureLogin prompts you to run the SecureLogin wizard, check the Don’t Prompt Me In the 
Future check box, then click No.

3 Expand the session in the Settings Groups panel.
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Click General in the Settings Groups panel, then click the Browse button next to the Auto Start 
Quick-Key drop-down list. 

4 Browse to where you saved the Quick Script macro file, then click Open.
The default path is c:\Documents and Settings\All Users\Application 
Data \Hummingbird\Connectivity 
\7.10\HostEx\QuickScript\Login.qsv.

5 Click OK, then close the emulator.
6 Open the session again.

You can use the shortcuts on the Start menu, then follow the prompts, or create a shortcut 
directly to the session.
To create a shortcut directly to the session, use the following format:
"Path to hostex32.exe" –P Session name

For example, type
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"C:\Progra~1\Hummingbird\hostex32.exe" –P Session1

The emulator connects and displays the following dialog box.

IMPORTANT: Don’t click OK.

3.1.5  Creating a SecureLogin Application Definition
1 Right-click the SecureLogin icon on the system tray, then click Add Applications.
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2 Click next until you reach the Select a Web Site or Application dialog box.

3 Select Windows Application, then click Next.
4 Drag the hand icon and drop it onto the title bar of the Username dialog box.
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5 In the Select Window Function dialog box, select Login Window from the drop-down list, then 
click Next.

6 Select the login fields.

6a Drag the hand icons and drop them onto the Username, Password, and (if appropriate) 
Optional fields.

6b Drag the hand icon for the OK Button and drop it onto the login button (for example OK, 
Next, or Continue). 

7 Click Next, confirm login details, then click Next again.
8 In the Name the Application Definition dialog box, specify a name, then click Finish.
Single Sign-On for Hummingbird HostExplorer 7 63



64 Novell Secu

novdocx (E
N

U
)  10 A

ugust 2006
3.1.6  Enabling Hummingbird HostExplorer for Single Sign-On
1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.
2 Select hostex32.exe from the My Logins list, then click Edit.

3 Click Definition, then edit the application definition.

Place the following application definition:
Dialog
 Class #32770
 Title "Username"
EndDialog
Click #2
Delay 50
Type -raw $Username
Type -raw \N
reLogin 6.0 SP1 Congifuration Guide for Terminal Emulation



novdocx (E
N

U
)  10 A

ugust 2006
Dialog
 Class #32770
 Title "Password"
EndDialog
Click #2
Delay 50
Type -raw $Password
Type -raw \N

4 Click OK twice, then close SecureLogin.

3.1.7  Testing the Configuration
1 Start the emulator session, specify your username, then click OK.

2 (Conditional) Respond to error messages.
Depending on the values that you entered for the Timeouts in the emulator macro, the error 
message might be displayed after you click OK. 
If the error message is displayed, click OK to close the session, then restart the session. This 
might happen twice. To avoid the problem, raise the timeout value in the Macro settings, or 
enter the username and password more quickly.

3 Specify the password, then click OK.
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SecureLogin launches the emulator, enters your username and password, and logs you in to the 
session.
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4Single Sign-On for MS Windows 
XP Telnet

This section helps you enable MS Windows* XP Telnet for single sign-on through Novell® 
SecureLogin.

4.1  Creating a SecureLogin Application 
Definition

1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click Applications > New.
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3 Click New Application Definition, then specify the information in the text boxes.

Specify a name in the Name text box.
Select Terminal Emulator from the Type drop-down list.

4 Click OK.
5 Click the Definition tab, then specify the following application definition:

Parts of the SecureLogin application definition are case sensitive. Omitting the "L" in “login” 
and the "P" in “password” allows the script to work regardless of whether the "L" and the "P" 
are displayed in uppercase or lowercase type. The application definition waits for the text 
"ogin". After the application definition detects the text "ogin", it enters the value of the variable 
$Username.

6 Click OK twice, then close SecureLogin.

4.2  Putting Telnet in Quick-Edit Mode
For SecureLogin to work with Microsoft Windows XP Telnet, the Telnet program must be in Quick 
Edit mode. 

1 Start Microsoft Windows Telnet XP. 
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2 Click the Telnet icon at the top of the Telnet window, then select Properties.

3 Check the Quick Edit Mode check box, then click OK.
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4.3  Configuring Terminal Launcher
1 Run SecureLogin Terminal Launcher, then click Edit Available Emulators.

2 Click New.

3 Specify a name for the emulator, select Advanced Generic as the emulator type, then click OK.
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4 Configure the emulator:

Emulator Path
This is the path to the telnet.exe file.
Host Name
This is the IP address, host name, or session file of the host that you want to connect to.
Output IDs
\n

Output Offsets
400,3000
Windows Classes
ConsoleWindowClass

5 Click OK, then click Done.
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4.4  Testing the Configuration
1 Double-click Windows XP Telnet in the Available Applications pane, select Windows XP 

Telnet from the Emulator drop-down list, then click Launch.

2 Enter login data.
The first time that the application definition is run, SecureLogin prompts you to specify a 
username and password, then click OK.
After you click OK, the emulator launches and you are logged in to the session.
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5Single Sign-On for PCXWare

PCXWare is not a standard emulator configuration. It does not use Terminal Launcher at all. This 
configuration relies on SecureLogin to detect when the emulator is launched and then send 
information to it. Therefore, do not use WaitForText commands in the application definition. 
Instead, use Delay commands.

5.1  Creating a SecureLogin Application 
Definition

1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click Applications > New.
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3 Click New Application Definition, then specify the information in the text boxes.

Specify xncd.exe in the Name text box.
Select Windows from the Type drop-down list.

4 Click OK.
5 Click the Definition tab, then type the following script:

The Delay commands are dependent on how long it takes PCXWare to load or connect to 
your UNIX*/SUN* server. The parameter 1000 is equal to 1 second. You can increase or 
decrease the number.

6 Click OK twice, then close SecureLogin.

5.2  Running the Emulator
The first time that the application definition is run, SecureLogin prompts you to specify a username 
and password, then click OK.

After you click OK, the emulator launches and you are logged in to the session.
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6Single Sign-On for SmarTerm for 
IBM 3270

This section helps you enable the SmarTerm for IBM* 3270 emulator for single sign-on through 
Novell® SecureLogin.

The configuration described in this section works only with SecureLogin v3.0.3 or later.

6.1  Creating a SecureLogin Application 
Definition

1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click Applications > New.
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3 Click New Application Definition, then specify information in the text boxes.

Specify a name in the Name text boxes.
Select Terminal Emulator from the Type drop-down list.

4 Click OK.
5 Click the Definition tab, then specify the following application definition:

Parts of the SecureLogin scripting language are case sensitive. Omitting the "L" in “login” and 
the "P" in “password” allows the application definition to work regardless of whether the "L" 
and the "P" are displayed in uppercase or lowercase type. The application definition waits for 
the text "ogin". The application definition detects the text "ogin", then enters the value of the 
variable $Username.

6 Click OK twice, then close SecureLogin.
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6.2  Configuring Terminal Launcher
1 Run SecureLogin Terminal Launcher, then click Edit Available Emulators.

2 Click New.

3 Specify a name for the emulator, select Advanced Generic as the emulator type, then click OK.
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4 Configure the emulator:

Emulator Path
This is the path to the stoffice.exe file. This path must follow the 8.3 filename format (for 
example, c:\Progra~1\ instead of c:\Program Files\).
Host Name
This is the session file of the host that you want to connect to.
Output IDs
57634
Input IDs
57637
Output Offsets
1300,9000
Windows Title
SmarTerm - [session name]

5 Click OK, then click Done.

6.3  Configure the Emulator Settings
1 Start the emulator.
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2 Select Properties > Emulation.

3 In the Function, Alt and Ctrl Keys Act As pane, select the Windows Keys option.

4 Click OK, then close the emulator.
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6.4  Testing the Configuration
1 Double-click SmarTerm in the Available Applications pane, select SmarTerm from the 

Emulator drop-down list, then click Launch.

2 Enter login data.
The first time that the application definition is run, SecureLogin prompts you to specify a 
username and password, then click OK.
After you click OK, the emulator launches and you are logged in to the session.
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7Single Sign-On for WRQ 
Reflection v10

This section helps you enable WRQ Reflection* v10 for single sign-on through Novell® 
SecureLogin.

7.1  Creating a SecureLogin Application 
Definition

1 Right-click the SecureLogin icon on the system tray, then click Manage Logins.

2 Click Applications > New.
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3 Select New Application Definition, then specify the information in the text boxes.

Specify a name in the Name text box.
Select Terminal Emulator from the Type drop-down list.

4 Click OK.
5 Click the Definition tab, then type the following application:

Parts of the SecureLogin application definition are case sensitive. Omitting the "L" in “login” 
and the "P" in “password” allows the application definition to work regardless of whether the 
"L" and the "P" are displayed in uppercase or lowercase type. The application definition waits 
for the text "ogin". The application definition detects the text "ogin", then enters the value of 
the variable $Username.

6 Click OK twice, then close SecureLogin.
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7.2  Creating and Configuring a Reflection 10 
Session File
The session file that you use must be configured to use a HLLAPI short name, so that SecureLogin 
can hook into Reflection using HLLAPI.

1 Open Reflection and either create a new session or open the existing one that you want to use 
with SecureLogin.

2 (Conditional) If the session has not been configured to connect to your host, do this now.
2a Select Setup, then select Terminal.
2b In the HLLAPI Names pane, specify a letter in the Short text box.

Specify any letter.
2c Click OK.
2d Save the session in the c:\Program Files\Reflection folder.

Remember the filename of the session.
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7.3  Configuring Terminal Launcher
1 Run Terminal Launcher, then click Edit Available Emulators.

2 Click New.

3 Specify a name for the emulator, select HLLAPI as the emulator type, then click OK.
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4 Configure the emulator:

Emulator Path
The path to the r8win.exe file.
Host Name
The folder that you want Reflection to operate from.
HLLAPI.DLL
The path to the HLLAPI32.DLL file.
HLLAPI Function
hllapi
Session Files
The name of the session file that you want to use.

5 Click OK, then click Done.

7.4  Creating a Desktop Shortcut for the Emulator
Create a new shortcut on the desktop to the following path:
C:\Program Files\Novell\SecureLogin\TLaunch.exe /auto /h{Short name 
letter} /eReflection 10 /pReflection 10

7.5  Testing the Configuration
The first time that the script is run, SecureLogin prompts you to type a username and password, then 
click OK.

After you click OK, the emulator launches and you are logged in to the session.
Single Sign-On for WRQ Reflection v10 85



86 Novell Secu

novdocx (E
N

U
)  10 A

ugust 2006
reLogin 6.0 SP1 Congifuration Guide for Terminal Emulation



8
novdocx (E

N
U

)  10 A
ugust 2006
8Single Sign-On for Reflections 2

This section provides information on the following:

“Before You Begin” on page 87
“Saving the Reflections Session” on page 87
“Creating the SecureLogin Enabling Application Definition” on page 88
“Configuring the Application Shortcut” on page 88

8.1  Before You Begin
1 Create a terminal emulation session file.

 Before enabling any terminal emulator for SecureLogin, you need to create a session file in the 
terminal emulator. The file must include all the required settings for deployment to end users. 

SecureLogin executes this session file when it launches the emulator. Any modifications to the 
session must be saved to this file. The session file can be saved locally or on the server. You can 
configure SecureLogin to access the file in the specified location.

2 Copy the sso.rbs file.
Reflections for Windows 2 version 5.2 requires the sso.rbs file. Save this file to the 
Reflection 2 installation directory (for example, c:\rwin). This file is specific to this version 
of Reflections. It is not required for other emulators.
You can request this file from Novell Technical Services.

8.2  Saving the Reflections Session
1 Start Reflections for Windows 2 version 5.2.
2 Connect to the required host.
3 Modify the terminal emulator settings as required.
4 Save the session.

For example, save the session as sso.r2w. The default is the application's installation 
directory.

5 Select Disconnect from the Connection menu.
The session file remains loaded but you have disconnected from the host.

6 Select Connection Setup from the Connection menu.
7 Click Connect Script, then browse to and select the sso.rbs file.
8 Click OK.

To save the changes to the session file:

1 Select Save [session name] from the File menu (for example, sso.r2w).
2 Quit Reflections for Windows.
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8.3  Creating the SecureLogin Enabling 
Application Definition

1 Double-click the SecureLogin icon on the system tray.
2 Select Applications, then click New > New Application Definition.
3 In the Name field, specify ntvdm.exe.
4 In the Description field, specify a name for the application enabler.

For example, specify Reflections for Windows.
5 From the Type drop-down list, select Windows.

For most terminal emulators, you would select Terminal Emulator.
6 Click OK.
7 Select Definition, then specify the following:
## Username dialog
Dialog
  Class "#32770"
  Title "Reflection 2 - Username"
EndDialog
SetPrompt "Username:"
Type $Username #101
Type "\N"
SetPrompt "Enter the following single sign-on variables."
## Password Dialog
Dialog
  Class "#32770"
  Title "Reflection 2 - Password"
EndDialog
SetPrompt "Password:"
Type $Password #101
Type "\N"
SetPrompt "Enter the following single sign-on variables."

8 Ensure that the Enabled check box is checked.
9 Save the enabled application by clicking OK.

The application enabler now displays in the Application list.
10 Save the data and close the SecureLogin interface by clicking OK.

8.4  Configuring the Application Shortcut
1 Right-click on the desktop, then select New > Shortcut.
2 Type the file path to the Reflections executable and session.

For example, type c:\rwin\sso.r2w.
3 Click Next.
4 In the Type a Name for This Shortcut text box, specify a name, then click Finish.
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8.5  Initially Logging In to Reflections 2 for 
Windows

1 Start Reflections by double-clicking the Reflections shortcut icon.
2 In the Username text box, specify your username, then click OK.
3 In the Password text box, specify your password, then click OK.

The Reflection 2 - Password dialog displays a second time so that you can re-enter your 
password to enable single sign-on.

4 In the Password text box, specify your password, then click OK.
Reflections for Windows 2 version 5.2 is now enabled for single sign-on.
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AError Codes: Terminal Launcher

This section contains error codes for Terminal Launcher.

For a full list of SecureLogin error codes, see “Error Codes” in the SecureLogin 6.0 SP1 
Administration Guide.

A.1  Error Codes with Tips

-102 BROKER_NO_SUCH_ENTRY

Possible Cause: You tried to load an application definition or variable that does not exist. For 
example, you set up Terminal Launcher to run from a shortcut or to run a 
particular application definition, but the application definition does not exist.

Action: Check that the name of the application definition is actually defined is 
SecureLogin. Verify that the name is the same as specified in the application 
definition editor.

-220 BROKER_HLLAPI_FUNCTION_NOT_FOUND

Possible Cause: You used an incorrect function when you defined the emulator. In the Terminal 
Launcher configuration, you specified a HLLAPI.DLL and the name of the 
function in that DLL. The name of the function cannot be found in the DLL.

Action: Using the Novell SecureLogin Configuration Guide for Terminal Emulators, 
check the configuration for the emulator. Make sure that you typed the 
HLLAPI function correctly.

-222 BROKER_HLLAPI_DLL_LOAD_FAILED

Possible Cause: Terminal Launcher was unable to load the HLLAPI.DLL that you specified. 

Action: Make sure that the path and file that you entered for the DLL are correct.

The HLLAPI.DLL for that emulator is looking for other DLL files that don’t 
exist or haven’t been installed for that emulator.

You have probably chosen the wrong .DLL file or have specified the wrong 
HLLAPI function (for example, HLLAPI or WinHLLAPI). Find the correct 
.dll and function. Check the vendor’s documentation for information about 
that emulator. 

You can use Microsoft* Spy++ to find Input and Output IDs.

-224 BROKER_ERROR_DURING_WINHLLAPICLEANUP

Possible Cause: Terminal Launcher has called the WinHLLAPI cleanup function for a 
WinHLLAPI emulator.

Action: Check the vendor’s documentation for information about that emulator.
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-225 BROKER_CANNOT_FIND_WINHLLAPISTARTUP_FUNCTION_IN_DLL

Possible Cause: In the Terminal Launcher configuration, you incorrectly specified that the 
emulator is a WinHLLAPI emulator.

Action: Using the Novell SecureLogin Configuration Guide for Terminal Emulators, 
check the configuration for the emulator. Specify the correct emulator type.

-226 BROKER_ERROR_DURING_WINHLLAPISTARTUP

Possible Cause: Check the vendor’s documentation for information about that emulator.

-227 BROKER_CANNOT_FIND_WINHLLAPICLEANUP_FUNCTION_IN_DLL

Possible Cause: In the Terminal Launcher configuration, you incorrectly specified that the 
emulator is a WinHLLAPI emulator.

Action: Using the Novell SecureLogin Configuration Guide for Terminal Emulators, 
check the configuration for the emulator. Specify the correct emulator type.

-264 BROKER_DDE_CONNECT_FAILED

Possible Cause: Terminal Launcher could not connect to a specified DDE emulator.

Action: Make sure that the emulator launched correctly and the emulator’s DDE 
support is turned on.

-273 BROKER_MSTELNET_OPERATION_NOT_SUPPORTED

Possible Cause: The generic emulator cannot support a particular operation (for example, 
SetCursor).

Action: For generic emulators, don’t use the command.

-279 BROKER_EMULATOR_LAUNCH_FAILED

Possible Cause: In Terminal Launcher, you can configure the path to the executable that will 
run. However, the specified executable is unable to run.

Action: Make sure that the path to the emulator is correct.

-280 BROKER_UNABLE_TO_CREATE_EMULATOR

Possible Cause: You have specified an invalid terminal type in TLAUNCH.INI (or the 
Terminal Launcher configuration).

Action: Specify the correct terminal type.

-281 BROKER_INVALID_CHARACTER_FOUND_IN_PASTE_ID_LIST

Possible Cause: A comma does not separate decimal numbers for input and output control IDs.

Action: For generic emulators, you must specify a set of input and output control IDs. 
Use a comma to separate decimal numbers.

-282 BROKER_INVALID_CHARACTER_FOUND_IN_COPY_ID_LIST

Possible Cause: A comma does not separate decimal numbers for copy IDs
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Action: For generic emulators, you must specify a set of copy control IDs. Use a 
comma to separate decimal numbers.

-283 BROKER_UNABLE_TO_READ_TLAUNCH_INI

Possible Cause: SecureLogin is unable to read the tlaunch.ini file because the file has been 
deleted.

Action: Create a blank tlaunch.ini file.

Create a default tlaunch.ini file by reinstalling SecureLogin.

-284 BROKER_NO_TERMINAL_TYPE_DEFINED

Possible Cause: The tlaunch.ini file contains an error. The terminal type for the emulator 
has not been defined.

Action: Using Terminal Launcher, specify a terminal type for the emulator.

-290 BROKER_FILE_LOAD_FAILED

Possible Cause: You don’t have enough rights to convert an earlier tlaunch.ini file to a later 
format, read an earlier tlaunch.ini file, or create a new tlaunch.ini file.

Action: The network administrator must assign necessary rights.

-349 BROKER_UNABLE_TO_FIND_SESSION_FILE

Possible Cause: Terminal Launcher could not find a session file for an emulator.

Action: Configure Terminal Launcher to have the correct path to the file for the 
emulator session.

-356 BROKER_INVALID_CHARACTER_FOUND_IN_STARTUP_ID_LIST

Possible Cause: For generic emulators, you specify the startup control ID. A comma must 
separate a list of numbers. You have used a character other than a comma.

Action: Remove unacceptable characters.

-373 BROKER_HLLAPI_CONNECT_FAILED

Possible Cause: Terminal Launcher could not find the function name and was therefore unable 
to connect to the emulator. The function name is probably wrong.

Action: Make sure that the emulator has HLLAPI enabled.

-380 BROKER_HLLAPI_NOT_CONNECTED_TO_PS

Possible Cause: You haven’t configured your emulator for an HLLAPI session. Terminal 
Launcher tried to use a HLLAPI function. However, the HLLAPI DLL is not 
connected to the emulator presentation space. 

Action:  Make sure that Terminal Launcher is set up correctly with the emulator.

-381 BROKER_HLLAPI_SPECIFYING_PARAMETERS_ERROR

Possible Cause: Incorrect parameters were given to a command that uses a HLLAPI function.
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Action: Contact Novell Technical Services.

-382 BROKER_HLLAPI_INVALID_PS_POSITION

Possible Cause: Terminal Launcher was able to initialize the emulator but was unable to read 
the contents of the screen. An attempt was made to move the cursor or read 
text from an invalid (out of bounds) position on the emulator presentation 
space. 

Action: Correct the positioning parameter in the script. 

-383 BROKER_HLLAPI_SYSTEM_ERROR

Possible Cause: Terminal Launcher is not configured correctly for the emulator.

Action: Make sure that Terminal Launcher is set up correctly with the emulator and 
that the emulator correctly supports HLLAPI.

-384 BROKER_HLLAPI_PS_BUSY_ERROR

Possible Cause: A HLLAPI function is being called while the emulator presentation space is 
unavailable. 

Action: Make sure that the emulator is not being used by other HLLAPI applications.

-385 BROKER_HLLAPI_INPUT_REJECTED

Possible Cause: The emulator rejected an attempt to input data into the emulator presentation 
space. 

Action: Make sure that the emulator presentation space is not locked.

-386 BROKER_HLLAPI_ERROR_QUERYING_SESSIONS

Possible Cause: SecureLogin is unable to query available HLLAPI sessions. 

Action: Make sure that Terminal Launcher is set up correctly with the emulator.
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