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About This Guide

This guide steps you through the following tasks: 

1. Setting up Novell Filr with test users and data on a Windows/Active Directory network. 
2. Briefly exploring Novell Filr administration and user functionality. 

A lab network is the assumed target environment, but the instructions can be adapted for installing 
Filr on a production network if desired. 

 Chapter 1, “Hands-on Evaluation Options,” on page 7
 Chapter 2, “Hands-on System Requirements,” on page 9
 Chapter 3, “Downloading Filr Software,” on page 11
 Chapter 4, “Creating Test Users,” on page 13
 Chapter 5, “Preparing Folders and Files,” on page 17
 Chapter 6, “Deploying and Configuring the Filr Appliance,” on page 41
 Chapter 7, “Administering Filr,” on page 49
 Chapter 8, “Using Filr,” on page 85
 Appendix A, “Documentation Updates,” on page 123

Audience

This guide is for administrators of Windows/Active Directory networks who want to evaluate Novell 
Filr.

Feedback

We want to hear your comments and suggestions about this guide and the other Filr documentation. 
Please use the comment on this topic link at the bottom of each page of the online documentation.

Documentation Updates

For the most recent version of this guide, access it on the web (http://www.novell.com/
documentation/novell-filr1/filr1_hands-on_w/data/bookinfo.html).

Additional Documentation

For additional Novell Filr documentation, see the Filr Documentation web page  (http://
www.novell.com/documentation/novell-filr1).
About This Guide 5
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1 1Hands-on Evaluation Options

You have two options for evaluating Novell Filr in a Windows AD environment:

 On the Novell Online Demonstration System (NODS)
 On your own network

Novell Online Demonstration System (NODS)

Figure 1-1   Evaluating Filr on the Novell’s Online Demo System

Novell hosts the Filr hands-on VMs on the Novell Online Demonstration System (NODS). 

If you are interested, go to the Novell.com How to Buy page (http://www.novell.com/products/
howtobuy.html) and request that a Novell Sales Representative contact you.

If you are working on NODS, start with Section 6.1, “If You Are Evaluating Filr on NODS,” on 
page 41.

Your Own Network—Choosing a Deployment Type

To evaluate Filr on your network, you must choose a deployment type.

 Small Deployment: Might be your best option if 
 Your interest in Filr is casual.
 You want to invest minimal time and effort. 

 Large Deployment: Definitely your best option if
 You might want to deploy Filr inside your organization.
 You want to investigate what that requires.

WinWin

win2008
VM

filr-win
VM

win7-win
VM

Users

After completing 
the Administrative Tasks

Evaluate the End User Experience

WinWin

Set Up Sharing

Set Up Net Folders

Set Up Personal Storage

Sychronize AD Users

Deploy Filr

Begin with 
Section 6.1 - “If You Are

Evaluating Filr on NODS”

Novell Sales
Representative

Novell.com/buy

Contact
Novell Sales
Hands-on Evaluation Options 7
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 Detailed comparison of Small and Large Deployment Types 

 This Guide Covers a Small Deployment: Because the purpose of this guide is to provide a 
simple hands-on experience, it only covers a small Filr deployment. If you want to set up a large 
deployment for the exercises, see the Quick Start: Filr Hands-on for Windows.

Continue with Chapter 2, “Hands-on System Requirements,” on page 9.

Small Deployment Large Deployment

Production 
Capabilities 

 Designed for evaluation 
environments. Not recommended 
for any but the smallest production 
environments.

 Supports all production 
environments.

Capacity and Scale  Capacity is fixed because it 
cannot be upgraded to a large 
deployment.

 Can “grow” to include multiple, 
clustered Filr appliances.

Software Required  Requires downloading two files: 

 A zip file that contains the 
exercise files

 Filr appliance software 

 Requires downloading four files:

 A zip file that contains the 
exercise files

 Filr appliance software 

 Search appliance software

 MySQL appliance software 
(unless using an existing 
SQL database)

Deployment Effort 
Required 

 Offers a streamlined, quick 
installation and configuration of 
Filr that is documented in this 
guide.

 Test user creation and test file and 
folder setup are the same as a 
large deployment.

 Requires a more involved 
installation and configuration of 
Filr that is summarized in Quick 
Start: Filr Hands-on for Windows.

 Test user creation and test file 
and folder setup are the same as 
a small deployment.

Integration with 
Existing Systems 

 Cannot leverage an existing 
MySQL database (all functionality 
is contained within the single 
appliance).

 Can leverage an existing MySQL 
or Microsoft SQL database in 
place of the MySQL appliance 
provided with Filr.
8 Filr 1.1 Hands-on Guide for Windows
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2 2Hands-on System Requirements

To set up Filr for the hands-on exercises, ensure that your system meets the requirements shown in 
Table 2-1.

Table 2-1   Small Deployment System Requirements

Item Details

A Windows 2003 R2, 2008 R2, or 2012 R2 server that is attached to an 
Active Directory domain

Administrative rights on the server

Software for the Filr appliance and the hands-on exercise files (see 
Chapter 3, “Downloading Filr Software,” on page 11)

One of the three virtualization platforms listed in “Filr Server Requirements” in 
the Novell Filr 1.1 Installation and Configuration Guide:

 Hyper-V

 VMware

 Xen

The virtualization server should have at least the following resources 
available for the Filr virtual machines:

 12 GB RAM

 125 GB free hard drive space

One IP address on the Active Directory domain network, including:

 DNS host name

 The subnet mask

 The primary gateway IP address

 A DNS server IP address

Two Web-based email addresses for receiving invitations and notifications

w
Windows Server

Filr Software

.zip

Exercise Files/Folders

Virtualization Server

Filr

One IP Address on
Your network

my-email1@example.com

my-email2@example.com

Two Email Addresses
Hands-on System Requirements 9

http://www.novell.com/documentation/novell-filr-1-1/pdfdoc/filr-1-1_inst/filr-1-1_inst.pdf#birvoo9
http://www.novell.com/documentation/novell-filr-1-1/pdfdoc/filr-1-1_inst/filr-1-1_inst.pdf#birvoo9


A Windows workstation for administering the appliances and testing the Filr 
Windows application:

 Enterprise-level (non-home) version of Windows 7 or Windows 8

 Joined to your Active Directory domain

 Mozilla Firefox 9, Mozilla Firefox 10, Microsoft Internet Explorer 8, or 
Microsoft Internet Explorer 9 for configuring and managing the 
appliance after the initial setup

 Microsoft Office or LibreOffice

 The latest Java Runtime Environment (JRE) from Java.com

Wireless connectivity on your network

At least one mobile device (iOS 5 or later or Android 2.3 or later) that is 
capable of connecting to your network’s wireless connection

Item Details

Windows Workstation

Wireless Connectivity

Mobile Devices
10 Filr 1.1 Hands-on Guide for Windows



3 3Downloading Filr Software

1 If you don’t already have a Novell account, register for one on the Novell website (https://
secure-www.novell.com/selfreg/jsp/createAccount.jsp?).

2 Access the Novell Downloads website (http://download.novell.com).
3 Do a keyword search for Novell Filr.

4 In the Results section, click the Novell Filr Evaluation Download button.

5 Continue the download process until you have successfully downloaded the following: 
 The Filr-Exercise-Folders.zip file
 The file for your virtualization platform:

6 Continue with Chapter 4, “Creating Test Users,” on page 13. 

VMware Filr.x86_64-version.ovf.zip

Hyper-V Filr.x86_64-version.vhd.zip

Xen Filr.x86_64-version.xen.tar
Downloading Filr Software 11
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4 4Creating Test Users

For information about users and groups in Filr, see “Users and Groups with Filr” in the How Filr 
Works–Overview Guide.

The tasks in this guide involve test users that you create in a separate test container.

1 Create an ou container named testusers in your AD domain.
Creating Test Users 13
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TIP: Locating the container at the top of the domain isn’t required, but it makes the path shorter 
during the LDAP import.
The use of a separate container simplifies the LDAP import process and the removal of users 
when your evaluation concludes.

2 Create the users listed in Table 4-1 in the testusers container and assign them passwords as 
indicated in the table and shown in the screen shots that follow.

Table 4-1   Test Users to Create

 If the simple passwords don’t meet your password policy requirements, specify passwords 
that do.

 Using the same password for all users simplifies the evaluation test process.
 Using the “administrative” password for the filrproxyuser user highlights its role as a Filr 

system user.

IMPORTANT: Ensure that you deselect User must change password at next login as shown. 

First 
Name

Last Name User Logon 
Name

Role in Organization Example 
Password

Home 
Folder

A Red ared Development Supervisor filrrocks Yes

A Pink apink Developer filrrocks No

A Blue ablue IT Supervisor filrrocks Yes

A Green agreen Network Technician filrrocks No

A Yellow ayellow Marketing Supervisor filrrocks Yes

A Orange aorange Marketing Administrative Assistant filrrocks No

A Black ablack Director of Sales filrrocks Yes

A Gray agray Sales Representative filrrocks No

Specify only the Full 
Name as filrproxyuser

filrproxyuser n/a novellfilr No
14 Filr 1.1 Hands-on Guide for Windows
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3 Ensure that you create all of the users.

4 Continue with Chapter 5, “Preparing Folders and Files,” on page 17.
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5 5Preparing Folders and Files

Figure 5-1 illustrates the folders and files that are contained in the zip that you downloaded in 
Chapter 3, “Downloading Filr Software,” on page 11.

Figure 5-1   Hands-on Files and Folders

 Section 5.1, “Unzipping the Exercise Folders and Files,” on page 18
 Section 5.2, “Setting Up the Home_Folders Share,” on page 19
 Section 5.3, “Assigning Home Folders,” on page 26
 Section 5.4, “Setting Up the Other Hands-on Exercise Folders and Files,” on page 28

Drive C:

Your Windows Server

Sales **Mrktg **

personnel

2014.xls

reviews ***

salaries ***

mpink

2013.doc

projects ***

current

future

abc-requ.doc

xyz-requ.doc

Novell_Filr.pdf

quick_starts ***

advertising

filr_flyer.pdf

brochures ***

revenue

2014.xls

projections ***

quotas ***

2013.xls

training

***  These blue folders become Net Folders with the implementation of Filr. 

Dev ** IS **

w

ablack ****

Home_Folders **

Filr Exercise Folders

Hands-on_Filr-Windows.zip *

download
.novell
.com

ablue ****

ared ****

ayellow ****

****  These darker yellow folders are created by Windows for the users that you create. 

*  Folders and files are downloaded in the .zip file.

**  You create Windows Shares for these. Then later you designate 
them as Net Folder Servers.
Preparing Folders and Files 17



5.1 Unzipping the Exercise Folders and Files
1 Copy the Filr-Exercise-Folders.zip file that you downloaded in Chapter 3, “Downloading 

Filr Software,” on page 11, to Local Disk (C:) on your Windows server.

2 Right-click the zip file, then select Extract All.

3 Change the extraction path to c:\, then click Extract.
18 Filr 1.1 Hands-on Guide for Windows



4 Double-click the extracted Filr-Exercise-Folders folder to reveal the five directories used in the 
exercises that follow.

5 Continue with Setting Up the Home_Folders Share.

5.2 Setting Up the Home_Folders Share
 Section 5.2.1, “Configuring Home_Folders Share Permissions,” on page 19
 Section 5.2.2, “Configuring Home_Folders NTFS Permissions,” on page 23

5.2.1 Configuring Home_Folders Share Permissions

1 On the Windows server, click the Windows Explorer icon .
2 Navigate to the Home_Folders folder that you downloaded and extracted in Section 5.1, 

“Unzipping the Exercise Folders and Files,” on page 18.

3 Share Home_Folders by doing the following:
3a Right-click the folder.
3b Click Properties.
Preparing Folders and Files 19



3c Click the Sharing tab, then click Advanced Sharing.

3d Select the Share this folder option, name the share Home_Folders$, then click Permissions.
As you probably know, the dollar sign ($) hides the folder from users browsing the 
network.
20 Filr 1.1 Hands-on Guide for Windows



4 Configure group permissions by doing the following:
4a Click Remove to remove access by the Everyone group.

4b Click Add.

4c In the Enter the object names to select field, type Domain Users, then click Check Names.
Preparing Folders and Files 21



4d Click OK.

4e Under Permissions for Domain Users, Allow full control, then click OK > OK.

4f Continue with Configuring Home_Folders NTFS Permissions.
22 Filr 1.1 Hands-on Guide for Windows



5.2.2 Configuring Home_Folders NTFS Permissions

1 Configure file permissions by doing the following:
1a Click the Security tab, then click Advanced.

1b Click Change Permissions.

1c Deselect Include inheritable permissions from this object’s parent, then on the warning, click 
Add.
Preparing Folders and Files 23



1d In the Permission entries list, Shift-click to select the two Users entries, then click Remove.

1e Click Add.

1f Type filrproxyuser, then click Check Names.
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1g Click OK.

1h Allow full control, then click OK > OK > OK > Close.

2 Continue with Assigning Home Folders.
Preparing Folders and Files 25



5.3 Assigning Home Folders
1 In Administrative Tools > Active Directory Users and Computers, right-click A Black, then select 

Properties.

2 Click the Profile tab.

3 Under Home folder, select Connect, then click the Connect drop-down list and select H:.
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4 For the first user, in the To field, type the full UNC path to the HOME_Folders share on your 
Windows server, followed by %username%. 
For example, the share path on the Windows server used for the development of this guide is 
\\Win2008.filr-lab.local\Home_Folders$\%username%.

5 Select the string and copy it to the clipboard by using Ctrl+C.
For the second and subsequent users, you can use Ctrl+V to paste the string into the To field.

6 Click OK.
7 Repeat from Step 1 for each of the following users:

 A Blue
 A Red
 A Yellow

8 After configuring the home folders indicated, verify that the home folders have been created by 
accessing the Home_Folders folder in Windows Explorer.
Preparing Folders and Files 27



9 Continue with Setting Up the Other Hands-on Exercise Folders and Files.

5.4 Setting Up the Other Hands-on Exercise Folders and Files
 Section 5.4.1, “Creating Shares and Changing Share Permissions,” on page 28
 Section 5.4.2, “Changing the NTFS Permissions,” on page 33

5.4.1 Creating Shares and Changing Share Permissions

Table 5-1 lists the rest of the Filr exercise folder names and the users to assign full share permissions.

Table 5-1   Share Permission Assignments

Create shares and assign share access by doing the following for each folder listed.

1 In Windows Explorer, right-click one of the four folders in Table 5-1, starting with Dev, then click 
Properties.

Folder Name Users to Assign Full Share Permissions

Dev  ared

 filrproxyuser

IS  ablue

 filrproxyuser

Mrktg  ayellow

 filrproxyuser

Sales  ablack

 filrproxyuser
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2 Click the Sharing tab, then click Advanced Sharing.

3 Select the Share this folder option, then click Permissions.
Preparing Folders and Files 29



4 Click Remove to remove access by the Everyone group.

5 Click Add.
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6 In the Enter the object names to select field, type the users listed in the second column of Table 5-1 
on page 28, separated by a semicolon.
For example, for the Dev folder, type ared;filrproxyuser, then click Check Names to validate 
your entries.

7 Click OK.

8 With Filr Proxyuser selected, under Permissions for Filr Proxyuser > Full Control, select Allow.
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9 Select the other user and assign it Full Control as well.

10 Click OK > OK > Close.
11 Right-click the next folder (skipping Home_Folders), then repeat from Step 1 until all of the 

folders have been shared and secured.
12 Continue with Changing the NTFS Permissions.
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5.4.2 Changing the NTFS Permissions

Table 5-2 lists the Filr exercise folder names and the users to assign full NTFS permissions.

Table 5-2   NTFS Permission Assignments

Adjust NTFS permissions to the Filr_Exercise_Folders folder by doing the following:

1 In Windows Explorer, right-click Filr_Exercise_Folders and select Properties.

2 Click the Security tab, then click Advanced.

Folder Name Users to Assign Full NTFS Permissions

Filr Exercise Folders filrproxyuser

Dev ared

IS ablue

Mrktg ayellow

Sales ablack
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3 Click Change Permissions.

4 Deselect Include inheritable permissions from this object’s parent, then click Add.
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5 In the Permission entries list, select the Users entries, then click Remove.

6 Click Add.
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7 Type filrproxyuser, then click Check Names.

8 Click OK.
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9 Allow full control, then click OK > OK > OK > OK.

10 Double-click Filr-Exercise-Folders.

11 Right-click the Dev folder listed in the right frame, then select Properties.
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12 Click the Security tab, then click Edit.

13 Click Add.
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14 Referring to Table 5-2 on page 33, type the user (object name) to assign full permissions to the 
directory (ared is for Dev), then click Check Names.

15 Click OK.
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16 Allow full control, then click OK > OK.

17 Right-click the next folder name listed in Table 5-2 on page 33, click Properties, then repeat from 
Step 12 on page 38 until full rights have been assigned as indicated in the table.
When all of the folders have been assigned, continue with Chapter 6, “Deploying and 
Configuring the Filr Appliance,” on page 41.
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6 6Deploying and Configuring the Filr 
Appliance

 Section 6.1, “If You Are Evaluating Filr on NODS,” on page 41
 Section 6.2, “If You Are Evaluating Filr on Your Own Network,” on page 41

6.1 If You Are Evaluating Filr on NODS
Start the pre-configured virtual appliances on Novell Online Demonstration System (NODS) as 
follows: 

1 Click the win2008 tab and power it on.
This is the Windows AD server and provides DNS services for the exercises.

2 When the Windows server is running, log in as user Administrator with password 
novellfilr.

3 Click the win7-win tab and power on the exercise workstation VM. 
4 Log in as user admin with password novellfilr.
5 Click the filr-win VM and power it on.

The Filr appliance is automatically configured with settings found in two files in the 
filr_win_h-o-autoinst.iso image file: 
 vaauto.conf: Sets the passwords, network configuration, disk assignments, and so on.
 appliance.conf: Configures the appliance as an all-in-one, “small deployment” installation, 

and sets up communications between the Filr and MySQL servers running in the appliance.
For more information on automatically installing Filr appliances, see “Installing Filr in Silent 
Mode” in the Novell Filr 1.1 Installation and Configuration Guide.

6 When the filr-win login: terminal prompt displays on the Filr console, continue with 
Chapter 7, “Administering Filr,” on page 49.

6.2 If You Are Evaluating Filr on Your Own Network
 Section 6.2.1, “Deploying Filr on Your Network,” on page 41
 Section 6.2.2, “Configuring the Filr Appliance,” on page 45

6.2.1 Deploying Filr on Your Network

IMPORTANT: The instructions in this section assume that Filr is being deployed on a VMware 
server. 
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If you are deploying Filr on Hyper-V, follow the instructions in “Hyper-V Configuration” in the 
Novell Filr 1.1 Installation and Configuration Guide to the point that you power on the appliance. Then 
resume these instructions at Step 6 on page 43.

If you are deploying Filr on Xen, follow the instructions in “Xen Configuration” in the Novell Filr 1.1 
Installation and Configuration Guide to the point that you power on the appliance. Then resume these 
instructions at Step 6 on page 43.

1 On a workstation with the vSphere client installed, extract the Filr.x86_64-version.ovf.zip 
file that you downloaded in Chapter 3, “Downloading Filr Software,” on page 11 until you have 
a folder containing three files with .mf, .ovf, and .vmdk extensions.

2 Using the vSphere client, attach to your VMware ESX server, then click File > Deploy OVF 
Template.

3 Browse to and open the Filr .ovf file, then proceed through the various dialogs as you normally 
would until the virtual machine is deployed.

4 Edit the virtual machine settings and add a 20 GB hard disk.
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5 Repeat Step 4 and add a second 20 GB hard disk.
6 After the hard disks have been added, click Power on the virtual machine.

7 After the appliance starts, accept the license agreement. 
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8 Complete the initial configuration settings, substituting the IP address and other settings that 
you identified in Chapter 2, “Hands-on System Requirements,” on page 9 for the Filr appliance 
on your network.

IMPORTANT: Ensure that the Time Zone settings match the settings of your Windows 
environment.

For example, the following screen shows the IP addresses and the other information that was 
used for the Filr appliance that was deployed in a private network when this guide was 
developed.
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9 Proceed through the screens, accepting the defaults, until the configuration process completes.

10 Continue with Configuring the Filr Appliance.

6.2.2 Configuring the Filr Appliance

1 In your management browser, enter the following URL: https://Filr-appliance-IP-
address:9443.

2 Click through the security warnings and accept the certificate if needed. 
3 Log in with Username: vaadmin and the password you set in Step 8 on page 44.
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4 Click the Novell Appliance Configuration icon.

5 Ensure that Small Deployment is selected, then click Next.

6 Specify and confirm novellfilr as the root password.
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7 Click Finish.

8 Skip to Chapter 7, “Administering Filr,” on page 49.
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7 7Administering Filr

The Filr administration exercises covered in this section are summarized in the following graphic.

NOTE: If you want the ability to repeat the exercises that follow, consider taking a snapshot of the 
Filr VMs before you begin. That way you can always restore the VMs to their original states without 
risking ripple effects from previous steps that you have completed.

This section guides you through the following tasks:

 Section 7.1, “Securing LDAP Communications between Filr and Active Directory,” on page 49
 Section 7.2, “Synchronizing LDAP Users,” on page 57
 Section 7.3, “Setting Up Users’ My Files Folders,” on page 65
 Section 7.4, “Enabling Sharing,” on page 66
 Section 7.5, “Setting Up Net Folders,” on page 68
 Section 7.6, “Setting Guest Access,” on page 79
 Section 7.7, “Allowing the Desktop Application to Be Deployed,” on page 80
 Section 7.8, “(Optional) Setting Up Email Communication with the Filr VM,” on page 81

7.1 Securing LDAP Communications between Filr and Active 
Directory

IMPORTANT: On NODS, all administrative passwords are novellfilr.

1 Generate a self-signed certificate for Active Directory.
1a On the Windows server, click Start > Run, then enter mmc. 

Filr
Virtual Appliance

Windows Server
Virtual Machine

1. Secure LDAP Communication

2. Sychronize Active Directory Users

3. Set Up Personal Storage

4. Set Up Net Folders

5. Set Up Sharing

My Files

NetFolder

Shared by MeShared with Me

Filr UsersWinWin
Home Folders

Share Name

AD Users
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1b In MMC, type Ctrl+M.
1c In the Add or Remove Snap-ins dialog, select the Internet Information Services (IIS) Manager 

snap-in. 
If the snap-in is not installed on your Windows server, install it. 

1d With IIS selected, click Add, then click OK.

1e In the left frame, click Internet Information Services, then click a Windows server that Filr can 
connect to for synchronizing the test users that you created in Chapter 4, “Creating Test 
Users,” on page 13.

1f In the Filter list, scroll down to Server Certificates and double-click the icon.
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1g In the Actions list (on the right), click Create Self-Signed Certificate.

1h Name the certificate with a name you can remember, such as the server name, then click 
OK.

1i Type Ctrl+M, select the Certificates plug-in, then click Add.

1j Select Computer account, then click Next.
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1k Click Finish.

1l In the Snap-ins dialog, click OK.
If you get a plug-in error, click Cancel.

1m In MMC, expand the Certificates plug-in, expand Personal, then click Certificates.

1n Right-click the certificate you created, select All Tasks, then click Export....
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1o In the Certificate Export wizard, click Next.

1p Ensure that No, do not export the private key is selected, then click Next.

1q Ensure that DER encoded binary is selected, then click Next.
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1r Name the certificate, then click Next.

1s Click Finish > OK.

By default, the certificate is saved in C:\Users\Your-User-Name.
On NODS, the directory is C:\Users\Administrator.

2 On the Windows server, open a browser and import the server’s certificate into the Filr 
appliance’s Java Keystore:
2a In the Windows server browser, launch the Filr Console through the following URL:

https://Appliance_IP_Address:9443

For example, on NODS this is
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https://172.17.2.112:9443

2b Click through all of the security warnings, add certificates, etc., here and later, and verify 
that you want to access the server.

2c Log in as vaadmin with the password novellfilr.

2d Click the Appliance System Configuration icon.

If you have accessed the console previously, you might need to click the Home link in the 
upper-right corner to see the icon.

2e Click the Digital Certificates icon.

2f Click File > Import > Trusted Certificate.
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2g Browse to the certificate file that you saved in Step 1s on page 54, then click Open.

2h Click OK > OK.

2i Click Close.

2j Click Reboot > OK > OK.
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2k Close the browser on the Windows server.

As soon as the Filr appliance restarts, both the Windows server and Filr are prepared for the exercises 
in Section 7.2, “Synchronizing LDAP Users,” on page 57.

7.2 Synchronizing LDAP Users
In Section 4, “Creating Test Users,” on page 13, you populated Active Directory with the users shown 
in Figure 7-1. (For NODS, the users already exist on the Win2008 server.)

Figure 7-1   Users Created for the Filr Exercises

You import AD users to Filr by setting up LDAP synchronization with Active Directory.

1 Ensure that the Filr appliance VM has restarted.
2 Open a browser on your exercise workstation (the win7-win VMm on NODS) and access Filr 

through the following URL:
https://Appliance_IP_Address:8443

For example, on NODS this is
https://172.17.2.112:8443

3 If prompted, accept and trust the certificate.
4 Sign in as User: admin with Password: admin.
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5 When prompted, change the password to novellfilr.

6 Click admin (upper right), then select Administration Console.

7 In the left navigation panel under System, click LDAP.
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8 Click Add.

9 Ensure that the Server Information tab is selected.

10 Enter the information to connect Filr with your Windows server.

Field Name Value to Enter

LDAP Server URL ldaps://windows-server-IP-address

On NODS this is 

ldaps://172.17.2.117 or ldaps://win2008.filr-lab.local

User DN IMPORTANT: This is the distinguished name of an Active Directory user 
who has sufficient rights to access the information for the test users that 
you created in Chapter 4, “Creating Test Users,” on page 13. For example, 
it could be the user name that you used for that task.

TIP: If you aren’t certain of the syntax, open a terminal prompt on the 
server and enter the dsquery user command. 

On NODS this is:

cn=Administrator,cn=users,dc=filr-lab,dc=local.

Password The password of the user above 

On NODS this is novellfilr.

Directory Type Active Directory
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For example, the NODS LDAP server information is reflected in the following screen shot.

11 Select the Users tab, then click Add.

LDAP Unique Identifier objectGUID

LDAP Attribute for Filr sAMAccountName

Field Name Value to Enter
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12 Click the LDAP browse icon.

13 Browse to testusers and select it.
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14 Click OK.

The testusers container is added, so click OK.
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15 Select the Synchronization Schedule tab, then select the following options: 
 Enable Schedule
 Every Day
 Repeat Every 0.25 Hours

16 Click the LDAP Servers tab, click the Sync All button, then click OK to save the configuration.

The nine users in the testusers container are added.
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17 Click Close > OK.
18 The proxy user is among those added to Filr. However, it is a system-only user.

Remove the filrproxyuser by doing the following:
18a In the left frame, click Users.

18b Select filrproxyuser.
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18c Click Delete, then select Delete user workspaces > Delete user objects > OK.

19 Click Close.
20 Do not close the Administration Console. Continue with Section 7.3, “Setting Up Users’ My Files 

Folders,” on page 65.

For complete instructions on using Filr LDAP synchronization, see “Synchronizing Users and 
Groups from an LDAP Directory,” in the Novell Filr 1.1 Administration Guide.

7.3 Setting Up Users’ My Files Folders
1 Some of the LDAP users that you imported need personal storage space on the Filr appliance 

itself. 
Under Management, click Users, then select the check boxes next to the names of the following 
users:
 A Black
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 A Green
 A Orange
 A Pink

2 Click More > Enable Personal Storage.

3 Click Close, then continue with Enabling Sharing.

7.4 Enabling Sharing
Before granting sharing rights to users, you must enable sharing for the Filr site.

1 Under System, click Share Settings.

2 In the User or Group field, start to type all, then select All Internal Users.
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3 Click Re-share items, Share with the public, and Share using Filr Link, then click OK.

This sets the maximum sharing rights that can be granted anywhere on the system. Re-sharing 
and public access are only available if they are actually enabled on specific Net Folders.
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4 Click OK.

7.5 Setting Up Net Folders
 Section 7.5.1, “Specifying Net Folder Servers,” on page 68
 Section 7.5.2, “Creating Net Folders and Setting Net Folder Access and Sharing Rights,” on 

page 75

7.5.1 Specifying Net Folder Servers

Net Folder Servers are connections to shares on Windows file servers. You can set up as many 
connections to each file server as needed. For the hands-on lab, you create one Net Folder Server for 
each Share defined in “Setting Up the Other Hands-on Exercise Folders and Files” on page 28.

 “Configuring the Home_Folders Net Folder Server” on page 68
 “Configuring the Other Net Folder Servers” on page 72

Configuring the Home_Folders Net Folder Server

1 Under Management, click Net Folder Servers.
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2 Four of the users that you synchronized with the Windows server have Home directories on the 
server. Therefore, the Net Folder Server for the Home_Folder$ share on your Windows server 
(for example, on NODS this is Win2008_Folders$) is already created and listed.

IMPORTANT: Although Home folders are technically like other Net Folders in Filr, their 
primary role is personal storage. Therefore, they are accessed through My Files rather than 
through Net Folders.

3 The Home Net Folder Server is marked with an icon that indicates that its configuration needs 
attention.
In the Name column, click the Win2008-Home_Folders$ server link.

4 Click the Server Type drop-down list, then select Microsoft Windows.

5 One valuable Filr feature is the ability to share files and folders with others who do not have 
native file system rights. 
This sharing functionality is provided through Net Folder proxy users. However, the “Home” 
Net Folder Server has no Net Folder proxy user configured. That is why the yellow icon is 
displayed.
You granted the Net Folder proxy user (filrproxyuser) full control of the Home_Folders$ share 
in Step 2 on page 14. You simply need to make Filr aware of that assignment.
5a Click the Authentication tab, then click the LDAP browser icon.
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5b Open the testusers container, then select the Filr proxy user.

5c Do the following in the Proxy Password field:
 Remove any spaces from the proxy user name.

This is only an issue if you have specified a first and last name for your Filr proxy user.
  In the Proxy Password field, type the password specified for the proxy user.

On NODS, the password is novellfilr.
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 Click Test Connection.

6 When you click Test Connection, you should see a message that the test succeeded.
Click OK.

7 Click the Synchronization Schedule tab, then select 
 Enable Scheduled Synchronization
 Every Day
 Repeat every 0.25 hours

Then click OK.

8 Click OK > OK.
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The warning icon is removed.

Configuring the Other Net Folder Servers

1 To add Net Folder Servers for the other shares on the Windows server, click Add.

2 Use the information in Table 7-1 as you add a Net Folder server for each share.
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Table 7-1   Net Folder Servers to Add

2a In the Configuration tab dialog, type the Name and Server Path for the Share, starting with 
Dev.

Share Field Text

Dev Name Development

Server Path \\windows-server-IP-address\Dev

On NODS: \\172.17.2.117\Dev

Proxy Name filrproxyuser DN

On NODS: cn=filrproxyuser,ou=testusers,dc=filr-
lab,dc=local

filrproxyuser Password For example: novellfilr

IS Name IS

Server Path \\windows-server-IP-address\IS

On NODS: \\172.17.2.117\IS

Proxy Name filrproxyuser DN

On NODS: cn=filrproxyuser,ou=testusers,dc=filr-
lab,dc=local

Proxy Password For example: novellfilr

Mrktg Name Marketing

Server Path \\windows-server-IP-address\Mrktg

On NODS: \\172.17.2.117\Mrktg

Proxy Name filrproxyuser DN

On NODS: cn=filrproxyuser,ou=testusers,dc=filr-
lab,dc=local

Proxy Password For example: novellfilr

Sales Name Sales

Server Path \\windows-server-IP-address\Sales

On NODS: \\172.17.2.117\Sales

Proxy Name filrproxyuser DN

On NODS: cn=filrproxyuser,ou=testusers,dc=filr-
lab,dc=local

Proxy Password For example: novellfilr
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Notice that the Net Folder Server names do not necessarily need to mirror the server and 
share names.

2b Click the Authentication tab, use the LDAP browser to select the filrproxyuser, then type its 
password and click Test Connection.

2c Click OK.

2d Click the Synchronization Schedule tab, then select 
 Enable Scheduled Synchronization
 Every Day
 Repeat every 0.25 hours

Then click OK.
74 Filr 1.1 Hands-on Guide for Windows



2e Repeat from Step 2 to create Net Folder Servers for the IS, Marketing, and Sales shares.
3 Click Sync.

When the sync operation completes, Filr has metadata for each Net Folder Server in its database.
4 Click Close.

5 Continue with Creating Net Folders and Setting Net Folder Access and Sharing Rights.

7.5.2 Creating Net Folders and Setting Net Folder Access and Sharing 
Rights

Net Folders are connections to specific directories on Net Folder Servers. You can set up as many Net 
Folders as needed. You can also specify a separate and independent synchronization schedule for 
each Net Folder.

1 Under Management, click Net Folders.
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2 Create the Net Folders needed for the hands-on exercises.
2a Click Add.

Notice that although the Home_Folders$ share is Net Folder Server and four users have 
Home folders, there are no Net Folders displayed. 
Home folders are displayed and managed under My Files rather than Net Folders.

2b Referring to Table 7-2, in the New Net Folder dialog type a name (starting with reviews). 
Select the appropriate Net Folder Server, type the relative path for the Net Folder, then click 
Test Connection to verify that the information is entered correctly.

Table 7-2   Net Folder Configuration Information

Name Server Relative Path Users with 
Rights to Net 
Folder

Sharing Rights

reviews Development personnel\reviews ared Allow Access

Internal

comp planning Development personnel\salaries ared Allow Access

projects Development projects ared Allow Access

Internal

External

training IS training\quick_starts ablue Allow Access

Internal

Re-share
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2c Click OK. 

2d Select the index and Just-in-Time synchronization options shown below.

cool stuff Marketing advertising\brochures ayellow Allow Access

Internal

External

Public

Share File Link

Re-share

projections Sales revenue\projections ablack Allow Access

Internal

2014 tracking Sales revenue\quotas ablack Allow Access

Internal

Name Server Relative Path Users with 
Rights to Net 
Folder

Sharing Rights
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Although content indexing carries significant processing overhead and should, therefore, 
probably not be applied to all Net Folders, the content used in these exercises is so small 
that the overhead involved with indexing is miniscule. 

2e Click the Rights tab. 
In the User or Group field, begin typing the user listed in the table, then select the correct 
user.

2f In the Grant Rights dialog, set the sharing rights as listed for the folder, then click OK.

2g Click OK.
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2h Click OK, then return to Step 2 for the next Net Folder.

2i When all of the Net Folders have been specified, click Close, then continue with Setting 
Guest Access.

7.6 Setting Guest Access
The hands-on exercises let you access Filr as a user who doesn’t have an account in Filr.

1 Under System, click Web Application.
Administering Filr 79



2 Select Allow Guest access and Guest access is read-only, then click OK.

The read-only option prevents public (guest) users from logging comments. This is generally a 
good idea in light of the risk of “spam” comments. Comments cannot be removed in this version 
of Filr.

3 Continue with Allowing the Desktop Application to Be Deployed.

7.7 Allowing the Desktop Application to Be Deployed
Some of the Filr end user exercises are done through the Desktop Application. To enable the Desktop 
Application to be deployed through the Web application:

1 Under System, click Desktop Application.

2 Select Be deployed > Deploy files contained locally > OK.

3 Continue with (Optional) Setting Up Email Communication with the Filr VM.
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7.8 (Optional) Setting Up Email Communication with the Filr VM
The hands-on exercises leverage two of your personal email addresses:

 One is assigned to user ared for demonstrating Filr’s notification capabilities.
 The other is used for inviting an external user to collaborate on a project.

If you are not interested in email notifications or external sharing as part of the end user exercises, 
you can skip all of the remaining sections and steps in this guide that are marked (Email Only).

If you want to experiment with email notifications that originate from Filr, you must complete the 
following sections:

 Section 7.8.1, “(Email Only) Entering an Email Address for User ared,” on page 81
 Section 7.8.2, “(Email Only) Synchronizing User ared’s Change with Filr,” on page 82

7.8.1 (Email Only) Entering an Email Address for User ared

1 On the Windows server, click Start > Administrative Tools > Active Directory Users and Computers.

2 Click the testusers container, then right-click user ared and select Properties.
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3 Type the email address you have chosen to use with these exercises, for example 
myworkemail@mycompany.com.

4 Click OK, then continue with (Email Only) Synchronizing User ared’s Change with Filr.

7.8.2 (Email Only) Synchronizing User ared’s Change with Filr

1 On the Windows workstation, in the Administration Console under System, click LDAP.
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2 Click Sync All.

ared’s changes are synchronized.

3 Click Close > OK.
4 Continue with Chapter 8, “Using Filr,” on page 85.
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8 8Using Filr

The Filr end user exercises can be summarized as follows:

This section guides you through the following tasks:

 Section 8.1, “Accessing Filr to Do the Filr End User Exercises,” on page 85
 Section 8.2, “Understanding Test Users and Their Roles,” on page 91
 Section 8.3, “Exploring Filr Functionality for End Users,” on page 91

IMPORTANT: On NODS, all administrative passwords are novellfilr; all user passwords are 
filrrocks.

8.1 Accessing Filr to Do the Filr End User Exercises
You need connections to Filr through the following access points to complete the Filr End User 
Exercises:

 A browser
 The Filr Desktop Application
 A mobile device (optional and not applicable on NODS)

 Section 8.1.1, “Connecting to Filr through a Browser and Installing the Filr Desktop 
Application,” on page 86

 Section 8.1.2, “Starting the Filr Desktop Application,” on page 88
 Section 8.1.3, “Installing and Starting a Filr Mobile App (Optional),” on page 90

Windows
Server

FilrYou Access Devices and Methods

WinWin

You use various clients, including 
mobile devices, to access Novell Filr. 

Filr provides access to test folders 
and files on a Windows server.
Using Filr 85



8.1.1 Connecting to Filr through a Browser and Installing the Filr Desktop 
Application

To connect through the browser and install the Filr Desktop Application:

1 If you are continuing from the Administrator exercises, sign out as user Admin, then skip to 
Step 3.

Otherwise, on your exercise workstation, start a browser and access the following URL:
https://Filr-appliance-IP-address:8443

2 If prompted, accept and install the certificate.
3 Sign in as User ID: apink with the password filrrocks.

4 In the upper-right corner, click apink, then select Download Filr Desktop App.
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5 Click the appropriate link for the host workstation. For example, Windows X64 Client.

6 Save the file.

7 After the file is saved, open the saved location, then right-click the file and select Run as 
administrator.
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8 Run the installation, accepting the licenses, rebooting the workstation, and so on until the 
desktop application is installed.
Depending on your download speed, downloading and installing Microsoft .NET can take a 
while.
For additional information, see the applicable Quick Start on the Novell Filr online 
documentation site.

9 Close the browser and continue with Starting the Filr Desktop Application.

8.1.2 Starting the Filr Desktop Application

1 On the Novell Filr welcome screen, click Start.

2 In the Server URL field, type https://Filr-appliance-IP-address:8443, type Username: 
apink and user apink’s Password, then click Next.
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3 Continue through any security warnings.
4 Click Next.

5 Click Next.
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6 Click Finish.

A Filr folder is now available in on the workstation (in Windows Explorer or Macintosh Finder).

8.1.3 Installing and Starting a Filr Mobile App (Optional)

NOTE: On NODS, skip to Section 8.2, “Understanding Test Users and Their Roles,” on page 91.

Filr mobile apps are available as free downloads in the Apple App Store, the Google Play App Store, 
and the Amazon Appstore for Android.

Download and install the Filr mobile app on the mobile device as you would any other device app.
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To access the Filr Mobile App:

1 Start the app in the same way that you start other apps on your mobile device.
2 Log in as Username: ablack.
3 Continue with Understanding Test Users and Their Roles.

8.2 Understanding Test Users and Their Roles
Table 4-1 lists eight users that have been synchronized from the Windows server to Filr.

As you can see, there are differences in their Home Folder and personal storage allocations (third 
column). Most have one or the other, but user ablack has both and user agray has no personal storage. 
We will briefly explore what this means in Section 8.3.1, “My Files—Home Folders and Personal 
Storage,” on page 92.

Notice also that only the manager-level users (ared, ablue, and so on) have file system rights on the 
Windows server (fourth column). Nevertheless, the hands-on exercises require that files be accessed 
by internal and external users who do not have file system rights. We will explore how this is 
accomplished in the “sharing” sections, starting with Section 8.3.2, “Internal Sharing,” on page 98.

Table 8-1   User Roles and Tasks

8.3 Exploring Filr Functionality for End Users
After you have completed the setup and administration instructions in this guide, the Filr VMs and 
your Windows server are ready for the exercises in the following sections:

 Section 8.3.1, “My Files—Home Folders and Personal Storage,” on page 92
 Section 8.3.2, “Internal Sharing,” on page 98
 Section 8.3.3, “(Email Only) External Sharing,” on page 106
 Section 8.3.4, “Public Sharing,” on page 114

User Name Role in the FILR-LAB 
organization

Home Folder and Personal 
Storage

File System Rights on the 
Windows Server

ared Development Manager Home folder Full control of Dev share and 
directory

apink Developer Personal None

ablue IT Manager Home folder Full control of IT share and 
directory

agreen Filr Administrator Personal None

ayellow Marketing Manager Home folder Full control of Mrktg share and 
directory

aorange Product Line Manager Personal None

ablack District Manager Home folder

Personal

Full control of Sales share and 
directory

agray Account Manager None
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 Section 8.3.5, “Creating a Filr Group,” on page 117
 Section 8.3.6, “Re-sharing and Searching,” on page 118
 Section 8.3.7, “More Things You Can Try,” on page 120

8.3.1 My Files—Home Folders and Personal Storage

The files and folders that users see when they access My Files are illustrated in Figure 8-1 and 
demonstrated in the steps that follow the figure.

 The top half shows that two storage locations can be assigned to users for their own use—
personal storage on the Filr data disk and/or home storage on a Windows file server.

 The bottom half shows how the assigned storage is displayed in My Files, depending on what a 
user is assigned. 

Figure 8-1   What Filr Users See in My Files Depends on What Is Set Up for Them

In the following steps, take the role and do the steps of the users that are indicated.

1 User ablack is a fan of the Hubble telescope and especially likes this image (http://hubblesite.org/
gallery/wallpaper/pr2007041a). 
On the exercise workstation, open a browser, then click the 1280X1024 link.

My Files

local.txt

Only
Filr Storage

My Files

remote.txt

Only
Home Folder

Home 

My Files

local.txt

Both

remote.txt

Filr Data Disk

local.txt

NTFS
Home Folders

remote.txt

My Files

and
or
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2 Right-click the displayed image, then save it to the desktop.

3 Close the browser.
4 Open Windows Explorer and access user ablack’s home folder by entering the UNC path to the 

folder and logging in as user ablack with the password filrrocks.
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The folder is empty.

5 Drag and drop (copy) the image from the desktop to user ablack’s home folder.

6 Open the web browser, access Filr on port 8443 (https://172.17.2.112:8443) and sign in as user 
ablack.

7 Click MyFiles and notice the folder named Home. This is user ablack’s home folder on the 
Windows server. 
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Refer to Table 4-1 and notice that user ablack has a home Folder and is also assigned personal 
storage. In other words, user ablack is an example of the section labeled “Both” in Figure 8-1. 

8 Open the Home folder. 
The Hubble image file is there as you would expect it to be.

9 Sign out as user ablack.

10 Sign in as User ID: admin.
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11 Access the Administration Console (upper-right corner).

12 Under Management, click Users. 

13 Select A Black, then click More and select Disable Personal Storage.
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14 Sign out as user admin, then sign in as user ablack.
15 Notice that the Home folder has disappeared from user ablack’s My Files folder (the up-arrow 

left of Home has disappeared) and the Hubble image file is now directly listed as a child. 

Because you removed the Personal Storage that was assigned to user ablack, user ablack now fits 
the definition in the section of Table 4-1 that is labeled “Only Home Folder.” (Purging user 
ablack’s personal storage had no effect on the Windows server’s file structure or files.)

16 Click the down-arrow next to the image, then select Share. 

17 In the Share with field, type all, then select All Internal Users.
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18 Click OK.
19 Feel free to explore further if you want to get more experience with Filr’s My Files functionality 

and the role that traditional home folders play in that context. Then continue with Internal 
Sharing.

8.3.2 Internal Sharing

The exercises in this section demonstrate how Novell Filr users can share files with users who are 
internal to your organization. 

 “User ared Initiates User apink’s Annual Review” on page 98
 “User apink Responds to the Annual Review Request” on page 102
 “User ared Approves User apink’s Annual Review” on page 105

User ared Initiates User apink’s Annual Review

User ared needs to complete the annual review for user apink, but user apink doesn’t have file system 
access to the review file (apink_2014.doc). Rather than sending the file in email or assigning user 
apink the required file system trustee rights on the Windows server, ared simply shares the review file 
with user apink and includes Editor privileges. First, however, ared optionally ensures that email 
notifications will be sent when the file changes.

1 Sign in to the Web application as user ared. (This requires that you sign out as user ablack first.)
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2 Click Shared with Me and notice that the image that ablack shared is listed.

IMPORTANT: If you are not experimenting with email notifications, skip to Step 4 and skip all 
subsequent steps that are marked (Email only).

3 (Email only) Click A Red in the upper-right corner, then select View Profile. 

When the profile displays, notice that the email address you configured in Active Directory for 
user ared is listed.
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4 Click Net Folders > reviews > apink.

5 Click the check box for apink_2014.doc, then click the file drop-down arrow  to the right of 
the file and select Share File.

6 In the Share with field, type p, then select A Pink.

7 Select Editor, then click OK
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8 (Email only) Click the check box for apink_2013.doc and the file drop-down arrow again, then 
click Subscribe.

9 (Email only) Expand the Email Only option, then select the email address you entered for user 
ared in Directory and click OK.
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10 Click the comment icon .
11 Add a comment, such as 

Hi pink. 

Will you please edit this with your objectives and achievements and let me know 
when you have finished? 
Thanks. 
red

12 Click Send, then close the Comments dialog.

User apink Responds to the Annual Review Request

1 On the Windows 7 VM desktop in the notifications area, right-click the Filr icon. 
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2 Select Synchronize Now.

3 Select Open Filr folder.

4 Double-click Shared with Me.

5 Right-click apink_2013.doc, then select Open.

The file should open in LibreOffice Writer, assuming the prerequisites are met for the Windows 
workstation.

6 Make a few changes, then save and close the file. 
You can be as verbose or brief as you want.

7 In the Shared with Me folder on the workstation, right-click the file you just edited and select 
Synchronize now.
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8 Sign in to the Web application as user apink

9 Click Shared with Me.

10 Click the drop-down arrow for apink_2013.doc, then click View HTML.

Your changes are reflected in the view.
11 Close the HTML view.
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12 Click the review file’s comment icon, type a comment indicating that the review is ready, then 
click Send and close the comment panel.

13 Continue with User ared Approves User apink’s Annual Review.

User ared Approves User apink’s Annual Review

1 (Email only) In the Windows VM, log in to the email account that you assigned to user ared, open 
the message from filr-admin (it might be in your SPAM folder), then click the Visit Message link.

2 Sign in to the Web application as user ared.
If you accessed it through the email link, the message from user apink is displayed. Otherwise, 
click Shared By Me, then click the message icon for apink’s review document.

3 In the new comment box, type a comment indicating that the review is approved, then click 
Send.
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4 Close the view. 
5 Continue with (Email Only) External Sharing.

8.3.3 (Email Only) External Sharing

The exercises in this section demonstrate how Filr users can share files with users who are external to 
your organization. 

 “About External Users” on page 106
 “User ared Gathers Input for the Next Release” on page 106
 “User opaque Self-Provisions and Responds to the Review Request” on page 109
 “User ared Responds to User opaque’s Input” on page 112

IMPORTANT: Completing the instructions in Section 7.8, “(Optional) Setting Up Email 
Communication with the Filr VM,” on page 81 is required for the exercises in this section.

About External Users

External users are those who receive share invitations through email and subsequently provision 
themselves as system users. They can then log in to the system using the credentials they establish 
with Filr, or they can elect to be authenticated through a Google or Yahoo Open ID account.

For more information about the different kinds of users who can access Filr, see “Users and Groups 
with Filr” in the How Filr Works–Overview Guide.

User ared Gathers Input for the Next Release

User ared managed the ABC product release and is responsible for gathering input for the upcoming 
XYZ product. User ared also wants to invite input from a key partner named M Opaque. Inviting M 
Opaque to participate requires using the second email address mentioned in Chapter 2, “Hands-on 
System Requirements,” on page 9 and further explained in Section 7.8, “(Optional) Setting Up Email 
Communication with the Filr VM,” on page 81.

1 If you aren’t already signed in to the Web application as user ared, do so now.
2 Click Net Folders > projects > current.
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3 Click the check box for abc_reqr.doc, then click the file drop-down arrow  to the right of the 
file and select Share File.

4 Click the envelope icon next to the search field. 

5 In the Share with External Users field, type your second email address, then click the plus sign (+) 
to add the external user.

6 Click OK.
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7 Click the check box for abc_reqr.doc and the file drop-down arrow again, then click Subscribe.

8 Expand the Email only option, then select the email address you entered for user ared and click 
OK.
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9 Click the comment icon  to the right of the down-arrow.
10 Add a comment, such as

This is the requirements doc for our current release.

It's time to gather input for the next release. 
Please log comments to let us know which features we need to include in the 
next release. 
Thank you. 
Then click Send.

11 Close the Comments dialog.
12 Continue with User opaque Self-Provisions and Responds to the Review Request.

User opaque Self-Provisions and Responds to the Review Request

1 Log in to the email account that you used to invite user opaque to participate in the review.
2 Open the message from the email address that you assigned to user ared, then click the 

abc_reqr.doc link.
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3 The Filr registration dialog lets external users register or log in as a guest.
Register as M Opaque by typing First name: M, Last name: Opaque, Password: filrrocks, and Re-
enter password: filrrocks. 
The User ID (email address) cannot be changed.

4 Open the confirmation email, then click Sign in and access shared items.
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5 Type the password that you registered for M Opaque, then click Sign in. 

6 Read the comment from user ared, click the Actions down arrow, then click Subscribe.

7 Click the arrow by Email only, then select M Opaque’s email and click Ok. 
Emails will now be sent to user opaque as others comment on the document or perform other 
actions.

8 Log the following comment, then click Send.
Competing products have had morning coffee functionality for over 18 months 
now.

If the next release doesn't include this, we will be forced to switch.

The comment is included.
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9 Continue with User ared Responds to User opaque’s Input.

User ared Responds to User opaque’s Input

User ared receives notification of user opaque’s comment (you can check ared’s email if you wish) and 
remembers that the requested feature has been discussed. It should already be in the next 
requirements document (xyz_reqr.doc), but ared isn’t certain that it is.

1 Log in to the Web application as user ared.
2 Click Net Folders > projects > future.
3 Click xyz_reqr.doc, then click OK. 

4 Insert the following text before the period:
, and it will make the morning coffee
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5 Save the file to the Desktop, then close LibreOffice.
6 Drag the file from the desktop to the browser.

7 Click Overwrite Files.

8 Send a comment indicating that the file has been updated.
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9 Log a comment for the abc_reqr.doc file that Opaque’s requirement has been included in the 
next version.

10 Continue with Public Sharing.

8.3.4 Public Sharing

User ayellow wants to get the word out about the abc version of the organization’s product and elicits 
the help of user aorange with the effort.

1 Log in to the Web application as User ID: ayellow.
2 Click Net Folders > cool stuff.

3 Click the file drop-down arrow  for abc_flyer.pdf, then select Share File. 
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4 In the Add a user ... field, type o, then select A Orange.

5 Click Public > File Link > OK.

6 Log in as User ID: aorange.
7 Click Shared with Me.

8 Click the action drop-down for the abc_flyer.pdf file, then click Share File.
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9 Click Make Public.

10 Click the link for exposing the public links to the file.

11 Enter one of the URLs in a separate browser window or tab, then click Enter as Guest to see what 
Internet users who access the URL will see.
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12 Continue with Creating a Filr Group.

8.3.5 Creating a Filr Group

1 Log in to the Web application as User ID: admin.
2 Open the Administration Console and under Management click Groups.

3 Type the Name, Title, and Description shown below, then click Edit group membership.

4 Type user names in the User: field and press Enter to add the users listed below to the group, 
then click OK > OK.
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5 Click Close.

6 Continue with Re-sharing and Searching.

8.3.6 Re-sharing and Searching

1 Log in to the Web application as User ID: ablue.
2 In Net Folders, navigate to training > Novell-Filr.pdf, then share the file with the filr_sig group 

with Viewer rights and rights to reshare the file with internal users.
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3 Close the Group Management dialog.

A few days after user ablue shared the file, user apink is talking with user ared in the hallway and 
mentions the Filr quick start.

1 Log in as user ared, then in the search field, type quick and press Enter.
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Because the file is not found, user ared asks user apink to share the file.
2 Log in as user apink and share the file with user ared.

3 Log in as user ared and search for the file again.
The file is listed in the search results window.

8.3.7 More Things You Can Try

There are a few additional files in the other Net Folders that you can experiment with as indicated 
below. You can also experiment with your own files. 
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Activity Type Net Folder File Location Task Descriptions

Planning comp planning 2015.xls 1. User ared opens the file in LibreOffice and plans a 
5.5% increase for user apink’s 2015 salary.

Planning projections fy_2015.xls 1. User ablack shares the file with user agray as a 
viewer and asks whether the goals are realistic.

2. User agray comments that the Q3 estimate is low and 
the Q4 estimate is high. User agray asks that $10,000 
be transferred from Q4 to Q3.

3. User ablack adjusts the Q3 and Q4 estimates, thanks 
user agray, and acknowledges the change.

Reporting quotas fy_2014.xls 1. User ablack shares this file with user agray as an 
Editor and requests that user agray update it with Q4 
actual results.

2. User agray opens the file, enters $110,900, and saves 
the file. 

3. User agray comments that the file is now ready for 
review.
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A ADocumentation Updates

This section summarizes the changes made to the guide since the initial release of Novell Filr 1.1.

October 10, 2014

Section Details

Administrator and User Tasks Minor clarifications and additional details.
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