Novell is now a part of Micro Focus

My Favorites

Close

Please to see your favorites.

Data Migration from Novell NetWare 6.5 to Open Enterprise Linux Server fails with error "Login Denied".

This document (3728366) is provided subject to the disclaimer at the end of this document.

Environment

Novell Open Enterprise Server Linux
Novell Open Enterprise Server NetWare
Novell NetWare 6.5
Novell Consolidation Migration Utility 4.11
Novell LUM
Novell SMS

Situation

Using the Server Consolidation Migration Utility migrating data from Novell NetWare to Novell Open Enterprise Server Linux the migration fails with the following errors:
- 0xfffeffff (fffeffff) An invalid connection handle was passed to SMDR.
- 0xfffdffd7 (fffdffd7) Login Denied.
- Unable to verify novell-sms installed version - //

Resolution

First verify that the latest TSA's are installed on the Novell NetWare servers. At the time of writing this the latest available version prior to Novell NetWare 6.5 Support Pack 6 is TSA5UP19.

Second check that the unique ID of the user that is being used matches the actual common name of the object within e-Directory. The latest LUM module is case sensitive and the authentication will fail if the case does not match. To verify this open the properties of the user object from within ConsoleOne and select the "Other" tab. Expand the "Unique id" option.

The migration utility passes the authentication credentials to the Novell Open Enterprise Server as the name appears in e-Directory ie. if the user name is "Admin" it will pass the name through as"Admin". If the unique ID for this user is "admin" however, the authentication will fail. If the migration is failing because of this, the following should be seen in "/var/log/messages":
sshd[8151]: Invalid user admin from
/usr/sbin/namcd[5621]: searchAndFillPwdStruct_fromNDS: case does not match: [uid=Admin] != [uid=admin]

After resolving the above in some cases you may still receive the following non-critical errors:
"Unable to verify novell-sms installed version, error details: ///sys/scu/installedsmsversion.txt does not exist."

If the installed "novell-sms" module version is the latest available version this error can be ignored and the migration will still complete if continued.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:3728366
  • Creation Date:02-FEB-07
  • Modified Date:27-APR-12
    • NovellNetWare
      Open Enterprise Server
      Server Consolidation and Migration Utility

Did this document solve your problem? Provide Feedback