Environment
Novell iPrint Appliance
Situation
When attempting to upload a Macintosh or Linux printer driver (ppd) from a Windows workstation which has the 5.92 version of the iPrint Client for Windows, the driver fails to upload and the following message is returned:
Check that the Driver Store (idsd) is loaded
Check that the Driver Store (idsd) is loaded
Resolution
Resolution:
Install iPrint Client version 5.94 or later.
Workaround: Use the command line tool iprntcmd from Mac or Linux to upload the driver.
Open a terminal on a Mac machine and type this command:
cn=admin,o=myorg
Install iPrint Client version 5.94 or later.
Workaround: Use the command line tool iprntcmd from Mac or Linux to upload the driver.
Open a terminal on a Mac machine and type this command:
When prompted for authentication, provide an eDirectory user in full LDAP format. Example:Syntax:
iprntcmd -u <ids-hostname or ids-address> <ppd path with or without wildcards>
Example:
iprntcmd -u drvstr-main.mycomp.com /Users/jdoe/Downloads/HPLaserJet8000.ppd
cn=admin,o=myorg
Cause
Novell identified a bug in the 5.92 version of the iPrint Client for Windows. This bug affects the ability to upload printer drivers to the Mac or Linux OS types, and not other OS types.