IPP ERROR 0x1007 (or 0x500) attempting Printer Agent Redirection

  • 7011333
  • 08-Nov-2012
  • 10-Dec-2012

Environment

Novell iPrint for Linux

Situation

IPP Error: 0x1007 is returned when attempting to redirect a printer agent to another.

The following error has also been reported for the same reason:

Request (SERVER_ERROR) - bad status code (0x500) - IPP Error : 0x500

Resolution

iManager -> iPrint  -> Manage Print Manager -> Printer Agent Redirection -> Deleted Printer Agent Redirection

Check the top "Delete" box.  Click Apply.

Note: Not all Deleted printers must be removed.  See the Cause section of this TID.

Cause

This problem is the result of a bug in the iPrint code.  If too many Deleted printers exist in the Print Manager database, this error results.  The number of "too many" has not been determined, however, it has been found in one situation that leaving under 100 Printer Agents in the deleted list caused the error to go away.

Status

Reported to Engineering

Additional Information

Purpose of the Deleted list.
When Printer Agents are deleted from the Print Manager, they are added to the database's deleted list. The deleted list serves two purposes:

  • If workstations have the printer installed to the workstation and the printer exists in the "Deleted" list, the printer will be auto removed from the workstation.
  • If workstations have the printer installed to the workstation and have not be powered on yet (so the printer has yet to be removed from the workstation), the administrator can schedule the deleted printer to be replaced (redirected) with a different printer.