Novell Home

My Favorites

Close

Please to see your favorites.

OES2SP3 and OES11 channels to be upgraded to eDirectory 8.8 SP7

This document (7011599) is provided subject to the disclaimer at the end of this document.

Environment

Novell eDirectory 8.8 SP7 for OES Platforms
Novell Open Enterprise Server 11 (OES 11) Linux
Novell Open Enterprise Server 2 (OES 2) Linux

Situation

In order to continue to provide world class support for our older versions of Open Enterprise Server, Novell will be upgrading the version of eDirectory offered through our OES patch channels.

OES2SP3 and OES11 both shipped with an older version of eDirectory, 8.8 SP6.  This version was released two years ago.  Our current version of eDirectory, 8.8 SP7, which shipped with OES11SP1, provides many additional enhancements and fixes in addition to resolving the latest security vulnerabilities found. 
 
To make eDirectory 8.8 SP7 available to older OES customers as well, this version of eDirectory will be introduced into the OES2SP3 and OES11 channels.  Novell expects this to take place in the April 2013 time frame.
Once eDirectory 8.8 SP7 is introduced to the OES2SP3 and OES11 channels, there will be no further 8.8 SP6 updates for the OES platform.  All future fixes & enhancements will be in 8.8 SP7.

Resolution

Though the eDirectory upgrade is being provided by the channel, the same prerequisites exist as for any upgrade of eDirectory whether on an OES or non-OES platform.  These include:

- Tree health checks
- Server Health checks
- Ensuring NTP time is in synch

These tasks are covered in the Upgrading to OES—Best Practices Guide
Additional information is also available in

To maximize the chances of a successful upgrade, an effort should be made to plan for and deploy the upgrade, especially if this is the first server in the tree to run 8.8 SP7.  For example, the first server to be upgraded from 8.8 SP6 to SP7 should be chosen carefully.  eDirectory 8.8 SP7 contains schema updates.  Upgrading a server that holds a copy of the [root] partition first, helps ensure the schema extensions created during the upgrade will propagate to all servers in the tree. 
More information can be found here:
A patch has just been released that contains the schema files for those customers that wish to extend their tree's schema prior to installing the first edirectory 8.8 SP7 server.  Both it and the instructions can be found here:

Additional Information

Known issues: 
- If ConsoleOne was installed on the server prior to patching\upgrading to eDirectory 887, dependancy errors will be seen during the first part of the process.  When prompted select Option 2: to overwrite the old packages.  For more information and additional resolution steps please see: TID 7010864

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7011599
  • Creation Date:09-JAN-13
  • Modified Date:25-MAY-13
    • NovellOpen Enterprise Server
    • NetIQeDirectory

Did this document solve your problem? Provide Feedback