My Favorites


Please to see your favorites.

System update fails with error 246

This document (7012831) is provided subject to the disclaimer at the end of this document.


Novell ZENworks Configuration Management 11.2


Error trying to update from 11.2.2 to 11.2.3

ERROR (from zmd-messages.log):

[ZENUpdater returned with code 246]

No errors in system-update log, but it stops at this line:

DEBUG;Launching ZENUpdater with argmuments: [/opt/novell/zenworks/bin/zenupdater  -w  -v  -c  /var/opt/novell/log/zenworks/system-update/5011020300fc50000000002013041002/update_commands.xml etc


In this situation, the Administrator had updated SLES primary server with jre 1.7 and jre 1.7 was incompatible with ZENUpdater.jar.  While 1.6 and 1.7 can be installed "side by side" it is necessary to fix any links under zenworks folder that point to /usr/java/latest and instead link them to /usr/java/jre1.6.0_16 as per the original install.


This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7012831
  • Creation Date:10-JUL-13
  • Modified Date:10-JUL-13
    • NovellZENworks Configuration Management

Did this document solve your problem? Provide Feedback