iPrint Support for Windows 8.1

  • 7014111
  • 13-Nov-2013
  • 01-Apr-2015

Environment

Microsoft Windows 8.1

Situation

What are the minimum software requirements to print to Windows 8.1?

Resolution

The iPrint Client for Windows 5.94 or later supports the Windows 8.1 operating system.  Follow the instructions within the iPrint Client readme to learn how to copy the client installation files to the server in a way that will auto distribute the clients to workstations.

The following iPrint Server platforms support printing from Windows 8.1:
  • iPrint Appliance version 1.0.1
    • Copy the iPrint Client version 5.94 or later to the iPrint Appliance
  • Open Enterprise Server 11 Support Pack 1 with updates
      • Note: Do not follow these steps on OES 11 SP0.  OES 11 SP0 does not allow for Windows 8.1 support.
    • Copy the iPrint Client version 5.94 or later to the OES 11 SP1 server.
    • The November 2013 novell-iprint* or later of the following RPMs must be installed to the OES11 SP1 Linux iPrint server to allow the configuration of iPrint printers for Windows 8.1.
      • novell-iprint-server
      • novell-iprint-management
      • novell-iprint-iprntman
      • novell-iprint-migration
        • To determine the version of novell-iprint* software on the OES Linux iPrint server, type this command:
          • rpm -qa | grep iprint
    • If the versions required are not installed, follow the steps below.
      • Download/copy the necessary software:
        • The minimum version iPrint RPMs required for Windows 8.1 support can be found here
        • Copy the RPMs to an empty directory on the OES 11 Linux server.
        • Decompress the files.
      • Install the RPMs:
        • At a Linux terminal session (putty or otherwise) while logged in as root, type these commands:
          • rpm -Uvh /tmp/EmptyDirectory/novell-iprint* --force
            • Note: The example command assumes the empty directory which you copied the RPMs is /tmp/EmptyDirectory/.  Change the directory path as appropriate.
      • Restart the necessary services:
        • rcapache2 restart; rcnovell-idsd restart; rcnovell-ipsmd restart
      • Install the updated iPrint plug-in to iManager.
        • Note: The rpm -Uvh command above installed the novell-iprint-management-<...>.rpm.  That rpm install command only copies the iPrint_Linux_iMan27.npm file to the /var/opt/novell/iManager/nps/packages directory. That does not install the plugin. To install the plugin:
        • Launch iManager -> Configure (Button along top of iManager) -> Plug-in Installation -> Available Novell Plug-in Modules
        • Check the box for the newly added plug-in:
          • iPrint Linux Management Plug-in
        • Click the "Install" link
        • When install complete, click the "Close" button, delete the tomcat cache, and restart tomcat
          • rm -r /var/opt/novell/tomcat6/work/
          • rcnovell-tomcat6 restart
            • Note: failure to delete the tomcat cache may result in the Windows 8/8.1 "Drivers Platform:" to not show.

Cause

Windows 8.1 made changes to the print spooler which requires Novell to update the iPrint Client. Windows 8.1 also changed the operating system version number, requiring the iPrint server code to interpret the new version number.

Additional Information

The following known issues exist with iPrint and Windows 8.1
  • User Printers not supported.
    • For Windows Operating Systems other than Windows 8, Windows 2012, and Terminal Server, the ability to install user printers is controlled by the AllowUserPrinter parameter in /var/opt/novell/iprint/htdocs/iprint.ini.  With Terminal Server, that ability is controlled within the iPrint Settings accessed from the iPrint icon in the Windows system tray icon.  For Windows 8 and Windows 2012, regardless of the AllowUserPrinter configuration, iPrint printers will always be installed as Workstation printers.  The iPrint Client for Windows 8.1 currently does not support User Printers. Future support for User printers on Windows 8.1 is in question.
  • Unable to upload printer drivers or create printer driver profiles from Windows 8.1.
    • The following error is returned when attempting to upload printer drivers or create printer driver profiles.
      • The option to add from file is not currently supported
    • Workaround these problems by:
      • Open Internet Explorer in "Run as Administrator Mode"
        • Using Windows 8.1 File Explorer, browse to c:\Program Files\Internet Explorer\iexplore.exe
        • Right-click iexplore.exe, and choose "Run as Administrator"
      • Go to the iManager URL.
        • Use the following 3 key combination to open the Compatibility View Settings dialog within Internet Explorer:
        • alt + t + b
        • Add the iManager URL.
      • Upload the printer driver or create the printer driver profile.