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How to get verbose debug logging from LM.Detection.exe

This document (7014131) is provided subject to the disclaimer at the end of this document.

Environment

Novell ZENworks Patch Management 11
Novell ZENworks Patch Management 2017

Situation

How to get verbose debug logging from LM.Detection.exe

Note:  Note:  It may be necessary to first delete HKEY_LOCAL_MACHINE\SOFTWARE\Patchlink.com\cache SYSTEM_HASH entry so that the logging is bypassing the cache.

Resolution

  1. Rename registry value HKEY_LOCAL_MACHINE\SOFTWARE\Patchlink.com\cache\SYSTEM_HASH entry to bypass cache and rescan fully.
  2. Look in registry HKEY_LOCAL_MACHINE\SOFTWARE\Patchlink.com\Discovery Agent\NativeScan search below for the name of the patch to test.  
  3. Example:  2018-02 Security Only Quality Update for Windows 7 x64 (KB4074587) is found under HKEY_LOCAL_MACHINE\SOFTWARE\Patchlink.com\Discovery Agent\NativeScan\038b7343-567a-489c-9a7b-99359061b585
  4. Or do a database query to get the guid from patch signature table. 
    Example:  select type from patchsignature where name =  '2018-02 Security Only Quality Update for Windows 7 x64 (KB4074587)' gives this:  038B7343-567A-489C-9A7B-99359061B585 (remove the brackets)
  5. Rename the registry key above so that it will force re-scan.
  6. Run the following command from %ZENWORKS_HOME%\zpm directory:

    LM.Detection_x64.exe or LM.Detection.exe /ErrorStdOut /registry /loglevel 4 /e /g 038B7343-567A-489C-9A7B-99359061B585
    "/g" is guid of the patch. 
  7. Once the patch has run on the device there will be a corresponding log file at the root of "%ZENWORKS_HOME%\zpm".

    Example:  "lm.detection-038B7343-567A-489C-9A7B-99359061B585.log"
  8. Confirm that the registry key under NativeScan is re-populated by the scan.
Note:  The guids are consistent across different zones, so the same patch will have the same guid for everyone.

Note:

Run LM.Detection_x64.exe /ErrorStdOut /registry /loglevel 4 /e to get logging for all patches.

/registry means populate the HKEY_LOCAL_MACHINE\SOFTWARE\Patchlink.com\Discovery Agent\NativeScan registry (that is not done when /g is used).  If /registry is not used, an xml file with results is created instead.

Cause

At times the need to troubleshoot LM.Detection.exe is needed to isolate why a patch will not install.

Additional Information

Other things to help with lm.detection.  Disable PD cache in case files in workdir are corrupt.  Ensure latest ospx files are present.  Sometimes corruption in system %temp% files also can contribute.

In standard agent patch scanning (running DAU or zac ps), analyze.exe launches lm.detection.  lm.detection writes to HKEY_LOCAL_MACHINE\SOFTWARE\Patchlink.com\Discovery Agent\NativeScan registry.  analyze reads from that registry and writes to the .state file.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7014131
  • Creation Date:18-NOV-13
  • Modified Date:21-MAY-18
    • NovellZENworks Patch Management

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