Incorrect Password using "Export Configuration" in iPrint Appliance

  • 7014340
  • 19-Dec-2013
  • 19-Dec-2013

Environment

iPrint Appliance

Situation

When attempting to export the iPrint Appliance Configuration, the eDirectory Administrator password is not accepted.

Error: The password you entered for the eDirectory administrator is incorrect.



When accessing "iPrint Printer Configuration (iManager)" from the the iPrint Appliance home page,the admin password is accepted.

Resolution

Reset the Administrator password by executing the following five commands at the iPrint Appliance console:

mkdir /opt/novell/iprintmobile/python/utils


wget -P /opt/novell/iprintmobile/python/utils ftp://ftp.novell.com/outgoing/pyUtils.pyc


wget -P /tmp ftp://ftp.novell.com/outgoing/iprint_edir_change_passwd.sh


chmod +x /tmp/iprint_edir_change_passwd.sh

/tmp/iprint_edir_change_passwd.sh  

Then,
1. Enter the current eDirectory Admin password when prompted.
2. Enter the desired new eDirectory Admin password when prompted.
3. Re-enter the desired new eDirectory Admin password when prompted.

Cause

This problem can be caused by changing the Administrator's password. For example, during the initial configuration, when prompted to enter the "eDirectory admin" password, the installer may enter the admin password for the production eDirectory tree. After realizing that the "eDirectory admin" in the iPrint Appliance refers to a separate tree for the iPrint Appliance, the installer changes the password. Now, neither password will work.