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BSOD during login with Imprivata OneSign Single Sign-On

This document (7014452) is provided subject to the disclaimer at the end of this document.

Environment

Novell Client 4.91 SP5 for Windows XP/2003 (IR2)
Imprivata OneSign® Single Sign-On
Windows XP SP3

Situation

When using the Imprivata OneSign Single Sign-On product as a smart card solution, users experience system crashes upon attempting login.

Steps to duplicate problem:
1. At the Ctrl + Alt + Del screen from Novell, the user presses Ctrl + Alt + Del key on the keyboard to unlock the system.
2. User gets Novell Login screen. Imprivata OneSign is also hooked to this Novell End Point login screen.
3. User enters username and password OR inserts their smart card (or at step 1).
a. If the user inserts smart card, Imprivata OneSign requests the PIN.
b. User enters the PIN.
c. After user authentication on Imprivata OneSign, Imprivata OneSign passes the user's credentials to the Novell Client for authentication to eDirectory.
4. User is authenticated to eDirectory & Imprivata OneSign.
5. User is logged to his/her desktop.

Instead of being authenticate at step 4, the user sees the "Blue Screen" as the system crashes with an error such as:

C00021a (typically)
or
C0000145 - application failed to initialized (rarely)
or
D0000144 - Unknown hard error (rarely).

Resolution

Update NWGINA.DLL to one dated 13Oct2013 (in 491psp5ir2_nwgina.zip) or later.

Cause

The Novell Client's NWGINA.DLL was incorrectly calling WlxDisplayStatusMessage.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7014452
  • Creation Date:24-JAN-14
  • Modified Date:13-FEB-14
    • NovellClient

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