Missing cacerts - [38445] A failure occurred in the document conversion process. The document cannot be viewed at this time.

  • 7014988
  • 30-Apr-2014
  • 26-Sep-2016

Environment

Novell GroupWise 2014
Novell GroupWise 2012
Novell GroupWise 8

Situation

Cannot view attachments when WA is on a different server, WA works when hosted on some servers
The following error is presented to the user in the browser:
Unable to view 'FILENAME'
[38445] A failure occurred in the document conversion process. The document cannot be viewed at this time.

Attachments downloaded from webaccess are corrupt
Unable to get into the administration console for webaccess

Resolution

  1. Verify cacerts file is indeed missing on the OES server using novell-tomcat6. From a terminal window, enter the following:
    ls /var/opt/novell/tomcat6/conf/cacerts


  2. If there is no cacerts file in the path above, then proceed to have it recreated:
    cd /var/opt/novell/tomcat6/conf/
    keytool -genkey -keyalg RSA -alias selfsigned -keystore cacerts -storepass changeit -validity 720 -keysize 2048
    • Fill in the prompts for your organization information. When it asks for your first and last name, enter the domain name of the server that users will be entering to connect to your application (e.g. www.myserver.com)
      Note: This will create a cacerts keystore file containing a private key and self-signed certificate.

  3. Restart tomcat: rcnovell-tomcat6 restart

Note: If the above does not resolve the issue, copy /var/opt/novell/tomcat6/conf/cacerts from another OES server and restart tomcat.

Cause

Missing cacerts file preventing WebAccess from functioning properly.

Additional Information

For another customer it was discovered that in addition to having to re-create the "cacerts" file, that was missing, there was also a missing directory under /var/opt/novell/groupwise/webaccess/ called "temp", once the directory was re-created and tomcat6 and groupwise restarted on the Linux box, the problem went away.