Firefox iPrint printer install results in blank white page

  • 7015285
  • 27-Jun-2014
  • 15-Apr-2015

Environment

Novell iPrint Client for Windows

Situation

After clicking the link to install an iPrint printer using Firefox version 30 (released June of 2014) the list of printers goes away and the iPrint printer does not install.  A careful viewing of the page will reveal a well blended in pop-up message just below Address bar, with the text of:

Allow <iPrint Server Address> to run "Novell iPrint?"     Continue Blocking | Allow

Resolution

Fix:
OES 11 SP2:

    Download the updated novell-iprint-server and novell-iprint-client RPM from here.
    Copy the RPMs to the iPrint server's /tmp directory
    Install the RPMs using the following commands:

        cd /tmp
        rpm -Uvh novell-iprint-server-6.7.0.20150218-0.6.5.x86_64.rpm
        rpm -Uvh novell-iprint-client-6.7.0.20150328-0.6.1.noarch.rpm
        rcapache2 restart
        rcnovell-idsd restart
        rcnovell-ipsmd restart


    Update the iPrint Client to version 6.0.0 or later on the workstation.

        After installing the novell-iprint-client RPM listed above, click the "Install iPrint Client" link from the /ipp page.

iPrint Appliance 1.1:


Apply the iPrint Appliance 1.1 Patch 1 update to the appliance.
Update the iPrint Client to version 6.0.0 or later on the workstation.

    After installing the Patch 1 listed above, click the "Install iPrint Client" link from the /ipp page.

Workaround:

Choose Allow when prompted to Allow <iPrint Server Address> to run "Novell iPrint?"

If that message is not presented (this can happen if "Continue Blocking" was previously chosen), you can activate the iPrint plug-in by:
  • click the Menu button
    • upper right of the Firefox browser with the 3 horizontal bars
  • Add-ons
    • Plugins
      • Click the drop down list for the Novell iPrint Plug-in and choose "Always Activate"
  • Click the link to install the iPrint printer
Note:  Installing iPrint printers via Internet Explorer is also an option.  To do this, you must:
  • Launch Internet Explorer in "Run as administrator" mode
    • Browse to c:\Program Files\Internet Explorer
    • Right-click iexplore
    • Choose "Run as administrator"
  • You may also need to add the iPrint server's address to the "Compatibility View settings".
    • Click the Gear button in the upper right of the browser
    • Choose "Compatibility View settings"
    • Click the "Add" button. Click "Close"

Cause

To improve the stability and performance of Firefox, Firefox version 30 introduced added security which blocks plugins by default. With the updates listed above, iPrint no longer relies on the browser plugin technology.