GroupWise 2014 users fail initial sync to Mobility

  • 7015542
  • 15-Aug-2014
  • 23-Feb-2015

Environment

Novell GroupWise Mobility Service
Novell Data Synchronizer Mobility Pack

Situation

Sync not working for users added from GroupWise 2014
User was added as part of a group, even fails after reinitializing
/var/log/datasync/connectors/groupwise-agent.log reports the following errors:
ERROR [] Error occured during direct query function call for user <userID> (deleteUser)
INFO Direct query received: clinton (reAddUser)
INFO Readd user request for: <user's_FDN>
ERROR Error occured during direct query function call for user <userID> (reAddUser)

Viewing the user's GroupWise settings in WebAdmin may report this error:
ERROR: User settings can not be parsed. Your user preferences may contain syntax errors. Contact your local system administrator.

Resolution

If this appears to be a single user issue:
See TID 7012677 - Unable to sync mail, contacts, or calendar.

If this appears to be a group-related issue:
  1. It's possible the group's targetName in the groupwise database, targets table is missing. This should be the group's ID in GroupWise. Please contact a Novell Engineer for help identifying this possibility.
  2. Otherwise, remove and readd the group:
    • Remove the group from Mobility.
    • Readd the group.
    • Restart GMS: rcgms restart.

If most users on the Mobility server have this issue and it doesn't appear to be group related:
See TID 7014473 - How to refresh a Mobility server

Cause

Corruption of user accounts in postgres database.