ZENworks Agent Install Fails on Device that had ZEN 7

  • 7015716
  • 30-Sep-2014
  • 30-Sep-2014

Environment

Novell ZENworks Configuration Management 11 Installation - Agent
Novell ZENworks Desktop Management 7.1

Situation

ZENworks 11.x agent installation fails on ZENPreAgent

The following messages can be seen in the Application Event logs:

ERROR:
[ bei System.Threading.ThreadHelper.ThreadStart_Context(Object state) ]
Previous agent uninstallation failure: msiexec error:1605


ERROR:
[ bei ZENPreAgent.PreAgentStatus.SendStatus(String msgKey) ]
Logging status:PRE_AGENT_ERR_UNINSTALL_FAILED


The following error can be seen in the PreviousAgentUninstallLog.txt:

ERROR:
Found a previous agent with ProductCode: {B74EF7F9-57F4-4772-805E-74D3C2C4A070}
Executing command: C:\WINDOWS\system32\msiexec /qn /x {B74EF7F9-57F4-4772-805E-74D3C2C4A070} REBOOT=ReallySuppress
Previous agent uninstallation failure: msiexec error:1605

Resolution

Download the Microsoft MsiZap.exe utility and copy it the failing workstation
  NOTE: MsiZap.exe is a Microsoft utility. The tool itself is in no way supported by Novell.
Run the following command on the failing workstation:

MsiZap.exe T {B74EF7F9-57F4-4772-805E-74D3C2C4A070}

Cause

The ZEN 7 agent didn't uninstall properly. There were still entries for the old agent left on the device that prevented the new install.