iPrint Appliance: Changing printer driver doesn't take effect

  • 7015857
  • 01-Nov-2014
  • 01-Nov-2014

Environment

Novell iPrint Appliance

Situation

The administrator has changed the driver assignment to a printer agent, but the internal or remote renderer is not using newly assigned printer driver. 

Resolution

There are two ways to cause the new printer driver assignment (for internal or remote render configurations) to get updated.

Method 1:
Wait 60 minutes and submit a print job.  The next print job will use the changed driver. 

Method 2:
Disable and re-enable the printer agent for mobile printing.  This is done by:
  1. Go to the iPrint Appliance Configuration printers page
    • https://<ip or dns of iPrint Appliance server>:9443/iprintconfig/printers
  2. Highlight the printer agent which recently had the driver changed
  3. Click Mobile -> Disable
  4. Click Mobile -> Enable
All of the information in this Resolution section applies to both internal and remote renderers.

Cause

This is working as designed.  Novell is considering changing this design.

Additional Information

To change the printer driver used to render print jobs when no remote renderer is configured, change the Linux printer driver associated to the printer agent using iManager.  This configuration action will not only cause the chosen printer driver to be downloaded to Linux workstations when installing that printer agent, but will also cause the iPrint Appliance internal renderer to use that PPD to render the print job with mobile or email submitted print jobs. 

To change the printer driver used to render print jobs when a remote renderer is configured, change the Windows OS printer driver associated to the printer agent using iManager.  Use Windows OS of the remote renderer.  If the Windows remote renderer is a Windows Server, see the equivalence matrix below:

Windows 7 = Windows 2008
Windows 8 = Windows 2012