Environment
NetIQ Sentinel Log Manager 1.2.2.0
Situation
After upgrading to Sentinel Log Manager 1.2.2.0, searches containing a large number of events, (more than 300,000), cause Sentinel Log Manager to become unresponsive and the searches will not finish. Reviewing the server0.0.log will reveal the following entries:
IO Error performing search for the day Oct 01, 2014 (UTC).; Exception
Map failed; java.io.IOException; ; Caused by Map failed; java.lang.OutOfMemoryError;
Resolution
Workaround:
1. Log in to the server
2. Edit the file /etc/security/limits.conf
vi /etc/security/limits.conf
3. At the bottom of the file, locate the following entries:
6. Restart Sentinel Log Manager
1. Log in to the server
2. Edit the file /etc/security/limits.conf
vi /etc/security/limits.conf
3. At the bottom of the file, locate the following entries:
novell soft as4. Complete these two lines as follows:
novell hard as
novell soft as unlimited5. Save the file.
novell hard as unlimited
6. Restart Sentinel Log Manager
Cause
There was a problem with the install script that was defining entries for Virtual Address Space for the novell user in the limits.conf file however the value being passed in to this parameter was not defined. The end result was an undefined value in the limits.conf causing the hard and soft limits for the novell users Virtual Address space to be undefined.