Identity Manager Office 365 Driver setting password forces users to change password when they login

  • 7015933
  • 28-Nov-2014
  • 15-Jul-2015

Environment

NetIQ Identity Manager 4.0.2
NetIQ Identity Manager Office 365 Driver

Situation

When users set their password via Identity Manager Password Management or Self Service Password Reset and the password then is being synchronized to Office 365 (Azur) they will then be asked to change the password on login.

Resolution

NetIQ have decided to make an exception to the support environments listed in the Documentation, and will support Identity Manager 4.0.2 Engine with Identity Manager 4.5 .net Remote Loader.

The support for this will end when NetIQ release a patch for the Office 356 driver.

The Identity Manager 4.5 Office 365 driver ships with a fix for the above issue; the fix was both in the Driver Shim, and Designer packages.

1) Download the Identity Manager 4.5 installation medium from here.
2) Install the Remote Loader and driver on a supported platform. Office 365 documentation: here.
3) Make sure to update the Designer Packages for the Office 365 driver to the latest versions.
Office 365 Base - 2.5.0.20140930161237 or later
Office 365 Default - 2.4.0.20140902162655 or later
3) Configure the driver according to documentation
4) Deploy the driver.

Cause

Powershell cmdlet Set-MsolUserPassword was prior to the fix being called without "-ForceChangePassword $false"