ncpserv.log filling up with 'Failed to perform synchronous I/O multiplexing using select, error: 9'.

  • 7016433
  • 17-Apr-2015
  • 17-Apr-2015

Environment

Novell Open Enterprise Server 11 (OES 11) Linux Support Pack 2

Situation

After performing some NSS Pool and Volume management, it was observed that for no apparent reason suddenly the /var/opt/novell/log/ncpserv.log file started filling up with erroneous messages as below :
Failed to perform synchronous I/O multiplexing using select, error: 9
Failed to perform synchronous I/O multiplexing using select, error: 9
Failed to perform synchronous I/O multiplexing using select, error: 9
Failed to perform synchronous I/O multiplexing using select, error: 9


There were so much messages spawned, that this started filling up the /var file system and the system started to exhibit additional problems, due to the fact that some occasions the /var file system completely ran out of disk space.

On one occasion, it was reported even that due to this problem, the ncpserv.log file had exceeded 23 GB (!) in size.

Resolution

A proper solution was made in the NCP server code which has been released to the public with the March 2015 OES 11 SP2 Scheduled Maintenance Update.


Alternatively, when observing such behavior during production hours (since thes messages here originate from NCP server), a quick workaround to prevent the continuous message flooding from occurring and creating enormous log files during production hours, a very simple but effective work-around can be put in place, by completely disabling the NCP logging.

E.g.:
oes11sp2 # ncpcon set LOG_LEVEL=nothing
... Executing "set LOG_LEVEL=nothing"

... completed OK [elapsed time = 336 usec
oes11sp2 #


Cause

There was a problem in function  IPCListenerThread() when logging an error in select function call.