Vibe 4.0 SSL Connection Error

  • 7016477
  • 08-May-2015
  • 15-Jun-2015

Environment

Novell Vibe 4.0
Novell GroupWise 2014
Novell GroupWise 2012

Situation

Using Vibe 4.0, end users trying to access Vibe site using a browser receive a SSL Connection Error. Restarting Vibe service fixes the error temporarily. Non-SSL (or http) connections are not affected.

Depending on the browser, the error message displayed may vary:
  • Mozilla FireFox:
    Secure Connection Failed; An error occurred during a connection to https://<vibe-host-name>. Peer reports it experienced an internal error. (Error code: ssl_error_internal_error_alert)

  • Google Chrome:
    SSL connection error; Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have.

  • Internet Explorer:
    This page can't be displayed; Make sure the web address https://<vibe-host-name> is correct.

Resolution

A fix for this issue is available in the Vibe 4.0 Hot Patch 1, available via the Novell Patch Finder.

Important Note: If you had previously implemented the following workaround, please remember to revert the changes:

As a temporary workaround to ensure that SSL remains functional for Web Access to Vibe, you can disable all SOAP requests to your Vibe 4.0 server by adding the following lines at the end of the /opt/novell/teaming/apache-tomcat/webapps/ssf/WEB-INF/classes/config/ssf-ext.properties file:

remoting.ws.enable=false
remoting.basic.enable=false
remoting.token.enable=false
remoting.anonymous.enable=false

Restart Vibe service for changes to take effect.

Note: With the temporary workaround in place, the following clients will be non-functional with Vibe:
  1. Novell GroupWise client
  2. Novell Vibe Desktop client version 1.x
    Note: Novell Vibe Desktop client version 2.0 will remain functional
  3. Novell Vibe Add-In for MS-Office

Cause

If your Vibe 4.0 site is accessed using any of the following clients (which use SOAP/WS-Security authentication), it causes the SSL connection interruption as soon as the first client attempts a connection:
  1. Novell GroupWise client
  2. Novell Vibe Desktop client version 1.x
    Note: Novell Vibe Desktop client version 2.0 does not cause this problem
  3. Novell Vibe Add-In for MS-Office