Service Desk Error Exporting Survey Responses to Excel

  • 7017488
  • 11-Apr-2016
  • 11-Apr-2016

Environment

Novell Service Desk 7.1 Knowledge Base

Situation

  • Exporting survey responses or results to an Excel spreadsheet
  • Clicking User > Knowledge > Surveys > [survey] > Responses > Excel
The following could be seen in the Service Desk web console:

ERROR:
Urgent
An error occurred whilst exporting to Excel


The following could be seen in the LiveTime.log:

ERROR775088[ajp-127.0.0.1-8009-10] (SurveyCustomers.java:256) - An error occurred whilst exporting to Excel
java.lang.NullPointerException
    at com.SurveyCustomers.closingTech(SurveyCustomers.java:264)

Resolution

This has been fixed in Micro Focus Service Desk 7.2.

Cause

The field "Close by Technician" was null for a number of closed requests. These requests were created using a Quick Call with Closed state as the default state.