gms monitor shows "dead"

  • 7017877
  • 22-Jul-2016
  • 12-Dec-2016

Environment

Novell GroupWise Mobility Service 2.0
Novell GroupWise Mobility Service
Novell GroupWise

Situation

rcgms status shows gms monitor dead
unable to view dashboard
gms dashboard is empty
Mobility 2014 R2 up and running, can login to Admin console, but dashboard empty / blank
postgresql database running
checking for gms monitor: dead

Resolution

  1. Please follow the steps below to confirm the issue:
    • In a terminal session on the mobility server type rcgms status and you find "checking for gms monitor: dead"
    • Verify that the "Dashboard" tab in GroupWise Mobility Administration page displays nothing
    • In a terminal session on the mobility server type rcgms restart and verify with rcgms status that the gms monitor is still dead
    • In a terminal session navigate to the following directory with cd /var/log/datasync/monitorengine/
    • Type less monitor.log
    • Navigate to the end of the log file by using the "End" button on your keyboard
    • At the end of the file, look for the following (or similar entry):
      2016-07-22 11:20:32.771 ERROR [MainThread] [monitorEngine:71] [userID:] [eventID:] [objectID:] [] MonitorEngine Terminated unexpectedly: FATAL:  database "dsmonitor" does not exist
          Traceback (most recent call last):
        File "/sbin/monitorEngine.py", line 64, in <module>
        File "/lib/monitorengine/monitorengine.py", line 104, in init
        File "/lib/monitorstorage/basestore.py", line 212, in __init__
        File "/lib/monitorstorage/basestore.py", line 111, in __init__
        File "/lib/monitorstorage/basestore.py", line 67, in __init__
        File "/lib/monitorstorage/basestore.py", line 42, in __init__
        File "/lib/monitorstorage/basestore.py", line 46, in connect
      OperationalError: FATAL:  database "dsmonitor" does not exist
    • Now we have verified that the dsmonitor database does not exist, to fix this please follow the steps below
    • Exit the log file with "q"

  2. If the situation has been validated with the above steps, please follow the steps below to resolve the issue:
    • Follow TID 7015282 and install dsapp on the mobility server
    • Stop mobility with rcgms stop
    • Verify and drop the dsmonitor database, if it exists:
      • Launch dsapp by typing dsapp into the terminal window on the server
      • Now that dsapp is launched type d (for database) and hit enter
      • To drop the dsmonitor database please type drop database dsmonitor;
      • Verify the database is actually gone by typing \l (for list)
      • Exit the database menu by typing \q (for quit)
    • To re-create the dsmonitor database please type this /opt/novell/datasync/update.sh
    • To start mobility please type rcgms start
    • Now type rcgms status to verify the gms monitor shows "running"
    • Verify the Mobility "Dashboard" tab is not blank


If the above steps did not resolve this issue that has been validated, please contact MicroFocus Customer Care.

Cause

For some reason either the dsmonitor database becomes corrupt or is entirely removed from the mobility database.
In turn the gms monitor will not start / run