Empty folders accessing the server through the Client for Open Enterprise Server SP4

  • 7022201
  • 26-Oct-2017
  • 26-Oct-2017

Environment

Open Enterprise Server 2015 SP1
Client for Open Enterprise Server 2 SP4
Dynamic Storage Technology (DST) 

Situation

After migrating from OES11 SP2 to OES2015 SP1, when accessing the network drives with the Client 2 for OES SP4, empty folders are displayed. 

When accessing the same folders through SSH or on the server itself, all files are displayed as expected.

Resolution

With the following configuration, files will not be displayed if the same file name exists in both the "primary" and the "shadow" volume:

DUPLICATE_SHADOW_FILE_BROADCAST = 1
DUPLICATE_SHADOW_FILE_ACTION = 0

The files will be visible if the following configuration is used: 

DUPLICATE_SHADOW_FILE_BROADCAST = 0
DUPLICATE_SHADOW_FILE_ACTION = 0

or 

DUPLICATE_SHADOW_FILE_BROADCAST = 1
DUPLICATE_SHADOW_FILE_ACTION = 4

Workaround: 

1. Review the current settings:

To display the current settings, type the following command at the server console:

ncpcon set  

2. Change the settings:

   1) In OES Remote Manager for Linux, select View File System, then select Dynamic Storage Technology Options.
   2) In the Duplicate File Resolution Options area, view the current setting for Actions to be taken and change it accordingly

For more information, see Configuring a Global Policy for Actions to Resolve Duplicate Files Conflicts.

Cause

This is a defect within DST, currently under investigation.

Status

Reported to Engineering