Updating other Primaries and adding new Primaries fails after first appliance is migrated to ZENworks 2017

  • 7022432
  • 05-Dec-2017
  • 05-Dec-2017

Environment

ZENworks Configuration Management 2017 Virtual Appliance
ZENworks Configuration Management 2017 System Update
ZENworks Configuration Management 2017 Installation - Server
Embedded OEM Sybase Database

Situation

  • The embedded Sybase database is running on the ZENworks 2017 Virtual Appliance
  • The appliance server with the database has been migrated to ZENworks 2017 from the ZENworks 11.4.x Virtual Appliance
  • Upgrading other Primary Servers in the zone fails
  • Adding new Primary Servers to the zone fails
  • The Embedded Audit database port (2639) remains blocked on the appliance hosting the database

The following is seen in jetty.stderrout.out:

ERROR:
[qtp1232367853-14] INFO com.novell.admin.zen.server.utils.AdditionalPrimaryUtils - isZoneAuthConfigureAction:true
[qtp1232367853-14] ERROR com.novell.admin.zen.server.validation.utils.ZoneDetailsValidator - problem in authenticating to zonecom.novell.zenworks.configure.DatabaseInfoException: Unable to contact the database server.  The database address specified by the parent primary server can not be resolved
by this server.  This usually indicates either a DNS resolution problem or that the database server could not be reached
from this server.  Try specifying your first primary server as the parent of this server.

Resolution

Workaround
On the Primary Server hosting the Audit Database, manually open the Audit Database port (2639) in the SUSE Firewall with YaST.
If assistance is required, please contact Micro Focus Customer Care.

Cause

Migrating to the ZENworks 2017 Virtual Appliance does not automatically open the Audit database port (2639). The SUSE Firewall blocks this port by default. This prevents other Primary Servers from being upgraded or added to the zone.

Status

Reported to Engineering