How to restore target server to pre-migration state after failed OES migration

  • 7022863
  • 17-Apr-2018
  • 20-Aug-2019

Environment

eDirectory 9
Open Enterprise Server 2018

Situation

OES migration fails at 'Restore DIB' step.
Source server's NDS DIB is locked.
How to re-cycle the target server configuration in order to attempt the migration again.

Resolution

Target server cannot be used for migration in its current state. Please follow the steps below to revert to pre-migration configuration in order to attempt the migration again:

  1. Restart ndsd on the SOURCE server to unlock the NDS DIB.

  2. Cleanup eDirectory on the TARGET server:
    • Delete all objects related to the target server from the tree using iManager:
      • Using the 'Directory Administration' Role
      • Select the 'Delete Object' task
      • Click the tab 'Select multiple objects' and use the object selector (magnifying glass).
      • In the pop-up window, change to the 'Search' tab and search for the target server name surrounded by asterisks, e.g. *mytargetserver*.
      • Select all the objects that are returned, and proceed to delete them.

  3. Check that replica synchronization and time synchronization show zero errors on the SOURCE server:
    ndsrepair -E

    ndsrepair -T

  4. Reconfigure eDirectory into a pre-migration configuration on the TARGET server:
    • Navigate to the OES Install and Configuration section:
      Open YaST2 > Open Enterprise Server > OES Install and Configuration.
    • On the "Software Selection" screen, verify that the 'Novell Pre-migration Server' box has been checked.
    • Click Accept.
      Note: If all went well, it will start the eDirectory configuration process. Once it is complete, the target server will be prepared for the OES migration once again.

Cause

In this case, the exact cause could not be ascertained. At the DIB Restore step, NDS error -663 was thrown, and the migration failed. Suspect that file corruption may have occurred during the DIB copy step.