DB2 sqlcode -2044 error - backups fail

This document (7022986) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 3 (SLES 11 SP3)
@namespace url(http://www.w3.org/1999/xhtml); @-moz-document domain("bugzilla.suse.com") { .bz_comment { margin: 0 0 20px; width: 100% !important; } .bz_comment_text { width: 100% !important; } }SUSE Linux Enterprise Server 11 Service Pack 4 (SLES 11 SP4)

Situation

After updating to kernel version 3.0.101-108.38.1 or version 3.0.101-108.41.1 storage backups were starting to fail. The DB2 errors pointed to ipc (interprocess communication) related errors.

The DB2 log (db2idag log) is showing an error like this:
FUNCTION: DB2 UDB, database utilities, sqluBufInUse, probe:1453
MESSAGE : SQL2044N An error occurred while accessing a message queue."

Resolution

The SLES11 SP4 kernel update: 3.0.101-108.52.1 and SLES11 SP3 LTSS kernel update: 3.0.101-0.47.106.32.1, both released May/31 include the patch to resolve the problem.


Cause

Cause is a faulty parsing of msgctl args in a fix of an ipc data structure inconsistency.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7022986
  • Creation Date: 18-May-2018
  • Modified Date:14-Oct-2022
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center