iPrint Appliance cannot retrieve mail from gmail.com using IMAPS

  • 7024038
  • 29-Jul-2019
  • 14-Aug-2019

Environment

Micro Focus iPrint Appliance 3.x
Micro Focus iPrint Appliance 4.x

Situation

After configure the iPrint Appliance IMAP server and port as imap.gmail.com on port 993 (SSL connection), email could not be retrieved from gmail.  The error" Unable to contact with gmail server" pops up in the Appliance Management Console.

The /var/opt/novell/log/iprintmobile/iprint_mobile0.log shows this error:
DATE WARN ExceptionHandlerExceptionResolver:186 - Handler execution resulted in exception: Failed to connect to mail server for user@company.org.
A LAN trace reveals that gmail is resetting the port 993 connection.

Resolution

Change the gmail account settings to "Allowing less secure apps to access your account".

Follow this document:

Cause

Because less secure apps can make your account more vulnerable, Google automatically turns this setting off if it’s not being used.  With this setting off, IMAPS connections from the Appliance will be rejected.