Enable Airprint option is greyed out in iPrint Appliance

  • 7024064
  • 14-Aug-2019
  • 14-Aug-2019

Environment

iPrint Appliance 3.x
iPrint Applaicne 4.x

Situation

Within the Management Console (https://appliance:9443) -> Printers, the option to enable AirPrint is greyed out, even if the network printer is properly configured for AirPrint.

Resolution

Disable IPP authentication on the network printer.  Refer to the network printer documentation to figure out how to do that.

Cause

iPrint Appliance will query the network printer using IPP to determine if the network printer supports AiPrint. If no reply is received or if the data in the reply is unexpected, the Appliance cannot verify if the printer is AirPrint capable. In that case, the printer within the Management Console will show greyed out. 

If the network printer has IPP authentication enabled (replying with HTTP 426 to change the connection to IPPS), the iPrint Appliance will register the printer as not being AirPrint capable.