GMS sync slows down Thousands of items in user's Trash or Sent Items folder

  • 7025076
  • 12-Apr-2021
  • 12-Apr-2021

Environment

GroupWise Mobility Service 18
GMS 18.1.0 and 18.1.1

Situation

GMS performance slows down
One or more users see duplicated items in the Sent Items folder or in their Trash folder

Resolution

The problem has been fixed in 18.3 and later code releases.

Cause

WIP (work in progress) auto saves were not being handled correctly resulting in duplicate messages that were not processing or deleting as they should.

Additional Information

As a work around you can remove the user from GMS, delete the duplicate items from WIP/Trash and then re-add the user to GMS

Updating the code is the ultimate fix.