List of commands used when inventorying and monitoring Linux/Solaris machines

  • 7920905
  • 09-Apr-2007
  • 26-Apr-2012

Environment

PlateSpin Recon 3.0 and higher

Situation

This article provides a list of commands that PowerRecon will execute on a Linux or Solaris machine during the inventory and monitoring process.


 

Resolution

The following table contains a list of commands used by PowerRecon during inventory and monitoring:

COMMAND

DESCRIPTION

 

 

Inventory Solaris:

kstat

#Get network connection speed.

chmod

#Change file access permissions for the inventory script that is placed on the machine being inventoried

rm

#Remove the inventory script that was placed on the machine

prtdiag

#Get CPU cache information and machine model for Sparc.

psrinfo

#Get processor information such as family, model, step, etc., which are related to x86 mainly.

isainfo

#Get CPU instruction set information such as sse, sse2, mmx, etc., which are related to x86 mainly.

prtconf

#Get configured device information, which is related to L2 cache information of x86, network adapter resolving, and ACPI support.

ifconfig

#Get network related information such as IP address, DHCP, net mask, etc.

ndd

#Get network connection speed.

uname

#Get CPU type to generate corresponding BIOS information such as UUID and serial number.

mount, cut, grep

#Get boot loader.

pkginfo

#Get installed programs.

grep

#Get DNS server.

cat

#Get default gateway.

ps

#Get process information

who

#Get run level

hostname

#Get host name

 

 

Inventory Linux:

chkconfig

#Get service(daemon) information

df

#Get volume information

mount

#Get volume information

e2label

#Get disk label

grep

#Get OS release, gateway, memory, wireless NIC information

route

#Get gateway

ifconfig

#Get network related information such as IP address, net address, and so on.

cat

#Get DHCP, memory information

egrep

#Get DHCP information

getcfg

#Get DHCP for SuSE

rpm

#Get installed programs.

lspci

#Get PCI device information such as vendor name, device model in human readable format.

iwconfig

#Get wireless network adapter NIC list

iwlist

#Get wireless bit rate

ethtool

#Get speed and link status for network connection

dmesg

#Get real MAC address

kudzu

#Get network device information for Redhat Linux

hwinfo

#Get network adapter information for SuSE Linux

fdisk

#Determine if a partition is active or not

runlevel

#Get current run level

hostname

#Get host name and DNS domain name

 

 

Monitoring:

 

awk

#Edit input stream

psrinfo

#count processor number

mpstat

#Get processor time per cpu instance

vmstat

#Get processor queue length and memory available

ifconfig

#Get NIC list

grep

#Edit input stream

cut

#Edit input stream

sed

#Edit input stream

tail

#Edit input stream

netstat

#Get network package transfer rate

kstat

#Get NIC speed

ls

#Find cdrom symbol link

prtconf

#Get module and instance binding for NIC

iostat

#Get disk io information such as queue and speed.

expr

#evaluate express