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Legal Notices

Novell, Inc. makes no representations or warranties with respect to the contents or use of this documentation, and 
specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. 
Further, Novell, Inc. reserves the right to revise this publication and to make changes to its content, at any time, 
without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc. makes no representations or warranties with respect to any software, and specifically disclaims 
any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. 
reserves the right to make changes to any and all parts of Novell software, at any time, without any obligation to 
notify any person or entity of such changes.

Any products or technical information provided under this Agreement may be subject to U.S. export controls and the 
trade laws of other countries. You agree to comply with all export control regulations and to obtain any required 
licenses or classification to export, re-export, or import deliverables. You agree not to export or re-export to entities 
on the current U.S. export exclusion lists or to any embargoed or terrorist countries as specified in the U.S. export 
laws. You agree to not use deliverables for prohibited nuclear, missile, or chemical biological weaponry end uses. 
Please refer to www.novell.com/info/exports/ for more information on exporting Novell software. Novell assumes no 
responsibility for your failure to obtain any necessary export approvals.

Copyright © 2006 Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, 
stored on a retrieval system, or transmitted without the express written consent of the publisher.

Novell, Inc. has intellectual property rights relating to technology embodied in the product that is described in this 
document. In particular, and without limitation, these intellectual property rights may include one or more of the U.S. 
patents listed at http://www.novell.com/company/legal/patents/ and one or more additional patents or pending patent 
applications in the U.S. and in other countries.
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404 Wyman Street, Suite 500
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About This Guide 

This guide describes how to use and manage Novell® iFolder® 2.1x client software. This guide is 
intended for users and is divided into the following sections:

• Chapter 1, “Overview,” on page 7
• Chapter 2, “Using the iFolder Client,” on page 13
• Chapter 3, “Using Web Access Methods to Access iFolder Data,” on page 31
• Appendix A, “Tips and Tricks for Synchronizing,” on page 37
• Appendix B, “Frequently Asked Questions,” on page 43

Additional Documentation

Your Novell iFolder administrator maintains an iFolder Web site with information about your 
iFolder service. To access this site, right-click the iFolder icon in the system tray, then click iFolder 
Web Site. 

You can go directly to your iFolder Web site by typing this URL in your Web browser:

http://nif1.your-domain-name.com/iFolder

Replace nif1.your-domain-name.com with the actual DNS name or IP address of your iFolder server. 
The URL is case sensitive. Get the actual URL from your iFolder administrator.

For documentation on installing, configuring, and managing iFolder, see the following:

• Online documentation for the iFolder server and client (http://www.novell.com/documentation/
lg/ifolder21/index.html)

• Novell iFolder Cool Solutions Web site (http://www.novell.com/coolsolutions/ifmag) for tips 
and tricks

• Novell iFolder Support Knowledgebase Web site (http://support.novell.com) for emerging 
issues for the iFolder server and client

Documentation Updates

For the most recent version of the Novell iFolder 2.1 User Guide, see the Novell iFolder 
Documentation Web site (http://www.novell.com/documentation/lg/ifolder21/index.html).

For emerging issues with the iFolder server and client, see the Novell iFolder 2.1 Readme 
Addendum (http://support.novell.com/cgi-bin/search/searchtid.cgi?/10079972.htm).

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
within a cross-reference path.

A trademark symbol (®, , etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.
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When a single pathname can be written with a backslash for some platforms, or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as UNIX* should use forward slashes as required by the software.
er 2.1 User Guide
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1Overview

Novell® iFolder® 2.1 is a Net services software solution that allows your files to automatically 
follow you everywhere—online, offline, all the time—across multiple workstations and the Net. 
You simply store your files in the iFolder directory on your workstation. 

As you work, the iFolder client intelligently tracks and logs updates to your files. It can 
automatically and transparently synchronize those changes through Internet or network connections 
with your files on the iFolder server and the various workstations that you use. 

It no longer matters where you are in the world. With iFolder, you can get your work done without 
having to e-mail files to yourself or deal with complicated remote logins or temperamental VPN 
clients. You no longer need to worry about keeping track of your files, because your work 
environment now revolves around you, and your data is with you, wherever you are. 

This overview describes the following information about Novell iFolder:

• Section 1.1, “Benefits of iFolder,” on page 7
• Section 1.2, “Key Features of iFolder,” on page 8
• Section 1.3, “How iFolder Works,” on page 10
• Section 1.5, “What's Next,” on page 11

1.1  Benefits of iFolder
Working in multiple locations has traditionally meant that you had to conscientiously manage file 
versions, secure data transfer, and periodic data backups for multiple workstations. Novell iFolder is 
an easy way to make sure your files are secure, accessible, and up to date.

With iFolder, you always have convenient and secure access to the most recent version of your 
documents. All you need is an active Internet or network connection and the Novell iFolder client 
software, a Web browser, or Novell NetDrive.

Novell iFolder provides the following benefits:

• Guards against local data loss by automatically backing up your local files to the iFolder server 
and your multiple workstations.

• Transparently updates your files to the iFolder server and your multiple workstations that have 
the iFolder client.

• Tracks and logs changes made while you work offline and synchronizes those changes when 
you go online.

• Provides access to your files on the iFolder server from any workstation that does not have the 
iFolder client, using a Web browser.

• Provides optional encryption to protect data as it travels across the wire and while it is stored on 
the iFolder server.

• Makes files on the iFolder server available for regularly scheduled data backup.
Overview 7
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1.2  Key Features of iFolder
The Novell iFolder client works in combination with the iFolder server to create a single virtual 
work folder that you can access from any computer. 

The key features of your iFolder account include the following:

• “The iFolder Client” on page 8 
• “Your Local iFolder Directory” on page 8
• “Your iFolder Server User Account” on page 8
• Section 1.2.4, “Web-Based Access,” on page 9
• “Your iFolder Conflict Bin” on page 9
• “File Synchronization” on page 10
• “File Encryption” on page 10

1.2.1  The iFolder Client 
The Novell iFolder client supports the synchronization of files in your local iFolder directory with 
the iFolder server and with other workstations. If you choose, the iFolder client can also encrypt 
your files for transmission and storage on the iFolder server. It also provides an interface for you to 
manage your iFolder account. 

An iFolder client session begins automatically each time your start your computer. The session runs 
in the background as you work with files in your local iFolder directory, tracking and logging any 
changes you make. When you log in to the iFolder server, the iFolder client synchronizes your files 
transparently as scheduled, or on demand, according to your specified preferences. 

When you move to a different location and a different workstation, and log in to the iFolder server, 
the iFolder client automatically updates your local iFolder directory to reflect the work you did 
elsewhere—with no floppies or manual file transfers required. 

For more information, see Section 2.12, “Managing Your iFolder Account,” on page 26.

1.2.2  Your Local iFolder Directory
Your local iFolder directory is your virtual work folder. This is where you will move any files that 
you want to synchronize among multiple workstations and the iFolder server, using the iFolder 
client. 

You determine the location of the local iFolder directory on your hard drive. Within the directory, 
you can set up any subdirectory structure that suits your personal or corporate work habits. Although 
the actual path to the local directory might be different on each of your workstations, the 
subdirectory structure remains the same for all your workstations.

For more information, see Section 2.13, “Accessing iFolder Files on Your Workstation,” on page 29.

1.2.3  Your iFolder Server User Account
Your iFolder server user account provides the network-based storage for the files in your iFolder 
directory. The iFolder server backs up your local files and enables you to synchronize files among 
er 2.1 User Guide
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your many workstations. Your files are always protected on the network and are easily recovered if 
your local data is lost.

After your iFolder administrator enables your user ID for iFolder services, you must use the iFolder 
client or the iFolder Java applet, which are available on your iFolder Web site, to initialize and 
configure your iFolder accounts. For information, see Section 2.1, “Initializing Your iFolder 
Account,” on page 13. 

1.2.4  Web-Based Access
The iFolder server supports Internet and network access to your iFolder data on the server without 
using the iFolder client. You can use a Web browser from any computer or Novell NetDrive from a 
Windows computer to access your files.

Web Access.  If you are away from your workstations or you want to access multiple iFolder 
accounts concurrently, you can access your files on the iFolder server using a Web browser instead 
of the iFolder client. You navigate to your iFolder Web site, then use the iFolder Java applet to 
manually download the files you want to work with. You must manually upload the files when you 
are done. You must also manually delete the local copy of the files before logging out of the 
borrowed workstation.

Novell iFolder 2.1.1 and 2.1.2 are bundled with Novell NetStorageTM and Novell Virtual Office. If 
available, you can use these interfaces to access your iFolder data using a Web browser. Virtual 
Office uses NetStorage to access your files. NetStorage requires manual download and upload of the 
files.

For more information, see Section 3.1, “Accessing iFolder Files Using a Web Browser,” on page 31.

Novell NetDrive Access.  If you sometimes work in an environment where you must share a 
Windows workstation with others, such as a university, iFolder provides an alternative to the iFolder 
client and Web access options: Novell NetDrive. With NetDrive, you can map the iFolder server as a 
network drive using a standard Internet or network connection. Then you access and work with your 
files as with any network drive. NetDrive transparently downloads and uploads files to a temporary 
directory on your workstation, similar to any mapped network drive. When you log out of NetDrive, 
it completes any outstanding uploads and deletes the files in the temporary directory. For more 
information, see Section 3.2, “Accessing iFolder Files Using Novell NetDrive,” on page 34.

1.2.5  Your iFolder Conflict Bin
The Novell iFolder conflict bin is a safety feature that helps prevent inadvertent deletion of your 
files during synchronization. The bin is an area of storage in your iFolder directory allotted to a file-
restore capability. Each workstation has its own conflict bin to store its files that encounter 
problems.

The iFolder Conflict Bin Viewer is a browser interface that lets you review files in the conflict bin. 
You can either manually delete files or restore them to the main portion of your iFolder directory 
from the bin. 

For more information, see “Viewing Files in the Conflict Bin” on page 27.
Overview 9
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1.2.6  File Synchronization
During synchronization using the iFolder client, iFolder downloads and uploads your personal files 
instantly. You must log in to the iFolder server to begin synchronization and log out to stop it. You 
can opt to log in when the client session begins or wait to log in later, depending on the 
synchronization needs in your personal work environment. 

The iFolder client allows you to set preferences to make the synchronization process as transparent 
to your daily operations as you want it to be. 

For example, you might set auto-synchronization to occur at fixed intervals while you are logged in. 
Alternatively, you might turn off auto-synchronization so that you manually control when 
synchronization occurs. Either way, the iFolder client session tracks and logs changes so that it is 
ready to synchronize files when you ask—as scheduled or on demand.

For more information, see Section 2.6, “Understanding File Synchronization,” on page 20.

1.2.7  File Encryption
Novell iFolder provides optional 128-bit Blowfish encryption to ensure the security of your files 
during synchronization. If you enable this option, you specify the encryption passphrase that iFolder 
uses to create the encryption keys for encrypting and decrypting your files. 

With encryption, iFolder provides secure transport across public and private IP connections and 
secure storage on the iFolder server. Your sensitive documents remain private as they travel and 
reside anywhere other than your local workstations.

For more information about file encryption, see Section 2.8, “Using File Encryption,” on page 24.

1.3  How iFolder Works
Novell iFolder is as simple and convenient to use as it appears. After installation, the iFolder client 
works transparently to synchronize your files. The following sequence reveals what is happening in 
the background:

1. The iFolder session begins when you start your computer.
2. The iFolder client logs and tracks changes you make to files in the iFolder directory.
3. You activate your Internet or network connection and log in to the iFolder server to activate 

synchronization, which then occurs at prespecified intervals or on demand.
4. When it is time to synchronize, the iFolder client reconciles changes in the iFolder directory 

with those on the server. It compares the metadata for the files and directories to determine if 
there have been changes since the last synchronization. 

5. The iFolder server downloads any new files from the iFolder server to the local iFolder 
directory. Typically, the synchronization transfers only the changed portion of an existing file 
on a 4 KB block level. It might transfer the entire file, depending on how the application in use 
saved file changes. If encryption is enabled for the account, the iFolder client decrypts the files 
before storing them in the directory. 

6. The iFolder client uploads any new files or changes to files from the local iFolder directory to 
the iFolder server. The synchronization transfers only the changed portion of an existing file on 
a 4 KB block level. It might transfer the entire file, depending on how the application in use 
er 2.1 User Guide
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saved file changes. If encryption is enabled for the account, the iFolder client encrypts the files 
before sending them out over the Internet or network connection to the iFolder server. 

7. The iFolder server receives the new files and increases its synchronization index.
8. If there is a conflict, iFolder uses time stamps for resolution and puts the old file in the conflict 

bin on the workstation.
9. Another of your iFolder client workstations connects to the iFolder server, and repeats Step 4 

through Step 8. The file changes from the first workstation are downloaded to second. The file 
changes from the second are uploaded to the iFolder server.

10. When the iFolder server next synchronizes with the first workstation, it downloads the new 
data it received from the second workstation to the first workstation.

In this way, iFolder captures information about the changes you make locally so that it can make 
those changes to files on the centralized iFolder server and, subsequently, to all your workstations.

1.4  What's New
• The iFolder client is now available on Linux desktops. The client supports SUSE® LINUX 9.2 

and Novell Linux Desktop.
• For more information about the install instructions and the known issues with the iFolder Linux 

client, refer to the Readme available with the client.
• The iFolder Linux client has been localized.
• The “Download iFolder Linux client” link has been integrated with the NetWare and Linux 

server Web pages.

1.5  What's Next
You must install and configure the iFolder client on your workstation before you can use it. For 
installation and configuration instructions, see the Novell iFolder Quick Start.

For detailed information about using iFolder, see Chapter 2, “Using the iFolder Client,” on page 13.
Overview 11
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2Using the iFolder Client

This section explains how to use the Novell® iFolder® client software to manage your iFolder files 
and to manage your iFolder account. It describes how to perform the following tasks:

• Section 2.1, “Initializing Your iFolder Account,” on page 13
• Section 2.2, “Installing the iFolder Client on Your Linux Workstations,” on page 15
• Section 2.3, “Installing and Configuring the iFolder Client on Your Windows Workstation,” on 

page 17
• Section 2.4, “Accessing iFolder Data,” on page 19
• Section 2.5, “Starting an iFolder Client Session,” on page 19
• Section 2.6, “Understanding File Synchronization,” on page 20
• Section 2.7, “Logging In to the iFolder Server,” on page 22
• Section 2.8, “Using File Encryption,” on page 24
• Section 2.9, “Using Proxy Settings,” on page 25
• Section 2.10, “Logging Out of the iFolder Server,” on page 25
• Section 2.11, “Exiting an iFolder Client Session,” on page 25
• Section 2.12, “Managing Your iFolder Account,” on page 26

2.1  Initializing Your iFolder Account
After the iFolder administrator enables your network User ID for iFolder services, you initialize 
your iFolder account the first time you log in to the iFolder server. During initialization, the iFolder 
server creates your iFolder data directory on the iFolder server, creates the LDAP iFolder User 
object for your account, and stores your user preferences for iFolder as attributes of the User object. 

If you plan to share an iFolder account with a small group of users, ask your administrator to set up 
a network user ID for that group. The first member to log in to the iFolder server under the group's 
username initializes the iFolder account.

Before you initialize your account, you must decide whether you want your iFolder account to 
encrypt files for transport across connections between your workstation and the server and while 
stored on the server. Otherwise, transport and storage on the server are in clear text only. The 
encryption setting (on or off) persists for the life of the account. The only way to change it is to 
delete the account completely from the server, then start the process again.

If the administrator allows encryption to occur, you must set the encryption or clear text preference 
when you initialize your account. To initialize your iFolder account with the encryption option, log 
in for the first time using the iFolder client or the iFolder Java applet. Make sure you log in for the 
first time to the iFolder server using a method that supports your preference.

Initialize your iFolder account using one of the following methods:

• Section 2.1.1, “Initializing an iFolder Account Using the iFolder Client,” on page 14
• Section 2.1.2, “Initializing an iFolder Account Using the iFolder Java Applet,” on page 14
• Section 2.1.3, “Initializing an iFolder Account Using NetDrive,” on page 14
Using the iFolder Client 13
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• Section 2.1.4, “Initializing an iFolder Account Using NetStorage,” on page 15

2.1.1  Initializing an iFolder Account Using the iFolder Client
You must use the iFolder client to take advantage of iFolder's automatic file synchronization. You 
can initialize encrypted or clear text iFolder accounts using the iFolder client. This method requires 
a workstation with a supported operating system for the iFolder client. For information, see Section 
2.3, “Installing and Configuring the iFolder Client on Your Windows Workstation,” on page 17. 

IMPORTANT: To enforce some global client settings, your iFolder administrator might require you 
to use the iFolder client to initialize your iFolder user account. 

2.1.2  Initializing an iFolder Account Using the iFolder Java 
Applet
The iFolder Java Applet allows an iFolder account to be initialized from any Windows or non-
Windows (such as Linux, UNIX, or Macintosh) workstation, using a Web browser. If your iFolder 
administrator sets the iFolder client policies to allow encryption, you can initialize your iFolder 
account to use encryption. Otherwise, only a cleart text iFolder account is possible.

IMPORTANT: The iFolder Java applet is offered as is. Novell no longer supports this software. 

To use this method, you must install and enable Sun* Java Virtual Machine 1.3 to 1.4.1_02 on your 
computer. To download Java software, see the Java Downloads Archive Web site (http://
java.sun.com/products/archive/index.html). 

Web-based access methods require manual file synchronization. You can install the iFolder client 
subsequently on multiple workstations to take advantage of iFolder's automatic file synchronization.

To initialize your iFolder account using the iFolder client:

1 Activate your Internet or network connection, then open your Web browser to the iFolder Web 
site. 

For example, enter 

http://nif1.your-domain-name.com/iFolder

Replace nif1.your-domain-name.com with the actual DNS name or IP address of your iFolder 
server. Get this information from your iFolder administrator.

2 From the iFolder Web site, click Login, then log in to the iFolder Java applet, using your 
username and password.

3 (Optional) To initialize the account with the encryption option, enter an encrytion passphrase 
for the iFolder user account. Otherwise, the account is a clear-text account.

2.1.3  Initializing an iFolder Account Using NetDrive
If your administrator provides Novell NetDrive 4.1 services, you can initialize your clear-text-only 
iFolder account using NetDrive. For information on installing and configuring NetDrive, see the 
Novell NetDrive 4.1 User Guide.
er 2.1 User Guide
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2.1.4  Initializing an iFolder Account Using NetStorage
For iFolder 2.1.x, iFolder is bundled with Novell NetStorage. If your system administrator 
configures NetStorage to support Web-based access to iFolder services, you can initialize a clear-
text-only iFolder account using NetStorage. Novell NetStorage can provide Web-based access to 
existing iFolder accounts that are clear text or encrypted, but it can initialize only clear-text 
accounts. 

1 Activate your Internet or network connection.
2 Open a Web browser to one of the following URLs:

• NetStorage (Folder View):  The folder view uses frames on the Web page to display the 
file management options.
http://nif1.your-domain-name.com/NetStorage

• NetStorage (Text View): The text view does not use frames to display file management 
options. It is an HTML-only view that is compatible with most Web browsers used on 
handheld devices.
http://nif1.your-domain-name.com/oneNet/NetStorage

In each example URL, replace nif1.your-domain-name.com with the actual IP address or DNS 
name of your iFolder server. Get the actual URL from your iFolder administrator.

3 Click Login. 
4 Log in for the first time to iFolder using your User ID and password.
5 If asked for a passphrase, uncheck the Encryption check box, then click OK.

For iFolder 2.1.x, NetStorage does not coordinate the passhprase with iFolder to initialize a 
new accounts. The NetStorage login simply passes the passphrase into the User object for 
storage. NetStorage sends only your username and password to iFolder, which iFolder uses to 
initialize a clear-text-only iFolder. 

2.2  Installing the iFolder Client on Your Linux 
Workstations
Install the iFolder client on every workstation that you typically use, including your desktops and 
laptops at work and home. The client supports the following Linux desktops:

• Novell Linux Desktop
• SUSE Linux 9.3

You need the iFolder client on your workstation to take advantage of the automatic synchronization 
feature of iFolder. However, you can access your files on the iFolder server from any computer or 
handheld device using a Web browser and an active Internet or network connection.

2.2.1  Prerequisites
Your iFolder administrator must provision your username for iFolder services before you can create 
and activate an iFolder account for that username. Typically, your username is the same as your 
network user ID. If you want to share an iFolder account with a small group of users, ask your 
iFolder administrator to create and provision a shared identity in the LDAP directory.
Using the iFolder Client 15
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Before you install the client, make sure your workstation meets the following prerequisites:

• Internet or network connection activated
• Free space of 5 MB on the disk to install the client

2.2.2  For iFolder Icon to be Visible on the Panel 
For iFolder icon to be visible on the panel, ensure Notification Area / System Tray is present on 
GNOME /KDE. 

• To enable Notification Area in GNOME desktop, right-click panel > Add to Panel > Utility > 
Notification Area.

• To enable System Tray in KDE desktop, right-click the panel > Add > Applet > System Tray.

2.2.3  Installing the iFolder Client on a Linux Desktop
1 Log on to the super user mode. This ensures that you have privileges to install software. 
2 (Conditional) Uninstall any prototype version of the client that exists on the desktop. This 

ensures a clean install.
3 Download the novell-ifolder-client.rpm file, the client install program.

3a Launch a Web browser.
3b Go to the beta download Web site.
3c From the beta Web site, download the .rpm file to a local download directory

4 Extract and install the .rpm file by executing the following command at the console prompt:
rpm -i novell-ifolder-client.rpm -h -v 

Or
rpm -U novell-ifolder-client.rpm -h -v 

where

For more details, refer to the man page of rpm command by executing man rpm at the system 
console.
Wait while the rpm extracts and installs the package.

5 Verify that the package was installed successfully by executing the following:

rpm Installs the package

-i Option to install

-U Option to upgrade. (However, because this is the 
first release, this option has same effect as -i 
option.)

-h Prints hash progress bar as the package archive 
is unpacked

-v Displays verbose messages

--test Tests the install. However, it does not install the 
package.
er 2.1 User Guide
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rpm -qa | grep novell-ifolder-client

where
-grep: Enables the search for the specified file

6 View the list of files by executing the following:
rpm - ql novell-ifolder-client

where
ql: Enables query list

7 View the iFolder man page by executing man novell-ifolder-client at the system console.

2.2.4  Automatically Starting iFolder Linux Client 
To automatically start iFolder Linux client, when the Linux System reboots, complete the following:

On Ximian Desktop

1 Select System > Personal Settings >Sessions.
2 In Sessions screen, select Startup Programs tab, Press Add and then add the following to the 

start up command:
/opt/novell/ifolder/bin/novell-ifolder-client

On KDE

Include the link in $HOME/.kde/Autostart.

2.3  Installing and Configuring the iFolder Client 
on Your Windows Workstation
You install the Novell iFolder client on each desktop or laptop that you typically use. You need the 
iFolder client on your workstation to take advantage of the automatic synchronization feature of 
iFolder. We recommend that you log in for the first time to the iFolder server from your workstation, 
using the iFolder client.

IMPORTANT: To enforce some global client settings, your iFolder administrator might require you 
to use the iFolder client to initialize your iFolder user account. 

The Win32 version of the iFolder client is designed for workstations that use the following 
Microsoft* operating systems:

• Windows* 98SE
• Windows XP Home and Professional 
• Windows 2000 Professional

To prepare for installing the iFolder client:

• Section 2.3.1, “Downloading the iFolder Client to Your Workstation,” on page 18
• “Installing and Using iFolder on a Workstation with Multiple Windows Logon Users” on 

page 18
Using the iFolder Client 17
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To install and configure the iFolder client, follow the instructions in the Novell iFolder Quick Start. 

2.3.1  Downloading the iFolder Client to Your Workstation
To download the iFolder client:

1 Activate your Internet or network connection.
2 Open your Web browser to the iFolder Web site. For example, enter 
http://nif1.your-domain-name.com/iFolder

Replace nif1.your-domain-name.com with the actual DNS name or IP address of your iFolder 
server. Get this information from your iFolder administrator.

3 From the iFolder Web site, click Download, then save the iFolder client installation file to your 
workstation.

4 To install and configure the iFolder client, follow the instructions in the Novell iFolder Quick 
Start. 
To download an HTML version of the Novell iFolder Quick Start, from the iFolder Web site, 
click Quick Start.

2.3.2  Installing and Using iFolder on a Workstation with 
Multiple Windows Logon Users
For Windows 2000/XP workstations, Windows requires that the Administrator user or a user with 
Administrator rights be the one who installs the iFolder 2.1 client on the workstation. If you define 
multiple Windows logon users for a Windows 2000/XP workstation, the iFolder users must log on to 
their Windows account to configure their own iFolder accounts. 

After the Administrator installs the iFolder client, a user can log on to the workstation using an 
assigned Windows logon account. The user starts the iFolder client and logs in for the first time to an 
iFolder server account. When this happens, iFolder 2.1 associates the active Windows logon account 
to that iFolder account for that workstation. No other Windows logon account on that workstation 
can access that iFolder account using the iFolder client. Other logon accounts can access the iFolder 
account using a Web browser or NetDrive.

If you want multiple Windows logon accounts to be able to access the same iFolder account from the 
same workstation, you have two options:

• You can set up a shared Windows logon account for all users of that workstation to use when 
they access that iFolder account.

• One Windows logon account can use the iFolder client to access the iFolder account, and other 
Windows logon accounts on the workstation can access the iFolder account using Novell 
NetDrive or the Web-browser interface to iFolder when they are logged in to their own 
accounts. 
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2.4  Accessing iFolder Data
After you initialize your iFolder account, you can store and access iFolder data using one or more of 
the following iFolder interfaces, depending on your iFolder system.

• iFolder Client:  The iFolder client stores a copy of your iFolder data in the local iFolder folder. 
Click the iFolder icon in your system tray to log in to the iFolder server and synchronize files 
automatically or on demand.

• iFolder Java Applet (iFolder Web site):  Go to the iFolder Web site, then click Login to open 
the Java applet. 
http://nif1.your-domain-name.com/iFolder

• iFolder Java Applet (URL):  Go to the following URL, then click Login to open the Java 
applet. 
http://nif1.your-domain-name.com/iFolder/applet/java.htm

• Novell NetDrive:  Download, install, and configure Novell NetDrive, then map a drive with 
NetDrive to the iFolder server where your existing iFolder account resides. Get the NetDrive 
download location and the iFolder server address from your iFolder administrator. For 
information, see the Novell NetDrive 4.1 User Guide

• Novell NetStorage (Folder View):  If your administrator makes Novell NetStorage available 
to you, go to the following URL, then log in to access your iFolder files. The folder view uses 
frames on the Web page to display the file management options.
http://nif1.your-domain-name.com/NetStorage

• Novell NetStorage (Text View): If your administrator makes Novell NetStorage available to 
you, go to the following URL, then log in to access your iFolder files in a text view. The text 
view does not use frames to display file management options. It is an HTML-only view that is 
compatible with most Web browsers used on handheld devices.
http://nif1.your-domain-name.com/oneNet/NetStorage

• Virtual Office:  If your administrator makes Novell NetStorage available to you, go to the 
following URL, then log in to access your iFolder files.
http://nif1.your-domain-name.com/vo

In each example URL, replace nif1.your-domain-name.com with the actual IP address or DNS name 
of your iFolder server. Get this information from your iFolder administrator.

For information, see Chapter 3, “Using Web Access Methods to Access iFolder Data,” on page 31.

2.5  Starting an iFolder Client Session
The Novell iFolder client automatically starts when you start your computer. It initiates an iFolder 
session and places an iFolder icon in the system tray on your desktop. 

The icon indicates when the iFolder synchronization is suspended (dimmed icon) and active 
(colored icon). Right-click the iFolder icon to manage synchronization of your files and to manage 
your iFolder account.

If you exit the iFolder session, you can start a new iFolder session by clicking Start > Programs > 
Novell iFolder > iFolder Client.
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2.6  Understanding File Synchronization
A Novell iFolder client session securely synchronizes files among your workstations and the iFolder 
server. The iFolder client encrypts and uploads your files across an Internet connection to an iFolder 
server that is located in your corporate data center or on the premises of your third-party iFolder 
service provider. 

Synchronization involves the following key tasks:

• “Synchronizing Files on All Your Workstations” on page 20
• “Activating Synchronization in an iFolder Session” on page 20
• “Synchronizing Files Automatically” on page 21
• “Stopping File Synchronization Automatically” on page 21
• “Synchronizing Files on Demand” on page 21
• “Stopping File Synchronization on Demand” on page 21

2.6.1  Synchronizing Files on All Your Workstations
Install the iFolder client software on each of your handheld devices, laptop computers, and other 
home and office computers where you will need to access your files. See the Novell iFolder Quick 
Start (http://www.novell.com/documentation/lg/ifolder21/index.html) on the Novell Documentation 
Web site for installation instructions.

When iFolder is active on your workstations, the iFolder client and the iFolder server work together 
to synchronize your files among all your work environments and the server. On those workstations 
that are not active, synchronization will occur when you next log in from that workstation.

When you do not have access to your own computers, you can access your files on the iFolder server 
by using a Web browser from any computer connected to the Internet. See Section 3.1, “Accessing 
iFolder Files Using a Web Browser,” on page 31 for more information. 

2.6.2  Activating Synchronization in an iFolder Session
Synchronization occurs only when you log in to the iFolder server. See Section 2.7, “Logging In to 
the iFolder Server,” on page 22 to learn more about the login process.

The client automatically prompts you to log in when it starts the session. If you log in, the iFolder 
session immediately connects to the iFolder server and synchronizes your files with those stored on 
the iFolder server. 

TIP: Do not log in to iFolder until you are ready for synchronization to begin. 

If you click Cancel, the iFolder client session stays open but suspends synchronization until you 
manually initiate the login process. It continues to log and track transparently any changes that you 
make to files in your local iFolder directory. Then when you log in, the iFolder client synchronizes 
those changes with your iFolder server. 
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2.6.3  Synchronizing Files Automatically
You must log in to the Novell iFolder server to activate the default auto-synchronization process 
between the iFolder client and the iFolder server. Log in as the session starts, or afterwards by right-
clicking the iFolder icon, then clicking Login. See Section 2.7, “Logging In to the iFolder Server,” 
on page 22 to learn more about the login process.

For information on how to set your default auto-synchronization preferences, see “Setting iFolder 
Preferences” on page 27.

2.6.4  Stopping File Synchronization Automatically
To stop auto-synchronization, you can suspend synchronization by logging out of the iFolder server. 
(Right-click the iFolder icon, then click Logout.)

You can also turn off auto-synchronization as part of your iFolder account preferences. For 
information on how to set your default auto-synchronization preferences, see“Setting iFolder 
Preferences” on page 27.

2.6.5  Synchronizing Files on Demand
There are two ways to synchronize files on demand for Novell iFolder when you are logged in:

• Right-click the iFolder icon, then click Sync Now. 
• Right-click the iFolder icon, then click Account Information > View Activity > Sync.

When you select these options, iFolder immediately synchronizes the files in your local iFolder 
directory with your files on the iFolder server, uploading and downloading any changes that have 
been made.

If you are logged out, you can log in to begin immediate synchronization.

2.6.6  Stopping File Synchronization on Demand
There are three ways to stop synchronizing files for Novell iFolder when an iFolder session is in 
progress:

• To suspend synchronization, right-click the iFolder icon, then click Logout.
• To temporarily stop a synchronization in progress without logging out, right-click the iFolder 

icon, click Account Information > View Activity > Stop. To resume, click Sync.
• To stop synchronization and background tracking of changes made in your local iFolder 

directory, right-click the iFolder icon, then click Exit. This ends your iFolder session. 
You will need to start an iFolder client session manually, or restart your computer, to initiate an 
iFolder session.

When you select these options, iFolder immediately ceases actively synchronizing the files in your 
local iFolder directory with your files on the iFolder server.
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2.7  Logging In to the iFolder Server
Log in to the Novell iFolder server only when you want to synchronize files in your local iFolder 
directory with those in the iFolder server. See Section 2.6, “Understanding File Synchronization,” 
on page 20 for more information about how iFolder works to synchronize your files.

2.7.1  Before You Begin
Before you begin the login process, you must have an active Internet or network connection to log in 
to the iFolder server.

You will need the following information:

Your iFolder user ID and password (typically the same as your network user ID and password).
If you enabled encryption, your iFolder encryption passphrase that you set during configuration 
of your iFolder account. 
SeeSection 2.8, “Using File Encryption,” on page 24 for more information.
If the iFolder client must access the iFolder server through a proxy server from this 
workstation, your network proxy server’s settings (IP address or DNS name and port number 
provided by your system administrator), your proxy user ID, and proxy password. 
See Section 2.9, “Using Proxy Settings,” on page 25 for more information.

2.7.2  Starting the Login Process
To log in to iFolder, right-click the iFolder icon, then click Login in the iFolder client pop-up menu. 
This opens a Login dialog box where you begin the login process. 

1 Enter your user ID and password for your iFolder account. 
2 If you use encryption, enter your encryption passphrase.
3 If you use proxy settings, enter your proxy ID and password. 

2.7.3  Remembering Your Password
If you choose, iFolder can remember your login password. The next time you begin the login 
process, the password will be entered automatically in the Password field.

To enable the automatic password exchange: 

1 Log in to the iFolder client.
2 Right-click the iFolder icon in the system tray, click Account Information > Preferences.
3 Uncheck the Remember Password check box.
4 Click Apply, then click Yes.
5 Close the iFolder account management window.

The next time you start your computer, the iFolder client automatically logs you in.

To disable the automatic password exchange: 

1 Log in to the iFolder client.
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2 Right-click the iFolder icon in the system tray, click Account Information > Preferences.
3 Uncheck the Remember Password check box.
4 Click Apply, then click Yes.
5 Log out of the iFolder client now or later, as desired.
6 Close the iFolder account management window.

The next time you log in to the iFolder client, you must enter your password to log in.

2.7.4  Using the Remember Password Option
If you work in an environment that requires frequent password changes, you might want to disable 
the Remember Password option in the login sequence. The iFolder client does not alert you about 
expired passwords and it is possible that you will exceed the number of grace logins allowed by your 
network. If your password expires while you are logged out, you will not be able to log in to iFolder 
to set the new password.

To avoid this problem, do not use the Remember Password option in environments that require 
frequent password changes.

Avoiding Being Locked Out of Your iFolder Account When Changing Your Password

If you choose to enable the Remember Password option in the iFolder client, make sure to monitor 
the validity of your password through other means. Whenever you receive notice to change your 
password for the user ID that is also your iFolder username, or if you decide to change your 
password, you must disable the Remember Password option for all instances of the iFolder client on 
your workstations before you change your password to avoid being locked out of your iFolder 
account.

To change the password associated with your iFolder username: 

1 For each instance of the iFolder client where you have enabled the Remember Password option, 
disable the Remember Password option.
1a Log in to the iFolder client.
1b Right-click the iFolder icon in the system tray, then click Account Information > 

Preferences.
1c Uncheck the Remember Password check box, click Apply, then click Yes.
1d Click File > Logout.

2 Log in to your network and change your password, following any procedures set by your 
network administrator.

3 Log in to your iFolder account using the iFolder client, entering the new password instead of 
the old one.

4 If desired, re-enable the Remember Password option.
4a Right-click the iFolder icon in the system tray, then click Account Information > 

Preferences.
4b Check the Remember Password check box, click Apply, then click Yes.

The next time your start your computer, the iFolder client logs in automatically.
4c Close the iFolder account management window.
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2.8  Using File Encryption
If you choose, Novell iFolder can use an encryption passphrase as the key to encrypt your data on 
the server and during transmission. After you set your encryption passphrase, it must be entered 
whenever you log in to the iFolder server.

The files in your local Novell iFolder directory reside on your workstation in plain text and on the 
iFolder server in encrypted form. To ensure security and privacy during transmission and storage, 
iFolder encrypts the files using the encryption passphrase you specified when you installed iFolder 
client. 

Encryption occurs before the files leave your workstation to travel securely across an Internet 
connection to be uploaded to, and stored on, the iFolder server. The files remain encrypted on the 
iFolder Server and during downloads to your workstations. The iFolder client decrypts the 
downloaded files as they arrive on your local workstations. 

After you successfully log in to iFolder, a Get Passphrase dialog box opens where you can enter 
your encryption passphrase. 

2.8.1  Remembering Your Encryption Passphrase
If you choose, iFolder can remember your passphrase. The next time you begin the login process, 
this passphrase exchange will be done automatically; no dialog box will appear.

To turn off the automatic passphrase exchange, right-click the iFolder icon, click Account 
Information > Preferences, uncheck the Remember Passphrase check box, then click Apply.

2.8.2  Recovering Your Encryption Passphrase
Encryption Passphrase Recovery is an option you can set during the installation process, if your 
iFolder administrator enables it. This option is highly recommended because it allows the iFolder 
administrator to help you access your files on the iFolder server if you ever forget your iFolder 
encryption passphrase.

Some iFolder administrators enable Passphrase Recovery as a default, making it mandatory for all 
users. If so, they can reveal your encryption passphrase after authenticating your identity. 

What to Do If You Forget Your Encryption Passphrase

Because you enter the encryption passphrase only after successfully logging in with the user ID and 
password, you can guess multiple times without consequence. However, if you cannot recall your 
encryption passphrase, and if you enabled the Passphrase Recovery option, your administrator can 
send you a hint to help you recall your encryption passphrase. 

If you disabled Passphrase Recovery, your iFolder administrator can reset your account as a last 
resort. However, this means that your files on the iFolder server will be deleted along with the 
metadata about your account. The only good copy of your data resides in the most current local 
iFolder directory among your workstations. 

Before the administrator resets your server account, log out of all client sessions with the iFolder 
server. After the reset, log in to the iFolder server from the workstation that has the most current 
version of your files. During login, you will set and confirm a new encryption passphrase. 
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Upon successful login, your files will synchronize with the iFolder server. This upload time will 
vary, depending on the amount of data to be uploaded and the speed of your Internet connection. 

2.9  Using Proxy Settings
In an enterprise that uses the Internet, a proxy server acts as an intermediary between you and the 
Internet so that the enterprise is kept secure. To you, the proxy server is invisible; all Internet 
requests and returned responses appear to be directly with the Internet server you are querying. 
However, the proxy is not quite invisible; its IP address must be specified as a configuration in the 
browser or, in this case, when logging in to the iFolder server.

If you need to connect to a proxy server, right-click the iFolder icon, click Login > Set Proxy, 
specify the IP address or DNS name and the port of your proxy server, then click OK. If you do not 
know this information, ask your iFolder or network administrator.

If you connect to your iFolder server through a proxy server, a third dialog box will open to get your 
proxy user ID and password. If you do not know this information, ask your system administrator.

2.10  Logging Out of the iFolder Server
There are three possible reasons you might want to log out of the iFolder server:

• To suspend synchronization of files.
• To allow another user to log in.

The Logout feature allows users to share an identity for accessing an iFolder account and to 
timeshare the same files. Because iFolder does not provide a file locking mechanism to enable 
file sharing, you cannot have multiple users simultaneously logged in to a single iFolder 
account from different workstations, using the same files collaboratively. 

• To log in to a different account.
The Logout feature allows you to log out of your current iFolder session, because a user cannot 
be logged in to more than one account at the same time on the iFolder server. 

To log out of your current iFolder client session, right-click the iFolder icon, then click Logout. 
Even though you are logged out, the iFolder client is still tracking changes between the files in your 
working folder and the iFolder server. 

2.11  Exiting an iFolder Client Session
The Exit command terminates your Novell iFolder client session. It also removes the iFolder icon 
from the system tray on your workstation.

Unlike the Logout command, which simply suspends synchronization, the Exit command turns off 
the logging and tracking of changes to files in your local iFolder directory. Without a log of changes, 
iFolder must search the metadata on the server and your workstation to determine what needs to be 
synchronized, create the log, and then synchronize files. Thus, the elapsed time you need to allow 
for the synchronization process can be much longer. 

Upload and download conflicts might also occur when you start a new iFolder client session after 
exiting. iFolder writes the files involved in conflicts to the Conflict Bin.

To start a new iFolder session after exiting, click Start > Programs > Novell iFolder > iFolder Client.
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2.12  Managing Your iFolder Account
To view and manage your Novell iFolder account, right-click the iFolder icon, then click Account 
Information. A Novell iFolder window opens on your desktop. 

You can use the toolbar at the top to view the conflict bin and access help.

The iFolder window also provides three property tabs:

• Account Information

See “Viewing Account Information” on page 26 for details.
• View Activity

See “Viewing Account Activity” on page 27 for details.
• Preferences

See “Setting iFolder Preferences” on page 27 for details.

2.12.1  Viewing Account Information
The Account Information tab displays information about how you have configured and are using 
your iFolder client. It is divided into the following three sections:

User Information

Lists your current user ID, the location of your local Novell iFolder directory on the current 
workstation, and the IP address of the iFolder server where your files are stored.

Server Information

Lists the total space you have on your iFolder server. It also lists how much of that total space is 
used space or free space. 

Your iFolder administrator assigns the storage quota that you are permitted on the iFolder server. On 
first install, the iFolder client sets up your iFolder account on the iFolder server with a default quota 
of online storage. Within that quota, you must manage your working files and the conflict bin. For 
example, given a quota of 200 MB, you might set aside 10 percent, or 20 MB, for the conflict bin.

TIP: If you need to make room for additional files, check the Conflict Bin to clear unneeded files 
and to reallocate space allotted to your bin.

Your iFolder administrator can help you determine an account quota that best meets your needs. 
When deciding what your quota should be, consider your work environment and the types and sizes 
of files typical for you. For example, any files that are larger than the quota will not be synchronized 
because doing so would exceed the storage allotment on the iFolder server. 

If you need more space, contact your iFolder administrator.

Client Information

Lists the size of the files that are waiting to be uploaded to the server from your workstation and the 
number of files that the iFolder client has yet to synchronize with the iFolder server.
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2.12.2  Viewing Account Activity
The View Account Activity tab displays a log of the changes that are uploaded or downloaded 
between the iFolder client and the iFolder server. The log records the time and date that a change 
was made, followed by a short description of what type of change took place. When you make a 
change to a file in your iFolder directory, the changes are automatically logged and tracked.

Click Sync to force the server to synchronize with your local iFolder directory. While files are 
synchronizing, click Stop to pause the synchronization process. 

You also have the option to save your log activities or to clear the log of all its current entries.

2.12.3  Setting iFolder Preferences
The Preference tab sets your preferences for synchronization, encryption passphrase, and login 
password. To set iFolder preferences, right-click the iFolder icon, then click Account Information > 
Preferences. 

Setting Synchronization Preferences

You can turn auto-synchronization on or off by checking or unchecking the Automatic Sync check 
box. 

• Synchronize to Server: Sets the delay (in seconds) between making changes to your iFolder 
files and the time that the iFolder client uploads them to the iFolder server. 

• Synchronize from Server: Sets the interval of time (in seconds) that the iFolder client waits to 
check with the iFolder server to see what changes need to be downloaded to your workstation. 

If you adjust either of these values, click Apply for your changes to take effect.

Setting Login Preferences

You can request that the iFolder client remember your password and encryption passphrase so that 
you do not need to enter them each time you activate synchronization for your iFolder files.

2.12.4  Viewing Files in the Conflict Bin
Conflicts sometimes occur between versions of files during synchronization, as files are exchanged 
between your workstations and the Novell iFolder server. If a conflict arises between versions of 
files being concurrently synchronized among your workstations, iFolder gives priority to the file 
with the most current time stamp. Then, it saves the disputed file in the Conflict Bin. However, if the 
file size exceeds the maximum capacity you have specified for the bin, the file will not be saved. 
Also, if the bin is full, iFolder deletes the files according to a first-in-first-out rule to make room for 
new conflicted files.

For example, suppose that you have the iFolder client installed on two computers: computer A and 
computer B. At some point in the day, you disconnect both of these computers from the network and 
continue to work from both computers offline. While you are working, you make a change to one of 
your iFolder files on computer A and then, later in the day, using computer B, you make a different 
change to that same file. You now decide to work online, so you reconnect computer B and then 
computer A to the network in order to synchronize your changes to the iFolder server. 
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When you reconnect computer B to the network, its change is uploaded to the iFolder server. 
However, when you reconnect computer A to the network, it also uploads its change to the iFolder 
server, overwriting the newer change that you made on computer B. To prevent data loss, iFolder 
saves the overwritten file to the conflict bin.

Opening the Conflict Bin Viewer

The Conflict Bin Viewer allows you to view and manage files that were saved in the conflict bin 
when they were overwritten or deleted during a synchronization. You must be logged in to the 
iFolder client to view and manage the files in the conflict bin. 

To view and manage the files saved in your iFolder conflict bin:

1 Log in to the iFolder client.
2 Open the Conflict Bin Viewer using one of the following methods:

• Right-click the iFolder icon in the system tray, then click View Conflict Bin.
• Right-click the iFolder icon in the system tray, then click Account Information > View > 

View Conflict Bin.

Setting the Bin Size

In the Conflict Bin Viewer, you can set the maximum space (in MB) you want to reserve for the files 
in conflict. This space is not part of the total space allocated to you for iFolder storage by your 
iFolder administrator. The conflict bin resides on your local hard drive, not on the server.

To set the maximum size of your conflict bin:

1 In the Conflict Bin Viewer, click File > Properties.
2 Specify the maximum space to reserve.
3 Click OK.

Restoring and Deleting Files in the Conflict Bin

You can restore or permanently delete the files in your Conflict Bin. A restored file moves from the 
conflict bin to your local iFolder directory. After it is restored, iFolder updates the copy of the file in 
your directory on the iFolder server whenever you next login to iFolder from that workstation.

To restore files in the conflict bin: 

1 In the Conflict Bin Viewer file list, select the files you want to restore.
2 Click Restore.

To permanently delete files in the conflict bin:

1 In the Conflict Bin Viewer file list, select the files you want to delete.
2 Click Delete.
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2.13  Accessing iFolder Files on Your 
Workstation
With Novell iFolder, you transparently maintain copies of your files in your local iFolder directory 
on each workstation and on the iFolder server.

2.13.1  Opening Your Local iFolder Directory
You can access the local Novell iFolder directory as you would any directory on your workstation. 

The iFolder client places a shortcut to your local iFolder directory on your desktop during 
installation. Another way to easily open your local iFolder directory is to right-click the iFolder icon 
in your system tray, then click Open iFolder.

To access any of the files in the local iFolder directory, your computer needs to have the application 
associated with each of the files. For example, if you have a Word document in the current local 
iFolder directory and you want to modify it, Word must be installed on the computer.

2.13.2  Changing Your Local iFolder Directory
Novell iFolder allows you to choose the location of your local iFolder directory during the 
installation of the iFolder client. You can also change the location at any time.

If you change the location of an existing local iFolder directory, you must manually move or copy 
any existing files from the old location to the new location in order for iFolder to synchronize 
properly. 

Moving the Location of Your Local iFolder Directory

To move the location of your iFolder directory:

1 Log in to iFolder.
2 Right-click the iFolder icon in the system tray, then click Account Information > File > Set 

iFolder Location.
3 Specify the path to new iFolder location.
4 Log out of iFolder.
5 Move your iFolder files from the old location to the new location. 

This will prevent iFolder from downloading your entire account to the new location.
6 Log in to iFolder.

Moving Files from an Old Local iFolder Directory to a New One

1 Double-click the iFolder shortcut (to the old location) on your desktop.
2 Click Edit > Select All.
3 Click Edit > Cut.
4 Close the window.
5 Double-click the iFolder shortcut (to the new location) on your desktop, or navigate to the 

location in your directory browser.
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6 Click Edit > Paste.
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3Using Web Access Methods to 
Access iFolder Data

Novell® iFolder® provides Web access to your iFolder data on the iFolder server. Using an active 
Internet or network connection and a Web browser, you can access your data from any workstation, 
without using the client software. After you initialize your iFolder account, you can access iFolder 
data from any of the user interfaces, including the iFolder client on Windows machines and a Web 
browser on any machine to access iFolder using the Java applet. For iFolder 2.1.1 and 2.1.2, you can 
also access your iFolder data through Novell NetStorageTM and Novell Virtual Office. Virtual Office 
provides access to iFolder through the NetStorage interface.

For more information:

• Section 3.1, “Accessing iFolder Files Using a Web Browser,” on page 31
• Section 3.2, “Accessing iFolder Files Using Novell NetDrive,” on page 34

3.1  Accessing iFolder Files Using a Web 
Browser
With Novell iFolder, you can access your iFolder data from any computer that has an active Internet 
or network connection—even from your handheld devices. From a Web browser, you can view, 
access, and modify all of your iFolder files stored on the iFolder server.

When you access your iFolder files through a Web browser, you can download only the files that 
you need instead of the whole directory. However, there is no automatic synchronization of changes 
to the iFolder server, as with the iFolder client. 

When you use a browser, you must manually download and save files to your desktop, work on 
them, and then upload the files to the Folder server. After the files have been uploaded to the iFolder 
server, iFolder synchronizes the changes to your other computers that do use the iFolder client. 

If you are working on a computer that is not yours, delete the files that you worked on from the 
location where you saved them on the hard drive; otherwise, someone could access them after you 
are gone.

With iFolder, you can access your account using any of the following Web access methods that are 
supported in your network environment:

• Java Applet (iFolder Web Site View):  Go to the following URL, then click Login to open 
the Java applet. 

http://nif1.your-domain-name.com/iFolder

• Java Applet (Applet Only View):  Go to the following URL to open the Java applet. 
http://nif1.your-domain-name.com/iFolder/applet/java.htm

• NetStorage (Folder View):  Go to the following URL, then log in to access your iFolder files. 
The folder view uses frames on the Web page to display the file management options.
http://nif1.your-domain-name.com/NetStorage
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• NetStorage (Text View): Go to the following URL, then log in to access your iFolder files in a 
text view. The text view does not use frames to display file management options. It is an 
HTML-only view that is compatible with most Web browsers used on handheld devices.
http://nif1.your-domain-name.com/oneNet/NetStorage

• Virtual Office:  Go to the following URL, then log in to access your iFolder files.
http://nif1.your-domain-name.com/vo

In each example URL, replace nif1.your-domain-name.com with the actual IP address or DNS name 
of your iFolder server. Get this information from your iFolder administrator.

For more information about the two main Web-based interfaces: 

• Section 3.1.1, “Accessing Files Using Novell NetStorage,” on page 32
• “Accessing Files Using the iFolder Java Applet” on page 33

3.1.1  Accessing Files Using Novell NetStorage
If Novell NetStorage services are available on your system, your administrator can configure 
NetStorage to support iFolder data access. Novell NetStorage is available in the bundled release of 
iFolder 2.1.x with NetWare® 6.5 and later and with Novell NterpriseTM Linux Services.

To access your iFolder data using the NetStorage folder view, enter the following URL in your Web 
browser:

https://nif1.your-domain-name.com/NetStorage

Figure 3-1   Example of the Novell NetStorage Folder View

To access your iFolder data using the NetStorage text view, enter the following URL in your Web 
browser:
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https://nif1.your-domain-name.com/oneNet/NetStorage

IMPORTANT: The NetStorage folder view and text view URLs are case sensitive.

Figure 3-2   Example of the Novell NetStorage Text View

3.1.2  Accessing Files Using the iFolder Java Applet
The iFolder Java applet provides basic file access to your iFolder data. You can browse, upload, 
download, copy, move, delete, and rename files.

1 Activate your Internet or network connection. 
2 Go to the iFolder Web site using one of these methods. 

• Right-click the iFolder icon in the system tray, then click iFolder Web Site.
• Open your Web browser directly to the iFolder Web site. For example, enter 
http://nif1.your-domain-name.com/iFolder

Replace nif1.your-domain-name.com with the actual DNS name or IP address of your 
iFolder server. You can get this information from your iFolder administrator.

3 Do one of the following:
• Click Login to access your local iFolder directory using the iFolder Java* applet.

In order to view and manipulate your iFolder files using the Java applet, you must install 
and enable Sun Java Virtual Machine 1.3 or later on your computer. To download free 
Java software, see the Java Web site (http://www.java.com).

• For iFolder 2.1 and 2.1.1, click Login (PDA) to access your local iFolder directory via 
HTML access (for PDA devices such as Palm* Pilots, etc.). 
This option is not available in iFolder 2.1.2. Instead, use the Novell NetStorage text view.

4 Enter your user ID, password, and encryption passphrase (if required), then click Connect.
The IP address of your iFolder server should already be filled in for you.
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After you are logged in, the iFolder Java applet displays the network files and folders currently 
accessible to you. They appear in a directory structure similar to what you would see in Windows 
Explorer. 

Figure 3-3   Example of the Java Applet via the iFolder Web Site

Click Folder View to display folders in another column and to expand and collapse folders. The Text 
View only displays the files and folders in the current directory and does not allow you to expand or 
collapse folders.

You can use many of the same conventions for expanding and collapsing folders and opening files 
that are available in Windows Explorer. To expand the folder and view the files, double-click the 
Home folder. To create new folders or copy, delete, rename, move, upload, or download existing 
files or folders, click the down-arrow next to the file or folder.

IMPORTANT: When downloading or uploading iFolder files from a browser, do not click any of 
the links on the current page; otherwise, the file transfer will be interrupted. If you want to go to 
another Web site while downloading or uploading files, open another browser window.

Local files and folders are not accessible using this interface. Use the file directory interface on your 
workstation to view local files and folders.

3.2  Accessing iFolder Files Using Novell 
NetDrive
Novell NetDrive allows you to map a drive from your computer to an iFolder server, using Internet 
protocols to connect to the server. NetDrive also allows you to map concurrently to multiple iFolder 
accounts by mapping each as a different drive.

Before you map a drive using NetDrive, you must do the following:

• Install NetDrive on your Windows workstation.
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For information, see the Novell NetDrive 4.1 User Guide.
• Activate your Internet or network connection.
• Know the IP address or DNS name of your iFolder server.

After mapping to the iFolder server, the drive letter appears in your directory browser and the drive 
functions like any conventionally mapped drive. You can easily view, access, and modify the files in 
your iFolder account as if they were on you local system. 

With NetDrive, no Web browser is required to access the files on the iFolder server. You do not need 
to download and upload files manually to your workstation as you would with Web access options 
or with the iFolder client. 

When you log out of the workstation, the mapping to your iFolder account is disabled. There are no 
local files to delete before you log off in the shared computing environment, unless you have moved 
a file to the local system during your session.

For information about using NetDrive to access files on your iFolder server, see the Novell NetDrive 
User Guide (http://www.novell.com/documentation/lg/ifolder21/index.html) on the Novell iFolder 
Documentation Web site.
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ATips and Tricks for Synchronizing

This section describes tips and tricks for synchronizing your personal files using the local Novell® 
iFolder® 2.1 directory, including the following:

• Section A.1, “Synchronizing your E-mail Archives,” on page 37.
• Section A.2, “Synchronizing Your IE Favorites,” on page 38.
• Section A.3, “Synchronizing Your Palm Desktop Database,” on page 39.
• Section A.4, “Synchronizing Your Lotus Notes Files,” on page 39.
• Section A.5, “Synchronizing to Protect Data of Various Programs,” on page 40.

A.1  Synchronizing your E-mail Archives
Depending on the file structure used for archiving your e-mail files, you might be able to use Novell 
iFolder to synchronize your e-mail accounts among your workstations. 

• “GroupWise Files” on page 37.
• “Microsoft Outlook Files” on page 37.
• “Microsoft Outlook Express Files” on page 38.
• “Netscape Communicator Files” on page 38.

A.1.1  GroupWise Files

WARNING: Do not try to synchronize your GroupWise® archive by setting a GroupWise archive 
path to the location of your iFolder directory. If you do this, the iFolder client will corrupt the 
GroupWise archive. This happens because iFolder does not synchronize files as a set and 
GroupWise needs the files in the archive to be maintained as a set of files.

A.1.2  Microsoft Outlook Files 
To move the default location of your Microsoft Outlook* e-mail files to your local iFolder directory: 

1 Create a folder called outlook in your local iFolder directory. 
2 Click Start > Search > For Files and Folders, then enter pst to identify the location of your 

Outlook e-mail archive files. 
3 Close Outlook, then locate and move the PST files to the outlook folder you created. 
4 Open Outlook. 

A message appears to report the PST as missing. 
5 Type the path to the outlook folder you created, or click Browse to navigate to the PST file. 
6 Click OK.
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A.1.3  Microsoft Outlook Express Files
To move the default location of your Microsoft Outlook Express e-mail files to your local iFolder 
directory:

1 Create a folder in your local iFolder directory called outlook_express.
2 Click Start > Search > For Files and Folders, then enter dbx to identify the location of your 

Outlook Express e-mail archive files.
3 Close Outlook Express, then locate and move the DBX files to the outlook_express folder you 

created.
4 Open Outlook Express.
5 Click Tools > Options > Maintenance > Store Folder > Change, then navigate to the new 

outlook_express folder in the iFolder directory.
6 Click OK three times.

A.1.4  Netscape Communicator Files 
To move your Netscape e-mail files to your local iFolder directory:

1 Create a folder called netscape_mail in your local iFolder directory. 
2 Locate your Netscape Communicator* e-mail files. Typically, these are located in 

c:\program files\netscape\users\userid\mail.
3 Close Netscape Communicator, then copy and paste the files and folders in the mail folder to 

the netscape_mail folder you created.
4 Open Netscape Communicator.
5 Click Edit > Preferences > Mail & Newsgroups > Mail Servers > Local Mail Directory.
6 Click Choose, then navigate to the netscape_mail folder you created.
7 Click OK, then click OK again.

A.2  Synchronizing Your IE Favorites
You can keep your Internet Explorer Favorites the same on each workstation using Novell iFolder.

For Windows XP Computers

Cut the Favorites folder from its current location (c:\documents and settings\username\favorites) 
and paste it into your local iFolder directory. 

For Windows 98/ME Computers

1 Download the freeware version of TweakUI from the CNET Web site (http://
download.cnet.com). 

This program is used to change the location of your Favorites.
2 Locate tweakui.exe and extract the files to a directory on your hard drive. Make a note of this 

location.
3 Go to the directory where you extracted tweakui.exe, right-click tweakui.inf, then click Install. 
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4 Click Start > Control Panel > TweakUI > My Computer.
5 From the Special Folders drop-down box, select Favorites.
6 Take note of the location of your Favorites directory, then go to Windows Explorer and copy 

the Favorites directory into your iFolder directory.
7 Change the location of the Favorites directory in TweakUI to the location of your iFolder 

directory.
8 Activate your Internet connection and log in to the iFolder server to activate synchronization of 

your files in the local iFolder directory with your files elsewhere on the iFolder server and 
workstations.

A.3  Synchronizing Your Palm Desktop Database
To keep your Palm Desktop database the same on each workstation using Novell iFolder:

1 Start your Palm Desktop program.
2 Click View > Options.
3 Change the location of your Data Directory to the location of either an iFolder directory or 

subdirectory.
4 Repeat this procedure on each of your personal computers.
5 Activate your Internet connection and log in to the iFolder server to activate synchronization of 

your files in the local iFolder directory with your files elsewhere on the iFolder server and 
workstations.

A.4  Synchronizing Your Lotus Notes Files
To synchronize your Lotus* Notes* files using Novell iFolder:

1 Add the following three lines to the notes.ini file:

NAMES=c:\documents and settings\username\my documents\
     ifolder\username\home\names.nsf

KEYFILENAME=c:\documents and settings\username\my documents\
     ifolder\username\home\username.id

DESKTOP5=c:\documents and settings\username\my documents\
     ifolder\username\home\desktop5.dsk

2 Copy the notes.ini, names.inf, desktop5.dsk, and username.id files to your iFolder directory.
3 Modify the shortcut that is used to start Notes by typing the following in the Target field in the 

shortcut's Properties page: 
c:\notes.exe =c:\docume~1\username\mydoc~1\ 
ifolder\username\home\notes.ini

To open the Properties page, right-click the Notes shortcut icon, then click Properties.
4 Activate your Internet connection and log in to the iFolder server to activate synchronization of 

your files in the local iFolder directory with your files elsewhere on the iFolder server and 
workstations.
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A.5  Synchronizing to Protect Data of Various 
Programs
Novell iFolder can help protect your local files by storing backup files on the iFolder server, and by 
synchronizing files to all your workstations. 

Use the following methods to set up your iFolder directory as the default location to store your local 
files:

• “Existing Data” on page 40.
• “QuickBooks Files” on page 40.
• “Microsoft Word Files” on page 41.
• “Microsoft Excel Files” on page 41.
• “Microsoft Access Files” on page 41.
• “Microsoft PowerPoint Files” on page 41.

A.5.1  Existing Data 
To move existing data to your local iFolder directory:

1 Open the My Documents folder in a directory browser.
2 Double-click the iFolder directory icon on your desktop to open the iFolder directory in a 

directory browser.
3 Drag and drop important files from My Documents to your local iFolder directory.
4 Update any desktop shortcuts to those files to reflect the new location.

A.5.2  QuickBooks Files
To move the default location of QuickBooks* files to your local iFolder directory:

1 Create a folder in your local iFolder directory called qbook.
2 Locate your existing QuickBooks file by opening QuickBooks and clicking File > Open 

Company. 
This displays a dialog box that will have the file name you are using as well as the directory and 
drive location. Remember this file name and location.

3 Close QuickBooks.
4 Navigate to the QuickBooks file in your directory browser and move the file to the qbook 

folder you created under the iFolder directory.
5 Open QuickBooks. 

It will not find your file and will open a dialog box where you can navigate to the file's new 
location.

6 Create a subfolder beneath qbook called backup and store your QuickBooks backups to this 
folder.
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A.5.3  Microsoft Word Files
To move the default location of Microsoft Word files to your local iFolder directory: 

1 Open a Microsoft Word document.
2 Click Tools > Options > File Locations > Documents > Modify.
3 Browse to find and select your local iFolder directory, then click OK.
4 In the Options window, click Save, then check the Always Create Backup Copy check box.
5 Click OK.

A.5.4  Microsoft Excel Files
To move the default location of Microsoft Excel files to your local iFolder directory: 

1 Open a Microsoft Excel document. 
2 Click Tools > Options > General.
3 Type the path of your local iFolder directory in the Default File Location box.
4 Click OK.

A.5.5  Microsoft Access Files
To move the default location of Microsoft Access* files to your local iFolder directory:

1 Open a Microsoft Access database.
2 Click Tools > Options > File Location.
3 Type the path of your local iFolder directory in the Default Database Folder Location box.
4 Click OK.

A.5.6  Microsoft PowerPoint Files
To move the default location of Microsoft PowerPoint* files to your local iFolder directory:

1 Open a Microsoft PowerPoint document.
2 Click Tools > Options > Save.
3 Type the path of your local iFolder directory in the Default File Location box. 
4 Click OK.
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BFrequently Asked Questions

This section answers typical questions asked by end users of Novell® iFolder® 2.1 client. Questions 
are grouped by the following topics:

• “Login” on page 43
• “Encryption” on page 43
• “Synchronization” on page 45 
• “Web Access to iFolder Files” on page 46
• “Collaboration” on page 46
• “iFolder Server Account” on page 47
• “iFolder Client and the Local iFolder Directory” on page 48
• “iFolder Client for Linux” on page 49

B.1  Login 
This section addresses the following issues, which are related to logging in to an iFolder account on 
a Novell iFolder server. 

• “What should I do if I get a -107 login error?” on page 43
• “What should I do if I try to log in but get an error message about an unauthorized account?” on 

page 43

What should I do if I get a -107 login error?

Explanation: This error means that you are having problems connecting to the Novell 
iFolder server. 

Action: Make sure that you can access the Internet by launching a browser before you 
log in. If you have an active Internet connection, but are still getting this error, 
contact your iFolder administrator. 

What should I do if I try to log in but get an error message about an unauthorized 
account?

Explanation: Your iFolder server account has not yet been enabled.

Action: Contact your iFolder administrator.

B.2  Encryption
This section addresses the following issues, which are related to the encryption of a user's iFolder 
files.

• “Does iFolder encrypt files located in my local iFolder directory?” on page 44
• “Is iFolder compatible with workstation-based encrypting files systems (EFS) features such as 

those used in Windows 2000/XP?” on page 44
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• “What should I do if I forget my encryption passphrase?” on page 44

Does iFolder encrypt files located in my local iFolder directory?

Explanation: No. If you select the Encryption option, iFolder uses your encryption 
passphrase to encrypt files before they depart your local workstation and to 
decrypt them after they arrive at any of your workstations. Your data remains 
encrypted only when it travels across the wire and when it is stored on the 
iFolder server. This secures your information when it is out of your direct 
control.

Action: If your computing environment requires the encryption of files on your local 
workstation, use a third-party solution that addresses local file encryption.

Is iFolder compatible with workstation-based encrypting files systems (EFS) 
features such as those used in Windows 2000/XP?

Explanation: Local EFS systems such as those available in Windows 2000/XP encrypt files 
on writes to the disk and decrypt the files on reads from the disk, given the 
proper authentication information. As iFolder reads and writes files, the 
operating system decrypts and encrypts, respectively, using the local EFS. If 
iFolder encryption is enabled, whenever iFolder uploads a file to the server, it 
retrieves the file from local EFS (automatically decrypted), then encrypts the 
file with the iFolder encryption method (Blowfish) before sending it to the 
iFolder server.

Action: The EFS on your local workstation provides local protection against 
unauthorized access. If you enable iFolder encryption, iFolder protects your 
files with its own encryption method any time your files are uploaded to the 
iFolder server and until they are downloaded to your other workstations. When 
the files arrive on your workstations, iFolder decrypts the files for local 
storage. You local systems can use any local EFS, if you choose.

What should I do if I forget my encryption passphrase?

Explanation: The encryption passphrase is the key that iFolder uses to encrypt your data on 
the server and during transmission. After you set your encryption passphrase, 
it must be entered whenever you log in to the iFolder server. 

Because you enter the encryption passphrase only after successfully logging in 
with the user ID and password, you can guess multiple times without 
consequence. 

Action: If you cannot recall your encryption passphrase, contact your iFolder 
administrator. If you enabled the Passphrase Recovery option during the 
iFolder client installation, your administrator can send you a hint to help you 
recall your encryption passphrase. If not, other alternatives are possible. See 
“Recovering Your Encryption Passphrase” on page 24 for more information 
about what to do if you forget your encryption passphrase.
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B.3  Synchronization
This section addresses the following issues, which are related to the synchronization of a user's 
iFolder files.

• “Can I synchronize my GroupWise archive database by setting the archive path to a location in 
the local iFolder directory?” on page 45

• “What happens when I delete a file in my local iFolder directory?” on page 45
• “How does iFolder handle synchronization when receiving concurrent input from multiple 

client sessions?” on page 45
• “My local hard drive failed with all my files on it. How do I get my iFolder files back?” on 

page 45

Can I synchronize my GroupWise archive database by setting the archive path to a 
location in the local iFolder directory?

Explanation: No, it is not possible because GroupWise® needs the files in the archive to be 
maintained as a set of files. iFolder does not synchronize files as a set. If you 
set the path to a location in the iFolder directory, the iFolder client will corrupt 
the GroupWise archive.

Action: Do not try to synchronize your GroupWise archive by setting a GroupWise 
archive path to the location of your iFolder directory. However, you can make 
a backup copy of the caching or remote database and store this in your local 
iFolder directory. 

This problem does not occur only with GroupWise. Similar problems might 
occur with any database that is implemented as a collection of linked files.

What happens when I delete a file in my local iFolder directory?

Explanation: During synchronization, iFolder deletes the file from the iFolder server. 
Eventually, iFolder deletes the file from every other workstation as you log in 
from them to synchronize your files. Depending on the synchronization time 
you have set, or your login preferences, this could happen immediately.

Action: If you prefer to have full control over synchronization, do not log in to the 
iFolder server until you are ready to synchronize all your files.

How does iFolder handle synchronization when receiving concurrent input from 
multiple client sessions?

Explanation: iFolder accepts the file with the latest time stamp into the iFolder directory. If 
the same file is saved on another machine with an earlier time stamp, iFolder 
saves the file with the older time stamp in the iFolder conflict bin, where you 
can restore it.

Action: Check your conflict bin periodically to recover files before they get pushed out 
to accommodate new additions to the bin.

My local hard drive failed with all my files on it. How do I get my iFolder files back?

Explanation: Your files are backed up by your account on the iFolder server.
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Action: After restoring your computer, follow the procedures for downloading, 
installing, and configuring the iFolder client, and then log in to your iFolder 
account. Your files will be automatically downloaded to your local iFolder 
directory. The download time will vary, depending on the amount of data to be 
downloaded and the speed of your Internet connection.

B.4  Web Access to iFolder Files
This section addresses the following issue, which is related to the accessing a user's iFolder files 
using methods other than the Novell iFolder client.

• “I have a wireless PDA. Can I access files in my iFolder account?” on page 46

I have a wireless PDA. Can I access files in my iFolder account?

Explanation: Yes, iFolder supports access via PDA.

Action: Log in to your iFolder Web site and click the File icon. You will then be able to 
download and view your files.

B.5  Collaboration
This section addresses the following issues, which are related to collaborative solutions that use a 
single iFolder account for multiple users.

• “What is a shared iFolder account?” on page 46
• “Is there a physical or administrative limit to the number of concurrent connections that can be 

made to a single iFolder account?” on page 47
• “Can I share my iFolder account with other iFolder users?” on page 47

What is a shared iFolder account?

Explanation: A shared iFolder account is one in which a group of users agree to work 
collaboratively within a single iFolder account. However, accounts in iFolder 
2.1 and earlier are designed for a single user. There are no official file-sharing 
capabilities in the product.

Action: To create a shared iFolder account, your iFolder administrator can create a 
unique user ID and password to be given to multiple users of that group 
account. In this way, multiple users can log in to the same iFolder account to 
synchronize the shared files.

Be aware of the following issues of shared iFolder accounts: 

• All member users of the shared account will have full Read/Write access 
to the files stored in the account. 

• Because iFolder has no file-locking features, member users would need to 
use an alternative method to manage file access and version control.
It is possible (but not desirable) for two users to modify the same file at 
the same time. When iFolder syncs, it will keep the file with the latest 
date and overwrite any previous versions. One way to help avoid this is to 
have users rename a file they want to work on by adding some distinctive 
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information to the file name such as adding their to the end of the file. 
The user can rename the file by removing the initials when finished. 

• If one user deletes or moves a file from his or her local iFolder directory, 
then that file will be deleted from all users' machines when they next 
synchronize. 

• The only way to remove someone's access to a shared iFolder account is 
to have the iFolder administrator change the password; then you can 
distribute the new password to the proper people. This will prevent 
someone from logging in to the account but will not remove the files from 
his or her computer.

• Each member user must retain the same directory structure within his or 
her local iFolder directory.

Is there a physical or administrative limit to the number of concurrent connections 
that can be made to a single iFolder account?

Explanation: If your iFolder administrator creates a shared iFolder account, multiple users 
might attempt to concurrently modify files in the same iFolder account from 
different workstations. In iFolder 2.1 and earlier, there is not a known or 
intentional limit to the number of concurrent connections to a single account.

Action: In iFolder 2.1 and earlier, iFolder does not prohibit access to the iFolder 
account from multiple locations and has no file-locking features to prevent two 
users from attempting to concurrently modify the same file. Users of the 
account are responsible for any coordination that might be necessary to ensure 
the integrity of the files stored in the account.

Can I share my iFolder account with other iFolder users?

Explanation: No, your iFolder files can be accessed only with your unique network user ID 
and password and your encryption passphrase. However, sharing will be 
available in a future release of iFolder.

Action: One possible workaround is to ask your iFolder administrator to create a group 
network identity for a shared iFolder account. 

B.6  iFolder Server Account
This section addresses the following issues, which are related to your iFolder account on the iFolder 
server.

• “What if I run out of disk space on the iFolder server?” on page 47
• “How many directories can I have in my iFolder account?” on page 48

What if I run out of disk space on the iFolder server?

Explanation: Your iFolder administrator assigns a storage quota for your iFolder account. 
The quota consists of the space for your active files and the space you reserve 
for your conflict bin.

Action: View your conflict bin to resolve conflicts. Then determine if you want to 
reduce the space allotted to it.
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You can also contact your iFolder administrator to determine if you are eligible 
for an increased storage quota.

How many directories can I have in my iFolder account?

Explanation: iFolder supports up to 32765 directories within your iFolder account. If you 
exceed this number, iFolder stops writing to your local directory and data loss 
is likely. Typical iFolder users are unlikely to exceed this upper limit with 
normal use.

Action: Periodically monitor the number of directories in your local iFolder directory. 
Reorganize your folders, as needed, to keep the number of directories below 
this upper limit.

B.7  iFolder Client and the Local iFolder Directory
This section addresses the following issues, which are related to using and managing files in your 
local iFolder directory using the iFolder client.

• “I have more than one workstation (office desktop, laptop, home desktop). Can all my 
computers use my same iFolder account?” on page 48

• “Can I move the location of my iFolder directory after I have installed or upgraded the iFolder 
client?” on page 48

• “If I change the location of my local iFolder directory, do I also have to move my files?” on 
page 49

• “Can I use the same iFolder client workstation for access to multiple iFolder accounts?” on 
page 49

• “We have a shared computing environment, where students want to access their personal 
iFolder accounts from the same computer. Is it possible to force every file that is downloaded 
for the client session to be deleted automatically from the workstation after the iFolder user 
logs out? Or is there any different solution that ensures the user files are stored only on the 
server?” on page 49

I have more than one workstation (office desktop, laptop, home desktop). Can all my 
computers use my same iFolder account?

Explanation: Yes, you can log in to the same iFolder account from as many computers as 
you like. 

Action: Install the iFolder client on every workstation that you typically use. Changes 
will be synchronized to each computer as you log in to the iFolder server from 
them.

Can I move the location of my iFolder directory after I have installed or upgraded the 
iFolder client?

Explanation: You can change the location of your iFolder directory on your workstation at 
any time. 

Action: For instructions, right-click the iFolder icon in the system tray, then click Help 
> Changing Your Local iFolder Directory.
er 2.1 User Guide
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If I change the location of my local iFolder directory, do I also have to move my files?

Explanation: iFolder does not automatically move the files from the old location to the new 
one. You must move your iFolder files manually to the new location.

Action: For instructions, right-click the iFolder icon in the system tray, then click Help 
> Changing Your Local iFolder Directory.

Can I use the same iFolder client workstation for access to multiple iFolder 
accounts?

Explanation: Yes, you can log in and out of different iFolder accounts. Each account will run 
a separate iFolder client session. An iFolder icon appears in your system tray 
for each session of the client. 

Action: Each account must have its own separate local iFolder directory on the local 
hard drive. Also, you can be logged in to only one iFolder account at a time. To 
change from one account to another, you must log out of the current iFolder 
account and then log in to the new account. 

We have a shared computing environment, where students want to access their 
personal iFolder accounts from the same computer. Is it possible to force every file 
that is downloaded for the client session to be deleted automatically from the 
workstation after the iFolder user logs out? Or is there any different solution that 
ensures the user files are stored only on the server?

Explanation: iFolder deletes local files only as part of the synchronization process. Use 
caution if you plan to delete all files from your local iFolder directory. iFolder 
will interpret this as a permanent deletion, which triggers the deletion of files 
on the iFolder server and all other workstations with the iFolder client. 

Action: Ask your iFolder administrator about using Novell NetDrive to access your 
iFolder account. NetDrive is shipped with iFolder and might be an option your 
iFolder administrator will allow you to use. See Section 3.2, “Accessing 
iFolder Files Using Novell NetDrive,” on page 34 for more information.

B.8  iFolder Client for Linux
This section addresses the following issues:

• “iFolder client login to iFolder server is not going through and it displays message "error -105". 
How can I resolve this?” on page 50

• “What kinds of files are not supported by iFolder client for Linux?” on page 50
• “Can I select same location as iFolder Home for both Windows and Linux machines?” on 

page 50
• “Where does iFolder store the user information?” on page 50
• “Why is it that the files that I just downloaded are getting uploaded yet again?” on page 50
• “Why is the Activity tab is not showing any activity?” on page 51
• “Why is that the Activity tab displays synchronizing with server and synchronization complete 

even when the client is disconnected?” on page 51
• “The About Novell iFolder box displays a question mark (?) as Machine Id. Why is this so?” on 

page 51
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• “Why do the icons for iFolder client for Linux differ from that of iFolder client for Windows?” 
on page 51

• “At time, I view X lib error on the terminal from where I run iFolder. What is this?” on page 51
• “I get this “gtk-critical error about gtktreeview change”. What does this imply?” on page 51
• “When we restart the machine, why doesn’t the iFolder client for Linux automatically log in as 

in the iFolder client for Windows?” on page 51
• “Why is it that unlike in iFolder client for Windows, the iFolder client for Linux supports 

Multiple instance of iFolder client on single machine, but same user cannot have Multiple 
instance of iFolder running?” on page 52

• “Why does iFolder client crash while uploading data existing in iFolder location? How can I 
resolve this?” on page 52

• “Why is it that iFolder client for Linux crashes while uploading Linux system specific files?” 
on page 52

iFolder client login to iFolder server is not going through and it displays message 
"error -105". How can I resolve this? 

Action: For Windows client, in the hosts file of local machine, enter the IP address and 
DNS name.

Or

For Linux client, got to /etc/hosts and enter the IP address and DNS name of 
iFolder server in this file.

What kinds of files are not supported by iFolder client for Linux?

Explanation: iFolder client does not support the following files:

• File with long name which include characters such as { } ) [ 
• Files with extended characters

Can I select same location as iFolder Home for both Windows and Linux machines?

Action: Yes, you can. However, there are a few characters that are not supported on 
Windows, but are supported by Linux (\/:*?"<>|). These characters are not yet 
handled with respect to both filesystem and this might cause problem. Make 
sure your filenames do not have such characters in them.

Where does iFolder store the user information? 

Explanation: iFolder stores most information in the  ~/.novell folder. If iFolder does 
not work for unknown reasons you could delete this folder and restart iFolder 
client.

Why is it that the files that I just downloaded are getting uploaded yet again?

Possible Cause: The iFolder home might be an NFS mounted directory. 

Action: To avoid this, use local directory as iFolder home because NFS causes the 
network congestion and delta synchronization of iFolder might not be useful if 
network is already clogged by certain applications.
er 2.1 User Guide
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Why is the Activity tab is not showing any activity?

Explanation: If there are several files to be uploaded or downloaded, the View Activity tab 
hangs. 

Action: To view the activity, move the mouse over the Activity tab.

Why is that the Activity tab displays synchronizing with server and synchronization 
complete even when the client is disconnected?

Explanation: Upload and download is very slow in case of iFolder client for Linux.

The About Novell iFolder box displays a question mark (?) as Machine Id. Why is this 
so?

Explanation: The iFolder server has the count of clients connected to it. At times, it gives the 
connected number that the client cannot comprehend. In such a case, a 
question mark (?) is displayed instead of actual connected number in the About 
Novell iFolder box.

Why do the icons for iFolder client for Linux differ from that of iFolder client for 
Windows?

Explanation: This difference in icons is to align with the themes we support on Linux.

At time, I view X lib error on the terminal from where I run iFolder. What is this?

Explanation: This is an issue with the synchronization of messages displayed in the View 
Activity tab. This does not affect synchronization, however, you will not be 
able to view the GUI because it is freezed.

Possible Cause: There might be either several operations being performed on the data or the 
data volume to synchronize might be large.

Action: Terminate the application and restart it.

I get this “gtk-critical error about gtktreeview change”. What does this imply?

Explanation: This is an issue with synchronization of messages in the View Activity tab; this 
does not prevent the iFolder client from synchronizing the files.

Possible Cause: The data to synchronize might be large.

Action: Restart the client.

When we restart the machine, why doesn’t the iFolder client for Linux automatically 
log in as in the iFolder client for Windows?

Explanation: The automatic login feature is not yet implemented on iFolder client for Linux. 

Action: To enable automatic login of the iFolder client when restarting the machine, in 
your first login, check autologin. With this iFolder client starts by pressing 
Enter.
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Why is it that unlike in iFolder client for Windows, the iFolder client for Linux 
supports Multiple instance of iFolder client on single machine, but same user cannot 
have Multiple instance of iFolder running?

Explanation: This behavior is added in Linux to comply with the UNIX standards.

Unlike Windows, Linux box can be used by multiple users as desktop too. In 
this scenario, it makes sense to have each user one instance of iFolder.

Why does iFolder client crash while uploading data existing in iFolder location? How 
can I resolve this?

Explanation: iFolder client for Linux does not support upload of files when separate code 
pages (multiple language) for client and server are used. For example, the 
english language iFolder client does not upload data on the french language 
server.

Action: Make sure that the client as well as server code page are the same for client to 
upload data successfully.

Why is it that iFolder client for Linux crashes while uploading Linux system specific 
files?

Explanation:  iFolder client for Linux does not support upload of Linux system files.
er 2.1 User Guide
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