Novell Designer 3.5 Readme

September 18, 2009

This document contains the known issues for Novell® Designer version 3.5.

1.0 Documentation

1.1 What's New in Designer 3.5

The What's New section for Designer 3.5 for Identity Manager is included in the build. It will also be available online after Designer 3.5 is released.

1.2 Finding Documentation

The documentation for Designer 3.5 for Identity Manager is included in the build. It will also be available online after the latest version is released.

This Readme contains the known issues for Designer version 3.5. In addition to this Readme, separate Readmes are available for Identity Manager 3.6.1 and the User Application Roles Based Provisioning Module:

Additional documentation resources are also available for the following:

1.3 Browsing or Searching

  • To browse the Designer help topics after Designer is installed:

    1. In Designer, click Help > Help Contents.

    2. Select a book, browse the table of contents, then click a topic.

  • To search for specific Designer information after Designer is installed:

    1. Click Help > Search, then enter text. Or press F1 on any page. (In Linux, press CTRL-F1.)

    2. Type a topic in the Search field, then click Go.

2.0 Localization

2.1 Available Languages

Designer includes User Interface translation for Brazilian Portuguese, Chinese (Simplified), Chinese (Traditional), Dutch, French, German, Italian, Japanese, and Spanish. The User Interface language can be chosen at install or at runtime through the preferences dialog box.

2.2 Non-Translated Components

This release does not include translation of Designer runtime help or product documentation. At this time, project documentation generated by Designer is available in English only.

2.3 Plug-Ins

Some plugins are provided by the metadirectory and are available only in languages supported by the metadirectory: Chinese (Simplified), Chinese (Traditional), French, German, and Japanese. Some third-party plugins might be available in English only.

3.0 Installation

3.1 Unable to Install Designer on Windows

Some users have reported the inability to install Designer on Windows*. The install starts to run but closes with the following error:

"This Application has Unexpectedly Quit." 

If you see this issue, do the following:

Right-click the Designer install.exe file and choose Properties. Select the Compatibility tab. Under the Compatibility mode section, choose the Run this program in compatibility mode option and select Windows 2000 from the drop-down menu. The Designer install should execute normally.

3.2 Installing Designer To a Network Drive with UAC Turned On in Windows Vista

Designer 3.5 is officially tested and supported on Windows Vista. However, if you turn on User Account Control (UAC) in Windows Vista, programs may be unable to access some network locations and you cannot install Designer to a network drive. This problem may also occur when you use the command prompt to access a network location.

To resolve this problem, you need to configure the EnableLinkedConnections registry value as per an article entitled "After you turn on User Account Control in Windows Vista, programs may be unable to access some network locations" dated July 20, 2007, in the Microsoft Knowledge Base.

Follow these steps to apply the workaround to configure the EnableLinkedConnections registry value:

  1. Click Start, type regedit in the Start Search box, and then press Enter.

  2. Locate and then right-click the following registry subkey:


  3. Point to New, and then click DWORD Value.

  4. Type EnableLinkedConnections, and then press Enter.

  5. Right-click EnableLinkedConnections, and then click Modify.

  6. In the Value data box, type 1, and then click OK.

  7. Exit Registry Editor, and then restart the computer.

3.3 Installing on English Windows with East Asian Language Pack and with Double Byte Install Path

When installing to a path where there are double byte characters and if your operating system is running the English version of Windows with the East Asian Language Packs installed, the install package throws an error saying that it cannot extract the compressed file. There are known issues with using Double Byte Character Sets (DBCS) in Windows file paths. We cannot provide fix at this time as this would have to come from the OS vendor or the install framework vendor. As an alternative you can install to DBCS paths when installing to a localized version of the operating system.

3.4 Designer Installs Its Own JRE

The installation installs a JRE specifically for Designer. This JRE won't impact Java* installed for other uses on the workstation.

3.5 During Linux Install, Root Privileges are Required

Installing NICI requires root privileges. The install program prompts you for the root password so that you can install this component.

3.6 On Linux, Install Throws an Exception Error

The following error occurs with some versions of Linux:

Invocation of this Java Application has caused an InvocationTargetException. This application will now exit.

The xhost program makes Linux more secure by not allowing other hosts and users to make connections to the X server. If you are logged in as a valid user and are trying to run the install as root, this error can occur. For more information on xhost, refer to the man page for xhost.

3.7 Starting Designer after Installing It Prompts Warning Messages

The following warning messages appear in SLED 11 and openSUSE 11.1 platforms:

Gtk-Message: Failed to load module "gnomebreakpad": cannot open shared object file: No such file or directory 

Gtk-Message: Failed to load module "canberra-gtk-module": cannot open shared object file: No such file or directory 

It is safe to ignore these messages.

3.8 Designer Installation Fails on openSUSE 11.1 and SLED 11

See TID7003965 for more information.

4.0 Encryption/Security

4.1 Project Files Are Not Encrypted

Passwords are obfuscated. However, if you have other sensitive data in your project file, it is not encrypted in any way, and you must take care to safeguard your information.

5.0 Generating Documentation for Projects

5.1 Use the Adobe Acrobat Reader for Linux

By default, Linux might be using a PDF reader (Evince) that doesn't support the embedded font we use to display double-byte characters. We recommend that you use the Adobe Acrobat Reader for Linux to support these languages.

5.2 Generating Documentation for Large Projects Might Cause Memory Outage

To avoid memory outage, generate documents individually for ID Vaults/Drivers/Driver Sets.

6.0 General Issues

The following sections provide information for known issues at the time of the product release.

6.1 Notification Templates Are Filtered by Name and Locality Settings

When running Designer in any language, by default you see only notification templates for the language that you are running in. To see templates in additional languages, change the filter settings for the Outline view:

  1. Click the filter icon in the upper-right corner of the Outline view.

  2. Select the languages that you want to see.

Also, when creating new templates, you must add the proper language code to the template name so that your new templates are filtered correctly. For example, a German template should be named <TemplateName_de>. The language codes are as follows:










zh-CN-Chinese Simplified

zh-TW-Chinese Traditional

en-English (or leave the language code off)

6.2 Manager-Employee String Not Localized for Relationships Under DAL for Portuguese Locale

6.3 Designer Doesn't Launch after Installation on Windows Vista

Windows Vista has implemented a new User Account Control feature that prevents applications to run as Administrator unless you specifically allow it. To run Designer in Vista, right-click the Designer shortcut and choose the option to "Run as Administrator". You can also choose to disable User Account Control by selecting Start > Control Panel > User Accounts > Turn User Account Control On or Off (have to be an administrator or equivalent).

6.4 Live Operations On Windows Vista Are Slow

When running Designer on Windows Vista, you may see poor performance when doing live operations against a Windows 2003 server. You can resolve this issue by disabling TCP Auto Tuning on Windows Vista. To do this, open a command prompt and enter the following:

netsh interface tcp set global autotuninglevel=disabled  

6.5 Live Import Fails with an Error

It throws java.lang.UnsatisfiedLinkError version `CXXABI_1.2' not found error. The error occurs on SLES 11, Open SUSE 11.1, and SLED 11 64-bit platforms.

To workaround this issue, do the following:

  1. Install the compat-5.0.7-22.2.rpm, which contains the libstdc++ .so.5.

  2. Copy the libstdc++so.5.0.7 to <designer_install_dir>/designer/plugins/com.novell.core.jars_3 location. Now import does not throw any errors.

6.6 JVM Crashes When Closing Designer On Windows Vista

After performing any live operation in Designer on Windows Vista, the JVM might crash when you close Designer. This is due to an errant call in JClient. If this happens, no data is lost--simply close the error window.

This issue is being addressed.

6.7 Minimum Resolution Required for Designer

The minimum resolution required for Designer is 1024 x 768. The minimum recommended resolution for Designer is 1280 x 1024.

6.8 Back Up Your Project Files and Project Data

It is a good practice to protect your work by periodically saving your project. We strongly suggest that you use the Version Control feature in Designer 3.x to automatically create versioned backups of your projects. You can also easily make a copy of your projects by performing the following:

  1. Right-click a project in the Project view.

  2. Select Copy Project.

6.9 Application Schema Is Not Imported by Default

Application schema is not automatically imported by default. You can always perform a refresh application schema operation on a particular application after the project has been imported:

  1. Right-click the driver.

  2. Select Live > Refresh application schema.

    You can also change this preference by selecting Window > Preferences >Novell >Identity Manager > Import/Deploy > Behaviors> Import, then select Include application schema when importing drivers.

6.10 Running Designer with 120 DPI Fonts in Windows

120 DPI is too large for text in standard Windows XP decorations. Adjust the Display settings:

  1. In the Control Panel, select Display > Appearance > Effects.

  2. In the Use the following method to smooth edges of screen fonts, toggle Standard to ClearType.

    If you have a display that necessitates 120+ DPI fonts, you need ClearType. Besides the obvious anti-aliasing aspects, ClearType gives fonts better weight. Without ClearType, the fonts are too thin and light, decreasing readability.

  3. Click OK, then click Advanced.

  4. In the Item field, reduce the Icon, Menu, Message Box, Selected Items, and ToolTip sizes.

  5. Reduce title bars and related controls to a preferred size.

  6. Fix icon spacing and scroll bar width.

  7. Make sure that you are running at a very high resolution.

    This helps eliminate most of the display issues on an HD monitor.

6.11 Boosting Modeler Performance

If you want to maximize the performance on large-scale operations (for example, copy/paste of several objects), you find that the performance is up to ten times faster if you hide or close the Outline view. You get even more performance if you also close the Properties view. To quickly restore these views, click Window > Reset Perspective.

6.12 If a Project Contains a JDBC 3.5 Driver

If a project contains a JDBC 3.5 driver, you might notice the default driver name is JDBC 3\.5. This is normal and allows the driver to deploy correctly.

6.13 Designer 3.5 Does Not Support 2.1.1 Workspaces

Designer 2.1.1 workspaces are not compatible with Designer 3.5. Designer stores projects and configuration information in a workspace. These workspaces are not compatible from one version of Designer to another. You need to point Designer 3.5 to a new workspace, and not to a workspace used by a previous version of Designer.

6.14 Unable to Import Schema with Class Names that Contain Double Quotation Marks

Designer cannot successfully import schema with class names that contain double quotes (for example, "customClass1"). The schema appears to be imported, but when you restart Designer it is no longer available.

To resolve this issue, you can deselect the quoted class (in the Designer Schema Import Wizard) before importing the schema.

6.15 Role Editor Limitations

Role Editor does not support the fan-out driver capability and cannot choose logical systems for SAP drivers. Though it displays entitlements, it cannot differentiate the logical systems.

6.16 Designer 3.5 Does Not Support Conversion of Projects Older than Designer 3.0

6.17 Document Generator Does Not Generate Documentation for Roles-based Entitlement Policies and RBPM Resources

7.0 Linux-Specific Issues

7.1 JVM Terminated. Exit Code=1 Error

Some installations have reported a JVM terminated. exit code=1 error on SLED 10 SP1 workstations. You can apply a temporary workaround by performing the following to the /etc/X11/xorg.conf:

Section "Extensions"

Option "MIT-SHM" "no"


Disabling this extension degrades performance, so it is not the best solution.

7.2 Installing Designer on openSUSE 10.3 with GNOME Interface

The GNOME interface in openSUSE 10.3 does not initially work with IDM Designer. Some of the problems have been that Designer doesn't launch under GNOME, or Designer crashes as soon as you hover over a tooltip activated place, or Designer crashes when deleting objects from the Project view. In order for openSUSE 10.3 with GNOME to work with Designer 3.x, you need to update all of the libraries from Be sure to include the following:

bug-buddy and


If you are having problems when running the updates, or if you need to configure the update server, go to the YaST Online Update documentation site for additional help.

7.3 Stack Smashing Error on openSUSE 10.3

When starting Designer (on openSUSE 10.3) with, you may receive the following error on the console:

"*** stack smashing detected ***: ~/designer/jre/bin/java terminated" 

and Designer fails to start. This error may be a result of using the Smart Common Input Method platform (SCIM) language input system on your Linux desktop, and specifically the scim-bridge-gtk module for GTK. You can fix this error in one of two ways:

  • Remove the scim-bridge-gtk module.


  • Export the enviroment variable GTK_IM_MODULE=xim (click export GTK_IM_MODULE=xim for further instructions).

7.4 Installing Designer on Debian-Based Linux Distributions

Although we cannot officially support all Linux distributions, many customers have reported success running Designer on Debian-based distributions, such as Ubuntu. To do this, perform the following steps:

  1. Download and extract (to a folder of your choice) Designer from the coolsolutions web site.

  2. Use Ubuntu's synaptic package manager to install the alien, rpm, and gettext packages (or from the command line, type sudo apt-get -f install alien rpm gettext).

  3. Change directories to the designerInstallDir directory.

  4. Use rpm to install the nici rpm (from the command line, type sudo rpm -ivh --nodeps components/nici/nici.i386.rpm) *this adds an entry to the rpm database that the installer checks for when you type rpm -qa at the command line.

  5. The gettext rpm is also required for the standard Designer installer. Download any installable gettext.rpm version and install it, such as rpm -ivh --nodeps gettext[version].rpm. This adds the gettext entry to the rpm database.

  6. Run the standard Designer ./install script as a normal desktop user.

7.5 Running eDirectory with Designer on Linux

If you are running eDirectory on Linux and also want to run Designer, you might need to run Designer as root. The eDirectory install requires you to install its base packages as root. This prevents a typical user from running them. Specifically, Designer crashes if you are running as a non-root user when importing or deploying and when connecting to a tree.

7.6 Running Designer on Linux with gtk-qt-engine

We don't recommend running Designer with the gtk-qt-engine RPM installed. This RPM package is installed with SUSE Linux and some other Linux Distributions. Known issues cause crashes and Designer theme issues when this package is installed.

If you must use this RPM package, obtain the latest version. You can download this version from

Even with the latest version of the package, Designer theme functionality might not be present.

To determine whether you have the gtk-qt-engine RPM package installed, enter:

rpm -qa|grep gtk-qt

If gtk-qt-engine appears in the list, you should remove the package by issuing the following command as the root user:

rpm -e gtk-qt-engine

7.7 If You Encounter Display Issues on Linux

7.7.1 GNOME

If you encounter display issues in GNOME*:

  1. Select the Applications menu.

  2. Click Preferences > Font, then decrease the size of the application font.

  3. You can also adjust the thematic elements to your liking. Keep in mind that GTK thematic elements can cause performance issues with Designer. If Designer is running slowly, especially when you use pull-down menus and other widgets, you might try changing to a simplified GTK theme.

    Normally, this process fixes display issues.

7.7.2 KDE

Because Eclipse (Designer) is a GTK application, it is recommended that you use GTK themes rather than qt-based themes. This can be accomplished using one of the following methods:


You must remove the gtk-qt-engine package mentioned in the previous section. This can be done through YaST or by using the instructions given above.

You need to have the following packages installed on your Linux system. If you installed the GNOME subsystem, you already have these packages installed:

  • gtk-engines

  • gtk2-engines

  • control-center2 > Gnome Control Center

  • gtk2-themes > or the themes you downloaded, and all the related dependencies

  • gnome-themes > only needed if you are going to use Gnome Control Center to set your theme

Do one of the following:

  • Set your GTK theme and font settings from the KDE SUSE menu. Select Utilities > Desktop >Gnome Control Center. You can set this control center application to automatically run each time KDE is started. The following command will accomplish this: ln -s /opt/gnome/lib/control-center-2.0/gnome-settings-daemon /home/user/.kde/Autostart (for "user", use your username) or

  • Create a GTK control file (usually named .gtkrc-2.0) in your user home directory or the directory where your system is configured to look for GTK2_RC_FILES. Entering "set |grep gtk" shows how this environment variable is configured and which files it is looking for. The file should include the following information. You can use any font and GTK theme that you prefer. include "/opt/gnome/share/themes/Xfce-stellar/gtk-2.0/gtkrc" style "user-font"

    /gtkrc" style "user-font"


    font_name="Sans Serif 6"


    widget_class "*" style "user-font" gtk-theme-name="Xfce-stellar"

    gtk-font-name="Sans Serif 6"

7.8 Launching Designer from the Shell on Linux

The file sets important variables, permissions, and memory parameters. If Designer isn't launched from this file, Designer won't function correctly or be able to call other programs (for example, Mozilla*) on Linux.

The is located in the <designer_install_dir> Designer Install Directory.

7.9 JVM Crashes when Launching Designer, the Welcome Page or Opening Help On 64-bit Linux

If the 32-bit version of xulrunner is installed on a 64-bit Linux distribution, the JVM might crash when you launch Designer, when the Welcome Page displays, or when you view a Help topic. To resolve this problem, perform the following:

  1. Open the Designer.ini file located in the Designer install directory

  2. Add the following line to the end of the Designer.ini file:

  3. Save the Designer.ini file and launch Designer.

7.10 Welcome Page and Help System Don't Display on Some Linux Distributions

If the welcome page and Help system don't display correctly on Linux, it is probably because your version of xulrunner isn't compatible with Eclipse. Designer uses the embedded browser that xulrunner provides in a few places, including the Welcome page and Help system.

To download a compatible version of xulrunner:

  1. Download the xulrunner installer for Linux.

  2. Unregister your current version of xulrunner by running the following command as root:

    xulrunner --unregister-global
  3. Follow the instructions to install xulrunner here.

  4. Restart Designer and confirm that the welcome page is working as expected.

8.0 Workflow/Provisioning

8.1 A Form Field That Returns Undefined Does Not Display an Error or Warning

If a field on a form used by a workflow returns the value "undefined", the form does not display an Error or Warning message. This situation results from a problem in the script. In general, if a form script evaluates to "undefined", the script is considered to be in error. The workaround is to make sure you do not set "undefined" in the preactivity mappings. To do this, use a try/catch/finally block to ensure that there is always a valid value being sent to each control.

8.2 Possible Timeout When Setting Trustee Rights on a Provisioning Request Definition

You might encounter the following error message when trying to set Trustee Rights on a provisioning request definition or when trying to access the Identity Vault via the ECMA expression builder:

Cannot connect to host 'xxx', verify the address is correct and the server is running.

If the address is correct and the server is running, this might be caused by a slow connection.

You can change the connection timeout by setting the Connection preference via Window > Preferences > Novell > Provisioning.

8.3 Saving Incorrect Credentials in the Provisioning Request Definition Editor

When you connect to the Identity Vault from the provisioning request editor (for example when setting Trustee rights on a provisioning request definition) you are prompted for your Identity Vault credentials. If you type an incorrect password and click the Save password button in the Identity Vault credentials dialog box, you cannot connect to the Identity Vault and you are not prompted to retype your credentials.

To work around this issue, access the Modeler view and reconfigure the Identity Vault credentials for the project.

8.4 Resources Associated with Roles are not Deleted from the Resources List of the Role Editor

Under the Resources List in the Role Editor, a read-only list of the associated resources is available along with the role. The information in this list is obtained and updated for all the roles when the Role Catalog is imported from eDirectory. You can only detect new resource associations but not the resource associations that have been removed in the User Application.

To workaround this issue, ensure that the deleted resource associations are removed from the Resources List.

  1. Before performing a Live Import from the Role Catalog, go to the Navigator View and navigate to the \MyProject\Model\Provisioning\AppConfig\RoleConfig\ResourceAssociations folder.

  2. Remove all the files in the folder except the ResourceAssociations.digest file.

  3. From the Provisioning View, select the Role Catalog object and run the Live Import to import all the resource associations again and to provide you the updated correct information.

8.5 Version Control Compare with New User Application Driver Shows Ignorable Error

If you add a User Application driver to a project under version control, and you perform a compare, (after checking in the project again), you might see the following exception in the error log:

Unable to find a light item for the path: Model/Provisioning/AppConfig/.appconfig 

You can safely ignore this error.

8.6 Exceptions Thrown When Importing Project Archive

If you import a project archive file into Designer, you might not see existing team definitions. You also see the following error in the error log:


To make the team definitions available, restart Designer.

8.7 Role Compare Shows Incorrect Results

If you use both the User Application user interface and Designer to create roles, Designer's Live > Compare feature might not display the expected results. To work around this problem, you can:

  • Use only Designer to create, delete, or modify all roles.

  • Use the Compare window that displays during a deploy. The Compare window displays the correct results. You can cancel the deploy, if you only want to see the compare results.

8.8 Null Pointer Exception Error When Checking In Provisioning Objects To Version Control

If you perform a Commit on any provisioning objects to version control when the Provisioning Request Definition (PRD) is open with unsaved changes, you'll receive a Null Pointer Exception error in the error log. You might not realize that the commit failed unless you have the Error Log view open. The easy workaround is to save the provisioning object before checking it into version control or close the object without saving it. This bug will be fixed in a future release of Designer.

8.9 Reverting an Open Provisioning Request Definition Causes an Unexpected Behavior

If you revert a provisioning request definition (PRD) while it is open in the provisioning request definition editor, the editor closes, then reopens with the refreshed version of the PRD. This is a normal action of the provisioning request definition editor.

8.10 Reverting Locale Changes Might Display Incorrect Status

When you use the Locales and Localization Resource Groups window (Configure > Locales) to add and remove locales, then perform a version control Revert, Designer might incorrectly indicate that the local object has changed. When you close the window by clicking OK and you have not made changes, Designer indicates that the local object has changed. You can ensure that this does not happen by clicking Cancel instead of OK.

8.11 Problems When Setting Trustees on Read-only Provisioning Request Definitions after Migrating User Application Driver to 3.6.1

If you set trustees on one of the read-only provisioning request definitions (such as the Roles or Attestation objects) on a User Application driver migrated to 3.6.1, Designer creates an extra copy of the provisioning request definition. You will see two objects with the same name in the Provisioning view.

To delete the extra object:

  1. Backup your project.

  2. With the project open, access the Navigator view, then navigate to the project's Model\Provisioning\AppConfig\RequestDefs folder. The Navigator view displays the provisioning request definitions as .prd and .digest files. The extra copy of the provisioning request definition has the same name but with a number appended to it. For example, the Attestation Report displays in the Navigator view as AttestationReport.prd and AttestationReport.digest. The extra copy displays as AttestationReport1.prd and AttestationReport1.digest.

  3. Delete the files with the number appended to the name; for example, AttestationReport1.prd and AttestionReport1.digest.

  4. Save the project.

9.0 Provisioning/Migration

9.1 User Application 3.7 Driver Migration Does not Automatically Deploy the Notification Templates

You should manually add and deploy the notification templates while working with the User Application drivers migrated from User Application versions prior to 3.7. Use the following steps to deploy the notification templates:

  1. Go to the Outline view in the Designer.

  2. Go to the Identity Vault where the migrated environment is created.

  3. Right-click the Default Notification Collection.

  4. Click Add All Templates, then right-click the Default Notification Collection.

  5. Go to the Live>Deploy and deploy all the changes.

10.0 Version Control

10.1 404 Error When Comparing Version Control Revisions On Large Projects

There is an intermittent problem that occurs when you compare a large project, or when you have a very slow connection when comparing a project. Compare takes a long time to run and not all of the items appear in the Compare window. Most of the time this problem goes away when you try again. If the problem persists, contact Novell Support for information about turning off the status thread temporarily.

10.2 Driver Not Appearing in Version Control or Modeler Views after Running Get Updates

If you add a driver to a driver set on one computer, save that update to a version control server, then perform a Get Updates on a second computer, you won't see the driver added to the driver set. The fix to this issue is to refresh the Modeler view by closing and then reopening the view. Then run refresh on the Version Control view.

10.3 Copy/Paste, Drag&Drop Operations in Navigator View Don't Update Version Control

Copy and paste, drag & drop operations in the Navigator View are not handling files properly if they are under version control. The workaround is to perform these operations from the Project view.

11.0 Uninstallation

11.1 Non-removal of Uninstall Designer Folder

  • Linux

    UninstallDesigner folder is not deleted from the Designer folder after the successful un-installation of Designer. The deletion is intentionally prevented to avoid 'cd ..' error if uninstallation is run from the <installdir>/UninstallDesigner location.

  • Windows

    The folder is not removed because it is in use.

12.0 Upgrade

12.1 Upgrade from Designer 3.0.1 to Designer 3.5 is Not Supported

Designer 3.5 is a full fledged RCP application. It does not support upgrades from previous versions of Designer. You can still export Designer 3.0.1 workspaces into Designer 3.5 that triggers the project conversion and converts the project to 3.5 version.

13.0 Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items in a cross-reference path.

A trademark symbol (®, ™, etc.) denotes a Novell® trademark; an asterisk (*) denotes a third-party trademark.

14.0 Legal Notices

Novell, Inc. makes no representations or warranties with respect to the contents or use of this documentation, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right to revise this publication and to make changes to its content, at any time, without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc. makes no representations or warranties with respect to any software, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right to make changes to any and all parts of Novell software, at any time, without any obligation to notify any person or entity of such changes.

Any products or technical information provided under this Agreement may be subject to U.S. export controls and the trade laws of other countries. You agree to comply with all export control regulations and to obtain any required licenses or classification to export, re-export, or import deliverables. You agree not to export or re-export to entities on the current U.S. export exclusion lists or to any embargoed or terrorist countries as specified in the U.S. export laws. You agree to not use deliverables for prohibited nuclear, missile, or chemical biological weaponry end uses. See the Novell International Trade Services Web page for more information on exporting Novell software. Novell assumes no responsibility for your failure to obtain any necessary export approvals.

Copyright © 2009 Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, stored on a retrieval system, or transmitted without the express written consent of the publisher.

Novell, Inc. has intellectual property rights relating to technology embodied in the product that is described in this document. In particular, and without limitation, these intellectual property rights may include one or more of the U.S. patents listed on the Novell Legal Patents Web page and one or more additional patents or pending patent applications in the U.S. and in other countries.

For Novell trademarks, see the Novell Trademark and Service Mark list.

All third-party trademarks are the property of their respective owners.