17.1 Planning Your Migration

This section lists the important requirements that must be verified before attempting eDirectory migration.

IMPORTANT:If the eDirectory version is 8.7.3.6 or earlier on the NetWare server, you must backup the sys:/system/backupcr.nlm file.

On performing migration from Netware to OES 11 SP2, the backupcr.nlm on NetWare server is overwritten with the newer version. In case of failure, restore the backupcr.nlm.

17.1.1 System Requirements

17.1.2 Prerequisites

  • The eDirectory migration utility can run only on the target server and must be able to access the source server remotely.

  • All servers that share a replica with the server to be restored are up and communicating. This allows the restore verification process to check with servers that participate in the same replica ring.

    For more information, see Preparing for a Restore in the NetIQ eDirectory 8.8 SP8 Administration Guide.

17.1.3 Supported Platforms

The eDirectory migration utility is designed to run on OES 11 SP2, which is the target platform for migration. For more information on the compatible eDirectory versions at the source and the corresponding target servers, refer to the Section 4.1, Prerequisites and Section 1.4, Support Matrix for NetWare and OES Services.

17.1.4 Considerations

  • IP address and DNS migrations are not performed by this migration utility.

  • Only the eDirectory instance is migrated. Applications depending on eDirectory are not migrated by this utility.

  • You should not use this migration methodology if you want both the servers to be available during the migration operation.

    NOTE:Only the target server is available after the Transfer ID migration. The eDirectory DIB on the source server is locked. Other service migrations cannot be performed after completing Transfer ID migration for eDirectory. The source server can be brought back by restarting the eDirectory server, but you should do this only if the Transfer ID migration is unsuccessful.

17.1.5 Troubleshooting

Migration Issue

If the source server is running eDirectory 8.6.2, the following error is encountered:

The NDS schema in this tree is out of date. You must run ndsrepair to correct it. Please consult the readme for further instructions. ERROR -722: Setup for NDS installation failed. Please make certain that you have provided the complete server and admin contexts.
ERROR: /opt/novell/eDirectory/bin/ndsconfig return value = 78.

To workaround this issue, do the following:

On the master eDirectory 8.6.2 server, run dsrepair, Advanced Options Menu > Global Schema Operations, then select Post NetWare 5 Schema Update > Yes.